































































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="22229890" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=e9a2af237371b1fbaade22e90726ee45" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=e9a2af237371b1fbaade22e90726ee45" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=e9a2af237371b1fbaade22e90726ee45" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=e9a2af237371b1fbaade22e90726ee45" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Whole Site" href="https://www.orlandoweekly.com/orlando/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Blogs Section" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2250908" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Blogs" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2250909" />
      
        <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Blogs: " href="https://www.orlandoweekly.com/orlando/Rss.xml?category=2250909&amp;topic=oid%3A2265200" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Comments on 12 bands and 2 stages converge for Stonewall's annual Sweater Fest" href="https://www.orlandoweekly.com/orlando/Rss.xml?id=comments&amp;oid=22229890" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=7443726fcecaca563c815a6349f5cb90"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=7443726fcecaca563c815a6349f5cb90"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.orlandoweekly.com\/orlando\/Profile", "https:\/\/posting.orlandoweekly.com\/orlando\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="297405715145-bcr8a9m9emb8a84o6qbd7utuefrfoknk.apps.googleusercontent.com">
  

    
  

  
  <!-- Begin Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->

<meta name="google-site-verification" content="06A5Yh5mu5xlqSkqBOzGlxA6P_yfmltTp1l0ssgpOBk" />


<!-- Google Verification -->   
<meta name="google-site-verification" content="9htXi1AfaHrVLNGB2JDLtdpWEFyb-JOf5ngnP_95Zuk" />
<meta name="google-site-verification" content="s4GBlkstS6PKQwO_gDlOGL8jFPmeuL_d3m60wxOBQR0" />


<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>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</script>
<!-- Begin Google Analytics -->
  
    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-585470-1', 'orlandoweekly.com');
    ga('send', 'pageview', { 'dimension1': 'blogs', 'dimension2': 'music' });
    </script>
  
  <!-- End Google Analytics -->




<!-- Quantcast Choice. Consent Manager Tag -->
  <script type="text/javascript" async=true>
    var __cmp = (function () {
      return typeof (__cmp) == "function" ? __cmp : function (c) {
        var b = arguments;
        if (!b.length) {
          return __cmp.a;
        }
        else if (c == '__cmp')
          return false;
        else {
          if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
          }
          __cmp.a.push([].slice.apply(b));
        }
      }
    })();
    var elem = document.createElement('script');
    elem.src = "https://quantcast.mgr.consensu.org/cmp.js";
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);

    window.__cmp('init', {
      'Language': 'en',
    'Initial Screen Reject Button Text': 'I do not accept',
    'Initial Screen Accept Button Text': 'I accept',
    'Purpose Screen Header Title Text': 'Privacy settings',
    'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
    'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
    'Vendor Screen Accept All Button Text': 'Accept all',
    'Vendor Screen Reject All Button Text': 'Reject all',
    'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
    'Initial Screen Body Text Option': 1,
    'Publisher Name': 'Orlando Weekly',
    'Publisher Purpose IDs': [1,2,5,4,3],
    'Post Consent Page': 'https://www.orlandoweekly.com/orlando/Policies/Page',
    });
  </script>
  <!-- End Quantcast Choice. Consent Manager Tag -->
    <style>
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            background-color: #000000 !important;
            border-color: #000000 !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            background-color: transparent !important;
            border-color: #000000 !important;
        }
        .qc-cmp-alt-action,
        .qc-cmp-link {
            color: #000000 !important;
        }
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            color: #ffffff !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            color: #000000 !important;
        }
        .qc-cmp-small-toggle.qc-cmp-toggle-on,
        .qc-cmp-toggle.qc-cmp-toggle-on {
            background-color: #ee1c25 !important;
            border-color: #ee1c25 !important;
        }
        .qc-cmp-small-toggle,
        .qc-cmp-toggle {
            background-color: #C0C0C0 !important;
            border-color: #C0C0C0 !important;
        }
    </style>

  

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'https://cdn.taboola.com/libtrc/sacurrent-orlandoweekly/loader.js');
</script>
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="12 bands and 2 stages converge for Stonewall&#39;s annual Sweater Fest | Blogs" />
  <meta name="description" content="How often do you have a reason to not only wear a sweater in Florida but to wear it while drinking and helping raise money..." />
  <meta name="keywords" content="The Heard" />
  <title>12 bands and 2 stages converge for Stonewall's annual Sweater Fest | Blogs</title>

  
  
    <meta name="date" content="2018-12-14 06:00:00" />
  

  
  
  
    <meta name="author" content="Jen Cray">
  

  
  
  <meta name="news_keywords" content="the heard" />

  
  
    
  
  
    <link rel="image_src" href="https://media2.fdncms.com/orlando/imager/u/slideshow/22229896/sweater_fest_adobestock_229465005.jpeg" />
    <meta name="thumbnail" content="https://media2.fdncms.com/orlando/imager/u/slideshow/22229896/sweater_fest_adobestock_229465005.jpeg" />
  

  
    
      <link rel="canonical" href="https://www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest" />
    
  

  
    <meta property="fb:app_id" content="1527160917534695" />
  

  
  <meta property="og:site_name" content="Orlando Weekly" />
  <meta property="og:title" content="12 bands and 2 stages converge for Stonewall&#39;s annual Sweater Fest" />
 
  
    

    
    

    
    

    <meta property="og:image" content="https://media2.fdncms.com/orlando/imager/u/slideshow/22229896/sweater_fest_adobestock_229465005.jpeg" />

    
      <meta property="og:image:width" content="600" />
      <meta property="og:image:height" content="400" />
    
  

  
  
    <meta property="og:description" content="How often do you have a reason to not only wear a sweater in Florida but to wear it while drinking and helping raise money..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/orlando/imager/u/slideshow/22229896/sweater_fest_adobestock_229465005.jpeg">

    
    

    

    <meta name="twitter:site" content="@orlandoweekly">
    <meta name="twitter:title" content="12 bands and 2 stages converge for Stonewall&#39;s annual Sweater Fest">
    <meta name="twitter:description" content="How often do you have a reason to not only wear a sweater in Florida but to wear it while drinking and helping raise money...">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">22229890</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20181214060014</Attribute>
        <Attribute name="creationdate">20181212151642</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20181214060000</Attribute>
            <Attribute name="releasedate">20181214</Attribute>
            <Attribute name="releaseepoch">1544785200</Attribute>
            <Attribute name="title">12 bands and 2 stages converge for Stonewall&#39;s annual Sweater Fest</Attribute>
            <Attribute name="author">2498624</Attribute>
            <Attribute name="authorname">Jen Cray</Attribute>
            <Attribute name="authorsortname">Cray, Jen</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.orlandoweekly.com\/Blogs\/archives\/2018\/12\/14\/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest"
          },
          "headline": "12 bands and 2 stages converge for Stonewall's annual Sweater Fest",
          
            "description": "How often do you have a reason to not only wear a sweater in Florida but to wear it while drinking and helping raise money for a good cause?",
          
          
            "image": {
              "url": "https:\/\/media2.fdncms.com\/orlando\/imager\/u\/original\/22229896\/sweater_fest_adobestock_229465005.jpeg",
              "width": 1000,
              "height": 667,
              "@type": "ImageObject"
            },
          
          "datePublished": "2018-12-14T06:00:00",
          "dateModified": "2018-12-14T06:00:14",
          
            "author": {
              "name": "Jen Cray",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Orlando Weekly",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.orlandoweekly.com\/imager\/b\/google-amp-logo\/808579\/5643\/OrlandoWeekly_fbook.jpg",
                "width": 117,
                "height": 60,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Post" class="BlogPost Blogs Iapetus10Zone">




<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KQ22CZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KQ22CZ');</script>
<!-- End Google Tag Manager -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  <div id="AdInterstitial" class="Leader BlogPost ">
  <!-- /43707298/ORL_DesktopInterstitial -->
          <div id="div-gpt-ad-orl_desktopinterstitial" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopinterstitial');
                  });
              </script>
          </div>
</div>
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="https://m.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  












<div id="LogoHeader" class="GlobalHeader BlogPost ">
  
    
    <div id="logoLeft">      
      <a href="https://www.orlandoweekly.com/" title="Orlando Weekly">Orlando Weekly</a>
    </div>

    <div id="leaderboardAdHeader">
      <!-- /43707298/ORL_728x90 -->
          <div id="div-gpt-ad-orl_728x90-1" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-1');
                  });
              </script>
          </div>
    </div>
      
      
</div>
<!-- End #LogoHeader -->















  <div id="NavigationHorizontal" class="GlobalHeader BlogPost  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_NewsFeatures">
          <a href="https://www.orlandoweekly.com/orlando/news-and-features/Section?oid=2240408"  class="subnav_link" id="SNAVL_NewsFeatures">News</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_ArtsCulture">
          <a href="https://www.orlandoweekly.com/orlando/arts-and-culture/Section?oid=2240407"  >Arts</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Music">
          <a href="https://www.orlandoweekly.com/orlando/music/Section?oid=2240410"  >Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Screens">
          <a href="https://www.orlandoweekly.com/orlando/screens/Section?oid=2240411"  >Screens</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_FoodDrink">
          <a href="https://www.orlandoweekly.com/orlando/food-and-drink/Section?oid=2240409"  >Food &amp; Drink</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Calendar">
          <a href="https://www.orlandoweekly.com/orlando/EventSearch"  >Calendar</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_BestOfOrlando">
          <a href="https://www.orlandoweekly.com/orlando/BestOf"  class="subnav_link" id="SNAVL_BestOfOrlando">Best Of Orlando</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Galleries">
          <a href="http://photos.orlandoweekly.com"  >Galleries</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_PromosEvents">
          <a href="#"  class="subnav_link" id="SNAVL_PromosEvents">Promos + Events</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Subscribe">
          <a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page"  >Subscribe</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_Advertise">
          <a href="https://www.orlandoweekly.com/orlando/AdvertiseWithOrlandoWeekly/Page"  >Advertise</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_NewsFeatures" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/IssueArchives"  title="">Browse Issues</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/joblistings/Page"  title="">Local Job Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413"  title="">Special Issues</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Promos + Events</h3>
            <ul class="subnav_content" id="SNAV_PromosEvents" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/FreeStuff"  title="">Giveaways</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273894"  title="">OW Events</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal --><div id="AdPencilBar" class="GlobalHeader BlogPost ">
  <!-- /43707298/ORL_970x90 -->
          <div id="div-gpt-ad-orl_970x90" style="" data-content-type="ad" data-slot="/43707298/ORL_970x90" data-output="asynchronous" data-width="970" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_970x90');
                  });
              </script>
          </div>
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        

 
   



 


  

    



  <div id="TopicHeader" class="SpanningFeature BlogPost  topic_the-heard">      
       <a href="https://www.orlandoweekly.com/Blogs/archives/the-heard/">
         <h2 id="ArchiveHead" class="archiveHead">
           The Heard
         </h2>
       </a>   
      
  </div>  




  
  















  
  
  

  
  
  

  
 
  




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="SpanningFeature BlogPost ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:16%; height: 20px; float:left;">
        <fb:like href="https://www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:16%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest&text=12%20bands%20and%202%20stages%20converge%20for%20Stonewall%27s%20annual%20Sweater%20Fest" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:16%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="https://www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.orlandoweekly.com/orlando/Tools/EmailFriend?oid=22229890" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest?mode=print" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:16%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-54d38c2c42ccebb5" addthis:url="https://www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest" addthis:title="12 bands and 2 stages converge for Stonewall's annual Sweater Fest" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54d38c2c42ccebb5", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  









  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  


  <div id="BlogsBlogPost" class="SpanningFeature BlogPost  topicView topic_the-heard">

    

    
































    
    
    
    
  
    
      
      
        <h2 class="blogDate">Friday, December 14, 2018</h2>
      
    
      
      <div class="blogPost blogs topic-the-heard">
    
    
      <div class="postCategories">
                
        <span class="postCategory CategoryBlogs">
          <a href="https://www.orlandoweekly.com/Blogs/archives/the-heard/" class="topic-the-heard">The Heard</a>
        </span>
      </div>
    
    <h1 class="postTitle" id="a22229890">
      
      
      
      
      
      
        12 bands and 2 stages converge for Stonewall's annual Sweater Fest
      

      
    </h1>

    

    
      <h4 class="postedBy">
        
        <span class="byAttribute">Posted</span>
        
          
          <span class="byAttribute">By</span> <a href="https://www.orlandoweekly.com/author/jen-cray" rel="author">Jen Cray</a>
        
        
          
            on <span class="postTime">Fri, Dec 14, 2018</span> at <span class="postTime"> 6:00 AM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    

    
    

    <div class="postBody">
      
          
      


      
     
       
      

        

        

        

        

        

        

        
        

        

        

        
      
      
      
      
       
      
      

      
      

      
      
        
        <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media2.fdncms.com/orlando/imager/u/original/22229896/sweater_fest_adobestock_229465005.jpeg" class="zoomable" rel="contentImg_gal-22229890" title="PHOTO VIA ADOBE">                  <img src="https://media2.fdncms.com/orlando/imager/u/blog/22229896/sweater_fest_adobestock_229465005.jpeg?cb=1544645972" width="580" height="387" alt="PHOTO VIA ADOBE" srcset="" />                </a>                                                                                                           <ul style="width:580px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Photo via Adobe                                          </li>                                                                                                                                                                                      </ul>                                                       </div>

How often do you have a reason to not only wear a sweater in Florida but to wear it while drinking and helping raise money for a good cause? Not real often – but once a year, for the last 12 in fact, Sweater Fest gives you a damn fine excuse. You may have to pair that hideous, impractical sweater with shorts and shades, but throw it on along with your dancing shoes because this year the fest is taking over Stonewall (that cool bar that you’ve been meaning to go to). See 12 bands on two stages – including Ghostflower, TV Dinner and Spoon Dogs – plus get a free shot of Captain Morgan upon entry, and half-price admission for early birds. Add that all up and you’ve got a solid opportunity to get on Santa’s “naughty” list. Oh, yeah, Santa is reported to be making an appearance. So put on your craziest, sweatiest, most Christmas-y bit of ill-advised Florida clothing and crack open your wallet, because Sweater Fest is raising funds for the Zebra Coalition this year. – Jen Cray 

            
          
            <br>
<br>
<i>Friday, Dec. 14 , 7 p.m. | Stonewall Bar, 741 W. Church St. | 407-373-0888 | <a href="http://stonewallorlando.com" target="_blank">stonewallorlando.com</a> | $5-$10</i>

            
          

          
          
            
            
              <div class="overflowComponent  EndContentInterstitial">
                <div id="AdNativeInline" class="SpanningFeature AdNativeInline ">
  <!-- /43707298/ORL_DesktopNative -->
          <div id="div-gpt-ad-orl_desktopnative-2" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-2');
                  });
              </script>
          </div>
</div>
              </div>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
    

    

    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>










<div id="JumptoComments" class="SpanningFeature BlogPost ">
  <a href="#Disqus">Jump to comments</a>
</div><!-- End JumptoComments -->










  
      <div id="RelatedEvents" class="SpanningFeature BlogPost RelatedItem">
      <h3><span class="headingText">Related Events</span></h3>
      
      <ul>
    
    
    
    <li class="l0 eventItem">
    
    <script type="application/ld+json">
        {
          "name": "Sweater Fest 12: Someday River, Fayroy, the Jackettes, Dirtbike, TV Dinner and more",
          
            "description": "Benefit holiday party.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/orlando\/imager\/u\/original\/22227579\/sweater_fest_adobestock_229465005.jpeg",
              "width": 1000,
              "height": 667,
              "@type": "ImageObject"
            },
          
          "startDate" : "2018-12-14T04:00:00",
          
          
            
                "endDate" : "2018-12-15T00:00:01",
            

          
          

          
          
            "url" : "https:\/\/www.orlandoweekly.com\/orlando\/sweater-fest-12-someday-river-fayroy-the-jackettes-dirtbike-tv-dinner-and-more\/Event?oid=22160691",
          

          "location" : {
            "sameAs" : "https:\/\/www.orlandoweekly.com\/orlando\/stonewall-bar-orlando\/Location?oid=2288450",
            "name" : "Stonewall Bar Orlando",
            "address" : "741 W. Church St., Orlando, FL 32805",
            "@type" : "Place"
          },
          "@context": "https://schema.org",
          "@type": "Event"
        }
      </script>

    

    

    
    
    <h4>
      <span class="longOnly"></span>
      <a href="https://www.orlandoweekly.com/orlando/sweater-fest-12-someday-river-fayroy-the-jackettes-dirtbike-tv-dinner-and-more/Event?oid=22160691">Sweater Fest 12: Someday River, Fayroy, the Jackettes, Dirtbike, TV Dinner and more</a>
      
         @ Stonewall Bar Orlando
        
      
    </h4>    
    <ul>
      
      
        
          <li class="l1 date">
            Fri., Dec. 14, 7 p.m.
            
              <span class="l1 price">$5-$10</li>
            
          </li>
        
        
      
      
      
      

      
    </ul>
  </li>
        
    
  
      </ul>
      </div>
    









  


  

      <div id="RelatedLocations" class="SpanningFeature BlogPost RelatedItem">
        <h3><span class="headingText">
           
              Related Locations
            
         </span></h3>
        <ul>
    
    

    <li id="vcard-2288450" class="l0 locationItem vcard">
    

    

    <h4>
      <span class="longOnly"><div class="FeaturesIcons">
<a href="/orlando/LocationSearch?feature=Menu" class="FeaturesIcons_menu" title="Menu"><span>Menu</span></a>
</div></span>
      <a href="https://www.orlandoweekly.com/orlando/stonewall-bar-orlando/Location?oid=2288450" class="fn org">Stonewall Bar Orlando</a>
    </h4>
    
    <ul>
      <li class="l1 longOnly adr">
        <span class="street-address">741 W. Church St.</span><span class="hidden">, <span class="locality">Orlando</span></span>
        <span class="locationRegion"><a href="https://www.orlandoweekly.com/orlando/LocationSearch?neighborhood=2282449">Downtown</a></span>
        <span class="hidden region">FL</span>
        <span class="hidden postal-code">32805</span>
      </li>
      
        <li class="l1 hidden geo">
          <span class="latitude">28.54035</span>;<span class="longitude">-81.39081</span>
        </li>
      
      
        <li class="l1 longOnly">
          <span class="locationPhone tel"><img src="/images/icons/phone.gif" alt="phone" /> <span class="value">407-373-0888</span></span>
        </li>
      
      

      
        <li class="l1 locationRating">                
          
            <span class="rating"><div class="starsContainer tiny">
      <div class="goldStarContainer" style="left:-55px;">
      </div>
      <div class="blankStarContainer">
        <div class="blankStarContainerSub">
          <div class="singleStar" style="left:0;"></div>
          <div class="singleStar" style="left:11px;"></div>
          <div class="singleStar" style="left:22px;"></div>
          <div class="singleStar" style="left:33px;"></div>
          <div class="singleStar" style="left:44px;"></div>
        </div>
      </div>
    </div></span>
            <a href="https://www.orlandoweekly.com/orlando/stonewall-bar-orlando/Location?oid=2288450">Be the first to review this location!</a>
          
        </li>
      
    </ul>
  </li>

    
  
        </ul>
      </div>

      
      
                

    
    
    
    





















  
  

  <div id="BlogsPreviousNext" class="SpanningFeature BlogPost ">
    <div class="prevNext">
      
        <a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/13/dark-synth-stars-boy-harsher-to-play-orlando-this-spring" class="prev" rel="prev">&laquo;&nbsp;Dark synth stars Boy Harsher to pla&hellip;</a>
        
    </div>
  </div>


<div id="AdNativeEndofArticle" class="SpanningFeature BlogPost ">
  <!-- /43707298/ORL_DesktopNative -->
          <div id="div-gpt-ad-orl_desktopnative-3" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-3');
                  });
              </script>
          </div>
</div>








  
  
    

    

    



    

    

      
      


      <div id="Disqus" class="SpanningFeature BlogPost ">
        <div class="fb-comments" data-href="https://www.orlandoweekly.com/Blogs/archives/2018/12/14/12-bands-and-2-stages-converge-for-stonewalls-annual-sweater-fest" data-numposts="10" data-width="100%"></div>
      </div>
    

  
  

<!-- End #Disqus -->





<!-- Debug 2250909 has value 
             && Blog eq "blog"
-->








  
  
      <div id="RecentbyTopic" class="SpanningFeature BlogPost ">
        <h3 class="latestthe_heard">
          <span class="headingText">
          
            More on The Heard
                
          </span>
        </h3>
        
        <ul class="moduleList">
    
    
    
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/13/dark-synth-stars-boy-harsher-to-play-orlando-this-spring?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/22258951/unnamed_23_.jpg"
             alt="Dark synth stars Boy Harsher to play Orlando this spring"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/22258951/unnamed_23_.jpg 1.5x, https://media2.fdncms.com/orlando/imager/u/bigsquare3x/22258951/unnamed_23_.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/13/dark-synth-stars-boy-harsher-to-play-orlando-this-spring?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">Dark synth stars Boy Harsher to play Orlando this spring</a>
    </h4>
    <div class="date">Dec 13, 2018</div>
  </li>

    
  
    
    
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/13/gin-blossoms-to-play-orlando-in-february?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/22256616/48337173_2080802101988207_8670620358723764224_o.jpg"
             alt="Gin Blossoms to play Orlando in February"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/22256616/48337173_2080802101988207_8670620358723764224_o.jpg 1.5x, https://media2.fdncms.com/orlando/imager/u/bigsquare3x/22256616/48337173_2080802101988207_8670620358723764224_o.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/13/gin-blossoms-to-play-orlando-in-february?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">Gin Blossoms to play Orlando in February</a>
    </h4>
    <div class="date">Dec 13, 2018</div>
  </li>

    
  
    
    
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/12/stonewalls-thick-and-funky-brings-in-benny-black-of-the-housekeepers?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/22228399/screen_shot_2018-12-12_at_2.38.05_pm.png"
             alt="Stonewall&#39;s Thick &amp;amp; Funky brings in Benny Black of the Housekeepers"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/22228399/screen_shot_2018-12-12_at_2.38.05_pm.png 1.5x, https://media2.fdncms.com/orlando/imager/u/bigsquare3x/22228399/screen_shot_2018-12-12_at_2.38.05_pm.png 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/12/stonewalls-thick-and-funky-brings-in-benny-black-of-the-housekeepers?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">Stonewall's Thick &amp; Funky brings in Benny Black of the Housekeepers</a>
    </h4>
    <div class="date">Dec 12, 2018</div>
  </li>

    
  
      
        <li class="l0 storyItem">
          
          
            
             <a href="https://www.orlandoweekly.com/Blogs/archives/the-heard/" class="more">More The Heard &raquo;</a>
            
          
          
        </li>
      
        </ul>
      </div>
    
  









  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningFeature BlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningFeature BlogPost ">
            <h3><span class="headingText">More by Jen Cray</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/orlando/whats-old-is-very-new-again-with-queen-of-jeans/Content?oid=21333895&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/21333894/queen_of_jeans_by_jen_cray.jpg"
             alt="What&#39;s old is very new again with Queen of Jeans"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/21333894/queen_of_jeans_by_jen_cray.jpg 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/21333894/queen_of_jeans_by_jen_cray.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/whats-old-is-very-new-again-with-queen-of-jeans/Content?oid=21333895&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">What's old is very new again with Queen of Jeans</a>
    </h4>
    <div class="date">Nov 21, 2018</div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/orlando/pale-waves-are-manchesters-newest-dark-pop-contenders/Content?oid=20370623&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/20370359/pale_waves_by_brian_griffin.jpg"
             alt="Pale Waves are Manchester&#39;s newest dark-pop contenders"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/20370359/pale_waves_by_brian_griffin.jpg 1.5x, https://media2.fdncms.com/orlando/imager/u/bigsquare3x/20370359/pale_waves_by_brian_griffin.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/pale-waves-are-manchesters-newest-dark-pop-contenders/Content?oid=20370623&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Pale Waves are Manchester's newest dark-pop contenders</a>
    </h4>
    <div class="date">Oct 31, 2018</div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/10/18/watch-local-band-expert-timings-new-music-video-for-alone-here-first?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/19803831/expertiming_jul18_6.jpg"
             alt="Watch local band Expert Timing&#39;s new music video for Alone here first"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/19803831/expertiming_jul18_6.jpg 1.5x, https://media2.fdncms.com/orlando/imager/u/bigsquare3x/19803831/expertiming_jul18_6.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/10/18/watch-local-band-expert-timings-new-music-video-for-alone-here-first?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Watch local band Expert Timing's new music video for Alone here first</a>
    </h4>
    <div class="date">Oct 18, 2018</div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?author=2498624" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  

  
    
        <div id="PeopleWhoLiked" class="SpanningFeature BlogPost ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/02/16/a-brief-history-of-gov-rick-scott-doing-jack-shit-about-florida-gun-violence?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/10867315/screen_shot_2016-08-02_at_12.39.42_pm.png"
             alt="A brief history of Gov. Rick Scott doing jack shit about Florida gun violence"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/10867315/screen_shot_2016-08-02_at_12.39.42_pm.png 1.5x, https://media2.fdncms.com/orlando/imager/u/bigsquare3x/10867315/screen_shot_2016-08-02_at_12.39.42_pm.png 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/02/16/a-brief-history-of-gov-rick-scott-doing-jack-shit-about-florida-gun-violence?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">A brief history of Gov. Rick Scott doing jack shit about Florida gun violence</a>
    </h4>
    <div class="date">Feb 16, 2018</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2017/07/24/orlando-premium-outlets-extend-hours-employees-complained-and-now-the-old-hours-are-back?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/5747640/vineland_outlets.jpg"
             alt="Orlando Premium Outlets extended hours, employees complained, and now the old hours are back"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/5747640/vineland_outlets.jpg 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/5747640/vineland_outlets.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2017/07/24/orlando-premium-outlets-extend-hours-employees-complained-and-now-the-old-hours-are-back?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">Orlando Premium Outlets extended hours, employees complained, and now the old hours are back</a>
    </h4>
    <div class="date">Jul 24, 2017</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2017/09/05/hurricane-irma-is-now-the-strongest-atlantic-storm-ever-recorded-outside-of-gulf-and-caribbean?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/6638915/screen_shot_2017-09-05_at_2.21.47_pm.png"
             alt="Irma is now the strongest Atlantic hurricane ever recorded outside of the Gulf and Caribbean"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/6638915/screen_shot_2017-09-05_at_2.21.47_pm.png 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/6638915/screen_shot_2017-09-05_at_2.21.47_pm.png 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2017/09/05/hurricane-irma-is-now-the-strongest-atlantic-storm-ever-recorded-outside-of-gulf-and-caribbean?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">Irma is now the strongest Atlantic hurricane ever recorded outside of the Gulf and Caribbean</a>
    </h4>
    <div class="date">Sep  5, 2017</div>
  </li>
      
      
    
          </ul>
        </div>
      
               



  
  

  

  

  <div id="BlogHeader" class="SpanningFeature BlogPost  topic_the-heard Blogs">
    <a href="https://www.orlandoweekly.com/blogs/Blogs/">
    <div class="Blogs">
      
        Blogs
      
    </div>
    </a>

    

    <p>
      
        <a href="https://www.orlandoweekly.com/orlando/Blogs/blogs/Archives">Archives</a> |
        <a href="/orlando/Rss.xml?category=2250909">RSS</a>
      
      
    </p>
  </div>


      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        









<div id="TabbedPopularity" class="SpanningIsland BlogPost ">
  <h2>Most Popular</h2>
  <div class="tabs">
    <div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
    <div id="tabCommented" class="tabBack tab"><a href="#">Most Commented</a></div>
    <div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
  </div>
  
  

  <div class="popularityBody">
    
        <ol class="moduleList">
      
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/13/ron-desantis-wants-to-pull-some-bullshit-before-restoring-rights-to-florida-felons?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Ron DeSantis wants to pull some bullshit before restoring rights to Florida felons <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/13/neil-degrasse-tyson-cancels-orlando-appearance-following-sexual-misconduct-accusations?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Neil deGrasse Tyson cancels Orlando appearance following sexual misconduct accusations <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/13/gin-blossoms-to-play-orlando-in-february?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Gin Blossoms to play Orlando in February <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/04/hurricane-michael-insurance-losses-top-4-billion?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Hurricane Michael insurance losses top $4 billion <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2018/12/12/trumps-limo-and-a-steakhouse-the-future-of-orlandos-artegon-marketplace-is-starting-to-take-shape?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Trump's limo and a steakhouse: The future of Orlando's Artegon Marketplace is starting to take shape <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>  

  

  <div class="popularityBody" style="display:none">
    

    
    <div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://disqus.com/forums/orlandoweekly/popular_threads_widget.js?num_items=5&hide_avatars=1&avatar_size=32&excerpt_length=200"></script></div>
  </div>
  
  

  <div class="popularityBody" style="display:none">
    
    
      <div class="currentIssue">
        <a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=22194654&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
          
            <img src="/imager/b/cover/22194654/e2db/121218_Cover.jpg" alt="Issue Cover" />
          
        </a>
        <p>December 12-18, 2018</p>
      </div>
    
    
        <ol class="moduleList">
      
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/john-waters-is-the-reason-for-the-sason/Content?oid=22194770&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">John Waters is the reason for the season <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/the-hunt-for-oil-along-floridas-atlantic-coast-may-be-a-reality-again-but-what-does-that-mean-for-marine-life/Content?oid=22195136&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">The hunt for oil along Florida's Atlantic coast may be a reality again, but what does that mean for marine life? <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/get-your-fill-of-old-country-staples-and-first-rate-sandwiches-at-stasios-italian-market-and-deli-in-the-milk-district/Content?oid=22195565&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Get your fill of Old Country staples and first-rate sandwiches at Stasio's Italian Market & Deli in the Milk District <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/bad-brains-frontman-hr-brings-reggae-to-deland/Content?oid=22196402&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Bad Brains frontman HR brings reggae to DeLand <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/ginger-minj-also-known-to-her-orlando-friends-as-actor-josh-eads-reveals-she-hasnt-forgotten-where-she-came-from/Content?oid=22196407&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Ginger Minj – also known to her Orlando friends as actor Josh Eads – reveals she hasn’t forgotten where she came from <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/cuarons-roma-is-one-of-the-years-best-films/Content?oid=22196840&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Cuarón’s 'Roma' is one of the year’s best films <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
<!-- End #TabbedPopularity -->










<div id="SearchRightCol" class="SpanningIsland BlogPost  search-wrap">
    
    <form class="prepTextForm" id="searchbox_017793458706336421686:1y5lan2fdja" action="https://www.orlandoweekly.com/orlando/Search">
      <input type="hidden" name="cx" value="017793458706336421686:1y5lan2fdja" />
      <input type="hidden" name="cof" value="FORID:9" />
      <input id="search-submit" type="submit" name="sa" value="Search" />    
      <input id="search-input" autocomplete="off" type="text"  name="q" size="25" placeholder="Search" />
    </form>
    <ul id="search-dropdown"  class="search-dropdown" style="display:none;">
      <li class="search-option"><a class="search-all" href="https://www.orlandoweekly.com/orlando/Search"><span class="dark-search-icon"></span>&nbsp;All</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/ArticleArchives"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/EventSearch"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/LocationSearch"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
    </ul>
  
</div>

<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            if( newLocation.match(/\?/)){
              newLocation = newLocation+'&';
            }else{
              newLocation = newLocation+'?';
            }
            window.location = newLocation + "keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>
<!-- End #SearchRightCol -->
<div id="AdMediumRectangle1300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-1" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-1');
                  });
              </script>
          </div>
</div>


  <div id="NewsletterSignup" class="SpanningIsland BlogPost ">
  <h2>Newsletters</h2>
    <div class="wrap">
    <h3>Never miss a beat</h3>
<a href="/orlando/NewsletterSignup/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color:#F7941E;font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
    </div>
  </div>
  <div id="ORATVAANPartnerWidget" class="SpanningIsland BlogPost ">
  <!--
  <iframe width="300" height="169" src="//www.ora.tv/embed/partner/orlandoweekly/playlist/179/v/1"frameBorder="0" scrolling="no" webkitAllowFullScreen mozallowfullscreen allowfullscreen></iframe>
  -->
  <iframe width="300" height="169" src="//www.ora.tv/embed/partner/orlandoweekly/playlist/179/v/1"frameBorder="0" scrolling="no" webkitAllowFullScreen mozallowfullscreen allowfullscreen></iframe>

</div>












































<div id="TabbedCalendar" class="SpanningIsland BlogPost ">
  <h2>Calendar</h2>

  <div class="tabs">
    <div id="tabEvents" class="tab"><a href="#">Events</a></div>
    <div id="tabMusic"  class="tab"><a href="#">Music</a></div>
    <div id="tabMovies" class="tab"><a href="#">Movies</a></div>
    <div id="tabArts"   class="tab"><a href="#">Arts</a></div>
    <div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/aquaman-vs-spider-man/Event?oid=20864046&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Aquaman vs Spider-Man <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/going-native/Event?oid=22160689&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Going Native</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/jaimie-roberts/Event?oid=20367583&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Jaimie Roberts <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/phantasmagorias-a-christmas-carol/Event?oid=20812469&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Phantasmagoria's <i>A Christmas Carol</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/santapalooza/Event?oid=22160692&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Santapalooza <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/opera-orlando-hansel-and-gretel/Event?oid=20132799&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Opera Orlando: <i>Hansel & Gretel</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/good-old-war-beta-radio-allman-brown/Event?oid=20770993&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Good Old War, Beta Radio, Allman Brown <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/wjrrs-not-so-silent-night-halestorm-in-this-moment/Event?oid=20663926&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        WJRR's Not So Silent Night: Halestorm, In This Moment <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/annual-violectric-holiday-show/Event?oid=20668781&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Annual Violectric Holiday Show <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/green-jelly/Event?oid=22160690&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Green Jelly <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/rare-exports/Event?oid=20671363&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Rare Exports</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/holiday-movie-at-lake-eola-park-the-santa-clause/Event?oid=20668783&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Holiday Movie at Lake Eola Park: <i>The Santa Clause</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/the-favourite/Event?oid=22081649&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>The Favourite</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/peanut-butter-matinee-the-wizard-of-oz/Event?oid=20670979&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Peanut Butter Matinee: <i>The Wizard of Oz</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/home-alone/Event?oid=20672567&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Home Alone</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/going-native/Event?oid=22160689&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Going Native</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/mount-dora-art-stroll/Event?oid=2293131&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Mount Dora Art Stroll <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/the-nutcracker-ballet-dance-showcases-at-rosen-shingle-creek-hotel/Event?oid=21979515&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        The Nutcracker Ballet, Dance Showcases at Rosen Shingle Creek Hotel <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/gekiga/Event?oid=22160688&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Gekiga</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/relationships-the-works-of-jose-manuel-rivas/Event?oid=21597802&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Relationships: The Works of José Manuel Rivas</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/vespr-craft-coffee-and-allures/Location?oid=2288963&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Vespr Craft Coffee & Allures <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/harry-buffalo/Location?oid=2292568&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Harry Buffalo <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/the-pita-pit/Location?oid=2292350&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        The Pita Pit <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
    <form name="diningSearchForm" method="get" action="https://www.orlandoweekly.com/orlando/LocationSearch">
      <input type="hidden" name="locationSection" value="2282258" />
      <input type="hidden" name="guide" value="2124367" />
      <select name="locationCategory">
        <option value="">-All Categories-</option>
        
          <option value="2282260">African</option>
        
          <option value="2282261">American</option>
        
          <option value="2282262">Argentine</option>
        
          <option value="2282263">Armenian</option>
        
          <option value="2282264">Bakery</option>
        
          <option value="2282265">Barbecue</option>
        
          <option value="2282266">Breakfast/Brunch</option>
        
          <option value="2282267">Brewpub</option>
        
          <option value="2282286">Burgers</option>
        
          <option value="2282268">Café/Bistro</option>
        
          <option value="2282269">Cajun/Creole</option>
        
          <option value="2282270">Caribbean</option>
        
          <option value="2282272">Chinese</option>
        
          <option value="2282271">Coffee house (chain)</option>
        
          <option value="2282289">Coffee house (independent)</option>
        
          <option value="2282274">Contemporary</option>
        
          <option value="2282275">Continental</option>
        
          <option value="2282276">Cuban</option>
        
          <option value="2297679">Deli</option>
        
          <option value="2282278">Diner</option>
        
          <option value="2282279">Eastern European</option>
        
          <option value="2282280">Ethiopian</option>
        
          <option value="2282281">Fondue</option>
        
          <option value="2304903">Food Truck</option>
        
          <option value="2282282">French</option>
        
          <option value="2282283">General</option>
        
          <option value="2282399">General Fare</option>
        
          <option value="2282284">German</option>
        
          <option value="2282285">Greek</option>
        
          <option value="2282287">Hawaiian</option>
        
          <option value="2282288">Hot Dogs</option>
        
          <option value="2282290">Indian</option>
        
          <option value="2282291">Indonesian</option>
        
          <option value="2282292">Irish</option>
        
          <option value="2282293">Israeli</option>
        
          <option value="2282294">Italian</option>
        
          <option value="2282295">Jamaican</option>
        
          <option value="2282296">Japanese/Sushi</option>
        
          <option value="2282297">Korean</option>
        
          <option value="2297696">Kosher</option>
        
          <option value="2282298">Latin American</option>
        
          <option value="2282299">Lebanese</option>
        
          <option value="2305936">Malaysian</option>
        
          <option value="2282300">Market</option>
        
          <option value="2282301">Mediterranean</option>
        
          <option value="2282302">Mexican</option>
        
          <option value="2282303">Middle Eastern</option>
        
          <option value="2345788">Modern American</option>
        
          <option value="2282304">Mongolian</option>
        
          <option value="2282305">Moroccan</option>
        
          <option value="2282306">Noodles</option>
        
          <option value="2282307">Pan-Asian</option>
        
          <option value="2282308">Persian</option>
        
          <option value="2282309">Peruvian</option>
        
          <option value="2282310">Philippine</option>
        
          <option value="2282311">Pizza</option>
        
          <option value="2282312">Polish</option>
        
          <option value="2297728">Pub Grub</option>
        
          <option value="2282313">Puerto Rican</option>
        
          <option value="2282314">Russian</option>
        
          <option value="2282315">Salads</option>
        
          <option value="2282277">Sandwiches/Subs</option>
        
          <option value="2282316">Seafood</option>
        
          <option value="2282317">Soup</option>
        
          <option value="2282318">Southern/Soul</option>
        
          <option value="2282319">Spanish</option>
        
          <option value="2282320">Steakhouse</option>
        
          <option value="2282321">Swedish</option>
        
          <option value="2282322">Sweets</option>
        
          <option value="2282323">Tapas</option>
        
          <option value="2282273">Tea</option>
        
          <option value="2282324">Tex-Mex</option>
        
          <option value="2282325">Thai</option>
        
          <option value="2282326">Turkish</option>
        
          <option value="2282327">Vegetarian/Vegan</option>
        
          <option value="2282328">Vietnamese</option>
        
          <option value="2282329">Wine</option>
        
      </select>
      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        <option value="2292883" >&nbsp;&nbsp;Apopka</option>
      
        <option value="2282447" >&nbsp;&nbsp;Central</option>
      
        <option value="2292887" >&nbsp;&nbsp;Audubon Park</option>
      
        <option value="2292884" >&nbsp;&nbsp;Casselberry</option>
      
        <option value="2282448" >&nbsp;&nbsp;Disney</option>
      
        <option value="2282449" >&nbsp;&nbsp;Downtown</option>
      
        <option value="2282450" >&nbsp;&nbsp;East</option>
      
        <option value="2399527" >&nbsp;&nbsp;Edgewood</option>
      
        <option value="2282451" >&nbsp;&nbsp;Elsewhere</option>
      
        <option value="2282452" >&nbsp;&nbsp;I-DriveUniversal</option>
      
        <option value="2292885" >&nbsp;&nbsp;Ivanhoe Village</option>
      
        <option value="2282453" >&nbsp;&nbsp;North</option>
      
        <option value="2282454" >&nbsp;&nbsp;South</option>
      
        <option value="2282455" >&nbsp;&nbsp;West</option>
      
        <option value="4366406" >&nbsp;&nbsp;Dr. Phillips</option>
      
        <option value="2282456" >&nbsp;&nbsp;Winter Park Area</option>
      
        <option value="2343583" >&nbsp;&nbsp;Milk District</option>
      
        <option value="2343582" >&nbsp;&nbsp;SoDo</option>
      
        <option value="2343585" >&nbsp;&nbsp;Kissimmee</option>
      
        <option value="2343584" >&nbsp;&nbsp;UCF</option>
      
        <option value="2343586" >&nbsp;&nbsp;Mount Dora</option>
      
        <option value="2343587" >&nbsp;&nbsp;Conway</option>
      
        <option value="2343589" >&nbsp;&nbsp;Belle Isle</option>
      
        <option value="2343590" >&nbsp;&nbsp;Mills 50</option>
      
        <option value="2345785" >&nbsp;&nbsp;College Park</option>
      
        <option value="2345787" >&nbsp;&nbsp;Thornton Park</option>
      
    
  </select>
      <div class="searchBox">
        <input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
        <input type="submit" value="go" />
      </div>
    </form>
  </div>
</div>




<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 0
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
<div id="AdMediumRectangle2300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-2" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-2');
                  });
              </script>
          </div>
</div><div id="PhotoSlideshows" class="SpanningIsland BlogPost ">
  <h2><a href="http://photos.orlandoweekly.com/" target="_blank">Newest Slideshows</a></h2>
  <iframe src="//photos.orlandoweekly.com/thumbnail-scroller-square/" 
          height="419" 
          width="364"
          scrolling="no" 
          frameborder="0"></iframe>
</div>
<!-- End #PhotoSlideshows -->
















    <div id="SpecialIssues" class="SpanningIsland BlogPost ">
      <h2><a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
  
  
  <div class="reportBox">
    <a href="/orlando/welcome-to-the-2018-orlando-weekly-city-guide/Content?oid=12827125&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/12863154/screen_shot_2018-04-18_at_12.47.44_pm.png);">
      <span class="grayRedBox">City Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/every-holiday-event-happening-in-orlando-till-the-end-of-the-year/Content?oid=21006445&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/orlando/imager/u/original/21335063/screen_shot_2018-11-20_at_4.12.47_pm.png);">
      <span class="grayRedBox">Holiday Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/Category?oid=2240491&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/orlando/imager/u/original/4587058/sidebar.jpg);">
      <span class="grayRedBox">Summer Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-orlando-weeklys-2018-newcomers-guide/Content?oid=16946054&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/orlando/imager/u/original/17005746/screen_shot_2018-08-10_at_11.01.15_am.png);">
      <span class="grayRedBox">Newcomers Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-the-best-of-orlando-2018/BestOf?oid=17445650&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/17484726/screen_shot_2018-08-22_at_7.23.27_am.png);">
      <span class="grayRedBox">Best of Orlando</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-bite-2018/Content?oid=15292363&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/15292364/screen_shot_2018-06-26_at_5.32.22_pm.png);">
      <span class="grayRedBox">Bite</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-orlando-weeklys-2018-fall-guide/Content?oid=18838010&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/18876408/screen_shot_2018-09-26_at_12.36.27_pm.png);">
      <span class="grayRedBox">Fall Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/puppy-love/Category?oid=2240490&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/2519912/sidebar_ow_homepage6.jpg);">
      <span class="grayRedBox">Puppy Love</span>
    </a>
  </div>
  

      <a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
    </div>
  
<div id="AdMediumRectangle3300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-3" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-3');
                  });
              </script>
          </div>
</div>
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      

<div id="FooterInfo" class="GlobalFooter BlogPost ">
  <div class="footerCustomInfo">
    <h2>Orlando Weekly</h2>
    <p>16 W. Pine St.</p>
    <p>Orlando, FL 32801</p>
    <p>Phone: (407) 377-0400</p>
    <p>Classified Phone: (407) 377-0415</p>
    <p>Fax: (407) 377-0420</p>
  </div>
  <div class="footerCustomWrap">
    <div class="footerCustomNav">
      <ul>
        <li><a target="_top" href="/orlando/AboutOrlandoWeekly/Page">About OW</a></li>
        <li><a target="_top" href="https://www.orlandoweekly.com/orlando/AdvertiseWithOrlandoWeekly/Page">Advertise</a></li>
        <li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
				
				    <li><a target="_blank" href="/blogs/LegalAdvertising/">Legal Advertising</a></li>
				
        <li><a target="_top" href="/orlando/WorkForUs/Page">Work Here</a></li>
      </ul>
      <p>All parts of this site Copyright &copy; 2018 Orlando Weekly.</p>
    </div>
    <div class="footerRssLink">
      <a href="https://www.orlandoweekly.com/orlando/Syndication" class="RSSLink">RSS Feeds</a>
    </div>    
    

    
    
      <div class="footerCustomLogin">
        

        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="https://posting.orlandoweekly.com/orlando/MyProfile">View Profile</a> / </li>
          <li><a href="https://posting.orlandoweekly.com/orlando/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="https://www.orlandoweekly.com/orlando/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      </div><!-- #FooterInfo -->

      <script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
    
  </div>
  <div class="clear"></div>
</div>
<!-- End #FooterInfo -->
<div id="AdFooter728x90" class="GlobalFooter BlogPost ">
  <!-- /43707298/ORL_728x90 -->
          <div id="div-gpt-ad-orl_728x90-2" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-2');
                  });
              </script>
          </div>
</div>































<div id="FooterNavigation" class="GlobalFooter BlogPost ">
  <div class="linkGroupColumn">

    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/news-and-features/Section?oid=2240408" 
               target="_">
              News & Features
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/news-and-features/Section?oid=2240408" >News Home</a></li>
          
            <li><a href="/orlando/first-words/Category?oid=2240418" >First Words</a></li>
          
            <li><a href="/orlando/happytown/Category?oid=2240414" >Happytown</a></li>
          
            <li><a href="/orlando/know-it-all/Category?oid=2240417" >Know It All</a></li>
          
            <li><a href="/orlando/give-me-your-money/Category?oid=2240416" >Give Me Your Money</a></li>
          
            <li><a href="/Blogs/archives/bloggytown/" >Blog: Bloggytown</a></li>
          
            <li><a href="/orlando/joblistings/Page" >Local Job Listings</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/EventSearch" 
               target="_">
              Arts & Culture
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/arts-and-culture/Section?oid=2240407" >Arts & Culture Home</a></li>
          
            <li><a href="/orlando/visual-arts/Category?oid=2240435" >Visual Arts</a></li>
          
            <li><a href="/orlando/performing-arts/Category?oid=2240436" >Performing Arts</a></li>
          
            <li><a href="/orlando/books/Category?oid=2240437" >Books</a></li>
          
            <li><a href="/orlando/live-active-cultures/Category?oid=2240438" >Live Active Cultures</a></li>
          
            <li><a href="/orlando/culture-2-go/Category?oid=2240439" >Culture 2 Go</a></li>
          
            <li><a href="/orlando/savage-love/Category?oid=2240424" >Savage Love</a></li>
          
            <li><a href="/orlando/free-will-astrology/Category?oid=2240441" >Free Will Astrology</a></li>
          
            <li><a href="/Blogs/archives/the-gist/" >Blog: The Gist</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/food-and-drink/Section?oid=2240409" 
               target="_">
              Food & Drink
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/food-and-drink/Section?oid=2240409" >Food & Drink Home</a></li>
          
            <li><a href="/orlando/restaurant-review/Category?oid=2240450" >Restaurant Reviews</a></li>
          
            <li><a href="/orlando/tip-jar/Category?oid=2240453" >Tip Jar</a></li>
          
            <li><a href="/orlando/bar-exam/Category?oid=2240455" >Bar Exam</a></li>
          
            <li><a href="/orlando/nosh-pit/Category?oid=2240452" >Nosh Pit</a></li>
          
            <li><a href="/orlando/remix/Category?oid=2240456" >Remix</a></li>
          
            <li><a href="/orlando/LocationSearch?locationSection=2282258" >Find a Restaurant</a></li>
          
            <li><a href="/orlando/LocationSearch?locationSection=2282256" >Find a Bar or Club</a></li>
          
            <li><a href="/Blogs/archives/tip-jar/" >Blog: Tip Jar</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/screens/Section?oid=2240411" 
               target="_">
              Screens
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/screens/Section?oid=2240411" >Screens Home</a></li>
          
            <li><a href="/orlando/movie-reviews-and-stories/Category?oid=2240471" >Movie reviews</a></li>
          
            <li><a href="/orlando/couchsurfing/Category?oid=2240472" >Couchsurfing</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/music/Section?oid=2240410" 
               target="_">
              Music
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/music/Section?oid=2240410" >Music Home</a></li>
          
            <li><a href="/orlando/music-stories-and-interviews/Category?oid=2240462" >Music Reviews & Stories</a></li>
          
            <li><a href="/orlando/feedback/Category?oid=2240463" >Feedback</a></li>
          
            <li><a href="/orlando/this-little-underground/Category?oid=2240465" >This Little Underground</a></li>
          
            <li><a href="/Blogs/archives/the-heard/" >Blog: The Heard</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/EventSearch" 
               target="_">
              Calendar
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/EventSearch" >Search Calendar Events</a></li>
          
            <li><a href="/orlando/EventSearch?feature=Staff%20Pick" >This Week's Selections</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/FreeStuff" 
               target="_">
              Giveaways
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273884">Contests</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2361070">25th Anniversary BIG Prizes</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2199663">Cool Stuff</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273883">Swag</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2361151">Concert Tickets</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Events</h3>
        

        <ul class="sublinkGroup">
          

          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/special-issues/Section?oid=2240413" 
               target="_">
              Special Issues
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/annual-manual/Category?oid=2240488">Annual Manual</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/summer-guide/Category?oid=2240491">Summer Guide</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/bite/Category?oid=2240489">Bite</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/newcomers-guide/Category?oid=2240498">Newcomers Guide</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/fall-guide/Category?oid=2240492">Fall Guide</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/BestOf" 
               target="_">
              Best of Orlando
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2018">2018</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2017">2017</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2016">2016</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2015">2015</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/ArticleArchives" 
               target="_">
              Search
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/ArticleArchives" >Search Authors or Stories</a></li>
          
            <li><a href="/orlando/IssueArchives" >Search Issues</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Sponsored Links</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="http://www.407apartments.com/" target="_blank">Orlando Apartments</a></li>
          
            <li><a href="http://www.407apartments.com/ucf-apartments.aspx" target="_blank">UCF Apartments</a></li>
          
            <li><a href="https://www.livesomewhere.com/ucf" target="_blank">UCF Off Campus Housing</a></li>
          
            <li><a href="http://www.407apartments.com/orlando-apartments/Winter-Park-Apartments" target="_blank">Winter Park Apartments</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/AboutOrlandoWeekly/Page" 
               target="_">
              About Us
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/AboutOrlandoWeekly/Page" >Staff Directory</a></li>
          
            <li><a href="/orlando/Policies/Page" >Policies</a></li>
          
            <li><a href="/orlando/FAQs/Page" >FAQ</a></li>
          
            <li><a href="/orlando/AboutOrlandoWeekly/Page" >Contact Us</a></li>
          
            <li><a href="/orlando/WorkForUs/Page" >Work for Us</a></li>
          
            <li><a href="/orlando/Wheretofindus/Page" >Where to Find Us</a></li>
          
            <li><a href="/orlando/AdvertiseWithOrlandoWeekly/Page" >Advertise</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Social Media</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="https://www.facebook.com/orlandoweekly" target="_blank">Facebook</a></li>
          
            <li><a href="https://twitter.com/OrlandoWeekly" target="_blank">Twitter</a></li>
          
            <li><a href="http://instagram.com/orlandoweekly/" target="_blank">Instagram</a></li>
          
        </ul>

      </div>
    

  </div><!-- End .linkGroupColumn -->
</div>
<!-- End #FooterNavigation -->
<div id="footerCopyright">
  <p>
   &copy; 2018
   Orlando Weekly 
   <br><br>
   Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div>


  <img src="/foundation/images/icons/pixel.gif?oid=22229890" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdBackground" class="Closer BlogPost ">
  <!-- /43707298/ORL_Reskin -->
          <div id="div-gpt-ad-orl_reskin" style="" data-content-type="ad" data-slot="/43707298/ORL_Reskin" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_reskin');
                  });
              </script>
          </div>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  


