
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">
<head>
<meta name="viewport" content="width=1000">
<meta name="layout" content="Content Default" />
<meta name="oid" content="31058282" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="imagetoolbar" content="no" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=61c191fc9055ada9066b887bdb5236ca" />
<link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=61c191fc9055ada9066b887bdb5236ca" />
<link rel="stylesheet" type="text/css" href="/styles/components.css?cb=61c191fc9055ada9066b887bdb5236ca" />
<link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=61c191fc9055ada9066b887bdb5236ca" />
<script src="/foundation/fontawesome/js/brands.min.js" async></script>
<script src="/foundation/fontawesome/js/solid.min.js" async></script>
<script src="/foundation/fontawesome/js/regular.min.js" async></script>
<script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
<script src="/foundation/fontawesome/js/light.min.js" async></script>
<script src="/foundation/fontawesome/js/duotone.min.js" async></script>
<style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>
<link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
<!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
<!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
<!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
<!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->
<link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Whole Site" href="https://www.orlandoweekly.com/orlando/Rss.xml" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: News + Views Section" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2240408" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Orlando Area News" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=31065036" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Comments on Florida looks to bar doctor from practicing for five years after undercover agents lied to him to get medical marijuana" href="https://www.orlandoweekly.com/orlando/Rss.xml?id=comments&amp;oid=31058282" />
<script>window.__FBAPIv__ = 'v3.2'</script>
<!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
<script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
<script src="/foundation/scripts/common.js?cb=4f967403aab512f10ee08b012993a889"></script>
<script src="/foundation/scripts/desktop-bundle.js?cb=4f967403aab512f10ee08b012993a889"></script>
<link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
<script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>
<script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.orlandoweekly.com\/orlando\/Profile", "https:\/\/posting.orlandoweekly.com\/orlando\/MyProfile");
  </script>
<meta name="google-signin-client_id" content="297405715145-bcr8a9m9emb8a84o6qbd7utuefrfoknk.apps.googleusercontent.com">

<script type="text/javascript" async=true>
  (function() {
    var host = window.location.hostname;
    var element = document.createElement('script');
    var firstScript = document.getElementsByTagName('script')[0];
    var url = 'https://quantcast.mgr.consensu.org'
      .concat('/choice/', 'ECpz7gxYXdCG2', '/', host, '/choice.js')
    var uspTries = 0;
    var uspTriesLimit = 3;
    element.async = true;
    element.type = 'text/javascript';
    element.src = url;

    firstScript.parentNode.insertBefore(element, firstScript);

    function makeStub() {
      var TCF_LOCATOR_NAME = '__tcfapiLocator';
      var queue = [];
      var win = window;
      var cmpFrame;

      function addFrame() {
        var doc = win.document;
        var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

        if (!otherCMP) {
          if (doc.body) {
            var iframe = doc.createElement('iframe');

            iframe.style.cssText = 'display:none';
            iframe.name = TCF_LOCATOR_NAME;
            doc.body.appendChild(iframe);
          } else {
            setTimeout(addFrame, 5);
          }
        }
        return !otherCMP;
      }

      function tcfAPIHandler() {
        var gdprApplies;
        var args = arguments;

        if (!args.length) {
          return queue;
        } else if (args[0] === 'setGdprApplies') {
          if (
            args.length > 3 &&
            args[2] === 2 &&
            typeof args[3] === 'boolean'
          ) {
            gdprApplies = args[3];
            if (typeof args[2] === 'function') {
              args[2]('set', true);
            }
          }
        } else if (args[0] === 'ping') {
          var retr = {
            gdprApplies: gdprApplies,
            cmpLoaded: false,
            cmpStatus: 'stub'
          };

          if (typeof args[2] === 'function') {
            args[2](retr);
          }
        } else {
          queue.push(args);
        }
      }

      function postMessageEventHandler(event) {
        var msgIsString = typeof event.data === 'string';
        var json = {};

        try {
          if (msgIsString) {
            json = JSON.parse(event.data);
          } else {
            json = event.data;
          }
        } catch (ignore) {}

        var payload = json.__tcfapiCall;

        if (payload) {
          window.__tcfapi(
            payload.command,
            payload.version,
            function(retValue, success) {
              var returnMsg = {
                __tcfapiReturn: {
                  returnValue: retValue,
                  success: success,
                  callId: payload.callId
                }
              };
              if (msgIsString) {
                returnMsg = JSON.stringify(returnMsg);
              }
              event.source.postMessage(returnMsg, '*');
            },
            payload.parameter
          );
        }
      }

      while (win) {
        try {
          if (win.frames[TCF_LOCATOR_NAME]) {
            cmpFrame = win;
            break;
          }
        } catch (ignore) {}

        if (win === window.top) {
          break;
        }
        win = win.parent;
      }
      if (!cmpFrame) {
        addFrame();
        win.__tcfapi = tcfAPIHandler;
        win.addEventListener('message', postMessageEventHandler, false);
      }
    };

    makeStub();

    var uspStubFunction = function() {
      var arg = arguments;
      if (typeof window.__uspapi !== uspStubFunction) {
        setTimeout(function() {
          if (typeof window.__uspapi !== 'undefined') {
            window.__uspapi.apply(window.__uspapi, arg);
          }
        }, 500);
      }
    };

    var checkIfUspIsReady = function() {
      uspTries++;
      if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
        console.warn('USP is not accessible');
      } else {
        clearInterval(uspInterval);
      }
    };

    if (typeof window.__uspapi === 'undefined') {
      window.__uspapi = uspStubFunction;
      var uspInterval = setInterval(checkIfUspIsReady, 6000);
    }
  })();
  </script>


<style>
    .ccpaNotice {
      clear: both;
      border: 2px solid #D0D1D3;
      padding: 13px;
      font-size: 16px;
    }
  </style>
<script>
  if (typeof window.__uspapi === 'function') {
    window.__uspapi('uspPing', 1, function(obj, status) {
      if (status && obj.mode.includes('USP') && obj.jurisdiction.includes(obj.location.toUpperCase())) {
        var message = document.createElement("p");
        message.setAttribute("class", "ccpaNotice");
        message.innerHTML = 'Our website uses technical, analytical, marketing, and preference cookies to provide the best experience for our readers and to give us information about how our site is used. You may request that your data not be shared with third parties here: ' 
          + `<a href="#" onclick="window.__uspapi('displayUspUi');"` 
          + '>Do Not Sell My Data</a>' 
          + '.';
        document.getElementById('gridFooter').append(message);
        window.__uspapi('setUspDftData', 1, function(obj, status) {
          if (!status) {
              console.log("Error: USP string not updated!")
          }
        });
     }
    });
  }
  </script>


<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>


<link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link href="https://fonts.googleapis.com/css2?family=Lato:wght@400;700&family=Montserrat:wght@400;700&family=Open+Sans+Condensed:wght@300;700&family=Titillium+Web:wght@400;700&display=swap" rel="stylesheet">

<style>
:root {
 --pub-primary-color:#F7941E;
 --pub-link-color:#F7941E;
  --real-1-primary-color: #F7941E;
  --real-1-secondary-color: #F7941E66;
}
</style>
<meta name="google-site-verification" content="06A5Yh5mu5xlqSkqBOzGlxA6P_yfmltTp1l0ssgpOBk" />

<meta name="google-site-verification" content="9htXi1AfaHrVLNGB2JDLtdpWEFyb-JOf5ngnP_95Zuk" />
<meta name="google-site-verification" content="s4GBlkstS6PKQwO_gDlOGL8jFPmeuL_d3m60wxOBQR0" />
<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
<script type='text/javascript'>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</script>

<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-585470-1', 'orlandoweekly.com');
    ga('set', 'anonymizeIp', true);
    ga('send', 'pageview', { 'dimension1': 'newsfeatures', 'dimension2': 'news' });
    </script>

<script>
  var Euclid = Euclid || {}
  Euclid.OrlandoWeekly = Euclid.OrlandoWeekly || {}
  Euclid.OrlandoWeekly.vertical = Euclid.OrlandoWeekly.vertical || 'arts'
  </script>
<script>
  (function() {
  if(document.getElementById('commitchange-script')) return;
  var npo = 5276;
  var script = document.createElement('script');
  var first = document.getElementsByTagName('script')[0];
  script.setAttribute('data-npo-id', npo);
  script.id = 'commitchange-script';
  script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
  first.parentNode.insertBefore(script, first);
  })();
  </script>
<style>
:root {
 --pub-primary-color:#F7941E;
 --pub-link-color:#F7941E;
}
</style>
<link rel="shortcut icon" href="/favicon.ico" />
<meta name="title" content="Florida looks to bar doctor from practicing for five years after undercover agents lied to him to get medical marijuana | Orlando Area News | Orlando | Orlando Weekly" />
<meta name="description" content="State health officials are asking an administrative law judge to permanently ban a Tallahassee physician from ordering medical marijuana for patients, suspend his medical license..." />
<meta name="keywords" content="medical marijuana, entrapment, Florida, doctors, marijuana, Bloggytown, News, Blog, Culture, Dining, Events" />
<title>Florida looks to bar doctor from practicing for five years after undercover agents lied to him to get medical marijuana | Orlando Area News | Orlando | Orlando Weekly</title>
<meta name="date" content="2022-02-22 10:39:00" />
<meta name="author" content="Dara Kam, NSF">
<meta name="news_keywords" content="medical marijuana, entrapment, florida, doctors, marijuana, bloggytown, news, blog, culture, dining" />
<link rel="image_src" href="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31058302/adobestock_73136989.jpeg" />
<meta name="thumbnail" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31058302/adobestock_73136989.jpeg" />
<link rel="canonical" href="https://www.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content?oid=31058282" />
<link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content?oid=31058282" />
<link rel="amphtml" href="https://www.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content?oid=31058282&media=AMP+HTML" />
<meta property="og:url" content="https://www.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content?oid=31058282" />
<meta property="fb:app_id" content="1527160917534695" />
<meta property="og:site_name" content="Orlando Weekly" />
<meta property="og:title" content="Florida looks to bar doctor from practicing for five years after undercover agents lied to him to get medical marijuana" />
<meta property="og:image" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31058302/adobestock_73136989.jpeg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="516" />
<meta property="og:description" content="State health officials are asking an administrative law judge to permanently ban a Tallahassee physician from ordering medical marijuana for patients, suspend his medical license..." />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31058302/adobestock_73136989.jpeg">
<meta name="twitter:site" content="@orlandoweekly">
<meta name="twitter:title" content="Florida looks to bar doctor from practicing for five years after undercover agents lied to him to get medical marijuana">
<meta name="twitter:description" content="State health officials are asking an administrative law judge to permanently ban a Tallahassee physician from ordering medical marijuana for patients, suspend his medical license...">

<script type="application/ld+json">
          {
            "mainEntityOfPage": {
              "@type": "WebPage",
              "@id":"https:\/\/www.orlandoweekly.com\/orlando\/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana\/Content?oid=31058282"
            },
            "headline": "Florida looks to bar doctor from practicing for five years after undercover agents lied to him to get medical marijuana",
            
              "description": "State health officials are asking an administrative law judge to permanently ban a Tallahassee physician from ordering medical marijuana for patients, suspend his medical license for five years and impose a $10,000 fine, after an investigation that included undercover agents posing as patients. The Department of Health’s proposed penalties against physician Joseph Dorn – who has practiced in Florida for more than three decades – date back to a 2019 complaint alleging that the physician violated state law by failing to conduct physical examinations of “Patient O.G.” and “Patient B.D.” The complaint also accused Dorn of employing a “trick or scheme” in the practice of medicine.",
            
            "image": {
              "url": "https:\/\/media2.orlandoweekly.com\/orlando\/imager\/u\/original\/31058302\/adobestock_73136989.jpeg",
              "width": 1000,
              "height": 860,
              "@type": "ImageObject"
            },
            "datePublished": "2022-02-22T10:39:00",
            "dateModified": "2022-02-23T11:43:42",
            
              
              "author": {
                "name": "Dara Kam, NSF",
                "url": "https:\/\/www.orlandoweekly.com\/author\/dara-kam-nsf",
                "@type": "Person"
              },
            
            "publisher": {
              "name": "Orlando Weekly",
              
                
                
                
                "logo": {
                  "url": "https:\/\/www.orlandoweekly.com\/imager\/b\/google-amp-logo\/808579\/5643\/OrlandoWeekly_fbook.jpg",
                  "width": 117,
                  "height": 60,
                  "@type": "ImageObject"
                },
              
              "@type": "Organization"
            },
            "@context": "https://schema.org",
            "@type": "NewsArticle"
          }
        </script>
</head>
<body id="Content" class="ContentDefault Iapetus10Zone newsfeatures OrlandoAreaNews">

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KQ22CZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KQ22CZ');</script>

<div id="fb-root"></div>
<script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>
<script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>

<div id="gridLeader">
<div id="AdInterstitial" class="Leader ContentDefault ">

<div id="div-gpt-ad-orl_desktopinterstitial" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopinterstitial');
                });
              </script>
</div>
</div>
<style>
  /*-- desktop styles --*/
   #AdBackground {top:50px!important;}
  .nominate-bar {
    background: #e27a00;
    z-index: 1;
    overflow:hidden;
    width: 100%;
    padding: 0;
    text-transform: uppercase;
    text-align: center;
    color: #fff;
    font-size: 18px;
  }
  .nominate-bar div {
    border: 1px solid #FFBF6E;
    margin: 5px auto;
    max-width: 1000px;
      color:#fff;
}
  .nominate-bar a {
    color:#fff;
  }

  /* Adjust the ad positioning */
  body {
    background-position-y: 39px !important;
  }
  </style>
<div class="nominate-bar">
<div>
<p><a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page">Support local journalism. Join the Orlando Weekly Press Club.</a></p>
</div>
</div>
</div>
<div id="gridClamp">

<div id="gridHeader">
<div id="MobileDetect" class="GlobalHeader ContentDefault " style="display:none">
Switch to the <a href="https://m.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content?oid=31058282" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
</div>
<script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
<div id="LogoHeader" class="GlobalHeader ContentDefault ">
<div id="logoLeft">
<a href="https://www.orlandoweekly.com/" title="Orlando Weekly">Orlando Weekly</a>
</div>
<div id="leaderboardAdHeader">

<div id="div-gpt-ad-orl_728x90-1" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-1');
                });
              </script>
</div>
</div>
</div>

<div id="NavigationHorizontal" class="GlobalHeader ContentDefault  ">
<ul id="mainNav">
<li class="first" id="NavItem_NewsViews">
<a href="https://www.orlandoweekly.com/orlando/news-and-features/Section?oid=2240408" class="subnav_link" id="SNAVL_NewsViews">News + Views</a>
</li>
<li class="" id="NavItem_ArtsCulture">
<a href="https://www.orlandoweekly.com/orlando/arts-and-culture/Section?oid=2240407" class="subnav_link" id="SNAVL_ArtsCulture">Arts + Culture</a>
</li>
<li class="" id="NavItem_FoodDrink">
<a href="https://www.orlandoweekly.com/orlando/food-and-drink/Section?oid=2240409" class="subnav_link" id="SNAVL_FoodDrink">Food + Drink</a>
</li>
<li class="" id="NavItem_Music">
<a href="https://www.orlandoweekly.com/orlando/music/Section?oid=2240410" class="subnav_link" id="SNAVL_Music">Music</a>
</li>
<li class="" id="NavItem_Screens">
<a href="https://www.orlandoweekly.com/orlando/movies/Section?oid=2240411" class="subnav_link" id="SNAVL_Screens">Movies</a>
</li>
<li class="" id="NavItem_Calendar">
<a href="https://www.orlandoweekly.com/orlando/EventSearch" class="subnav_link" id="SNAVL_Calendar">Calendar</a>
</li>
<li class="" id="NavItem_BestOfOrlando">
<a href="https://www.orlandoweekly.com/orlando/BestOf" class="subnav_link" id="SNAVL_BestOfOrlando">Best Of Orlando&reg;</a>
</li>
<li class="" id="NavItem_Slideshows">
<a href="http://photos.orlandoweekly.com">Slideshows</a>
</li>
<li class="last" id="NavItem_Support">
<a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" class="subnav_link" id="SNAVL_Support">Support</a>
</li>
</ul>
<h3 class="hidden">Browse News + Views</h3>
<ul class="subnav_content" id="SNAV_NewsViews" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/orlando-area-news/Category?oid=31065036" title="">Orlando Area News</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/pulse/Topics?oid=31060458" title="">Pulse</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413" title="">Orlando Guides</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=this%20week" title="">Digital Issue</a>
</li>
<li class="">
<a href="https://photos.orlandoweekly.com/category/newsslideshows/" title="">News Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Arts + Culture</h3>
<ul class="subnav_content" id="SNAV_ArtsCulture" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/arts-stories-interviews/Category?oid=2240434" title="">Arts Stories + Interviews</a>
</li>
<li class="">
<a href="https://photos.orlandoweekly.com/category/artsslideshows/" title="">Arts + Culture Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Food + Drink</h3>
<ul class="subnav_content" id="SNAV_FoodDrink" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/food-news/Category?oid=31065305" title="">Food News</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/drinking-bars/Category?oid=31065312" title="">Drinking + Bars</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/restaurant-review/Category?oid=2240450" title="">Restaurant Reviews</a>
</li>
<li class="">
 <a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationSection=2282258" title="">Find a Restaurant</a>
</li>
<li class="">
<a href="https://photos.orlandoweekly.com/category/foodslideshows/" title="">Food + Drink Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Music</h3>
<ul class="subnav_content" id="SNAV_Music" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/music-stories-interviews/Category?oid=2240462" title="">Music Stories + Interviews</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/orlando-music-news/Category?oid=31065388" title="">Orlando Music News</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/live-music-picks-previews/Category?oid=31065380" title="">Live Music Picks + Previews</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&sortType=date&v=d" title="">Find a Concert</a>
</li>
<li class="">
<a href="https://photos.orlandoweekly.com/category/musicslideshows/" title="">Music Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Movies</h3>
<ul class="subnav_content" id="SNAV_Screens" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/movie-reviews/Category?oid=31065358" title="">Movie Reviews</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/streaming/Category?oid=31065342" title="">Streaming</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationCategory=2282370&sortType=name" title="">Find a Theater</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/MovieTimes" title="">Movie Times</a>
</li>
</ul>
<h3 class="hidden">Browse Calendar</h3>
<ul class="subnav_content" id="SNAV_Calendar" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&v=d" title="">Today&#39;s Events</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&sortType=date&v=d" title="">This Weekend</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?feature=Free&sortType=date&v=d" title="">Free Events</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/Events/AddEvent" title="">Submit an Event</a>
</li>
</ul>
<h3 class="hidden">Browse Best Of Orlando&reg;</h3>
<ul class="subnav_content" id="SNAV_BestOfOrlando" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2255299" title="">Arts &amp; Culture</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240483" title="">Food &amp; Drink</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240486" title="">Goods &amp; Services</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240482" title="">Local Color</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240485" title="">Music &amp; Nightlife</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240487" title="">Sports &amp; Recreation</a>
</li>
</ul>
<h3 class="hidden">Browse Support</h3>
<ul class="subnav_content" id="SNAV_Support" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" title="">Support</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page" title="">Subscribe</a>
</li>
<li class="">
<a href="https://mediakit.orlandoweekly.com/" target="_blank" title="">Advertise</a>
</li>
<li class="">
<a href="http://instagram.com/orlandoweekly/" target="_blank" title="">Instagram</a>
</li>
<li class="">
<a href="https://twitter.com/orlandoweekly" target="_blank" title="">Twitter</a>
</li>
<li class="">
<a href="https://www.facebook.com/orlandoweekly" target="_blank" title="">Facebook</a>
</li>
</ul>
</div>
<script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>

<div id="AdPencilBar" class="GlobalHeader ContentDefault ">

<div id="div-gpt-ad-orl_970x90" style="" data-content-type="ad" data-slot="/43707298/ORL_970x90" data-output="asynchronous" data-width="970" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_970x90');
                });
              </script>
</div>
</div>
</div>
<div id="gridMain">
<div id="gridFrame">
<div id="gridSpanningFeature">
<div id="StoryBreadcrumb" class="SpanningFeature ContentDefault  news___views orlando_area_news">
<p class="issueInfo ">
<span class="date">
<a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=31059070">February 22, 2022</a>
</span>
<a href="https://www.orlandoweekly.com/orlando/news-views/Section?oid=2240408">News + Views</a>
&raquo; <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=31065036">Orlando Area News</a>
</p>
</div> 
<style>
    div.l0.last div:first-child {float:right;}
  </style>
<div id="ToolBarHorizontal" class="SpanningFeature ContentDefault ">
<div style="width:100%; height: 20px;">
<div class="l0 first" style="width:20%; height: 20px; float:left;">
<fb:like href="https://www.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content?oid=31058282" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:20%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content%3Foid%3D31058282&text=Florida%20looks%20to%20bar%20doctor%20from%20practicing%20for%20five%20years%20after%20undercover%20agents%20lied%20to%20him%20to%20get%20medical%20marijuana" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:20%; height: 20px; float:left;">
<a class="emailAction" title="Email" href="https://posting.orlandoweekly.com/orlando/Tools/EmailFriend?oid=31058282" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>
</div> <div class="l0" style="width:20%; height: 20px; float:left;">
<a class="printAction" title="Print" href="https://www.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content?mode=print&amp;oid=31058282" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:20%; height: 20px; float:right;">
<div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-54d38c2c42ccebb5" addthis:url="https://www.orlandoweekly.com/orlando/florida-looks-to-bar-doctor-from-practicing-for-five-years-after-undercover-agents-lied-to-him-to-get-medical-marijuana/Content?oid=31058282" addthis:title="Florida looks to bar doctor from practicing for five years after undercover agents lied to him to get medical marijuana" addthis:description="" class="addthis_button_compact">Share</a></div>
<script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54d38c2c42ccebb5", true);
  </script>
</div>
</div>
</div>
<script type="text/javascript">
      Foundation.Tools.setup();
    </script>
<div id="StoryHeader" class="SpanningFeature ContentDefault   ">
<div class="storyHead">
<h1 class="headline headline-31058282">Florida looks to bar doctor from practicing for five years after undercover agents lied to him to get medical marijuana&nbsp;</h1>
<cite class="byline">
<span class="byAttribute">By</span> <a href="https://www.orlandoweekly.com/author/dara-kam-nsf" rel="author">Dara Kam, NSF</a>
</cite>
</div>
</div> 
<div id="StoryLayout" class="SpanningFeature ContentDefault ">
<div id="storyBody" class="page1">
<div class="contentImageCenter" style="overflow:hidden;"> <span class="clicktozoom">click to enlarge</span> <a href="https://media2.orlandoweekly.com/orlando/imager/u/original/31058302/adobestock_73136989.jpeg" class="zoomable" rel="contentImg_gal-31058282" title="ADOBE"> <img src="https://media2.orlandoweekly.com/orlando/imager/u/blog/31058302/adobestock_73136989.jpeg?cb=1645623987" width="660" height="568" alt="ADOBE" srcset="" /> </a> <ul style="width:660px;overflow:hidden;margin-left:auto;margin-right:auto;"> <li class="imageCredit"> Adobe </li> </ul> </div><br>
State health officials are asking an administrative law judge to permanently ban a Tallahassee physician from ordering medical marijuana for patients, suspend his medical license for five years and impose a $10,000 fine, after an investigation that included undercover agents posing as patients.
<br>
<br>
The Department of Health’s proposed penalties against physician Joseph Dorn – who has practiced in Florida for more than three decades – date back to a 2019 complaint alleging that the physician violated state law by failing to conduct physical examinations of “Patient O.G.” and “Patient B.D.” The complaint also accused Dorn of employing a “trick or scheme” in the practice of medicine.
<br><br>

<div class="inlineComponent AdNativeInline">
<div id="AdNativeInline" class="SpanningFeature AdNativeInline ">

<div id="div-gpt-ad-orl_desktopnative-2" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-2');
                });
              </script>
</div>
</div>
</div>
<br>
<br>
Administrative Law Judge W. David Watkins, who held a hearing in Dorn’s case in October, is weighing proposed recommended orders submitted Thursday by the health department and Dorn’s lawyer, Ryan Andrews.
<br>
<br>
Andrews maintains that the doctor didn’t do anything wrong.
<br>
<br>
“Ironically, the only trick or scheme employed in this case was that of petitioner (the agency), by intentionally sending B.D. and O.G. to Dr. Dorn to trick him into ordering medical marijuana for B.D. and O.G. based on their presentation of unlawful falsehoods concerning their qualifying conditions (i.e., PTSD and anxiety, inter alia),” Andrews wrote in his proposed recommended order.
<br>
<br>
Health officials accused Dorn of failing to “appropriately vet his patients” and follow a 2017 law requiring physicians to use certain procedures before determining patients are eligible for medical marijuana, such as deciding that its use would outweigh potential health risks.
<br>
<br>
“Instead of recognizing this responsibility, respondent (Dorn) used his designation as a qualified physician to liberally qualify patients to receive medical marijuana by only performing perfunctory consultations and ignoring many of the requirements imposed by the Legislature,” the agency’s lawyers wrote in their proposed recommended order.
<br>
<br>
But Andrews argued the Department of Health “offered no evidence whatsoever to support its allegation” that Dorn failed to determine that the health benefits of marijuana outweighed the risks for O.G. and B.D. Andrews noted the department does “not know what the health benefits or risks are of medical marijuana,” which he called “shocking in light of the fact that DOH is the agency charged with regulating qualifying physicians and medical marijuana.”
<br>
<br>
<div class="content connection "> <h5> <span class="typeHeader">Related</span> <a href="https://www.orlandoweekly.com/orlando/judge-rules-that-online-orders-of-medical-marijuana-are-ok-in-florida/Content?oid=30202509">Judge rules that online orders of medical marijuana are OK in Florida </a> </h5> <a href="https://www.orlandoweekly.com/orlando/judge-rules-that-online-orders-of-medical-marijuana-are-ok-in-florida/Content?oid=30202509"> <div class="image"> <img class="image" src="https://media2.orlandoweekly.com/orlando/imager/u/square/30202514/adobestock_94181814.jpeg" width="120" height="120" alt="" title="" /> </div> <div class="info"> <div class="headline">Judge rules that online orders of medical marijuana are OK in Florida</div> <div class="author">By Dara Kam, News Service of Florida</div> <div class="category">Orlando Area News</div> </div> </a> </div>
<br>
The complaint against Dorn involves department employees “who lied to Dr. Dorn about their conditions and were actively trying to be evasive and untruthful” but doesn’t include facts from any of the doctor’s many genuine patients, Andrews wrote.
<br>
<br>
The state agency’s “position is that because O.G. and B.D. were lying about their conditions, it was impossible for Dr. Dorn to have concluded that the benefits of medical marijuana outweighed the risks for O.G. and B.D., placing Dr. Dorn in a position of ‘heads I win tails you lose’ in favor of the health department,” he argued.
<br>
<br>
The 2017 law, aimed at carrying out a constitutional amendment that broadly legalized medical marijuana, requires doctors to undergo training to be qualified by the state to order cannabis for patients and lays out requirements for physicians before certifying that patients are eligible for the treatment. The law also makes it a crime for patients to lie to doctors about their conditions to obtain marijuana.
<br>
<br>
<div class="content connection "> <h5> <span class="typeHeader">Related</span> <a href="https://www.orlandoweekly.com/orlando/florida-based-marijuana-retailer-is-now-the-largest-in-the-nation/Content?oid=30083879">Florida-based marijuana retailer is now the largest in the nation </a> </h5> <a href="https://www.orlandoweekly.com/orlando/florida-based-marijuana-retailer-is-now-the-largest-in-the-nation/Content?oid=30083879"> <div class="image"> <img class="image" src="https://media2.orlandoweekly.com/orlando/imager/u/square/30083885/trulieve.jpg" width="120" height="120" alt="" title="" /> </div> <div class="info"> <div class="headline">Florida-based marijuana retailer is now the largest in the nation</div> <div class="author">By Dara Kam, News Service of Florida</div> <div class="category">Orlando Area News</div> </div> </a> </div>
<br>
The complaint against Dorn centers on visits by investigators Brent Johnson, who posed as “Patient B.D.,” and Ben Lanier, who posed as “Patient O.G.”
<br>
<br>
In November 2017, Johnson told the physician he had anxiety, difficulty sleeping, cold sweats, back pain and leg cramps following a car accident eight years earlier. According to the complaint, Dorn also entered other symptoms associated with PTSD in B.D.’s patient record and approved him for medical marijuana.
<br>
<br>
During a visit with Dorn five months later, Lanier presented a handwritten medical record saying that O.G had been diagnosed with post-traumatic stress disorder by the military a decade earlier.
<br>
<br>
Lanier, who was one of the state’s witnesses during the October hearing, said he told Dorn he had anxiety after serving in Kandahar, Afghanistan, where the doctor’s son had served in the military.
<br>
<br>
<div class="content connection "> <h5> <span class="typeHeader">Related</span> <a href="https://www.orlandoweekly.com/orlando/best-medical-marijuana-physician-or-clinic/BestOf?oid=29860371">Best Medical Marijuana Physician or Clinic: <span class="subHeadline">Marijuana Doctor</span> </a> </h5> <a href="https://www.orlandoweekly.com/orlando/best-medical-marijuana-physician-or-clinic/BestOf?oid=29860371"> <div class="image"> <img class="image" src="https://media1.orlandoweekly.com/orlando/imager/u/square/29860370/gs_rp_1.jpg" width="120" height="120" alt="" title="" /> </div> <div class="info"> <div class="headline">Best Medical Marijuana Physician or Clinic</div> <div class="subHeadline">Marijuana Doctor</div> <div class="category">Goods & Services</div> </div> </a> </div>
<br>
O.G. provided to Dorn a “single-page, handwritten, barely legible document purporting to be a medical note from Camp Pendleton, dated Dec. 19, 2008,” the state’s proposed order said, adding that the investigator “could not read most of the note and did not know more about its content outside of it stating that he had symptoms of PTSD.”
<br>
<br>
Had Dorn inquired further into O.G.’s purported military experience, “it would have been quickly revealed that O.G. was not prepared to field even the simplest questions,” health officials argued.
<br>
<br>
But Andrews maintained that Dorn “had a reasonable belief” that O.G. had PTSD and that the physician “went through a full assessment” of the undercover agent’s medical history.
<br>
<br>
“Dr. Dorn did not rush O.G. out of the consultation. … Dr. Dorn did not refuse to answer any of O.G.’s questions. Dr. Dorn did not cut O.G. off or prevent him from asking or answering questions,” he argued.
<br>
<br>
The state also accused Dorn of failing to conduct a “physical examination” of the agents before deciding they were eligible for treatment, as required by the 2017 law.
<br>
<br>
But Andrews argued that the doctor performed a “visual examination” of the fake patients and that nothing in the law requires a hands-on evaluation.
<br>
<br>
The issue arose during Office of Medical Marijuana Use Director Chris Ferguson’s testimony at the October hearing, where Andrews grilled him about the law.
<br>
<br>
Ferguson’s office is responsible for implementing the law, but the director “has no idea whether a qualifying physician is required to physically touch a patient, even though the statute explicitly does not require it,” Andrews wrote.
<br>
<br>
But the Department of Health said in its proposed order that Ferguson’s office “does not regulate medical professionals and is not responsible for implementing or enforcing the allegations” in the complaint against Dorn.
<br>
<br>
“It would be inappropriate to rely on Mr. Ferguson’s lay opinion regarding his interpretation of these statutes,” they wrote.
<br>
<br>
<br>
<br>
– <br>
<i>Stay on top of Central Florida news and views with our weekly <a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page" target="_blank">newsletters</a>, and consider <a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" target="_blank">supporting this free publication</a>. Our small but mighty team is working tirelessly to bring you Central Florida news, and every little bit helps.</i>
</div>
</div> 

<link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=010f1886d9a686107e57358b9e6bc99e" />

<script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=010f1886d9a686107e57358b9e6bc99e"></script>
<script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=010f1886d9a686107e57358b9e6bc99e"></script>
<style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>
<div id="StoryTags" class="SpanningFeature ContentDefault ">
<p class="tags">Tags: <a href="/orlando/ArticleArchives?topic=2265199" rel="tag">Bloggytown</a>, <a href="/orlando/ArticleArchives?tag=medical%20marijuana" rel="tag">medical marijuana</a>, <a href="/orlando/ArticleArchives?tag=entrapment" rel="tag">entrapment</a>, <a href="/orlando/ArticleArchives?tag=Florida" rel="tag">Florida</a>, <a href="/orlando/ArticleArchives?tag=doctors" rel="tag">doctors</a>, <a href="/orlando/ArticleArchives?tag=marijuana" rel="tag">marijuana</a></p>
</div> 
<style>
    #SendaLettertotheEditor {
      border:1px solid #D0D1D3;
      padding:10px 10px 10px 120px;
      min-height:100px;
      background-image:url('/binary/5643/OrlandoWeekly_fbook.jpg');
      background-position:10px 10px;
      background-repeat:no-repeat;
      background-size:100px auto;
    }
      #SendaLettertotheEditor p {
        margin-top:1em;
        margin-bottom:1em;
      }
        #SendaLettertotheEditor p:first-child {
          margin-top:0;
        }
        #SendaLettertotheEditor p:last-child {
          margin-bottom:0;
        }
  </style>
<div id="SendaLettertotheEditor" class="SpanningFeature ContentDefault ">
<p>
We welcome readers to submit letters regarding articles and content in <i>Orlando Weekly</i>. Letters should be a minimum of 150 words, refer to content that has appeared on <i>Orlando Weekly</i>, and must include the writer's full name, address, and phone number for verification purposes. No attachments will be considered. Writers of letters selected for publication will be notified via email. Letters may be edited and shortened for space.
</p>
<p>
Email us at <a href="/cdn-cgi/l/email-protection#6c0a0909080e0d0f0749585c031e000d0208031b0909070015420f0301531f190e06090f185120091818091e495e5c1803495e5c180409495e5c29080518031e"><span class="__cf_email__" data-cfemail="44222121202625272f042b3628252a202b3321212f283d6a272b29">[email&#160;protected]</span></a>.
</p>
</div>
<div id="DonationArticleWidget" class="SpanningFeature ContentDefault " style="background-color: rgba(250, 250, 153, 1); padding: 10px;">
<center><p><big><b>Support Local Journalism.</b></big><br>
<big><b>Join the <i>Orlando Weekly</i> Press Club</b></big><br><br>
Local journalism is information. Information is power. And we believe <b>everyone</b> deserves access to accurate independent coverage of their community and state. Our readers helped us continue this coverage in 2020, and we are so grateful for the support.
<br><br>
Help us keep this coverage going in 2021. Whether it's a one-time acknowledgement of this article or an ongoing membership pledge, your support goes to local-based reporting from our small but mighty team.
<br><br>
<big><b><a href="https://trypico.com/orlandoweekly?short_code=9ede46xb">Join the Orlando Weekly Press Club for as little as $5 a month.</a>
</b></big>
</center>
</div>
<div id="PreviousNextInCategory" class="SpanningFeature ContentDefault ">
<div class="prevNext">
<a href="https://www.orlandoweekly.com/orlando/florida-senate-prepares-to-hear-15-week-abortion-ban-proposal/Content?oid=31058279" class="prev" title="previous">&laquo;&nbsp;Florida Senate prepares to hear 15-week abortion ban proposal</a>
&nbsp;&nbsp;|&nbsp;&nbsp;
<a href="https://www.orlandoweekly.com/orlando/williston-rep-pushes-amendment-to-floridas-dont-say-gay-bill-that-would-force-schools-to-out-students-to-parents/Content?oid=31059068" class="next" title="next">Williston rep. pushes amendment to Florida's 'Don't Say Gay' bill that would force schools to out students to parents&nbsp;&raquo;</a>
</div>
</div>
<div id="ArchiveLink" class="SpanningFeature ContentDefault ">
<p class="moreArticles">
<a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=31065036">More Orlando Area News &raquo;</a>
</p>
</div> 
<div class="uk-root">
<div class="componentGrid-TwoZones-Auto-Expand uk-root uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-component-grid-row@m" uk-height-match data-component-grid-id="TopStoriesVideoPair">
<div class="uk-width-1-1 uk-width-auto@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<div class="ComponentZoneA Real1PlayerTrendingPairresponsive  trending-by-day uk-root fdn-margin-vert TrendingContentList comp-landing-trending" data-component-id="TrendingContentList">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Trending
</h3>
</div>
<ul class="pres-ContentListHeadline uk-list uk-list-divider">
<li class="fdn-pres-item">
<a class="uk-flex uk-flex-top" href="https://www.orlandoweekly.com/orlando/williston-rep-pushes-amendment-to-floridas-dont-say-gay-bill-that-would-force-schools-to-out-students-to-parents/Content?oid=31059068">
<p class="fdn-teaser-headline">
Williston rep. pushes amendment to Florida's 'Don't Say Gay' bill that would force schools to out students to parents
</p>
</a>
</li>
<li class="fdn-pres-item">
<a class="uk-flex uk-flex-top" href="https://www.orlandoweekly.com/orlando/paddleboarders-pass-near-massive-hammerhead-shark-in-drone-video-off-florida-beach/Content?oid=31058275">
<p class="fdn-teaser-headline">
Paddleboarders pass near massive hammerhead shark in drone video off Florida beach
</p>
</a>
</li>
<li class="fdn-pres-item">
<a class="uk-flex uk-flex-top" href="https://www.orlandoweekly.com/orlando/floridas-dont-say-gay-crt-fearmongering-bills-under-discussion-in-state-house/Content?oid=31065027">
<p class="fdn-teaser-headline">
Florida's 'Don't Say Gay', CRT fearmongering bills under discussion in state House
</p>
</a>
</li>
</ul>
</div>
</div>
<div class="uk-width-1-1 uk-width-expand@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="https://www.voqally.com/hub/app/r.js?key=73bad6b0b99988cb9a30860324a0f8a8" async></script>
</div>
</div>
</div>
<div id="RelatedStories" class="SpanningFeature ContentDefault RelatedItem">
<h3><span class="headingText">Related Stories</span></h3>
<ul class="">
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/cannabis-compounds-can-prevent-covid-19-infection-new-study-finds/Content?oid=30689743&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/30689747/adobestock_288880207_web.jpeg" alt="Cannabis compounds can prevent COVID-19 infection, new study finds" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/cannabis-compounds-can-prevent-covid-19-infection-new-study-finds/Content?oid=30689743&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Cannabis compounds can prevent COVID-19 infection, new study finds</a>
</h4>
 <div class="date"> Jan 24, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/florida-senate-moves-forward-with-bill-that-would-allow-businesses-to-sue-over-local-ordinances-that-cause-loss-of-profit/Content?oid=30674087&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/30674302/adobestock_348025619.jpeg" alt="Florida Senate moves forward with bill that would allow businesses to sue over local ordinances that cause loss of profit" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/florida-senate-moves-forward-with-bill-that-would-allow-businesses-to-sue-over-local-ordinances-that-cause-loss-of-profit/Content?oid=30674087&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Florida Senate moves forward with bill that would allow businesses to sue over local ordinances that cause loss of profit</a>
</h4>
<div class="date"> Jan 21, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/nikki-fried-faces-ethics-inquiry-over-financial-disclosures/Content?oid=30444457&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/30444461/ag-nikki-fried.jpeg" alt="Nikki Fried faces ethics inquiry over financial disclosures" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/nikki-fried-faces-ethics-inquiry-over-financial-disclosures/Content?oid=30444457&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Nikki Fried faces ethics inquiry over financial disclosures</a>
</h4>
<div class="date"> Dec 9, 2021 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/senators-call-on-president-biden-to-pardon-all-nonviolent-cannabis-offenders/Content?oid=30313456&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/30313460/shutterstock_1352515136.jpeg" alt="Senators call on President Biden to pardon all nonviolent cannabis offenders" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/senators-call-on-president-biden-to-pardon-all-nonviolent-cannabis-offenders/Content?oid=30313456&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Senators call on President Biden to pardon all nonviolent cannabis offenders</a>
</h4>
<div class="date"> Nov 15, 2021 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/florida-recreational-marijuana-amendment-gets-fundraising-boost-from-trulieve/Content?oid=30286360&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/30286608/trulieve.jpg" alt="Florida recreational marijuana amendment gets fundraising boost from Trulieve" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/florida-recreational-marijuana-amendment-gets-fundraising-boost-from-trulieve/Content?oid=30286360&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Florida recreational marijuana amendment gets fundraising boost from Trulieve</a>
</h4>
<div class="date"> Nov 10, 2021 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/judge-rules-that-online-orders-of-medical-marijuana-are-ok-in-florida/Content?oid=30202509&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/30202514/adobestock_94181814.jpeg" alt="Judge rules that online orders of medical marijuana are OK in Florida" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/judge-rules-that-online-orders-of-medical-marijuana-are-ok-in-florida/Content?oid=30202509&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Judge rules that online orders of medical marijuana are OK in Florida</a>
</h4>
<div class="date"> Oct 26, 2021 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/florida-based-marijuana-retailer-is-now-the-largest-in-the-nation/Content?oid=30083879&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/30083885/trulieve.jpg" alt="Florida-based marijuana retailer is now the largest in the nation" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/florida-based-marijuana-retailer-is-now-the-largest-in-the-nation/Content?oid=30083879&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Florida-based marijuana retailer is now the largest in the nation</a>
</h4>
<div class="date"> Oct 4, 2021 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/best-medical-marijuana-physician-or-clinic/BestOf?oid=29860371&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/29860370/gs_rp_1.jpg" alt="Best Medical Marijuana Physician or Clinic" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/best-medical-marijuana-physician-or-clinic/BestOf?oid=29860371&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Best Medical Marijuana Physician or Clinic</a>
</h4>
<div class="date"> Aug 25, 2021 </div>
</li>
</ul>
</div>
<div id="AdNativeEndofArticle" class="SpanningFeature ContentDefault ">

<div id="div-gpt-ad-orl_desktopnative-3" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-3');
                });
              </script>
</div>
</div>
<div id="RecentByTag" class="SpanningFeature ContentDefault ">
<h3 class="latestorlando_area_news">
<span class="headingText">
Speaking of...
</span>
</h3>
<ul class="moduleList">

<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/video-florida-man-steals-crossbow-by-stuffing-it-down-his-pants/Content?oid=31065367&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31065930/screenshot_2022-02-23_12.14.28_pm.png" alt="[VIDEO] Florida man steals crossbow by stuffing it down his pants" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/video-florida-man-steals-crossbow-by-stuffing-it-down-his-pants/Content?oid=31065367&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">[VIDEO] Florida man steals crossbow by stuffing it down his pants</a>
</h4>
<div class="date"> Feb 23, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/florida-transgender-bathroom-case-heard-by-federal-appeals-court/Content?oid=31065433&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31065677/adobestock_277746322.jpeg" alt="Florida transgender bathroom case heard by federal appeals court" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/florida-transgender-bathroom-case-heard-by-federal-appeals-court/Content?oid=31065433&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">Florida transgender bathroom case heard by federal appeals court</a>
</h4>
<div class="date"> Feb 23, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/floridas-dont-say-gay-crt-fearmongering-bills-under-discussion-in-state-house/Content?oid=31065027&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31065032/screenshot_2022-02-23_9.22.44_am.png" alt="Florida&#39;s &#39;Don&#39;t Say Gay&#39;, CRT fearmongering bills under discussion in state House" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/floridas-dont-say-gay-crt-fearmongering-bills-under-discussion-in-state-house/Content?oid=31065027&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">Florida's 'Don't Say Gay', CRT fearmongering bills under discussion in state House</a>
</h4>
<div class="date"> Feb 23, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=medical%20marijuana%7C%7Centrapment%7C%7CFlorida%7C%7Cdoctors%7C%7Cmarijuana" class="more">More &raquo;</a>
</li>
</ul>
</div>
<div id="LatestInCategory" class="SpanningFeature ContentDefault ">
<h3 class="latestorlando_area_news"><span class="headingText">Latest in Orlando Area News</span></h3>
<ul class="moduleList ui list grouped expanded">
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/video-florida-man-steals-crossbow-by-stuffing-it-down-his-pants/Content?oid=31065367&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31065930/screenshot_2022-02-23_12.14.28_pm.png" alt="[VIDEO] Florida man steals crossbow by stuffing it down his pants" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/video-florida-man-steals-crossbow-by-stuffing-it-down-his-pants/Content?oid=31065367&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">[VIDEO] Florida man steals crossbow by stuffing it down his pants</a>
</h4>
<div class="date"> Feb 23, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/florida-transgender-bathroom-case-heard-by-federal-appeals-court/Content?oid=31065433&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31065677/adobestock_277746322.jpeg" alt="Florida transgender bathroom case heard by federal appeals court" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/florida-transgender-bathroom-case-heard-by-federal-appeals-court/Content?oid=31065433&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">Florida transgender bathroom case heard by federal appeals court</a>
</h4>
<div class="date"> Feb 23, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/floridas-dont-say-gay-crt-fearmongering-bills-under-discussion-in-state-house/Content?oid=31065027&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31065032/screenshot_2022-02-23_9.22.44_am.png" alt="Florida&#39;s &#39;Don&#39;t Say Gay&#39;, CRT fearmongering bills under discussion in state House" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/floridas-dont-say-gay-crt-fearmongering-bills-under-discussion-in-state-house/Content?oid=31065027&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">Florida's 'Don't Say Gay', CRT fearmongering bills under discussion in state House</a>
</h4>
<div class="date"> Feb 23, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=31065036&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory" class="more">More &raquo;</a>
</li>
</ul>
</div>
<div id="MorebyThisAuthorWrapper" class="SpanningFeature ContentDefault Wrapper">
<div id="MorebyThisAuthor" class="SpanningFeature ContentDefault ">
<h3><span class="headingText">More by Dara Kam, NSF</span></h3>
<ul class="moduleList">
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/florida-republicans-changes-to-mail-in-voting-are-a-recipe-for-disaster/Content?oid=31018248&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/31018500/adobestock_368879392_editorial_use_only.jpeg" alt="Florida Republicans&#39; changes to mail-in-voting are &#39;a recipe for disaster&#39;" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/florida-republicans-changes-to-mail-in-voting-are-a-recipe-for-disaster/Content?oid=31018248&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Florida Republicans' changes to mail-in-voting are 'a recipe for disaster'</a>
</h4>
<div class="date"> Feb 15, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/florida-democrats-promise-to-double-down-on-registration-efforts-after-numbers-in-florida-dip/Content?oid=30974285&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/30974290/adobestock_340508711.jpeg" alt="Florida Democrats promise to double down on registration efforts after numbers in Florida dip" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/florida-democrats-promise-to-double-down-on-registration-efforts-after-numbers-in-florida-dip/Content?oid=30974285&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Florida Democrats promise to double down on registration efforts after numbers in Florida dip</a>
</h4>
<div class="date"> Feb 7, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/activists-draw-line-between-florida-voting-restrictions-jim-crow-in-court-case/Content?oid=30956853&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/30956857/adobestock_131791279.jpeg" alt="Activists draw line between Florida voting restrictions, Jim Crow in court case" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/activists-draw-line-between-florida-voting-restrictions-jim-crow-in-court-case/Content?oid=30956853&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Activists draw line between Florida voting restrictions, Jim Crow in court case</a>
</h4>
<div class="date"> Feb 4, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.orlandoweekly.com/orlando/ArticleArchives?author=27847625" class="more">More &raquo;</a>
</li>
</ul>
</div>
</div>
<div id="PeopleWhoLiked" class="SpanningFeature ContentDefault ">
<h3><span class="headingText">Readers also liked&hellip;</span></h3>
<ul>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/rep-anna-eskamani-and-florida-bar-association-to-hold-virtual-workshop-on-evictions-on-friday/Content?oid=27759681&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/27760164/117232921_975075836267115_3958339688974702665_o.jpg" alt="Rep. Anna Eskamani and Florida Bar Foundation to hold virtual workshop on evictions on Friday" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/rep-anna-eskamani-and-florida-bar-association-to-hold-virtual-workshop-on-evictions-on-friday/Content?oid=27759681&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">Rep. Anna Eskamani and Florida Bar Foundation to hold virtual workshop on evictions on Friday</a>
</h4>
<div class="date"> Aug 12, 2020 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/three-crappy-days-in-florida-whose-so-called-leaders-didnt-learn-anything-last-summer/Content?oid=29750647&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/29750646/ow_cover-08042021-b.jpg" alt="Three crappy days in Florida, whose so-called leaders didn&#39;t learn anything last summer" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/three-crappy-days-in-florida-whose-so-called-leaders-didnt-learn-anything-last-summer/Content?oid=29750647&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">Three crappy days in Florida, whose so-called leaders didn't learn anything last summer</a>
</h4>
<div class="date"> Aug 4, 2021 </div>
</li>
</ul>
</div>
</div>
<div id="gridSpanningFeature2">
</div>
<div id="gridColumnContainer" class="clearfix">
<div id="gridMainColumn1">
</div>
<div id="gridMainColumn2">
</div>
</div>
</div>
<div id="gridRightColumn">
<div id="gridSpanningIsland">
<div id="TabbedPopularity" class="SpanningIsland ContentDefault ">
<h2>Most Popular</h2>
<div class="tabs">
<div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
<div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
</div>
<div class="popularityBody">
<ol class="moduleList">
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/williston-rep-pushes-amendment-to-floridas-dont-say-gay-bill-that-would-force-schools-to-out-students-to-parents/Content?oid=31059068&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Williston rep. pushes amendment to Florida's 'Don't Say Gay' bill that would force schools to out students to parents <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/paddleboarders-pass-near-massive-hammerhead-shark-in-drone-video-off-florida-beach/Content?oid=31058275&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Paddleboarders pass near massive hammerhead shark in drone video off Florida beach <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/floridas-dont-say-gay-crt-fearmongering-bills-under-discussion-in-state-house/Content?oid=31065027&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Florida's 'Don't Say Gay', CRT fearmongering bills under discussion in state House <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/if-you-think-the-democrats-are-screwed-and-you-want-to-blame-it-on-aoc-perhaps-that-says-more-about-you-than-her/Content?oid=31060963&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">If you think the Democrats are screwed and you want to blame it on AOC, perhaps that says more about you than her <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/legislature-gov-desantis-split-three-ways-over-florida-redistricting-maps/Content?oid=31052167&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Legislature, Gov. DeSantis split three ways over Florida redistricting maps <span class="more">Read More</span></a></h4>
</li>
</ol>
</div>
<div class="popularityBody" style="display:none">
<div class="currentIssue">
<a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=31059070&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
<img src="/imager/b/cover/31059070/bf80/OW-Cover-02232022.jpg" alt="Issue Cover" />
</a>
<p>February 23- 1, 2022</p>
</div>
<ol class="moduleList">
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/floridas-dont-say-gay-crt-fearmongering-bills-under-discussion-in-state-house/Content?oid=31065027&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Florida's 'Don't Say Gay', CRT fearmongering bills under discussion in state House <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/orlando-electronics-showcase-circuit-church-puts-on-monthly-shows-that-are-free-outdoors-and-switched-on/Content?oid=31060717&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Orlando electronics showcase Circuit Church puts on monthly shows that are free, outdoors and switched on <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/winter-parks-jam-hot-chicken-tests-the-courage-of-poultry-pyros/Content?oid=31060724&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Winter Park's Jam Hot Chicken tests the courage of poultry pyros <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/its-nonstop-viking-on-viking-violence-in-vikings-valhalla-new-on-netflix-friday/Content?oid=31060728&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">It's nonstop Viking-on-Viking violence in 'Vikings: Valhalla,' new on Netflix Friday <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/neo-nazi-nick-fuentes-is-hosting-another-white-nationalist-conference-in-orlando-during-cpac/Content?oid=31036865&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Holocaust denier Nick Fuentes is hosting another white nationalist conference in Orlando during CPAC <span class="more">Read More</span></a></h4>
</li>
</ol>
</div>
</div>
<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>

<div id="SearchRightCol" class="SpanningIsland ContentDefault  search-wrap">
<form class="prepTextForm" id="searchbox_017793458706336421686:1y5lan2fdja" action="https://posting.orlandoweekly.com/orlando/Search">
<input type="hidden" name="cx" value="017793458706336421686:1y5lan2fdja" />
<input type="hidden" name="cof" value="FORID:9" />
<input id="search-submit" type="submit" name="sa" value="Search" />
<input id="search-input" autocomplete="off" type="text" name="q" size="25" placeholder="Search" />
</form>
<ul id="search-dropdown" class="search-dropdown" style="display:none;">
<li class="search-option"><a class="search-all" href="https://posting.orlandoweekly.com/orlando/Search"><span class="dark-search-icon"></span>&nbsp;All</a></li>
<li class="search-option"><a href="https://www.orlandoweekly.com/orlando/ArticleArchives"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
<li class="search-option"><a href="https://www.orlandoweekly.com/orlando/EventSearch"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
<li class="search-option"><a href="https://www.orlandoweekly.com/orlando/LocationSearch"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
</ul>
</div>
<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            if( newLocation.match(/\?/)){
              newLocation = newLocation+'&';
            }else{
              newLocation = newLocation+'?';
            }
            window.location = newLocation + "keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>

<div id="AdMediumRectangle1300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-orl_300x250-1" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-1');
                });
              </script>
</div>
</div>
<div id="NewsletterSignup" class="SpanningIsland ContentDefault ">
<h2>Newsletters</h2>
<div class="wrap">
<h3>Never miss a beat</h3>
<a href="/orlando/NewsletterSignup/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color:#F7941E;font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
</div>
</div>
<div id="CurrentIssuu" class="SpanningIsland ContentDefault ">
<h2>Read the Digital Print Issue</h2>
<div class="wrap">
<h3>February 23, 2022</h3>
<iframe src="https://e.issuu.com/embed.html?d=orlando_weekly_february_23_2022&hideIssuuLogo=true&pageLayout=singlePage&u=euclidmediagroup" allowfullscreen allow="fullscreen" style="border:none;width:100%;height:300px;"></iframe>
<p style="margin:10px 0;">
<a class="more" href="https://www.orlandoweekly.com/orlando/IssueArchives">View more issues</a>
</p>
</div>
</div>
<div id="AdMediumRectangle2300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-orl_300x250-2" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-2');
                });
              </script>
</div>
</div><div id="PhotoSlideshows" class="SpanningIsland ContentDefault ">
<h2><a href="http://photos.orlandoweekly.com/" target="_blank">Newest Slideshows</a></h2>
<iframe src="//photos.orlandoweekly.com/thumbnail-scroller-square/" height="419" width="364" scrolling="no" frameborder="0"></iframe>
</div>

<div id="SpecialIssues" class="SpanningIsland ContentDefault ">
<h2><a href="https://www.orlandoweekly.com/orlando/orlando-guides/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
<div class="reportBox">
<a href="/orlando/welcome-to-the-2020-orlando-weekly-city-guide/Content?oid=27837298&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media1.orlandoweekly.com/orlando/imager/u/original/28122110/cover_rightrailcrop.jpg);">
<span class="grayRedBox">City Guide</span>
</a>
</div>
<div class="reportBox">
<a href="/orlando/welcome-to-orlando/Content?oid=25798051&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media2.orlandoweekly.com/orlando/imager/u/original/26132383/newcomers2019_rrlink.jpg);">
<span class="grayRedBox">Newcomers Guide</span>
</a>
</div>
<div class="reportBox">
<a href="/orlando/BestOf?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media2.orlandoweekly.com/orlando/imager/u/original/28122109/ow_cover-boo2020.jpg);">
<span class="grayRedBox">Best of Orlando</span>
</a>
</div>
<div class="reportBox">
<a href="/orlando/welcome-to-bite-2019-the-best-guide-to-orlando-dining/Content?oid=25603613&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media1.orlandoweekly.com/orlando/imager/u/original/25632553/cover_bite2019_rightrailwidget.jpg);">
<span class="grayRedBox">Bite</span>
</a>
</div>
<div class="reportBox">
<a href="/orlando/fall-guide-2020-orlando-arts-and-events-happening-between-sept-30-and-nov-17/Content?oid=28027224&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media2.orlandoweekly.com/orlando/imager/u/original/28122108/cover_rightrailcrop.jpg);">
<span class="grayRedBox">Fall Guide</span>
</a>
</div>
<a href="https://www.orlandoweekly.com/orlando/orlando-guides/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
</div>
<div id="AdMediumRectangle3300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-orl_300x250-3" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-3');
                });
              </script>
</div>
</div><div id="slideshow-feed"></div>
<div id="TabbedCalendar" class="SpanningIsland ContentDefault ">
<h2>Calendar</h2>
<div class="tabs">
<div id="tabEvents" class="tab"><a href="#">Events</a></div>
<div id="tabMusic" class="tab"><a href="#">Music</a></div>
<div id="tabMovies" class="tab"><a href="#">Movies</a></div>
<div id="tabArts" class="tab"><a href="#">Arts</a></div>
<div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/second-harvest-hosts-a-behind-the-scenes-look-at-hunger-relief-efforts/Event?oid=30957333&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Second Harvest Hosts a Behind-the-Scenes Look at Hunger Relief Efforts <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/ucf-knights-mens-basketball-vs-cincinnati-bearcats-mens-basketball/Event?oid=30140727&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
UCF Knights Mens Basketball vs. Cincinnati Bearcats Mens Basketball <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/hot-rod-night/Event?oid=5563981&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Hot Rod Night <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/2022-mfa-exhibition/Event?oid=29578411&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
2022 MFA Exhibition <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/the-jewish-pavilion-fashion-show/Event?oid=30953094&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
The Jewish Pavilion Fashion Show <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/i-love-randb-concert/Event?oid=30692283&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
I love R&B concert <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/amine/Event?oid=30333158&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Amine <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/supersuckers-jesse-dayton-rod-gator/Event?oid=30956230&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Supersuckers, Jesse Dayton, Rod Gator <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/the-wonder-years-the-upsides-and-suburbia-anniversary-tour/Event?oid=30397377&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
The Wonder Years: The Upsides & Suburbia Anniversary Tour <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/guest-artist-recital-chris-dingman-percussion/Event?oid=31057809&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Guest Artist Recital: Chris Dingman, Percussion <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li style="list-style-type:none;">No results <a class="more" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar"> Film Event Search</a></li>
</ol>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/2022-mfa-exhibition/Event?oid=29578411&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
2022 MFA Exhibition <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/frozen/Event?oid=29996434&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Frozen <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/jay-leno/Event?oid=30421201&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Jay Leno <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/free-friday-nights-at-the-morse/Event?oid=30489375&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Free Friday Nights at the Morse <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/american-modernisms-at-the-rollins-museum-of-art/Event?oid=29989383&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
"American Modernisms at the Rollins Museum of Art" <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
</div>
<div class="eventTabGuts" style="display:none">
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/natura-coffee-and-tea/Location?oid=2285603&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Natura Coffee & Tea <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/amigos/Location?oid=2289771&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Amigo's <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/flippers-pizzeria/Location?oid=2285180&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Flippers Pizzeria <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<form name="diningSearchForm" method="get" action="https://www.orlandoweekly.com/orlando/LocationSearch">
<input type="hidden" name="locationSection" value="2282258" />
<input type="hidden" name="guide" value="2124367" />
<select name="locationCategory">
<option value="">-All Categories-</option>
<option value="2282260">African</option>
<option value="2282261">American</option>
<option value="2282262">Argentine</option>
<option value="2282263">Armenian</option>
<option value="2282264">Bakery</option>
<option value="2282265">Barbecue</option>
<option value="27096422">Brazilian</option>
<option value="2282266">Breakfast/Brunch</option>
<option value="2282267">Brewpub</option>
<option value="2282286">Burgers</option>
<option value="2282268">Café/Bistro</option>
<option value="2282269">Cajun/Creole</option>
<option value="2282270">Caribbean</option>
<option value="2282272">Chinese</option>
<option value="2282271">Coffee house (chain)</option>
<option value="2282289">Coffee house (independent)</option>
<option value="2282274">Contemporary</option>
<option value="2282276">Cuban</option>
<option value="2297679">Deli</option>
<option value="27294676">Desserts</option>
<option value="2282278">Diner</option>
<option value="27012503">Dutch</option>
<option value="2282279">Eastern European</option>
<option value="26255950">Egyptian</option>
<option value="26628154">Eritrean</option>
<option value="2282280">Ethiopian</option>
<option value="2282275">European</option>
<option value="26302999">Filipino-American</option>
<option value="2282281">Fondue</option>
<option value="28902623">Food Hall</option>
<option value="2304903">Food Truck</option>
<option value="2282282">French</option>
<option value="2282283">General</option>
<option value="2282399">General Fare</option>
<option value="2282284">German</option>
<option value="2282285">Greek</option>
<option value="2282287">Hawaiian</option>
<option value="2282288">Hot Dogs</option>
<option value="27069718">Ice Cream</option>
<option value="2282290">Indian</option>
<option value="2282291">Indonesian</option>
<option value="2282292">Irish</option>
<option value="2282293">Israeli</option>
<option value="2282294">Italian</option>
<option value="2282295">Jamaican</option>
<option value="27069314">Japanese</option>
<option value="2282296">Japanese/Sushi</option>
<option value="25626307">Juice</option>
<option value="2282297">Korean</option>
<option value="2297696">Kosher</option>
<option value="27095777">Laotian</option>
<option value="2282298">Latin American</option>
<option value="2282299">Lebanese</option>
<option value="2305936">Malaysian</option>
<option value="2282300">Market</option>
<option value="2282301">Mediterranean</option>
<option value="2282302">Mexican</option>
<option value="2282303">Middle Eastern</option>
<option value="2345788">Modern American</option>
<option value="2282304">Mongolian</option>
<option value="2282305">Moroccan</option>
<option value="2282306">Noodles</option>
<option value="2282307">Pan-Asian</option>
<option value="2282308">Persian</option>
<option value="2282309">Peruvian</option>
<option value="2282310">Philippine</option>
<option value="2282311">Pizza</option>
<option value="26186721">Poké</option>
<option value="2282312">Polish</option>
<option value="2297728">Pub Grub</option>
<option value="2282313">Puerto Rican</option>
<option value="2282314">Russian</option>
<option value="2282315">Salads</option>
<option value="2282277">Sandwiches/Subs</option>
<option value="26147501">Saudi</option>
<option value="26147502">Saudi-Indonesian</option>
<option value="2282316">Seafood</option>
<option value="2282317">Soup</option>
<option value="2282318">Southern/Soul</option>
<option value="2282319">Spanish</option>
<option value="2282320">Steakhouse</option>
<option value="2282321">Swedish</option>
<option value="2282322">Sweets</option>
<option value="2282323">Tapas</option>
<option value="2282273">Tea</option>
<option value="2282324">Tex-Mex</option>
<option value="2282325">Thai</option>
<option value="2282326">Turkish</option>
<option value="2282327">Vegetarian/Vegan</option>
<option value="2282328">Vietnamese</option>
<option value="2282329">Wine</option>
</select>
<select name="neighborhood">
<option value="">-All Neighborhoods-</option>
<option value="2292883">&nbsp;&nbsp;Apopka</option>
<option value="2282447">&nbsp;&nbsp;Central</option>
<option value="2292887">&nbsp;&nbsp;Audubon Park</option>
<option value="2292884">&nbsp;&nbsp;Casselberry</option>
<option value="2282448">&nbsp;&nbsp;Disney</option>
<option value="2282449">&nbsp;&nbsp;Downtown</option>
<option value="2282450">&nbsp;&nbsp;East</option>
<option value="2399527">&nbsp;&nbsp;Edgewood</option>
<option value="2282451">&nbsp;&nbsp;Elsewhere</option>
<option value="2282452">&nbsp;&nbsp;I-Drive/Universal</option>
<option value="2292885">&nbsp;&nbsp;Ivanhoe Village</option>
<option value="2282453">&nbsp;&nbsp;North</option>
<option value="2282454">&nbsp;&nbsp;South</option>
<option value="2282455">&nbsp;&nbsp;West</option>
<option value="4366406">&nbsp;&nbsp;Dr. Phillips</option>
<option value="2282456">&nbsp;&nbsp;Winter Park Area</option>
<option value="2343583">&nbsp;&nbsp;Milk District</option>
<option value="2343582">&nbsp;&nbsp;SoDo</option>
<option value="2343585">&nbsp;&nbsp;Kissimmee</option>
<option value="2343584">&nbsp;&nbsp;UCF</option>
<option value="2343586">&nbsp;&nbsp;Mount Dora</option>
<option value="2343587">&nbsp;&nbsp;Conway/Curry Ford</option>
<option value="2343589">&nbsp;&nbsp;Belle Isle</option>
<option value="2343590">&nbsp;&nbsp;Mills 50</option>
<option value="2345785">&nbsp;&nbsp;College Park</option>
<option value="2345787">&nbsp;&nbsp;Thornton Park</option>
<option value="26484602">&nbsp;&nbsp;North Florida</option>
<option value="26718775">&nbsp;&nbsp;Baldwin Park</option>
<option value="26947375">&nbsp;&nbsp;Eola Heights</option>
<option value="26947376">&nbsp;&nbsp;South Eola</option>
<option value="27106618">&nbsp;&nbsp;Online Only</option>
<option value="27050023">&nbsp;&nbsp;Sanford</option>
<option value="29376566">&nbsp;&nbsp;Colonialtown</option>
<option value="28994110">&nbsp;&nbsp;New Smyrna</option>
</select>
<div class="searchBox">
<input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
<input type="submit" value="go" />
</div>
</form>
</div>
</div>
<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 0
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
</div>
<div id="gridMainSidebar">
</div>
<div id="gridAdSidebar">
</div>
<div id="gridBottomSidebar">
</div>
</div>

<div id="gridFooter">
<div id="FooterInfo" class="GlobalFooter ContentDefault ">
<div class="footerCustomInfo">
<h2>Orlando Weekly</h2>
<p>16 W. Pine St.</p>
<p>Orlando, FL 32801</p>
<p>Phone: (407) 377-0400</p>
<p>Classified Phone: (407) 377-0415</p>
<p>Fax: (407) 377-0420</p>
</div>
<div class="footerCustomWrap">
<div class="footerCustomNav">
<ul>
<li><a target="_top" href="/orlando/AboutOrlandoWeekly/Page">About OW</a></li>
<li><a target="_top" href="https://www.orlandoweekly.com/orlando/AdvertiseWithOrlandoWeekly/Page">Advertise</a></li>
<li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
<li><a target="_blank" href="/blogs/LegalAdvertising/">Legal Advertising</a></li>
<li><a target="_top" href="/orlando/WorkForUs/Page">Work Here</a></li>
</ul>
<p>All parts of this site Copyright &copy; 2022 Orlando Weekly.</p>
</div>
<div class="footerRssLink">
<a href="https://www.orlandoweekly.com/orlando/Syndication" class="RSSLink">RSS Feeds</a>
</div>
<div class="footerCustomLogin">
<ul data-view="loggedin" style="display:none">
<li><strong data-label="username">Username</strong> / </li>
<li><a href="https://posting.orlandoweekly.com/orlando/MyProfile">View Profile</a> / </li>
<li><a href="https://posting.orlandoweekly.com/orlando/Profile/MySettings">Edit Profile</a> / </li>
<li><a href="https://www.orlandoweekly.com/orlando/Logout">Log Out</a></li>
</ul>
<ul data-view="loggedout" style="display:none">
<li><a href="#LogIn">Log in</a> / </li>
<li><a href="#CreateAccount">Create Account</a></li>
</ul>
</div>
<script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
</div>
<div class="clear"></div>
</div>

<div id="AdFooter728x90" class="GlobalFooter ContentDefault ">

<div id="div-gpt-ad-orl_728x90-2" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-2');
                });
              </script>
</div>
</div>
<div id="FooterNavigation" class="GlobalFooter ContentDefault ">
<div class="linkGroupColumn">
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>News + Views</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/orlando-area-news/Category?oid=31065036">Orlando Area News</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/pulse/Topics?oid=31060458">Pulse</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/orlando-sports/Topics?oid=31060463">Orlando Sports</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/savage-love/Category?oid=2240424">Savage Love</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/comics/Category?oid=2240423">Comics</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=this%20week">Digital Issue</a></li>
<li><a href="https://photos.orlandoweekly.com/category/newsslideshows/">News Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Movies</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/movie-reviews/Category?oid=31065358">Movie Reviews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/streaming/Category?oid=31065342">Streaming</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationCategory=2282370&sortType=name">Find a Theater</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/MovieTimes">Movie Times</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>Arts + Culture</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/arts-stories-interviews/Category?oid=2240434">Arts Stories + Interviews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/astrology/Category?oid=31065290">Astrology</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/performing-arts/Topics?oid=31060468">Performing Arts</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/visual-arts/Topics?oid=31060469">Visual Arts</a></li>
<li><a href="https://photos.orlandoweekly.com/category/artsslideshows/">Arts + Culture Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="/orlando/EventSearch" target="_">
Calendar
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&v=d">Today's Events</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&sortType=date&v=d">This Weekend</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/EventSearch?feature=Free&sortType=date&v=d">Free Events</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/Events/AddEvent">Submit an Event</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Social Media</h3>
<ul class="sublinkGroup">
<li><a href="http://instagram.com/orlandoweekly/" target="_blank">Instagram</a></li>
<li><a href="https://twitter.com/orlandoweekly" target="_blank">Twitter</a></li>
<li><a href="https://www.facebook.com/orlandoweekly" target="_blank">Facebook</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>Food + Drink</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/food-news/Category?oid=31065305">Food News</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/drinking-bars/Category?oid=31065312">Drinking + Bars</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/restaurant-review/Category?oid=2240450">Restaurant Reviews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationSection=2282258">Find a Restaurant</a></li>
<li><a href="https://photos.orlandoweekly.com/category/foodslideshows/">Food + Drink Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Best of Orlando®</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2255299">Arts & Culture</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240483">Food & Drink</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240486">Goods & Services</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240482">Local Color</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240485">Music & Nightlife</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240487">Sports & Recreation</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="/orlando/music/Section?oid=2240410" target="_">
Music
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/music-stories-interviews/Category?oid=2240462">Music Stories + Interviews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/orlando-music-news/Category?oid=31065388">Orlando Music News</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/live-music-picks-previews/Category?oid=31065380">Live Music Picks + Previews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/this-little-underground/Topics?oid=31060485">This Little Underground</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&sortType=date&v=d">Find a Concert</a></li>
<li><a href="https://photos.orlandoweekly.com/category/musicslideshows/">Music Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Orlando Guides</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/summer-guide/Category?oid=2240491">Summer Guide</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/holiday-guide/Category?oid=2240493">Holiday Guide</a></li>
<li><a href="https://www.orlandoweekly.com/blogs/LegalAdvertising/">Legal Advertising</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Sponsored Links</h3>
<ul class="sublinkGroup">
<li><a href="https://www.407apartments.com/ucf-apartments" target="_blank" rel="sponsored">Apartments Near UCF</a></li>
<li><a href="https://www.407apartments.com/orlando-apartments/apartments-near-valencia-college" target="_blank" rel="sponsored">Apartments Near Valencia College</a></li>
<li><a href="https://www.407apartments.com/orlando-apartments/student-apartments-in-orlando" target="_blank" rel="sponsored">Student Housing in Orlando</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>Giveaways + Events</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273884">Contests</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=2541677">Beer 'Merica</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=23026965">Orlando Burger Week</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=2321136">Bite30</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=9414612">Orlando Taco Week</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=4575095">Tacos & Tequila</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=2387425">Orlando Beer Festival</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=2387353">Whiskey Business</a></li>

</ul>
</div>
<div class="linkGroup ">
<h3>About Us</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/AboutOrlandoWeekly/Page">Contact Us</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/WorkForUs/Page">Work For Us</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/AboutOrlandoWeekly/Page">Staff Directory</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/Wheretofindus/Page">Where to Find Us</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FAQs/Page">FAQ</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/Policies/Page">Policies</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page">Support</a></li>
<li><a href="https://mediakit.orlandoweekly.com/" target="_blank">Advertise</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page">Subscribe</a></li>
</ul>
</div>
</div>
</div>

<style>
.sister-links {
  padding: 1em 0;
  border-top: 1px solid #ccc;
}
.sister-links h3 {
  text-align: center;
  font-size: 16px;
}
.sister-links h4 {
  text-align: center;
  font-size: 12px;
  text-transform:uppercase
}
.sister-links p {
  text-align: center;
  font-size: 12px;
}
.sister-links ul {
  text-align: center;
  display: flex;
  flex-wrap: wrap;
  margin: 10px auto;
  justify-content: center;
}
.sister-links li {
  text-align: center;
  padding: 5px 1em;
  border-right: 1px solid #ccc;
}
.sister-links li:last-child {
  border-right:none;
}
</style>
<div id="sister-links" class="sister-links">
<h3>Euclid Media Group, LLC</h3>
<h4>Read Our Sister Publications </h4>
<ul>
<li>
<a href="https://www.clevescene.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Cleveland Scene
</a>
</li>
<li>
<a href="https://www.citybeat.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Cincinnati CityBeat
</a>
</li>
<li>
<a href="https://www.cltampa.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Creative Loafing Tampa
</a>
</li>
<li>
<a href="https://www.metrotimes.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Detroit Metro Times
</a>
</li>
<li>
<a href="https://www.leoweekly.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Louisville LEO Weekly
</a>
</li>
<li>
<a href="https://www.riverfronttimes.com/" rel="noreferrer" target="_blank" heap-ignore="true">
St. Louis Riverfront Times
</a>
</li>
<li>
<a href="https://www.sacurrent.com/" rel="noreferrer" target="_blank" heap-ignore="true">
San Antonio Current
</a>
</li>
<li>
<a href="https://outinsa.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Out in SA
</a>
</li>
<li>
<a href="https://outinstl.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Out in STL
</a>
</li>
</ul>
<h4>Marketing Services</h4>
<p>
<a href="https://localculturecreative.com/" target="_blank" heap-ignore="true">
Local Culture Creative
</a>
</p>
</div>
<div id="footerCopyright">
<p>
&copy; 2022
Orlando Weekly
<br><br>
Website powered by <a href="https://www.publishwithfoundation.com/" target="_blank">Foundation</a>
</p>
</div>
<script type="text/javascript">
  (function(e,t,o,n,p,r,i){e.visitorGlobalObjectAlias=n;e[e.visitorGlobalObjectAlias]=e[e.visitorGlobalObjectAlias]||function(){(e[e.visitorGlobalObjectAlias].q=e[e.visitorGlobalObjectAlias].q||[]).push(arguments)};e[e.visitorGlobalObjectAlias].l=(new Date).getTime();r=t.createElement("script");r.src=o;r.async=true;i=t.getElementsByTagName("script")[0];i.parentNode.insertBefore(r,i)})(window,document,"https://diffuser-cdn.app-us1.com/diffuser/diffuser.js","vgo");
  vgo('setAccount', '26668640');
  vgo('setTrackByDefault', true);

  vgo('process');
</script>
</div>
</div>
</div>

<div id="gridCloser">
<div id="AdBackground" class="Closer ContentDefault ">

<div id="div-gpt-ad-orl_reskin" style="" data-content-type="ad" data-slot="/43707298/ORL_Reskin" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_reskin');
                });
              </script>
</div>
</div>
</div>
</body>
</html>
