
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">
<head>
<meta name="viewport" content="width=1000">
<meta name="layout" content="Content Default" />
<meta name="oid" content="31190200" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="imagetoolbar" content="no" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=c600b22f83b9a437fdf2aa969ff7c825" />
<link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=c600b22f83b9a437fdf2aa969ff7c825" />
<link rel="stylesheet" type="text/css" href="/styles/components.css?cb=c600b22f83b9a437fdf2aa969ff7c825" />
<link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=c600b22f83b9a437fdf2aa969ff7c825" />
<script src="/foundation/fontawesome/js/brands.min.js" async></script>
<script src="/foundation/fontawesome/js/solid.min.js" async></script>
<script src="/foundation/fontawesome/js/regular.min.js" async></script>
<script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
<script src="/foundation/fontawesome/js/light.min.js" async></script>
<script src="/foundation/fontawesome/js/duotone.min.js" async></script>
<style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>
<link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
<!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
<!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
<!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
<!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->
<link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Whole Site" href="https://www.orlandoweekly.com/orlando/Rss.xml" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Arts + Culture Section" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2240407" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Things to Do" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=31066175" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Comments on Florida Film Festival announces 2022 fest lineup with over 160 films and William Shatner" href="https://www.orlandoweekly.com/orlando/Rss.xml?id=comments&amp;oid=31190200" />
<script>window.__FBAPIv__ = 'v3.2'</script>
<!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
<script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>

<script src="/foundation/scripts/common.js?cb=a46c7412a3794aef307f52c25cce3812"></script>
<script src="/foundation/scripts/desktop-bundle.js?cb=a46c7412a3794aef307f52c25cce3812"></script>
<link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
<script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>
<script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.orlandoweekly.com\/orlando\/Profile", "https:\/\/posting.orlandoweekly.com\/orlando\/MyProfile");
  </script>
<meta name="google-signin-client_id" content="297405715145-bcr8a9m9emb8a84o6qbd7utuefrfoknk.apps.googleusercontent.com">

<script type="text/javascript" async=true>
  (function() {
    var host = window.location.hostname;
    var element = document.createElement('script');
    var firstScript = document.getElementsByTagName('script')[0];
    var url = 'https://quantcast.mgr.consensu.org'
      .concat('/choice/', 'ECpz7gxYXdCG2', '/', host, '/choice.js')
    var uspTries = 0;
    var uspTriesLimit = 3;
    element.async = true;
    element.type = 'text/javascript';
    element.src = url;

    firstScript.parentNode.insertBefore(element, firstScript);

    function makeStub() {
      var TCF_LOCATOR_NAME = '__tcfapiLocator';
      var queue = [];
      var win = window;
      var cmpFrame;

      function addFrame() {
        var doc = win.document;
        var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

        if (!otherCMP) {
          if (doc.body) {
            var iframe = doc.createElement('iframe');

            iframe.style.cssText = 'display:none';
            iframe.name = TCF_LOCATOR_NAME;
            doc.body.appendChild(iframe);
          } else {
            setTimeout(addFrame, 5);
          }
        }
        return !otherCMP;
      }

      function tcfAPIHandler() {
        var gdprApplies;
        var args = arguments;

        if (!args.length) {
          return queue;
        } else if (args[0] === 'setGdprApplies') {
          if (
            args.length > 3 &&
            args[2] === 2 &&
            typeof args[3] === 'boolean'
          ) {
            gdprApplies = args[3];
            if (typeof args[2] === 'function') {
              args[2]('set', true);
            }
          }
        } else if (args[0] === 'ping') {
          var retr = {
            gdprApplies: gdprApplies,
            cmpLoaded: false,
            cmpStatus: 'stub'
          };

          if (typeof args[2] === 'function') {
            args[2](retr);
          }
        } else {
          queue.push(args);
        }
      }

      function postMessageEventHandler(event) {
        var msgIsString = typeof event.data === 'string';
        var json = {};

        try {
          if (msgIsString) {
            json = JSON.parse(event.data);
          } else {
            json = event.data;
          }
        } catch (ignore) {}

        var payload = json.__tcfapiCall;

        if (payload) {
          window.__tcfapi(
            payload.command,
            payload.version,
            function(retValue, success) {
              var returnMsg = {
                __tcfapiReturn: {
                  returnValue: retValue,
                  success: success,
                  callId: payload.callId
                }
              };
              if (msgIsString) {
                returnMsg = JSON.stringify(returnMsg);
              }
              event.source.postMessage(returnMsg, '*');
            },
            payload.parameter
          );
        }
      }

      while (win) {
        try {
          if (win.frames[TCF_LOCATOR_NAME]) {
            cmpFrame = win;
            break;
          }
        } catch (ignore) {}

        if (win === window.top) {
          break;
        }
        win = win.parent;
      }
      if (!cmpFrame) {
        addFrame();
        win.__tcfapi = tcfAPIHandler;
        win.addEventListener('message', postMessageEventHandler, false);
      }
    };

    makeStub();

    var uspStubFunction = function() {
      var arg = arguments;
      if (typeof window.__uspapi !== uspStubFunction) {
        setTimeout(function() {
          if (typeof window.__uspapi !== 'undefined') {
            window.__uspapi.apply(window.__uspapi, arg);
          }
        }, 500);
      }
    };

    var checkIfUspIsReady = function() {
      uspTries++;
      if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
        console.warn('USP is not accessible');
      } else {
        clearInterval(uspInterval);
      }
    };

    if (typeof window.__uspapi === 'undefined') {
      window.__uspapi = uspStubFunction;
      var uspInterval = setInterval(checkIfUspIsReady, 6000);
    }
  })();
  </script>


<style>
    .ccpaNotice {
      clear: both;
      border: 2px solid #D0D1D3;
      padding: 13px;
      font-size: 16px;
    }
  </style>
<script>
  if (typeof window.__uspapi === 'function') {
    window.__uspapi('uspPing', 1, function(obj, status) {
      if (status && obj.mode.includes('USP') && obj.jurisdiction.includes(obj.location.toUpperCase())) {
        var message = document.createElement("p");
        message.setAttribute("class", "ccpaNotice");
        message.innerHTML = 'Our website uses technical, analytical, marketing, and preference cookies to provide the best experience for our readers and to give us information about how our site is used. You may request that your data not be shared with third parties here: ' 
          + `<a href="#" onclick="window.__uspapi('displayUspUi');"` 
          + '>Do Not Sell My Data</a>' 
          + '.';
        document.getElementById('gridFooter').append(message);
        window.__uspapi('setUspDftData', 1, function(obj, status) {
          if (!status) {
              console.log("Error: USP string not updated!")
          }
        });
     }
    });
  }
  </script>


<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>


<link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link href="https://fonts.googleapis.com/css2?family=Lato:wght@400;700&family=Montserrat:wght@400;700&family=Open+Sans+Condensed:wght@300;700&family=Titillium+Web:wght@400;700&display=swap" rel="stylesheet">

<style>
:root {
  --pub-primary-color:#F7941E;
  --pub-link-color:#F7941E;
  --real-1-primary-color: #F7941E;
  --real-1-secondary-color: #F7941E66;
}
</style>
<meta name="google-site-verification" content="06A5Yh5mu5xlqSkqBOzGlxA6P_yfmltTp1l0ssgpOBk" />
<meta name="google-site-verification" content="9htXi1AfaHrVLNGB2JDLtdpWEFyb-JOf5ngnP_95Zuk" />
<meta name="google-site-verification" content="s4GBlkstS6PKQwO_gDlOGL8jFPmeuL_d3m60wxOBQR0" />
<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
 <script type='text/javascript'>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</script>

<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-585470-1', 'orlandoweekly.com');
    ga('set', 'anonymizeIp', true);
    ga('send', 'pageview', { 'dimension1': 'artsculture', 'dimension2': 'art' });
    </script>

<script>
  var Euclid = Euclid || {}
  Euclid.OrlandoWeekly = Euclid.OrlandoWeekly || {}
  Euclid.OrlandoWeekly.vertical = Euclid.OrlandoWeekly.vertical || 'arts'
  </script>
<script>
  (function() {
  if(document.getElementById('commitchange-script')) return;
  var npo = 5276;
  var script = document.createElement('script');
  var first = document.getElementsByTagName('script')[0];
  script.setAttribute('data-npo-id', npo);
  script.id = 'commitchange-script';
  script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
  first.parentNode.insertBefore(script, first);
  })();
  </script>
<link rel="shortcut icon" href="/favicon.ico" />
<meta name="title" content="Florida Film Festival announces 2022 fest lineup with over 160 films and William Shatner | Things to Do | Orlando | Orlando Weekly" />
<meta name="description" content="The Florida Film Festival returns in April for a 31st year with a massive lineup of 167 films &hellip; and a very special guest in..." />
<meta name="keywords" content="Enzian Theater, Maitland, Orlando, Florida Film Festival, Film, Cinema, Event, Movies, FFF, William Shatner, News, Blog, Culture, Dining, Events" />
<title>Florida Film Festival announces 2022 fest lineup with over 160 films and William Shatner | Things to Do | Orlando | Orlando Weekly</title>
<meta name="date" content="2022-03-17 11:24:00" />
<meta name="author" content="Matthew Moyer">
<meta name="news_keywords" content="enzian theater, maitland, orlando, florida film festival, film, cinema, event, movies, fff, william shatner" />
<link rel="image_src" href="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31190837/173821059_10165333932640314_5800611748280598168_n.jpeg" />
<meta name="thumbnail" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31190837/173821059_10165333932640314_5800611748280598168_n.jpeg" />
<link rel="canonical" href="https://www.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content?oid=31190200" />
<link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content?oid=31190200" />
<link rel="amphtml" href="https://www.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content?oid=31190200&media=AMP+HTML" />
<meta property="og:url" content="https://www.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content?oid=31190200" />
<meta property="fb:app_id" content="1527160917534695" />
<meta property="og:site_name" content="Orlando Weekly" />
<meta property="og:title" content="Florida Film Festival announces 2022 fest lineup with over 160 films and William Shatner" />
<meta property="og:image" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31190837/173821059_10165333932640314_5800611748280598168_n.jpeg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="462" />
<meta property="og:description" content="The Florida Film Festival returns in April for a 31st year with a massive lineup of 167 films &hellip; and a very special guest in..." />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31190837/173821059_10165333932640314_5800611748280598168_n.jpeg">
<meta name="twitter:site" content="@orlandoweekly">
<meta name="twitter:title" content="Florida Film Festival announces 2022 fest lineup with over 160 films and William Shatner">
<meta name="twitter:description" content="The Florida Film Festival returns in April for a 31st year with a massive lineup of 167 films &hellip; and a very special guest in...">

<script type="application/ld+json">
          {
            "mainEntityOfPage": {
              "@type": "WebPage",
              "@id":"https:\/\/www.orlandoweekly.com\/orlando\/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner\/Content?oid=31190200"
            },
            "headline": "Florida Film Festival announces 2022 fest lineup with over 160 films and William Shatner",
            
              "description": "The Florida Film Festival returns in April for a 31st year with a massive lineup of 167 films … and a very special guest in the form of William Shatner. Kicking off in just a few scant weeks, FFF offers all manner of new, diverse and challenging cinema, be it long-form features, documentaries, short films and animation.",
            
            "image": {
              "url": "https:\/\/media2.orlandoweekly.com\/orlando\/imager\/u\/original\/31190837\/173821059_10165333932640314_5800611748280598168_n.jpeg",
              "width": 750,
              "height": 577,
              "@type": "ImageObject"
            },
            "datePublished": "2022-03-17T11:24:00",
            "dateModified": "2022-03-17T11:24:40",
            
              
              "author": {
                "name": "Matthew Moyer",
                "url": "https:\/\/www.orlandoweekly.com\/author\/matthew-moyer",
                "@type": "Person"
              },
            
            "publisher": {
              "name": "Orlando Weekly",
              
                
                
                
                "logo": {
                  "url": "https:\/\/www.orlandoweekly.com\/imager\/b\/google-amp-logo\/808579\/5643\/OrlandoWeekly_fbook.jpg",
                  "width": 117,
                  "height": 60,
                  "@type": "ImageObject"
                },
              
              "@type": "Organization"
            },
            "@context": "https://schema.org",
            "@type": "NewsArticle"
          }
        </script>
</head>
<body id="Content" class="artsculture ContentDefault Iapetus10Zone ThingstoDo">

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KQ22CZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KQ22CZ');</script>

<div id="fb-root"></div>
<script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>
<script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>

<div id="gridLeader">
<div id="AdInterstitial" class="Leader ContentDefault ">

<div id="div-gpt-ad-orl_desktopinterstitial" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopinterstitial');
                });
              </script>
</div>
</div>
<style>
  /*-- desktop styles --*/
   #AdBackground {top:50px!important;}
  .nominate-bar {
    background: #e27a00;
    z-index: 1;
    overflow:hidden;
    width: 100%;
    padding: 0;
    text-transform: uppercase;
    text-align: center;
    color: #fff;
    font-size: 18px;
  }
  .nominate-bar div {
    border: 1px solid #FFBF6E;
    margin: 5px auto;
    max-width: 1000px;
      color:#fff;
}
  .nominate-bar a {
    color:#fff;
  }

  /* Adjust the ad positioning */
  body {
    background-position-y: 39px !important;
  }
  </style>
<div class="nominate-bar">
<div>
<p><a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page">Support local journalism. Join the Orlando Weekly Press Club.</a></p>
</div>
</div>
</div>
<div id="gridClamp">

<div id="gridHeader">
<div id="MobileDetect" class="GlobalHeader ContentDefault " style="display:none">
Switch to the <a href="https://m.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content?oid=31190200" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
</div>
<script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
<div id="LogoHeader" class="GlobalHeader ContentDefault ">
<div id="logoLeft">
<a href="https://www.orlandoweekly.com/" title="Orlando Weekly">Orlando Weekly</a>
</div>
<div id="leaderboardAdHeader">

<div id="div-gpt-ad-orl_728x90-1" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-1');
                });
              </script>
</div>
</div>
</div>

<div id="NavigationHorizontal" class="GlobalHeader ContentDefault  ">
<ul id="mainNav">
<li class="first" id="NavItem_News">
<a href="https://www.orlandoweekly.com/orlando/news/Section?oid=2240408" class="subnav_link" id="SNAVL_News">News</a>
</li>
<li class="navCurrent" id="NavItem_ArtsCulture">
<a href="https://www.orlandoweekly.com/orlando/arts-and-culture/Section?oid=2240407" class="subnav_link" id="SNAVL_ArtsCulture">Arts + Culture</a>
</li>
<li class="" id="NavItem_FoodDrink">
<a href="https://www.orlandoweekly.com/orlando/food-and-drink/Section?oid=2240409" class="subnav_link" id="SNAVL_FoodDrink">Food + Drink</a>
</li>
<li class="" id="NavItem_Music">
<a href="https://www.orlandoweekly.com/orlando/music/Section?oid=2240410" class="subnav_link" id="SNAVL_Music">Music</a>
</li>
<li class="" id="NavItem_Screens">
<a href="https://www.orlandoweekly.com/orlando/movies/Section?oid=2240411" class="subnav_link" id="SNAVL_Screens">Movies</a>
</li>
<li class="" id="NavItem_Calendar">
<a href="https://www.orlandoweekly.com/orlando/EventSearch" class="subnav_link" id="SNAVL_Calendar">Calendar</a>
</li>
<li class="" id="NavItem_BestOfOrlando">
<a href="https://www.orlandoweekly.com/orlando/BestOf" class="subnav_link" id="SNAVL_BestOfOrlando">Best Of Orlando&reg;</a>
</li>
<li class="" id="NavItem_Slideshows">
<a href="http://photos.orlandoweekly.com">Slideshows</a>
</li>
<li class="last" id="NavItem_Support">
<a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" class="subnav_link" id="SNAVL_Support">Support</a>
</li>
</ul>
<h3 class="hidden">Browse News</h3>
<ul class="subnav_content" id="SNAV_News" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/orlando-area-news/Category?oid=31065036" title="">Orlando Area News</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/florida-news/Category?oid=31065043" title="">Florida News</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/pulse/Topics?oid=31060458" title="">Pulse</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413" title="">Orlando Guides</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=this%20week" title="">Digital Issue</a>
</li>
<li class="">
<a href="https://photos.orlandoweekly.com/category/newsslideshows/" title="">News Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Arts + Culture</h3>
<ul class="subnav_content" id="SNAV_ArtsCulture" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/arts-stories-interviews/Category?oid=2240434" title="">Arts Stories + Interviews</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/orlando-theme-parks/Topics?oid=31060466" title="">Orlando Theme Parks</a>
</li>
<li class="">
<a href="https://photos.orlandoweekly.com/category/artsslideshows/" title="">Arts + Culture Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Food + Drink</h3>
<ul class="subnav_content" id="SNAV_FoodDrink" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/food-news/Category?oid=31065305" title="">Food News</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/drinking-bars/Category?oid=31065312" title="">Drinking + Bars</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/restaurant-review/Category?oid=2240450" title="">Restaurant Reviews</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationSection=2282258" title="">Find a Restaurant</a>
</li>
<li class="">
<a href="https://photos.orlandoweekly.com/category/foodslideshows/" title="">Food + Drink Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Music</h3>
 <ul class="subnav_content" id="SNAV_Music" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/music-stories-interviews/Category?oid=2240462" title="">Music Stories + Interviews</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/orlando-music-news/Category?oid=31065388" title="">Orlando Music News</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/live-music-picks-previews/Category?oid=31065380" title="">Live Music Picks + Previews</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&sortType=date&v=d" title="">Find a Concert</a>
</li>
<li class="">
<a href="https://photos.orlandoweekly.com/category/musicslideshows/" title="">Music Slideshows</a>
</li>
</ul>
<h3 class="hidden">Browse Movies</h3>
<ul class="subnav_content" id="SNAV_Screens" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/movie-reviews/Category?oid=31065358" title="">Movie Reviews</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/streaming/Category?oid=31065342" title="">Streaming</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationCategory=2282370&sortType=name" title="">Find a Theater</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/MovieTimes" title="">Movie Times</a>
</li>
</ul>
<h3 class="hidden">Browse Calendar</h3>
<ul class="subnav_content" id="SNAV_Calendar" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&v=d" title="">Today&#39;s Events</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&sortType=date&v=d" title="">This Weekend</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?feature=Free&sortType=date&v=d" title="">Free Events</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/Events/AddEvent" title="">Submit an Event</a>
</li>
</ul>
<h3 class="hidden">Browse Best Of Orlando&reg;</h3>
<ul class="subnav_content" id="SNAV_BestOfOrlando" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2255299" title="">Arts &amp; Culture</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240483" title="">Food &amp; Drink</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240486" title="">Goods &amp; Services</a>
 </li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240482" title="">Local Color</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240485" title="">Music &amp; Nightlife</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240487" title="">Sports &amp; Recreation</a>
</li>
</ul>
<h3 class="hidden">Browse Support</h3>
<ul class="subnav_content" id="SNAV_Support" style="display:none;">
<li class="">
<a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" title="">Support</a>
</li>
<li class="">
<a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page" title="">Subscribe</a>
</li>
<li class="">
<a href="https://mediakit.orlandoweekly.com/" target="_blank" title="">Advertise</a>
</li>
<li class="">
<a href="http://instagram.com/orlandoweekly/" target="_blank" title="">Instagram</a>
</li>
<li class="">
<a href="https://twitter.com/orlandoweekly" target="_blank" title="">Twitter</a>
</li>
<li class="">
<a href="https://www.facebook.com/orlandoweekly" target="_blank" title="">Facebook</a>
</li>
</ul>
</div>
<script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>

<div id="AdPencilBar" class="GlobalHeader ContentDefault ">

<div id="div-gpt-ad-orl_970x90" style="" data-content-type="ad" data-slot="/43707298/ORL_970x90" data-output="asynchronous" data-width="970" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_970x90');
                });
              </script>
</div>
</div>
</div>
<div id="gridMain">
<div id="gridFrame">
<div id="gridSpanningFeature">
<div id="StoryBreadcrumb" class="SpanningFeature ContentDefault  arts___culture things_to_do">
<p class="issueInfo ">
<span class="date">
<a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=31183859">March 17, 2022</a>
</span>
<a href="https://www.orlandoweekly.com/orlando/arts-culture/Section?oid=2240407">Arts + Culture</a>
&raquo; <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=31066175">Things to Do</a>
</p>
</div> 
<style>
    div.l0.last div:first-child {float:right;}
  </style>
<div id="ToolBarHorizontal" class="SpanningFeature ContentDefault ">
<div style="width:100%; height: 20px;">
<div class="l0 first" style="width:20%; height: 20px; float:left;">
<fb:like href="https://www.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content?oid=31190200" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:20%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content%3Foid%3D31190200&text=Florida%20Film%20Festival%20announces%202022%20fest%20lineup%20with%20over%20160%20films%20and%20William%20Shatner" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:20%; height: 20px; float:left;">
<a class="emailAction" title="Email" href="https://posting.orlandoweekly.com/orlando/Tools/EmailFriend?oid=31190200" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>
</div> <div class="l0" style="width:20%; height: 20px; float:left;">
<a class="printAction" title="Print" href="https://www.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content?mode=print&amp;oid=31190200" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:20%; height: 20px; float:right;">
<div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-54d38c2c42ccebb5" addthis:url="https://www.orlandoweekly.com/orlando/florida-film-festival-announces-2022-fest-lineup-with-over-160-films-and-william-shatner/Content?oid=31190200" addthis:title="Florida Film Festival announces 2022 fest lineup with over 160 films and William Shatner" addthis:description="" class="addthis_button_compact">Share</a></div>
<script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54d38c2c42ccebb5", true);
  </script>
</div>
</div>
</div>
<script type="text/javascript">
      Foundation.Tools.setup();
    </script>
<div id="StoryHeader" class="SpanningFeature ContentDefault   ">
<div class="storyHead">
<h1 class="headline headline-31190200">Florida Film Festival announces 2022 fest lineup with over 160 films and William Shatner&nbsp;</h1>
<cite class="byline">
<span class="byAttribute">By</span> <a href="https://www.orlandoweekly.com/author/matthew-moyer" rel="author">Matthew Moyer</a>
</cite>
</div>
</div> 
<div id="StoryLayout" class="SpanningFeature ContentDefault ">
<div id="storyBody" class="page1">
<div class="contentImageCenter" style="overflow:hidden;"> <span class="clicktozoom imageHasURL">click image</span> <a href="https://www.facebook.com/floridafilmfestival/photos/10165333932635314" target="_blank" title="PHOTO COURTESY THE FLORIDA FILM FESTIVAL/FACEBOOK"> <img src="https://media2.orlandoweekly.com/orlando/imager/u/blog/31190837/173821059_10165333932640314_5800611748280598168_n.jpeg?cb=1647528939" width="660" height="508" alt="PHOTO COURTESY THE FLORIDA FILM FESTIVAL/FACEBOOK" srcset="" /> </a> <ul style="width:660px;overflow:hidden;margin-left:auto;margin-right:auto;"> <li class="imageCredit"> Photo courtesy the Florida Film Festival/Facebook </li> </ul> </div> <br>
The Florida Film Festival returns in April for a 31st year with a massive lineup of 167 films … and a very special guest in the form of William Shatner.
<br>
<br>
Kicking off in just a few scant weeks, FFF offers all manner of new, diverse and challenging cinema, be it long-form features, documentaries, short films and animation. There will be&nbsp;24 world premieres for local film buffs to take in, and a number of special events, forums and an awards party —&nbsp;some of these taking place in the Winter Park Public Library.
<br><br>
<div class="inlineComponent AdNativeInline">
<div id="AdNativeInline" class="SpanningFeature AdNativeInline ">

<div id="div-gpt-ad-orl_desktopnative-2" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-2');
                });
              </script>
</div>
</div>
</div>
<br>
<br>
And then there's the matter of <a href="https://www.floridafilmfestival.com/films/an-evening-with-william-shatner-featuring-star-trek-iv-the-voyage-home/" target="_blank">William Shatner</a> beaming in to Mailtand for a screening of <i>Star Trek IV: The Voyage Home</i> and conducing a Q&amp;A after the film.
<br>
<br>
The program for this year's festival can be perused on the <a href="https://www.floridafilmfestival.com/films/" target="_blank">FFF website</a>.
<br>
<br>
The Florida Film Festival happens from&nbsp;April 8-17 with screenings at the Enzian and special events happening around Winter Park. Passes can be purchased through the <a href="https://www.floridafilmfestival.com/attend/tickets/" target="_blank">FFF's website</a>.
<br>
<br>
<br>
– <br>
<i>Stay on top of Central Florida news and views with our weekly <a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page" target="_blank">newsletters</a>, and consider <a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" target="_blank">supporting this free publication</a>. Our small but mighty team is working tirelessly to bring you Central Florida news, and every little bit helps.</i>
</div>
</div> 

<link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=bd9fbcc5980de49d9236d538e43f6c80" />

<script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=bd9fbcc5980de49d9236d538e43f6c80"></script>
<script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=bd9fbcc5980de49d9236d538e43f6c80"></script>
<style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>
<div id="StoryTags" class="SpanningFeature ContentDefault ">
<p class="tags">Tags: <a href="/orlando/ArticleArchives?category=31066175" rel="tag">Things to Do</a>, <a href="/orlando/ArticleArchives?tag=Enzian%20Theater" rel="tag">Enzian Theater</a>, <a href="/orlando/ArticleArchives?tag=Maitland" rel="tag">Maitland</a>, <a href="/orlando/ArticleArchives?tag=Orlando" rel="tag">Orlando</a>, <a href="/orlando/ArticleArchives?tag=Florida%20Film%20Festival" rel="tag">Florida Film Festival</a>, <a href="/orlando/ArticleArchives?tag=Film" rel="tag">Film</a>, <a href="/orlando/ArticleArchives?tag=Cinema" rel="tag">Cinema</a>, <a href="/orlando/ArticleArchives?tag=Event" rel="tag">Event</a>, <a href="/orlando/ArticleArchives?tag=Movies" rel="tag">Movies</a>, <a href="/orlando/ArticleArchives?tag=FFF" rel="tag">FFF</a>, <a href="/orlando/ArticleArchives?tag=William%20Shatner" rel="tag">William Shatner</a></p>
</div> 
<style>
    #SendaLettertotheEditor {
      border:1px solid #D0D1D3;
      padding:10px 10px 10px 120px;
      min-height:100px;
      background-image:url('/binary/5643/OrlandoWeekly_fbook.jpg');
      background-position:10px 10px;
      background-repeat:no-repeat;
      background-size:100px auto;
    }
      #SendaLettertotheEditor p {
        margin-top:1em;
        margin-bottom:1em;
      }
        #SendaLettertotheEditor p:first-child {
          margin-top:0;
        }
        #SendaLettertotheEditor p:last-child {
          margin-bottom:0;
        }
  </style>
<div id="SendaLettertotheEditor" class="SpanningFeature ContentDefault ">
<p>
We welcome readers to submit letters regarding articles and content in <i>Orlando Weekly</i>. Letters should be a minimum of 150 words, refer to content that has appeared on <i>Orlando Weekly</i>, and must include the writer's full name, address, and phone number for verification purposes. No attachments will be considered. Writers of letters selected for publication will be notified via email. Letters may be edited and shortened for space.
</p>
<p>
Email us at <a href="/cdn-cgi/l/email-protection#05636060616764666e2031356a7769646b616a7260606e697c2b666a683a7670676f60667138496071716077203735716a203735716d6020373540616c716a77"><span class="__cf_email__" data-cfemail="b6d0d3d3d2d4d7d5ddf6d9c4dad7d8d2d9c1d3d3dddacf98d5d9db">[email&#160;protected]</span></a>.
</p>
</div>
<div id="DonationArticleWidget" class="SpanningFeature ContentDefault " style="background-color: rgba(250, 250, 153, 1); padding: 10px;">
<center>
<big><b>Join the <i>Orlando Weekly</i> Press Club</b></big><br><br>
Local journalism is information. Information is power. And we believe <b>everyone</b> deserves access to accurate independent coverage of their community and state.<br>
<b><a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page">Help us keep this coverage going with a one-time donation or an ongoing membership pledge.</a></b><br>
</center>
</div>
<div id="PreviousNextInCategory" class="SpanningFeature ContentDefault ">
<div class="prevNext">
<a href="https://www.orlandoweekly.com/orlando/things-to-do-in-orlando-march-16-22-soccer-mommy-rich-homie-quan-tyler-the-creator-winter-park-sidewalk-art-festival/Content?oid=31184331" class="prev" title="previous">&laquo;&nbsp;Things to do in Orlando, March 16-22: Soccer Mommy, Rich Homie Quan, Tyler the Creator, Winter Park Sidewalk Art Festival</a>
</div>
</div>
<div id="ArchiveLink" class="SpanningFeature ContentDefault ">
<p class="moreArticles">
<a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=31066175">More Things to Do &raquo;</a>
</p>
</div> 
<div class="uk-root">
<div class="componentGrid-TwoZones-Auto-Expand uk-root uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-component-grid-row@m" uk-height-match data-component-grid-id="TopStoriesVideoPair">
<div class="uk-width-1-1 uk-width-auto@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<div class="ComponentZoneA Real1PlayerTrendingPairresponsive  trending-by-day uk-root fdn-margin-vert TrendingContentList comp-landing-trending" data-component-id="TrendingContentList">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Trending
</h3>
</div>
<ul class="pres-ContentListHeadline uk-list uk-list-divider">
<li class="fdn-pres-item">
<a class="uk-flex uk-flex-top" href="https://www.orlandoweekly.com/orlando/things-to-do-in-orlando-march-16-22-soccer-mommy-rich-homie-quan-tyler-the-creator-winter-park-sidewalk-art-festival/Content?oid=31184331">
<p class="fdn-teaser-headline">
Things to do in Orlando, March 16-22: Soccer Mommy, Rich Homie Quan, Tyler the Creator, Winter Park Sidewalk Art Festival
</p>
</a>
</li>
<li class="fdn-pres-item">
<a class="uk-flex uk-flex-top" href="https://www.orlandoweekly.com/orlando/billy-joel-plays-some-unexpected-hits-during-a-freezing-show-at-orlandos-camping-world-stadium/Content?oid=31178110">
<p class="fdn-teaser-headline">
Billy Joel plays some unexpected hits during a freezing show at Orlando's Camping World Stadium
</p>
</a>
</li>
<li class="fdn-pres-item">
<a class="uk-flex uk-flex-top" href="https://www.orlandoweekly.com/orlando/free-will-astrology-your-horoscope-for-the-week-of-march-16-22/Content?oid=31184093">
<p class="fdn-teaser-headline">
Free Will Astrology: Your horoscope for the week of March 16-22
</p>
</a>
</li>
</ul>
</div>
</div>
<div class="uk-width-1-1 uk-width-expand@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src="https://www.voqally.com/hub/app/r.js?key=73bad6b0b99988cb9a30860324a0f8a8" async></script>
</div>
</div>
</div>
<div id="RelatedLocations" class="SpanningFeature ContentDefault RelatedItem">
<h3><span class="headingText">
Related Locations
</span></h3>
<ul>
<li id="vcard-2291964" class="l0 locationItem vcard">
<h4>
<span class="longOnly"><div class="FeaturesIcons">
<a href="/orlando/LocationSearch?feature=Kid%20Friendly" class="FeaturesIcons_kid_friendly" title="Kid Friendly"><span>Kid Friendly</span></a>
</div></span>
<a href="https://www.orlandoweekly.com/orlando/enzian-theater/Location?oid=2291964" class="fn org">Enzian Theater</a>
</h4>
<ul>
<li class="l1 longOnly adr">
<span class="street-address">1300 S. Orlando Ave.</span><span class="">, <span class="locality">Maitland</span></span>
<span class="locationRegion"><a href="https://www.orlandoweekly.com/orlando/LocationSearch?neighborhood=2282456">Winter Park Area</a></span>
<span class="hidden region">FL</span>
<span class="hidden postal-code">32751-6415</span>
</li>
<li class="l1 hidden geo">
<span class="latitude">28.61646</span>;<span class="longitude">-81.36442</span>
</li>
<li class="l1 longOnly">
<span class="locationPhone tel"><img src="/images/icons/phone.gif" alt="phone" /> <span class="value">407-629-0054</span></span>
</li>
<li class="l1 longOnly">
<span class="locationUrl"><a href="http://enzian.org" target="_blank" class="url">enzian.org</a></span>
</li>
</ul>
</li>
</ul>
</div>
<div id="RelatedStories" class="SpanningFeature ContentDefault RelatedItem">
<h3><span class="headingText">Related Stories</span></h3>
<ul class="">
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/timucua-arts-foundation-to-kick-off-month-of-jazz-event-series-at-the-end-of-march/Content?oid=31189959&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31189968/ulysses_owens_jr_b.jpeg" alt="Timucua Arts Foundation to kick off &#39;Month of Jazz&#39; event series at the end of March" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/timucua-arts-foundation-to-kick-off-month-of-jazz-event-series-at-the-end-of-march/Content?oid=31189959&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Timucua Arts Foundation to kick off 'Month of Jazz' event series at the end of March</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/orlando-chefs-and-restaurateurs-shut-out-of-james-beard-award-nominations-yet-again/Content?oid=31189491&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/31189493/rabii.jpg" alt="Orlando chefs and restaurateurs shut out of James Beard Award nominations yet again" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/orlando-chefs-and-restaurateurs-shut-out-of-james-beard-award-nominations-yet-again/Content?oid=31189491&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Orlando chefs and restaurateurs shut out of James Beard Award nominations yet again</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/lgbtq-disney-employees-plan-walkouts-over-companys-response-to-dont-say-gay-bill/Content?oid=31189497&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31189731/disney.jpg" alt="LGBTQ Disney employees plan walkouts over company&#39;s response to &#39;Don&#39;t Say Gay&#39; bill" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/lgbtq-disney-employees-plan-walkouts-over-companys-response-to-dont-say-gay-bill/Content?oid=31189497&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">LGBTQ Disney employees plan walkouts over company's response to 'Don't Say Gay' bill</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/video-shows-huge-lakeland-alligator-grandpappy-eating-a-smaller-gator-on-a-golf-course/Content?oid=31189261&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31189265/screenshot_2022-03-16_9.21.44_am.png" alt="Video shows huge Lakeland alligator &quot;Grandpappy&quot; eating a smaller gator on a golf course" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/video-shows-huge-lakeland-alligator-grandpappy-eating-a-smaller-gator-on-a-golf-course/Content?oid=31189261&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Video shows huge Lakeland alligator "Grandpappy" eating a smaller gator on a golf course</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/at-orlando-weekly-we-say-gay-and-we-will-keep-saying-gay-regardless-of-what-gov-ron-desantis-or-91-florida-legislators-think/Content?oid=31183867&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/31189508/main-imgl8700.jpg" alt="At Orlando Weekly, we say gay, and we also say lesbian, queer, bi, trans and intersex" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/at-orlando-weekly-we-say-gay-and-we-will-keep-saying-gay-regardless-of-what-gov-ron-desantis-or-91-florida-legislators-think/Content?oid=31183867&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">At Orlando Weekly, we say gay, and we also say lesbian, queer, bi, trans and intersex</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/republicans-across-the-country-are-trying-to-use-legislation-to-privilege-their-beliefs-over-the-human-rights-of-others/Content?oid=31184083&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/31184087/infodiss_shutterstock_237231721.jpg" alt="Republicans across the country are trying to use legislation to privilege their beliefs over the human rights of others" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/republicans-across-the-country-are-trying-to-use-legislation-to-privilege-their-beliefs-over-the-human-rights-of-others/Content?oid=31184083&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Republicans across the country are trying to use legislation to privilege their beliefs over the human rights of others</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/phase-2-of-marc-with-a-cs-career-is-a-sweeping-sea-change-that-shifts-to-the-direct-perspective-of-the-real-marc-sirdoreus/Content?oid=31184321&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31184099/tlu-marc-with-a-c-photo-by-vikka-leoni-1.jpg" alt="Phase 2 of Marc With a C&rsquo;s career is a sweeping sea change that shifts to the direct perspective of the real Marc Sirdoreus" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/phase-2-of-marc-with-a-cs-career-is-a-sweeping-sea-change-that-shifts-to-the-direct-perspective-of-the-real-marc-sirdoreus/Content?oid=31184321&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Phase 2 of Marc With a C’s career is a sweeping sea change that shifts to the direct perspective of the real Marc Sirdoreus</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/orlando-staple-southern-fried-sunday-celebrates-turning-old-enough-to-drive-with-a-great-big-musical-bash/Content?oid=31184341&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/31184338/music-sfs-photo-by-michael-lothrop.jpg" alt="Orlando staple Southern Fried Sunday celebrates turning old enough to drive with a great big musical bash" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/orlando-staple-southern-fried-sunday-celebrates-turning-old-enough-to-drive-with-a-great-big-musical-bash/Content?oid=31184341&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Orlando staple Southern Fried Sunday celebrates turning old enough to drive with a great big musical bash</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/yummy-taste-in-east-orlando-makes-kitchen-play-with-sichuan-peppercorns/Content?oid=31185011&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31185009/yummy-taste-3.jpg" alt="Yummy Taste in East Orlando makes kitchen play with Sichuan peppercorns" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/yummy-taste-in-east-orlando-makes-kitchen-play-with-sichuan-peppercorns/Content?oid=31185011&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Yummy Taste in East Orlando makes kitchen play with Sichuan peppercorns</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
</ul>
</div>
<div id="AdNativeEndofArticle" class="SpanningFeature ContentDefault ">

<div id="div-gpt-ad-orl_desktopnative-3" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-3');
                });
              </script>
</div>
</div>
<div id="RecentByTag" class="SpanningFeature ContentDefault ">
<h3 class="latestorlando_area_news">
<span class="headingText">
Speaking of...
</span>
</h3>
<ul class="moduleList">
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/alligator-unsuccessfully-tries-out-for-high-school-swim-team-near-orlando/Content?oid=31190601&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31190607/gator.jpg" alt="Alligator unsuccessfully tries out for high school swim team near Orlando" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/alligator-unsuccessfully-tries-out-for-high-school-swim-team-near-orlando/Content?oid=31190601&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">Alligator unsuccessfully tries out for high school swim team near Orlando</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/all-hail-valencia-colleges-proposed-sentient-orange-mascot/Content?oid=31183629&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/31183632/screenshot_2022-03-15_1.20.42_pm.png" alt="All hail Valencia College&#39;s (proposed) sentient orange mascot" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/all-hail-valencia-colleges-proposed-sentient-orange-mascot/Content?oid=31183629&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">All hail Valencia College's (proposed) sentient orange mascot</a>
</h4>
<div class="date"> Mar 15, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/reggaeton-duo-wisin-y-yandel-to-stop-at-orlandos-amway-center-on-final-tour/Content?oid=31182896&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31183132/sony_music_latin.jpg" alt="Reggaeton duo Wisin y Yandel to stop at Orlando&#39;s Amway Center on final tour" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/reggaeton-duo-wisin-y-yandel-to-stop-at-orlandos-amway-center-on-final-tour/Content?oid=31182896&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">Reggaeton duo Wisin y Yandel to stop at Orlando's Amway Center on final tour</a>
</h4>
<div class="date"> Mar 15, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=Enzian%20Theater%7C%7CMaitland%7C%7COrlando%7C%7CFlorida%20Film%20Festival%7C%7CFilm%7C%7CCinema%7C%7CEvent%7C%7CMovies%7C%7CFFF%7C%7CWilliam%20Shatner" class="more">More &raquo;</a>
</li>
</ul>
</div>
<div id="LatestInCategory" class="SpanningFeature ContentDefault ">
<h3 class="latestthings_to_do"><span class="headingText">Latest in Things to Do</span></h3>
<ul class="moduleList ui list grouped expanded">
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/things-to-do-in-orlando-march-16-22-soccer-mommy-rich-homie-quan-tyler-the-creator-winter-park-sidewalk-art-festival/Content?oid=31184331&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31184330/the-week-soccer-mommy-photo-by-brian-ziff.jpg" alt="Things to do in Orlando, March 16-22: Soccer Mommy, Rich Homie Quan, Tyler the Creator, Winter Park Sidewalk Art Festival" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/things-to-do-in-orlando-march-16-22-soccer-mommy-rich-homie-quan-tyler-the-creator-winter-park-sidewalk-art-festival/Content?oid=31184331&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">Things to do in Orlando, March 16-22: Soccer Mommy, Rich Homie Quan, Tyler the Creator, Winter Park Sidewalk Art Festival</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/mister-rogers-neighborhood-walking-tour-resumes-at-rollins-to-celebrate-his-birthday/Content?oid=31183386&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31183394/27655336_10155425407407169_6445338402893105737_n.jpg" alt="Mister Rogers&#39; Neighborhood Walking Tour resumes at Rollins to celebrate his birthday" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/mister-rogers-neighborhood-walking-tour-resumes-at-rollins-to-celebrate-his-birthday/Content?oid=31183386&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">Mister Rogers' Neighborhood Walking Tour resumes at Rollins to celebrate his birthday</a>
</h4>
<div class="date"> Mar 15, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/oviedos-first-ever-st-patricks-day-festival-will-take-place-on-march-19/Content?oid=31182651&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31183385/adobestock_32591405.jpeg" alt="Oviedo throws first ever St. Patrick&#39;s Day Festival on March 19" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/oviedos-first-ever-st-patricks-day-festival-will-take-place-on-march-19/Content?oid=31182651&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">Oviedo throws first ever St. Patrick's Day Festival on March 19</a>
</h4>
<div class="date"> Mar 15, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=31066175&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory" class="more">More &raquo;</a>
</li>
</ul>
</div>
<div id="MorebyThisAuthorWrapper" class="SpanningFeature ContentDefault Wrapper">
<div id="MorebyThisAuthor" class="SpanningFeature ContentDefault ">
<h3><span class="headingText">More by Matthew Moyer</span></h3>
<ul class="moduleList">
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/timucua-arts-foundation-to-kick-off-month-of-jazz-event-series-at-the-end-of-march/Content?oid=31189959&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31189968/ulysses_owens_jr_b.jpeg" alt="Timucua Arts Foundation to kick off &#39;Month of Jazz&#39; event series at the end of March" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/timucua-arts-foundation-to-kick-off-month-of-jazz-event-series-at-the-end-of-march/Content?oid=31189959&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Timucua Arts Foundation to kick off 'Month of Jazz' event series at the end of March</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/orlando-staple-southern-fried-sunday-celebrates-turning-old-enough-to-drive-with-a-great-big-musical-bash/Content?oid=31184341&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
<img src="https://media2.orlandoweekly.com/orlando/imager/u/bigsquare/31184338/music-sfs-photo-by-michael-lothrop.jpg" alt="Orlando staple Southern Fried Sunday celebrates turning old enough to drive with a great big musical bash" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/orlando-staple-southern-fried-sunday-celebrates-turning-old-enough-to-drive-with-a-great-big-musical-bash/Content?oid=31184341&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Orlando staple Southern Fried Sunday celebrates turning old enough to drive with a great big musical bash</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem">
<a href="https://www.orlandoweekly.com/orlando/things-to-do-in-orlando-march-16-22-soccer-mommy-rich-homie-quan-tyler-the-creator-winter-park-sidewalk-art-festival/Content?oid=31184331&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
<img src="https://media1.orlandoweekly.com/orlando/imager/u/bigsquare/31184330/the-week-soccer-mommy-photo-by-brian-ziff.jpg" alt="Things to do in Orlando, March 16-22: Soccer Mommy, Rich Homie Quan, Tyler the Creator, Winter Park Sidewalk Art Festival" width="190" height="190" srcset="" />
</a>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/things-to-do-in-orlando-march-16-22-soccer-mommy-rich-homie-quan-tyler-the-creator-winter-park-sidewalk-art-festival/Content?oid=31184331&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Things to do in Orlando, March 16-22: Soccer Mommy, Rich Homie Quan, Tyler the Creator, Winter Park Sidewalk Art Festival</a>
</h4>
<div class="date"> Mar 16, 2022 </div>
</li>
<li class="l0 storyItem more">
<a href="https://www.orlandoweekly.com/orlando/ArticleArchives?author=2478783" class="more">More &raquo;</a>
</li>
</ul>
</div>
</div>
</div>
<div id="gridSpanningFeature2">
</div>
<div id="gridColumnContainer" class="clearfix">
<div id="gridMainColumn1">
</div>
<div id="gridMainColumn2">
</div>
</div>
</div>
<div id="gridRightColumn">
<div id="gridSpanningIsland">
<div id="TabbedPopularity" class="SpanningIsland ContentDefault ">
<h2>Most Popular</h2>
<div class="tabs">
<div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
<div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
</div>
<div class="popularityBody">
<ol class="moduleList">
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/things-to-do-in-orlando-march-16-22-soccer-mommy-rich-homie-quan-tyler-the-creator-winter-park-sidewalk-art-festival/Content?oid=31184331&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Things to do in Orlando, March 16-22: Soccer Mommy, Rich Homie Quan, Tyler the Creator, Winter Park Sidewalk Art Festival <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/billy-joel-plays-some-unexpected-hits-during-a-freezing-show-at-orlandos-camping-world-stadium/Content?oid=31178110&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Billy Joel plays some unexpected hits during a freezing show at Orlando's Camping World Stadium <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/free-will-astrology-your-horoscope-for-the-week-of-march-16-22/Content?oid=31184093&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Free Will Astrology: Your horoscope for the week of March 16-22 <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/oviedos-first-ever-st-patricks-day-festival-will-take-place-on-march-19/Content?oid=31182651&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Oviedo throws first ever St. Patrick's Day Festival on March 19 <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/vegas-mega-attraction-area15-is-officially-coming-to-orlando-heres-everything-we-know/Content?oid=31153253&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Las Vegas mega-attraction AREA15 is officially coming to Orlando. Here's everything we know. <span class="more">Read More</span></a></h4>
</li>
</ol>
</div>
<div class="popularityBody" style="display:none">
<div class="currentIssue">
<a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=31183859&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
<img src="/imager/b/cover/31183859/e6fe/OW-Cover-03162022.jpg" alt="Issue Cover" />
</a>
<p>March 16-22, 2022</p>
</div>
<ol class="moduleList">
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/things-to-do-in-orlando-march-16-22-soccer-mommy-rich-homie-quan-tyler-the-creator-winter-park-sidewalk-art-festival/Content?oid=31184331&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Things to do in Orlando, March 16-22: Soccer Mommy, Rich Homie Quan, Tyler the Creator, Winter Park Sidewalk Art Festival <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/orlando-staple-southern-fried-sunday-celebrates-turning-old-enough-to-drive-with-a-great-big-musical-bash/Content?oid=31184341&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Orlando staple Southern Fried Sunday celebrates turning old enough to drive with a great big musical bash <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/new-on-netflix-this-week-the-principles-of-pleasure-soil-black-crab-is-it-cake-and-more/Content?oid=31184567&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">New on Netflix this week: ‘The Principles of Pleasure,’ ‘Soil,’ ‘Black Crab,’ ‘Is It Cake?’ and more <span class="more">Read More</span></a></h4>
</li>
<li>
<h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/yummy-taste-in-east-orlando-makes-kitchen-play-with-sichuan-peppercorns/Content?oid=31185011&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Yummy Taste in East Orlando makes kitchen play with Sichuan peppercorns <span class="more">Read More</span></a></h4>
</li>
</ol>
</div>
</div>
<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>

<div id="SearchRightCol" class="SpanningIsland ContentDefault  search-wrap">
<form class="prepTextForm" id="searchbox_017793458706336421686:1y5lan2fdja" action="https://posting.orlandoweekly.com/orlando/Search">
<input type="hidden" name="cx" value="017793458706336421686:1y5lan2fdja" />
<input type="hidden" name="cof" value="FORID:9" />
<input id="search-submit" type="submit" name="sa" value="Search" />
<input id="search-input" autocomplete="off" type="text" name="q" size="25" placeholder="Search" />
</form>
<ul id="search-dropdown" class="search-dropdown" style="display:none;">
<li class="search-option"><a class="search-all" href="https://posting.orlandoweekly.com/orlando/Search"><span class="dark-search-icon"></span>&nbsp;All</a></li>
<li class="search-option"><a href="https://www.orlandoweekly.com/orlando/ArticleArchives"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
<li class="search-option"><a href="https://www.orlandoweekly.com/orlando/EventSearch"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
<li class="search-option"><a href="https://www.orlandoweekly.com/orlando/LocationSearch"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
</ul>
</div>
<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            if( newLocation.match(/\?/)){
              newLocation = newLocation+'&';
            }else{
              newLocation = newLocation+'?';
            }
            window.location = newLocation + "keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>

<div id="AdMediumRectangle1300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-orl_300x250-1" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-1');
                });
              </script>
</div>
</div>
<div id="NewsletterSignup" class="SpanningIsland ContentDefault ">
<h2>Newsletters</h2>
<div class="wrap">
<h3>Never miss a beat</h3>
<a href="/orlando/NewsletterSignup/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color:#F7941E;font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
</div>
</div>
<div id="CurrentIssuu" class="SpanningIsland ContentDefault ">
<h2>Read the Digital Print Issue</h2>
<div class="wrap">
<h3>March 16, 2022</h3>
<iframe src="https://e.issuu.com/embed.html?d=orlando_weekly_march_16_2022&hideIssuuLogo=true&pageLayout=singlePage&u=euclidmediagroup" allowfullscreen allow="fullscreen" style="border:none;width:100%;height:300px;"></iframe>
<p style="margin:10px 0;">
<a class="more" href="https://www.orlandoweekly.com/orlando/IssueArchives">View more issues</a>
</p>
</div>
</div>
<div id="AdMediumRectangle2300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-orl_300x250-2" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-2');
                });
              </script>
</div>
</div><div id="PhotoSlideshows" class="SpanningIsland ContentDefault ">
<h2><a href="http://photos.orlandoweekly.com/" target="_blank">Newest Slideshows</a></h2>
<iframe src="//photos.orlandoweekly.com/thumbnail-scroller-square/" height="419" width="364" scrolling="no" frameborder="0"></iframe>
</div>

<div id="SpecialIssues" class="SpanningIsland ContentDefault ">
<h2><a href="https://www.orlandoweekly.com/orlando/orlando-guides/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
<div class="reportBox">
<a href="/orlando/annual-manual/Category?oid=2240488&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media1.orlandoweekly.com/orlando/imager/u/original/28122110/cover_rightrailcrop.jpg);">
<span class="grayRedBox">Annual Manual</span>
</a>
</div>
<div class="reportBox">
<a href="/orlando/bite/Category?oid=2240489&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media1.orlandoweekly.com/orlando/imager/u/original/25632553/cover_bite2019_rightrailwidget.jpg);">
<span class="grayRedBox">Bite</span>
</a>
</div>
<div class="reportBox">
<a href="/orlando/newcomers-guide/Category?oid=2240498&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media2.orlandoweekly.com/orlando/imager/u/original/26132383/newcomers2019_rrlink.jpg);">
<span class="grayRedBox">Newcomers Guide</span>
</a>
</div>
<div class="reportBox">
<a href="/orlando/summer-guide/Category?oid=2240491&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" style="background-image:url(https://media1.orlandoweekly.com/orlando/imager/u/original/31106308/alisonwinterroth.jpeg);">
<span class="grayRedBox">Summer Guide</span>
</a>
</div>
<a href="https://www.orlandoweekly.com/orlando/orlando-guides/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
</div>
<div id="AdMediumRectangle3300x250" class="SpanningIsland ContentDefault ">

<div id="div-gpt-ad-orl_300x250-3" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-3');
                });
              </script>
</div>
</div><div id="slideshow-feed"></div>
<div id="TabbedCalendar" class="SpanningIsland ContentDefault ">
<h2>Calendar</h2>
<div class="tabs">
<div id="tabEvents" class="tab"><a href="#">Events</a></div>
<div id="tabMusic" class="tab"><a href="#">Music</a></div>
<div id="tabMovies" class="tab"><a href="#">Movies</a></div>
<div id="tabArts" class="tab"><a href="#">Arts</a></div>
<div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/st-patricks-day-at-the-pub/Event?oid=31150595&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
St. Patrick's Day at The Pub <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/st-patricks-day-outdoor-street-party-w-tim-hamlin-dj-scotty-b-and-the-hooligans/Event?oid=30973326&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
St. Patricks Day Outdoor Street Party w/Tim Hamlin, DJ Scotty B, and The Hooligans <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/mighty-st-patricks-festival/Event?oid=31073744&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Mighty St. Patrick's Festival <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/orlando-magic-vs-detroit-pistons/Event?oid=29845464&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Orlando Magic vs. Detroit Pistons <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/beaches-and-deserts-paintings-by-david-fithian/Event?oid=31064283&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Beaches and Deserts: Paintings by David Fithian <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/estopa/Event?oid=30321624&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Estopa <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/the-bailsmen/Event?oid=31018508&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
The Bailsmen <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/patti-labelle/Event?oid=30140721&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Patti LaBelle <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/the-english-beat-oklahoma-stackhouse/Event?oid=30441818&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
The English Beat, Oklahoma Stackhouse <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/st-patricks-day-90s-jams/Event?oid=31176745&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
St. Patrick's Day 90's Jams <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li style="list-style-type:none;">No results <a class="more" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar"> Film Event Search</a></li>
</ol>
</div>
<div class="eventTabGuts" style="display:none">
<div class="tabsButtonRow">
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
<a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
</div>
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/beaches-and-deserts-paintings-by-david-fithian/Event?oid=31064283&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Beaches and Deserts: Paintings by David Fithian <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/third-thursdays-open-house/Event?oid=15249972&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Third Thursdays Open House <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/third-thursday-gallery-hop/Event?oid=2304895&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Third Thursday Gallery Hop <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/winter-park-sidewalk-art-festival-celebration/Event?oid=31184572&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Winter Park Sidewalk Art Festival Celebration <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/free-friday-nights-at-the-morse/Event?oid=30489375&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Free Friday Nights at the Morse <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
</div>
<div class="eventTabGuts" style="display:none">
<ol class="moduleList">
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/taboule-cafe/Location?oid=2288465&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Taboule Cafe <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/india-palace/Location?oid=2285335&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
India Palace <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
<li>
<h4 class="headline">
<a href="https://www.orlandoweekly.com/orlando/smokey-bones-barbeque/Location?oid=2288425&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
Smokey Bones Barbeque <span class="more">&nbsp;Read More</span>
</a>
</h4>
</li>
</ol>
<form name="diningSearchForm" method="get" action="https://www.orlandoweekly.com/orlando/LocationSearch">
<input type="hidden" name="locationSection" value="2282258" />
<input type="hidden" name="guide" value="2124367" />
<select name="locationCategory">
<option value="">-All Categories-</option>
<option value="2282260">African</option>
<option value="2282261">American</option>
<option value="2282262">Argentine</option>
<option value="2282263">Armenian</option>
<option value="2282264">Bakery</option>
<option value="2282265">Barbecue</option>
<option value="27096422">Brazilian</option>
<option value="2282266">Breakfast/Brunch</option>
<option value="2282267">Brewpub</option>
<option value="2282286">Burgers</option>
<option value="2282268">Café/Bistro</option>
<option value="2282269">Cajun/Creole</option>
<option value="2282270">Caribbean</option>
<option value="2282272">Chinese</option>
<option value="2282271">Coffee house (chain)</option>
<option value="2282289">Coffee house (independent)</option>
<option value="2282274">Contemporary</option>
<option value="2282276">Cuban</option>
<option value="2297679">Deli</option>
<option value="27294676">Desserts</option>
<option value="2282278">Diner</option>
<option value="27012503">Dutch</option>
<option value="2282279">Eastern European</option>
<option value="26255950">Egyptian</option>
<option value="26628154">Eritrean</option>
<option value="2282280">Ethiopian</option>
<option value="2282275">European</option>
<option value="26302999">Filipino-American</option>
<option value="2282281">Fondue</option>
<option value="28902623">Food Hall</option>
<option value="2304903">Food Truck</option>
<option value="2282282">French</option>
<option value="2282283">General</option>
<option value="2282399">General Fare</option>
<option value="2282284">German</option>
<option value="2282285">Greek</option>
<option value="2282287">Hawaiian</option>
<option value="2282288">Hot Dogs</option>
<option value="27069718">Ice Cream</option>
<option value="2282290">Indian</option>
<option value="2282291">Indonesian</option>
<option value="2282292">Irish</option>
<option value="2282293">Israeli</option>
<option value="2282294">Italian</option>
<option value="2282295">Jamaican</option>
<option value="27069314">Japanese</option>
<option value="2282296">Japanese/Sushi</option>
<option value="25626307">Juice</option>
<option value="2282297">Korean</option>
<option value="2297696">Kosher</option>
<option value="27095777">Laotian</option>
<option value="2282298">Latin American</option>
<option value="2282299">Lebanese</option>
<option value="2305936">Malaysian</option>
<option value="2282300">Market</option>
<option value="2282301">Mediterranean</option>
<option value="2282302">Mexican</option>
<option value="2282303">Middle Eastern</option>
<option value="2345788">Modern American</option>
<option value="2282304">Mongolian</option>
<option value="2282305">Moroccan</option>
<option value="2282306">Noodles</option>
<option value="2282307">Pan-Asian</option>
<option value="2282308">Persian</option>
<option value="2282309">Peruvian</option>
<option value="2282310">Philippine</option>
<option value="2282311">Pizza</option>
<option value="26186721">Poké</option>
<option value="2282312">Polish</option>
<option value="2297728">Pub Grub</option>
<option value="2282313">Puerto Rican</option>
<option value="2282314">Russian</option>
<option value="2282315">Salads</option>
<option value="2282277">Sandwiches/Subs</option>
<option value="26147501">Saudi</option>
<option value="26147502">Saudi-Indonesian</option>
<option value="2282316">Seafood</option>
<option value="2282317">Soup</option>
<option value="2282318">Southern/Soul</option>
<option value="2282319">Spanish</option>
<option value="2282320">Steakhouse</option>
<option value="2282321">Swedish</option>
<option value="2282322">Sweets</option>
<option value="2282323">Tapas</option>
<option value="2282273">Tea</option>
<option value="2282324">Tex-Mex</option>
<option value="2282325">Thai</option>
<option value="2282326">Turkish</option>
<option value="2282327">Vegetarian/Vegan</option>
<option value="2282328">Vietnamese</option>
<option value="2282329">Wine</option>
</select>
<select name="neighborhood">
<option value="">-All Neighborhoods-</option>
<option value="2292883">&nbsp;&nbsp;Apopka</option>
<option value="2282447">&nbsp;&nbsp;Central</option>
<option value="2292887">&nbsp;&nbsp;Audubon Park</option>
<option value="2292884">&nbsp;&nbsp;Casselberry</option>
<option value="2282448">&nbsp;&nbsp;Disney</option>
<option value="2282449">&nbsp;&nbsp;Downtown</option>
<option value="2282450">&nbsp;&nbsp;East</option>
<option value="2399527">&nbsp;&nbsp;Edgewood</option>
<option value="2282451">&nbsp;&nbsp;Elsewhere</option>
<option value="2282452">&nbsp;&nbsp;I-Drive/Universal</option>
<option value="2292885">&nbsp;&nbsp;Ivanhoe Village</option>
<option value="2282453">&nbsp;&nbsp;North</option>
<option value="2282454">&nbsp;&nbsp;South</option>
<option value="2282455">&nbsp;&nbsp;West</option>
<option value="4366406">&nbsp;&nbsp;Dr. Phillips</option>
<option value="2282456">&nbsp;&nbsp;Winter Park Area</option>
<option value="2343583">&nbsp;&nbsp;Milk District</option>
<option value="2343582">&nbsp;&nbsp;SoDo</option>
<option value="2343585">&nbsp;&nbsp;Kissimmee</option>
<option value="2343584">&nbsp;&nbsp;UCF</option>
<option value="2343586">&nbsp;&nbsp;Mount Dora</option>
<option value="2343587">&nbsp;&nbsp;Conway/Curry Ford</option>
<option value="2343589">&nbsp;&nbsp;Belle Isle</option>
<option value="2343590">&nbsp;&nbsp;Mills 50</option>
<option value="2345785">&nbsp;&nbsp;College Park</option>
<option value="2345787">&nbsp;&nbsp;Thornton Park</option>
<option value="26484602">&nbsp;&nbsp;North Florida</option>
<option value="26718775">&nbsp;&nbsp;Baldwin Park</option>
<option value="26947375">&nbsp;&nbsp;Eola Heights</option>
<option value="26947376">&nbsp;&nbsp;South Eola</option>
<option value="27106618">&nbsp;&nbsp;Online Only</option>
<option value="27050023">&nbsp;&nbsp;Sanford</option>
<option value="29376566">&nbsp;&nbsp;Colonialtown</option>
<option value="28994110">&nbsp;&nbsp;New Smyrna</option>
</select>
<div class="searchBox">
<input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
<input type="submit" value="go" />
</div>
</form>
</div>
</div>
<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 3
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
</div>
<div id="gridMainSidebar">
</div>
<div id="gridAdSidebar">
</div>
<div id="gridBottomSidebar">
</div>
</div>

<div id="gridFooter">
<div id="FooterInfo" class="GlobalFooter ContentDefault ">
<div class="footerCustomInfo">
<h2>Orlando Weekly</h2>
<p>16 W. Pine St.</p>
<p>Orlando, FL 32801</p>
<p>Phone: (407) 377-0400</p>
<p>Classified Phone: (407) 377-0415</p>
<p>Fax: (407) 377-0420</p>
</div>
<div class="footerCustomWrap">
<div class="footerCustomNav">
<ul>
<li><a target="_top" href="/orlando/AboutOrlandoWeekly/Page">About OW</a></li>
<li><a target="_top" href="https://www.orlandoweekly.com/orlando/AdvertiseWithOrlandoWeekly/Page">Advertise</a></li>
<li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
<li><a target="_blank" href="/blogs/LegalAdvertising/">Legal Advertising</a></li>
<li><a target="_top" href="/orlando/WorkForUs/Page">Work Here</a></li>
</ul>
<p>All parts of this site Copyright &copy; 2022 Orlando Weekly.</p>
</div>
<div class="footerRssLink">
<a href="https://www.orlandoweekly.com/orlando/Syndication" class="RSSLink">RSS Feeds</a>
</div>
<div class="footerCustomLogin">
<ul data-view="loggedin" style="display:none">
<li><strong data-label="username">Username</strong> / </li>
<li><a href="https://posting.orlandoweekly.com/orlando/MyProfile">View Profile</a> / </li>
<li><a href="https://posting.orlandoweekly.com/orlando/Profile/MySettings">Edit Profile</a> / </li>
<li><a href="https://www.orlandoweekly.com/orlando/Logout">Log Out</a></li>
</ul>
<ul data-view="loggedout" style="display:none">
<li><a href="#LogIn">Log in</a> / </li>
<li><a href="#CreateAccount">Create Account</a></li>
</ul>
</div>
<script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
</div>
<div class="clear"></div>
</div>

<div id="AdFooter728x90" class="GlobalFooter ContentDefault ">

<div id="div-gpt-ad-orl_728x90-2" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-2');
                });
              </script>
</div>
</div>
<div id="FooterNavigation" class="GlobalFooter ContentDefault ">
<div class="linkGroupColumn">
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="/orlando/news-and-features/Section?oid=2240408" target="_">
News
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/orlando-area-news/Category?oid=31065036">Orlando Area News</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/florida-news/Category?oid=31065043">Florida News</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/pulse/Topics?oid=31060458">Pulse</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/orlando-sports/Topics?oid=31060463">Orlando Sports</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/savage-love/Category?oid=2240424">Savage Love</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/reader-reactions/Topics?oid=31067344">Reader Reactions</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/comics/Category?oid=2240423">Comics</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=this%20week">Digital Issue</a></li>
<li><a href="https://photos.orlandoweekly.com/category/newsslideshows/">News Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Movies</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/movie-reviews/Category?oid=31065358">Movie Reviews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/streaming/Category?oid=31065342">Streaming</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationCategory=2282370&sortType=name">Find a Theater</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/MovieTimes">Movie Times</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>Arts + Culture</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/arts-stories-interviews/Category?oid=2240434">Arts Stories + Interviews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/orlando-theme-parks/Topics?oid=31060466">Orlando Theme Parks</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/astrology/Category?oid=31065290">Astrology</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/performing-arts/Topics?oid=31060468">Performing Arts</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/visual-arts/Topics?oid=31060469">Visual Arts</a></li>
<li><a href="https://photos.orlandoweekly.com/category/artsslideshows/">Arts + Culture Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>
<a href="/orlando/EventSearch" target="_">
Calendar
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&v=d">Today's Events</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&sortType=date&v=d">This Weekend</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/EventSearch?feature=Free&sortType=date&v=d">Free Events</a></li>

<li><a href="https://www.orlandoweekly.com/orlando/Events/AddEvent">Submit an Event</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Social Media</h3>
<ul class="sublinkGroup">
<li><a href="http://instagram.com/orlandoweekly/" target="_blank">Instagram</a></li>
<li><a href="https://twitter.com/orlandoweekly" target="_blank">Twitter</a></li>
<li><a href="https://www.facebook.com/orlandoweekly" target="_blank">Facebook</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>Food + Drink</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/food-news/Category?oid=31065305">Food News</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/drinking-bars/Category?oid=31065312">Drinking + Bars</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/restaurant-review/Category?oid=2240450">Restaurant Reviews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationSection=2282258">Find a Restaurant</a></li>
<li><a href="https://photos.orlandoweekly.com/category/foodslideshows/">Food + Drink Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Best of Orlando®</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2255299">Arts & Culture</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240483">Food & Drink</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240486">Goods & Services</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240482">Local Color</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240485">Music & Nightlife</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/BestOf?category=2240487">Sports & Recreation</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>
<a href="/orlando/music/Section?oid=2240410" target="_">
Music
</a>
</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/music-stories-interviews/Category?oid=2240462">Music Stories + Interviews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/orlando-music-news/Category?oid=31065388">Orlando Music News</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/live-music-picks-previews/Category?oid=31065380">Live Music Picks + Previews</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/this-little-underground/Topics?oid=31060485">This Little Underground</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&sortType=date&v=d">Find a Concert</a></li>
<li><a href="https://photos.orlandoweekly.com/category/musicslideshows/">Music Slideshows</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Orlando Guides</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/summer-guide/Category?oid=2240491">Summer Guide</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/holiday-guide/Category?oid=2240493">Holiday Guide</a></li>
<li><a href="https://www.orlandoweekly.com/blogs/LegalAdvertising/">Legal Advertising</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/sponsored/Section?oid=27656040">Sponsored Articles</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>Sponsored Links</h3>
<ul class="sublinkGroup">
<li><a href="https://www.407apartments.com/ucf-apartments" target="_blank" rel="sponsored">Apartments Near UCF</a></li>
<li><a href="https://www.407apartments.com/orlando-apartments/apartments-near-valencia-college" target="_blank" rel="sponsored">Apartments Near Valencia College</a></li>
<li><a href="https://www.407apartments.com/orlando-apartments/student-apartments-in-orlando" target="_blank" rel="sponsored">Student Housing in Orlando</a></li>
</ul>
</div>
</div>
<div class="linkGroupColumn">
<div class="linkGroup ">
<h3>Giveaways + Events</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273884">Contests</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=2541677">Beer 'Merica</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=23026965">Orlando Burger Week</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=2321136">Bite30</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=9414612">Orlando Taco Week</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=4575095">Tacos & Tequila</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=2387425">Orlando Beer Festival</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?oid=2387353">Whiskey Business</a></li>
</ul>
</div>
<div class="linkGroup ">
<h3>About Us</h3>
<ul class="sublinkGroup">
<li><a href="https://www.orlandoweekly.com/orlando/AboutOrlandoWeekly/Page">Contact Us</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/WorkForUs/Page">Work For Us</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/AboutOrlandoWeekly/Page">Staff Directory</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/Wheretofindus/Page">Where to Find Us</a></li>

<li><a href="https://www.orlandoweekly.com/orlando/FAQs/Page">FAQ</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/Policies/Page">Policies</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page">Support</a></li>
<li><a href="https://mediakit.orlandoweekly.com/" target="_blank">Advertise</a></li>
<li><a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page">Subscribe</a></li>
</ul>
</div>
</div>
</div>

<style>
.sister-links {
  padding: 1em 0;
  border-top: 1px solid #ccc;
}
.sister-links h3 {
  text-align: center;
  font-size: 16px;
}
.sister-links h4 {
  text-align: center;
  font-size: 12px;
  text-transform:uppercase
}
.sister-links p {
  text-align: center;
  font-size: 12px;
}
.sister-links ul {
  text-align: center;
  display: flex;
  flex-wrap: wrap;
  margin: 10px auto;
  justify-content: center;
}
.sister-links li {
  text-align: center;
  padding: 5px 1em;
  border-right: 1px solid #ccc;
}
.sister-links li:last-child {
  border-right:none;
}
</style>
<div id="sister-links" class="sister-links">
<h3>Euclid Media Group, LLC</h3>
<h4>Read Our Sister Publications </h4>
<ul>
<li>
<a href="https://www.clevescene.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Cleveland Scene
</a>
</li>
<li>
<a href="https://www.citybeat.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Cincinnati CityBeat
</a>
</li>
<li>
<a href="https://www.cltampa.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Creative Loafing Tampa
</a>
</li>
<li>
<a href="https://www.metrotimes.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Detroit Metro Times
</a>
</li>
<li>
<a href="https://www.leoweekly.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Louisville LEO Weekly
</a>
</li>
<li>
<a href="https://www.riverfronttimes.com/" rel="noreferrer" target="_blank" heap-ignore="true">
St. Louis Riverfront Times
</a>
</li>
<li>
<a href="https://www.sacurrent.com/" rel="noreferrer" target="_blank" heap-ignore="true">
San Antonio Current
</a>
</li>
<li>
<a href="https://outinsa.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Out in SA
</a>
</li>
<li>
<a href="https://outinstl.com/" rel="noreferrer" target="_blank" heap-ignore="true">
Out in STL
</a>
</li>
</ul>
<h4>Marketing Services</h4>
<p>
<a href="https://localculturecreative.com/" target="_blank" heap-ignore="true">
Local Culture Creative
</a>
</p>
</div>
<div id="footerCopyright">
<p>
&copy; 2022
Orlando Weekly
<br><br>
Website powered by <a href="https://www.publishwithfoundation.com/" target="_blank">Foundation</a>
</p>
</div>
<script type="text/javascript">
  (function(e,t,o,n,p,r,i){e.visitorGlobalObjectAlias=n;e[e.visitorGlobalObjectAlias]=e[e.visitorGlobalObjectAlias]||function(){(e[e.visitorGlobalObjectAlias].q=e[e.visitorGlobalObjectAlias].q||[]).push(arguments)};e[e.visitorGlobalObjectAlias].l=(new Date).getTime();r=t.createElement("script");r.src=o;r.async=true;i=t.getElementsByTagName("script")[0];i.parentNode.insertBefore(r,i)})(window,document,"https://diffuser-cdn.app-us1.com/diffuser/diffuser.js","vgo");
  vgo('setAccount', '26668640');
  vgo('setTrackByDefault', true);

  vgo('process');
</script>
</div>
</div>
</div>

<div id="gridCloser">
<div id="AdBackground" class="Closer ContentDefault ">

<div id="div-gpt-ad-orl_reskin" style="" data-content-type="ad" data-slot="/43707298/ORL_Reskin" data-output="asynchronous" data-width="" data-height="">
<script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_reskin');
                });
              </script>
</div>
</div>
</div>
</body>
</html>
