






























































    
         
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Content Default" />
  
    <meta name="oid" content="21006450" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=f25f9b803be6ff9f767a5a2d0a3a9e01" />

  
  
    <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=f25f9b803be6ff9f767a5a2d0a3a9e01" />
    <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=f25f9b803be6ff9f767a5a2d0a3a9e01" />
    <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=f25f9b803be6ff9f767a5a2d0a3a9e01" />
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Whole Site" href="https://www.orlandoweekly.com/orlando/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Arts &amp; Culture Section" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2240407" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Arts Stories &amp; Interviews" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2240434" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Comments on Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays" href="https://www.orlandoweekly.com/orlando/Rss.xml?id=comments&amp;oid=21006450" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=4de2d92d92161ae9feecded8e052889b"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=4de2d92d92161ae9feecded8e052889b"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.orlandoweekly.com\/orlando\/Profile", "https:\/\/posting.orlandoweekly.com\/orlando\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="297405715145-bcr8a9m9emb8a84o6qbd7utuefrfoknk.apps.googleusercontent.com">
  

    
  

  
  <!-- Begin Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->

<meta name="google-site-verification" content="06A5Yh5mu5xlqSkqBOzGlxA6P_yfmltTp1l0ssgpOBk" />


<!-- Google Verification -->   
<meta name="google-site-verification" content="9htXi1AfaHrVLNGB2JDLtdpWEFyb-JOf5ngnP_95Zuk" />
<meta name="google-site-verification" content="s4GBlkstS6PKQwO_gDlOGL8jFPmeuL_d3m60wxOBQR0" />


<script type="text/javascript" src="https://bcdn.grmtas.com/pub/ga_pub_9465_s.js"></script>

<script type='text/javascript'>
              var googletag = googletag || {};
              googletag.cmd = googletag.cmd || [];
              (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
              })();
          </script>
          <script type='text/javascript'>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</script>
<!-- Begin Google Analytics -->
  
    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-585470-1', 'orlandoweekly.com');
    ga('send', 'pageview', { 'dimension1': 'artsculture', 'dimension2': 'art' });
    </script>
  
  <!-- End Google Analytics -->




<!-- Quantcast Choice. Consent Manager Tag -->
  <script type="text/javascript" async=true>
    var __cmp = (function () {
      return typeof (__cmp) == "function" ? __cmp : function (c) {
        var b = arguments;
        if (!b.length) {
          return __cmp.a;
        }
        else if (c == '__cmp')
          return false;
        else {
          if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
          }
          __cmp.a.push([].slice.apply(b));
        }
      }
    })();
    var elem = document.createElement('script');
    elem.src = "https://quantcast.mgr.consensu.org/cmp.js";
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);

    window.__cmp('init', {
      'Language': 'en',
    'Initial Screen Reject Button Text': 'I do not accept',
    'Initial Screen Accept Button Text': 'I accept',
    'Purpose Screen Header Title Text': 'Privacy settings',
    'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
    'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
    'Vendor Screen Accept All Button Text': 'Accept all',
    'Vendor Screen Reject All Button Text': 'Reject all',
    'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
    'Initial Screen Body Text Option': 1,
    'Publisher Name': 'Orlando Weekly',
    'Publisher Purpose IDs': [1,2,5,4,3],
    'Post Consent Page': 'https://www.orlandoweekly.com/orlando/Policies/Page',
    });
  </script>
  <!-- End Quantcast Choice. Consent Manager Tag -->
    <style>
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            background-color: #000000 !important;
            border-color: #000000 !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            background-color: transparent !important;
            border-color: #000000 !important;
        }
        .qc-cmp-alt-action,
        .qc-cmp-link {
            color: #000000 !important;
        }
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            color: #ffffff !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            color: #000000 !important;
        }
        .qc-cmp-small-toggle.qc-cmp-toggle-on,
        .qc-cmp-toggle.qc-cmp-toggle-on {
            background-color: #ee1c25 !important;
            border-color: #ee1c25 !important;
        }
        .qc-cmp-small-toggle,
        .qc-cmp-toggle {
            background-color: #C0C0C0 !important;
            border-color: #C0C0C0 !important;
        }
    </style>

  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays | Arts Stories &amp; Interviews | Orlando Weekly" />
  <meta name="description" content="Wednesday, Nov. 21 AAHZ 30th Anniversary: Rabbit in the Moon&#39;s David Chistophere, Kimball Collins, Dave Cannalte &amp;#10;9 pm; The Beacham, 46 N. Orange Ave.; $19.88-$50;..." />
  <meta name="keywords" content="News, Blog, Culture, Dining, Events" />
  <title>Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays | Arts Stories & Interviews | Orlando Weekly</title>

  
  
    <meta name="date" content="2018-11-14 01:00:00" />
  

  
  
  
    <meta name="author" content="Thaddeus McCollum">
  

  
  
  <meta name="news_keywords" content="news, blog, culture, dining, events" />

  
  
  
    <link rel="image_src" href="https://media2.fdncms.com/orlando/imager/u/slideshow/21006449/atmosphere.jpg" />
    <meta name="thumbnail" content="https://media2.fdncms.com/orlando/imager/u/slideshow/21006449/atmosphere.jpg" />
  

  
    
      <link rel="canonical" href="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450&media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" />
    
  

  
    <meta property="fb:app_id" content="1527160917534695" />
  

  
  <meta property="og:site_name" content="Orlando Weekly" />
  <meta property="og:title" content="Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays" />
 
  
    

    
    

    
    

    <meta property="og:image" content="https://media2.fdncms.com/orlando/imager/u/slideshow/21006449/atmosphere.jpg" />

    
      <meta property="og:image:width" content="600" />
      <meta property="og:image:height" content="400" />
    
  

  
  
    <meta property="og:description" content="Wednesday, Nov. 21 AAHZ 30th Anniversary: Rabbit in the Moon&#39;s David Chistophere, Kimball Collins, Dave Cannalte &amp;#10;9 pm; The Beacham, 46 N. Orange Ave.; $19.88-$50;..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media2.fdncms.com/orlando/imager/u/slideshow/21006449/atmosphere.jpg">

    
    

    

    <meta name="twitter:site" content="@orlandoweekly">
    <meta name="twitter:title" content="Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays">
    <meta name="twitter:description" content="Wednesday, Nov. 21 AAHZ 30th Anniversary: Rabbit in the Moon&#39;s David Chistophere, Kimball Collins, Dave Cannalte &amp;#10;9 pm; The Beacham, 46 N. Orange Ave.; $19.88-$50;...">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">21006450</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20181114011247</Attribute>
        <Attribute name="creationdate">20181113171938</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20181114010000</Attribute>
            <Attribute name="releasedate">20181114</Attribute>
            <Attribute name="releaseepoch">1542175200</Attribute>
            <Attribute name="title">Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays</Attribute>
            <Attribute name="author">2289467</Attribute>
            <Attribute name="authorname">Thaddeus McCollum</Attribute>
            <Attribute name="authorsortname">McCollum, Thaddeus</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.orlandoweekly.com\/orlando\/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays\/Content?oid=21006450"
          },
          "headline": "Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays",
          
            "description": "Wednesday, Nov. 21 AAHZ 30th Anniversary: Rabbit in the Moon's David Chistophere, Kimball Collins, Dave Cannalte &#10;9 pm; The Beacham, 46 N. Orange Ave.; $19.88-$50; 407-648-8363.",
          
          
            "image": {
              "url": "https:\/\/media2.fdncms.com\/orlando\/imager\/u\/original\/21006449\/atmosphere.jpg",
              "width": 1000,
              "height": 667,
              "@type": "ImageObject"
            },
          
          "datePublished": "2018-11-14T01:00:00",
          "dateModified": "2018-11-14T01:12:47",
          
            "author": {
              "name": "Thaddeus McCollum",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Orlando Weekly",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.orlandoweekly.com\/imager\/b\/google-amp-logo\/808579\/5643\/OrlandoWeekly_fbook.jpg",
                "width": 117,
                "height": 60,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Content" class="artsculture Artsstories ContentDefault Iapetus10Zone">




<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KQ22CZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KQ22CZ');</script>
<!-- End Google Tag Manager -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  <div id="AdInterstitial" class="Leader ContentDefault ">
  <!-- /43707298/ORL_DesktopInterstitial -->
          <div id="div-gpt-ad-orl_desktopinterstitial" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopinterstitial');
                  });
              </script>
          </div>
</div>
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader ContentDefault " style="display:none">
        
        
          Switch to the <a href="https://m.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  












<div id="LogoHeader" class="GlobalHeader ContentDefault ">
  
    
    <div id="logoLeft">      
      <a href="https://www.orlandoweekly.com/" title="Orlando Weekly">Orlando Weekly</a>
    </div>

    <div id="leaderboardAdHeader">
      <!-- /43707298/ORL_728x90 -->
          <div id="div-gpt-ad-orl_728x90-1" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-1');
                  });
              </script>
          </div>
    </div>
      
      
</div>
<!-- End #LogoHeader -->















  <div id="NavigationHorizontal" class="GlobalHeader ContentDefault  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_NewsFeatures">
          <a href="https://www.orlandoweekly.com/orlando/news-and-features/Section?oid=2240408"  class="subnav_link" id="SNAVL_NewsFeatures">News</a>
        </li>
        
      
        

        

        

        

        <li class="navCurrent" id="NavItem_ArtsCulture">
          <a href="https://www.orlandoweekly.com/orlando/arts-and-culture/Section?oid=2240407"  >Arts</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Music">
          <a href="https://www.orlandoweekly.com/orlando/music/Section?oid=2240410"  >Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Screens">
          <a href="https://www.orlandoweekly.com/orlando/screens/Section?oid=2240411"  >Screens</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_FoodDrink">
          <a href="https://www.orlandoweekly.com/orlando/food-and-drink/Section?oid=2240409"  >Food &amp; Drink</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Calendar">
          <a href="https://www.orlandoweekly.com/orlando/EventSearch"  >Calendar</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_BestOfOrlando">
          <a href="https://www.orlandoweekly.com/orlando/BestOf"  class="subnav_link" id="SNAVL_BestOfOrlando">Best Of Orlando</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Galleries">
          <a href="http://photos.orlandoweekly.com"  >Galleries</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_PromosEvents">
          <a href="#"  class="subnav_link" id="SNAVL_PromosEvents">Promos + Events</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Subscribe">
          <a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page"  >Subscribe</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_Advertise">
          <a href="https://www.orlandoweekly.com/orlando/AdvertiseWithOrlandoWeekly/Page"  >Advertise</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_NewsFeatures" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/IssueArchives"  title="">Browse Issues</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/joblistings/Page"  title="">Local Job Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413"  title="">Special Issues</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Promos + Events</h3>
            <ul class="subnav_content" id="SNAV_PromosEvents" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/FreeStuff"  title="">Giveaways</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273894"  title="">OW Events</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal --><div id="AdPencilBar" class="GlobalHeader ContentDefault ">
  <!-- /43707298/ORL_970x90 -->
          <div id="div-gpt-ad-orl_970x90" style="" data-content-type="ad" data-slot="/43707298/ORL_970x90" data-output="asynchronous" data-width="970" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_970x90');
                  });
              </script>
          </div>
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  
    <div id="StoryBreadcrumb" class="SpanningFeature ContentDefault ">
      <p class="issueInfo ">
        <span class="date">
          
            <a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=21006179">November 14, 2018</a>
          
        </span>

  			
          <a href="https://www.orlandoweekly.com/orlando/arts-and-culture/Section?oid=2240407">Arts & Culture</a>
        
        
          &raquo; <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=2240434">Arts Stories & Interviews</a>
        
      </p>
    </div> <!-- end StoryBreadcrumb -->
  





  
  















  
  
  

  
  
  

  
 
  




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="SpanningFeature ContentDefault ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:16%; height: 20px; float:left;">
        <fb:like href="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:16%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content%3Foid%3D21006450&text=Everything%20worth%20doing%20in%20Orlando%20from%20now%20till%20the%20end%20of%20the%20year%20that%20has%20nothing%20to%20do%20with%20the%20damn%20holidays" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:16%; height: 20px; float:left;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" size="medium" count="true"></g:plusone></div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.orlandoweekly.com/orlando/Tools/EmailFriend?oid=21006450" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:16%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?mode=print&amp;oid=21006450" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:16%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-54d38c2c42ccebb5" addthis:url="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" addthis:title="Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54d38c2c42ccebb5", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  










  
  
  
  
  
    
  
    

    
      <div id="MagnumImage" class="SpanningFeature ContentDefault ">
        <div class="magnumContainer">
          

          
          
          
          
          
            
          

          
          
          

          
          

          
          
            <span class="clicktozoom">click to enlarge</span>
            <a href="https://media1.fdncms.com/orlando/imager/u/original/21006448/atmosphere.jpg" class="zoomable"><img src="https://media1.fdncms.com/orlando/imager/u/magnum/21006448/atmosphere.jpg" width="600" height="400" class="magnum" alt="Atmosphere" srcset="" /></a>
          
          
          
            
            
              
                
              
            
              
                
                  <p class="caption">Atmosphere</p>
                
              
            
          
        </div>
      </div>
    
    
    
    
  




  

  

  
    <div id="StoryHeader" class="SpanningFeature ContentDefault  ">
      <div class="storyHead">
        <h1 class="headline headline-21006450">Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays&nbsp;</h1>        
        
        
          

          <cite class="byline">
            <span class="byAttribute">By</span> <a href="https://www.orlandoweekly.com/author/thaddeus-mccollum" rel="author">Thaddeus McCollum</a>
               
          </cite>

          

        
      </div>
    </div> <!-- end StoryHeader -->
  





  
  





<div id="StoryLayout" class="SpanningFeature ContentDefault ">

  

    

    













    
    

    
      
    
    
    
    
      
      

      
              
    

      
     
       
      

        

        

        

        

        

        

        
        

        

        

        
      
      
      
      
    
      <div id="storyBody" class="page1">
        
      
        

        
        
          <p>Wednesday, Nov. 21</p>



            
          
            <p><b>AAHZ 30th Anniversary: Rabbit in the Moon's David Chistophere, Kimball Collins, Dave Cannalte</b> <b>&#10;</b>9 pm; The Beacham, 46 N. Orange Ave.; $19.88-$50; 407-648-8363.</p>



            
          
            <p><b>John DePaola Quintet</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $15; 407-636-9951.</p>



            

              
              

              <div class="inlineComponent ">
                <div id="AdNativeInline" class="SpanningFeature AdNativeInline ">
  <!-- /43707298/ORL_DesktopNative -->
          <div id="div-gpt-ad-orl_desktopnative-2" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-2');
                  });
              </script>
          </div>
</div>
              </div>
            
          
            <p><b>Pinky Doodle Poodle, Tesplora, Linqo, City of Stages</b> 8 pm; Will's Pub, 1042 N. Mills Ave.; $5.</p>



            
          
            <p><b>Yandel</b> 8 pm; House of Blues, Disney Springs, Lake Buena Vista; $60; 407-934-2583.</p>



            
          
            <p>Friday, Nov. 23</p>



            
          
            <p><b>Allan Vache Quartet</b> 8:15 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $15; 407-636-9951.</p>



            
          
            <p><b>Classic Albums Live: Pink Floyd's</b></p>



            
          
            <p><b><i>Wish You Were Here</i></b> 7 pm; Hard Rock Live, 6050 Universal Blvd.; $16-$31; 407-351-5483.</p>



            
          
            <p><b>Folk Yeah, Vol. 3: Electric</b> <b>&#10;</b>5 pm; Will's Dirty Laundry, 1036 N. Mills Ave.; $15-$25.</p>



            
          
            <p><b>Gargamel!</b> 8 pm; The Veranda Live, 707 E. Washington St.; Free; 407-405-1144.</p>



            
          
            <p><b>Ghost</b> 8 pm; Walt Disney Theater, Dr. Phillips Center, 445 S. Magnolia Ave.; $39.50-$225; 844-513-2014.</p>



            
          
            <p><b>Hurricane Bill on Mills Benefit: Eat the Elderly, Tracey Blades &amp; the Born Losers, Grace Return</b> 9 pm; Will's Pub, 1042 N. Mills Ave.; $7.</p>



            
          
            <p><b>Mayday Parade, This Wild Life, William Ryan Key, Oh, Weatherly</b> 7 pm; House of Blues, Disney Springs, Lake Buena Vista; $27.50; 407-934-2583.</p>



            
          
            <p><b>Silverstein, Hawthorne Heights, As Cities Burn, Capstan</b> 5 pm; The Beacham, 46 N. Orange Ave.; $22.50-$25; 407-648-8363.</p>



            
          
            <p><b>Spite, Shadow of Intent, Left Behind, Orthodox</b> 6:30 pm; Soundbar, 37 W. Pine St.; $15.</p>



            
          
            <p><b>The Story So Far, Turnover, Citizen, Movements</b> 6:30 pm; The Plaza Live, 425 N. Bumby Ave.; $27.50-$32.50; 407-228-1220.</p>



            
          
            <p>Saturday, Nov. 24</p>



            
          
            <p><b>Black Violin</b> <b>7 &amp; 9:30 pm; Alexis &amp; Jim Pugh Theater, Dr. Phillips Center, 445 S. Magnolia Ave.; SOLD OUT.</b></p>



            
          
            <p><b>El Yonki</b> 10 pm; Gilt Nightclub, 740 Bennett Road; $35-$40; 407-504-7699.</p>



            
          
            <p><b>Folk Yeah, Vol. 3</b> Noon; Will's Pub, 1042 N. Mills Ave.; $15-$25.</p>



            
          
            <p><b>The Long Run: Tribute to the Eagles</b></p>



            
          
            <p>7:30 pm; Wayne Densch Performing Arts Center, 201 S. Magnolia Ave., Sanford; $23-$30; 407-321-8111.</p>



            
          
            <p><b>Mark Dawson</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $20; 407-636-9951.</p>



            
          
            <p><b>Seaway, Trophy Eyes, Microwave, Can't Swim, Hot Mulligan</b> 6 pm; Soundbar, 37 W. Pine St.; $18.</p>



            
          
            <p><b>Seven Lions, Jason Ross, Au5</b> 7:30 pm; House of Blues, Disney Springs, Lake Buena Vista; $27.50-$69.68; 407-934-2583.</p>



            
          
            <p>Sunday, Nov. 25</p>



            
          
            <p><b>Folk Yeah, Vol. 3: Hangover</b> <b>&#10;</b>5 pm; Lil Indies, 1036 N. Mills Ave.; $10 suggested donation.</p>



            
          
            <p><b>It's a G.A.S.: Gospel and Soul Celebration of Aretha Franklin</b> 5 pm; Will's Pub, 1042 N. Mills Ave.; $5.</p>



            
          
            <p><b>Mike Arroyo: The Expand Jazz Organ Trio</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $20; 407-636-9951.</p>



            
          
            <p><b>Queen Naija</b> <b>&#10;</b>6 pm; The Beacham, 46 N. Orange Ave.; $20-$65; 407-648-8363.</p>



            
          
            <p><b>Tera Melos</b> 7 pm; Soundbar, 37 W. Pine St.; $13.</p>



            
          
            <p><b>Tuesday, Nov. 27</b></p>



            
          
            <p><b>Atmosphere, Dem Atlas, the Lioness &amp; DJ Keezy</b></p>



            
          
            <p>7 pm; The Beacham, 46 N. Orange Ave.; $22.50-$25; 407-648-8363.</p>



            
          
            <p><b>Circa Survive, La Dispute, Queen of Jeans</b> 6:30 pm; House of Blues, Disney Springs, Lake Buena Vista; $23; 407-934-2583.</p>



            
          
            <p><b>Elton John</b> 8 pm; Amway Center, 400 W. Church St.; $204-$2,869; 800-745-3000.</p>



            
          
            <p><b>Wednesday, Nov. 28</b></p>



            
          
            <p><b>Fonseca</b> 8 pm; House of Blues, Disney Springs, Lake Buena Vista; $40; 407-934-2583.</p>



            
          
            <p><b>Run Raquel, Shay Butter &#10;Band, Carly Jo Jackson</b> <b>&#10;</b>9 pm; Will's Pub, 1042 N. Mills Ave.; $5; 407-463-0121.</p>



            
          
            <p>Thursday, Nov. 29</p>



            
          
            <p><b>Moe.</b> <b>&#10;</b>7 pm; The Plaza Live, 425 N. Bumby Ave.; $24.50-$49.50; 407-228-1220.</p>



            
          
            <p><b>Nu Depth, TIME, Ivy Hollivana, Gay-Z, J.A.S.O.N., Alien Witch</b> 9 pm; Will's Pub, 1042 N. Mills Ave.; $5.</p>



            
          
            <p><b>Velcro Pygmies</b> <b>&#10;</b>7 pm; House of Blues, Disney Springs, Lake Buena Vista; $8.75; 407-934-2583.</p>



            
          
            <p><b>Yung Pinch, Tyla Yaweh</b> <b>&#10;</b>7 pm; The Social, 54 N. Orange Ave.; $20; 407-246-1419.</p>



            
          
            <p>Friday, Nov. 30</p>



            
          
            <p><b>Anuel AA</b> <b>&#10;</b>8 pm; Amway Center, 400 W. Church St.; $39-$190; 800-745-3000.</p>



            
          
            <p><b>Born Ruffians, Little Junior</b> 7:30 pm; Soundbar, 37 W. Pine St.; $15.</p>



            
          
            <p><b>Colors Presents: R&amp;B Only</b> 8:30 pm; House of Blues, Disney Springs, Lake Buena Vista; contact for price; 407-934-2583.</p>



            
          
            <p><b><i>Hansel &amp; Gretel</i></b> 11:30 am-1 pm; luncheon featuring an Opera Orlando Ambassadors production of <i>Hansel &amp; Gretel</i>. Enzian Theater, 1300 S. Orlando Ave., Maitland; $35; 407-512-1900; <a href="http://operaorlando.org" target="_blank">operaorlando.org</a>.</p>



            
          
            <p><b>UCF Choirs Concert</b> 6:30-8:30 pm; St. James Cathedral School and Assembly Hall, 215 N. Orange Ave.; Free; 407-823-1500.</p>



            
          
            <p>Saturday, Dec. 1</p>



            
          
            <p><b>Diego Figueiredo</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $20-$35; 407-636-9951.</p>



            
          
            <p><b>Habstrakt</b> 10 pm; Gilt Nightclub, 740 Bennett Road; $10-$20; 407-504-7699.</p>



            
          
            <p><b>Hands Like Houses, Emarosa, Devour the Day</b> 6 pm; Soundbar, 37 W. Pine St.; $18.</p>



            
          
            <p><b>Hurricane Party (Bleubird &amp; Rickolus)</b> 9 pm; Lil Indies, 1036 N. Mills Ave.; free.</p>



            
          
            <p><b>The Kill, Darling Machine</b> <b>&#10;</b>8 pm; The Veranda Live, 707 E. Washington St.; $10-$15.</p>



            
          
            <p><b>Marc Broussard, Kristopher James</b> 6 pm; The Social, 54 N. Orange Ave.; $20-$25; 407-246-1419.</p>



            
          
            <p><b>The Petty Hearts: Tribute to Tom Petty</b> 7:30 pm; Wayne Densch Performing Arts Center, 201 S. Magnolia Ave., Sanford; $23-$30; 407-321-8111.</p>



            
          
            <p><b>We Are the Union, Skatune Network, the Hoverounds</b> 8 pm; Will's Pub, 1042 N. Mills Ave.; $12-$15.</p>



            
          
            <p><b>Willie Col&oacute;n: La Rumba del Siglo</b> 8 pm; House of Blues, Disney Springs, Lake Buena Vista; $57.25; 407-934-2583.</p>



            
          
            <p>Sunday, Dec. 2</p>



            
          
            <p><b>Brett Young, Tyler Rich</b> 6:30 pm; House of Blues, Disney Springs, Lake Buena Vista; $59; 407-934-2583.</p>



            
          
            <p><b>Central Florida Jazz Society Presents Birth of the Cool</b> 3 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $15-$20; 407-636-9951.</p>



            
          
            <p><b>Chief Keef</b> 10 pm; Gilt Nightclub, 740 Bennett Road; $15-$50; 407-504-7699.</p>



            
          
            <p><b>Dimas Sanchez with Fusion Beat</b> 7:30-9:30 pm; Timucua White House, 2000 S. Summerlin Ave.; $10-$20; 772-418-0851.</p>



            
          
            <p><b>The Robert Cray Band</b> 7 pm; The Plaza Live, 425 N. Bumby Ave.; $37.50-$57.50; 407-228-1220.</p>



            
          
            <p>Monday, Dec. 3</p>



            
          
            <p><b>Claptone</b> 10 pm; Gilt Nightclub, 740 Bennett Road; $10-$25; 407-504-7699.</p>



            
          
            <p><b>Downtown Brown, Danny Feedback's Crack Rock Opera, Gloriosa, the Rip, Suckerpunch</b> 8 pm; Will's Pub, 1042 N. Mills Ave.; $10-$13.</p>



            
          
            <p>Tuesday, Dec. 4</p>



            
          
            <p><b>Gouge Away, Drug Church, Seattle's New Gods, Witchbender</b> 7 pm; Will's Pub, 1042 N. Mills Ave.; $10-$13.</p>



            
          
            <p><b>Jason Marsalis Quartet</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $25; 407-636-9951.</p>



            
          
            <p>Wednesday, Dec. 5</p>



            
          
            <p><b>Ballyhoo!, Propaganjah</b> <b>&#10;</b>8 pm; The Social, 54 N. Orange Ave.; $15; 407-246-1419.</p>



            
          
            <p><b>Broncho, Yip Deceiver</b> <b>&#10;</b>8 pm; Will's Pub, 1042 N. Mills Ave.; $12-$15.</p>



            
          
            <p><b>Cannibal Corpse, Hate Eternal, Harm's Way</b> 7 pm; The Abbey, 100 S. Eola Drive; $25; 407-704-6261.</p>



            
          
            <p><b>Five Finger Death Punch, Breaking Benjamin</b> 5 pm; CFE Arena, 12777 N. Gemini Blvd.; $36-$482; 407-823-6006.</p>



            
          
            <p><b>Myles Kennedy &amp; Co.</b> 6:30 pm; The Beacham, 46 N. Orange Ave.; $25-$27; 407-648-8363.</p>



            
          
            <p><b>Thursday, Dec. 6</b></p>



            
          
            <p><b>Dusky</b> 10 pm; The Social, 54 N. Orange Ave.; $10-$20; 407-246-1419.</p>



            
          
            <p><b>The Outlaws, Atlanta Rhythm Section</b> 7 pm; The Plaza Live, 425 N. Bumby Ave.; $34.50-$135; 407-228-1220.</p>



            
          
            <p><b>Zach Deputy</b> 8 pm; Soundbar, 37 W. Pine St.; $15.</p>



            
          
            <p>Friday, Dec. 7</p>



            
          
            <p><b>Diane Marino Quartet</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $20; 407-636-9951.</p>



            
          
            <p><b>Migos, Tee Grizzley, BlocBoy JB, La4ss</b> 7 pm; CFE Arena, 12777 N. Gemini Blvd.; $59-$315; 407-823-6006.</p>



            
          
            <p><b>Pictureplane, J.A.S.O.N., Ootheca, Mother Juno</b> 8 pm; Will's Pub, 1042 N. Mills Ave.; $12-$15.</p>



            
          
            <p><b>Thievery Corporation, the Suffers</b> 7:30 pm; House of Blues, Disney Springs, Lake Buena Vista; $35; 407-934-2583.</p>



            
          
            <p>Saturday, Dec. 8</p>



            
          
            <p><b>Barry Manilow</b> 7:30 pm; Amway Center, 400 W. Church St.; $56.75-$246.25; 800-745-3000.</p>



            
          
            <p><b>The Garden, LE1F, Machine Girl</b> <b>&#10;</b>6 pm; Soundbar, 37 W. Pine St.; $16.</p>



            
          
            <p><b>Jonathan Baptiste and The Urban Intellectuals</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $25; 407-636-9951.</p>



            
          
            <p><b>Opera Orlando:</b></p>



            
          
            <p><b><i>Hansel &amp; Gretel</i></b> <b><i>&#10;</i></b>2 &amp; 7 pm; Operatic retelling of the classic Brothers Grimm fairy tale. Alexis &amp; Jim Pugh Theater, Dr. Phillips Center, 445 S. Magnolia Ave.; $29-$69; <a href="http://drphillipscenter.org" target="_blank">drphillipscenter.org</a>.</p>



            
          
            <p><b>Riot 10</b> <b>&#10;</b>10 pm; Gilt Nightclub, 740 Bennett Road; $10-$20; 407-504-7699.</p>



            
          
            <p><b>St. Paul &amp; the Broken Bones, &#10;the Seratones</b> 8 pm; The Plaza Live, 425 N. Bumby Ave.; $29.50-$44.50; 407-228-1220.</p>



            
          
            <p>Sunday, Dec. 9</p>



            
          
            <p><b>Convictions, Limbs, Roseview</b> 6 pm; Soundbar, 37 W. Pine St.; $13.</p>



            
          
            <p><b>Escape Velocity</b> <b>&#10;</b>7:30 pm; a recital of rarely heard masterworks for violin and piano. Timucua White House, 2000 S. Summerlin Ave.; donations; 727-515-5900; <a href="http://timucua.com" target="_blank">timucua.com</a>.</p>



            
          
            <p><b>Generation Axe: Steve Vai, Zakk Wylde, Yngwie Malmsteen, Nuno Bettencourt, Tosin Abasi</b> 8 pm; Hard Rock Live, 6050 Universal Blvd.; $35.50-$70.50; 407-351-5483.</p>



            
          
            <p><b>Opera Orlando:</b></p>



            
          
            <p><b><i>Hansel &amp; Gretel</i></b> <b>&#10;</b>2 pm; Operatic retelling of the classic Brothers Grimm fairy tale. Alexis &amp; Jim Pugh Theater, Dr. Phillips Center, 445 S. Magnolia Ave.; $29-$69; <a href="http://drphillipscenter.org" target="_blank">drphillipscenter.org</a>.</p>



            
          
            <p><b>Post Animal</b> 8 pm; Will's Pub, 1042 N. Mills Ave.; $12-$15.</p>



            
          
            <p>Monday, Dec. 10</p>



            
          
            <p><b>Erika Jayne</b> <b>&#10;</b>8 pm; The Plaza Live, 425 N. Bumby Ave.; $40-$250; 407-228-1220.</p>



            
          
            <p><b>Tuesday, Dec. 11</b></p>



            
          
            <p><b>Opera Orlando:</b></p>



            
          
            <p><b><i>Hansel &amp; Gretel</i></b> 6 pm; This reduced version of Opera Orlando's mainstage production introduces opera to children. Free for youth under 18. Women's Club of Winter Park, 419 Interlachen Ave., Winter Park; $25; 407-644-2237; <a href="http://orlandoweeklytickets.com" target="_blank">orlandoweeklytickets.com</a>.</p>



            
          
            <p>Thursday, Dec. 13</p>



            
          
            <p><b>Betamaxx, Korine</b> 8 pm; Will's Pub, 1042 N. Mills Ave.; $12-$15.</p>



            
          
            <p><b>Guaco</b> 8 pm; House of Blues, Disney Springs, Lake Buena Vista; $90-$100; 407-934-2583.</p>



            
          
            <p><b>H.R. (Bad Brains), the Dollyrots</b> 7 pm; Cafe DaVinci, 112 W. Georgia Ave., DeLand; $18; 386-873-2943.</p>



            
          
            <p><b>Friday, Dec. 14</b></p>



            
          
            <p><b>Good Old War, Beta Radio, Allman Brown</b> 6 pm; Soundbar, 37 W. Pine St.; $16.</p>



            
          
            <p><b>Opera Orlando:</b></p>



            
          
            <p><b><i>Hansel &amp; Gretel</i></b> 5 &amp; 7:30 pm; This reduced version of Opera Orlando's mainstage production introduces opera to children. Free for youth under 18. Atlantic Center for the Arts, 1414 Art Center Ave., New Smyrna Beach; free-$25; 386-427-6975; <a href="http://orlandoweeklytickets.com" target="_blank">orlandoweeklytickets.com</a>.</p>



            
          
            <p><b>WJRR's Not So Silent Night: Halestorm, In This Moment</b> 6:45 pm; Amway Center, 400 W. Church St.; $32.50-$49.50; 800-745-3000.</p>



            
          
            <p><b>Saturday, Dec. 15</b></p>



            
          
            <p><b>ARMNHMR</b> 10 pm; Gilt Nightclub, 740 Bennett Road; $10-$20; 407-504-7699.</p>



            
          
            <p><b>Cathedral Bells, Sugarplum, .Org, Harsh Radish</b> 8 pm; The Falcon, 819 E. Washington St.; free; 407-423-3060.</p>



            
          
            <p><b>Orlando Blues &amp; Jazz Fest</b> 2-7 pm; Eagle Nest Park, 5165 Metrowest Blvd.; $10-$100.</p>



            
          
            <p>Sunday, Dec. 16</p>



            
          
            <p><b>Angel Vivaldi, Nita Strauss</b> 6 pm; The Haven, 6700 Aloma Ave., Winter Park; $20-$25; 407-673-2712.</p>



            
          
            <p><b>Bayside (Acoustic), Kayleigh Goldsworthy</b> 6 pm; The Social, 54 N. Orange Ave.; $22-$25; 407-246-1419.</p>



            
          
            <p><b>Celtic Thunder</b> 7 pm; Hard Rock Live, 6050 Universal Blvd.; $53-$83; 407-351-5483.</p>



            
          
            <p><b>Marty Morell</b> 7:30 pm; Timucua White House, 2000 S. Summerlin Ave.; $10-$20; 772-418-0851.</p>



            
          
            <p>Monday, Dec. 17</p>



            
          
            <p><b>6lack</b> 8 pm; Hard Rock Live, 6050 Universal Blvd.; $35-$65; 407-351-5483.</p>



            
          
            <p>Tuesday, Dec. 18</p>



            
          
            <p><b>Tuesday Night Sessions: Cortez and Koelble</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; free; 407-636-9951.</p>



            
          
            <p>Thursday, Dec. 20</p>



            
          
            <p><b>Minnesota</b> 10 pm; The Social, 54 N. Orange Ave.; $15-$25; 407-246-1419.</p>



            
          
            <p>Friday, Dec. 21</p>



            
          
            <p><b>Respect: Tribute to Aretha Franklin</b> 7 pm; House of Blues, Disney Springs, Lake Buena Vista; $8.75; 407-934-2583.</p>



            
          
            <p>Saturday, Dec. 22</p>



            
          
            <p><b>Gost</b> 8 pm; Will's Pub, 1042 N. Mills Ave.; $15-$18.</p>



            
          
            <p><b>Joel DaSilva Band</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $20.00; 407-636-9951.</p>



            
          
            <p>Sunday, Dec. 23</p>



            
          
            <p><b>Fat Night, the Sh-Booms, DJ BMF</b> 8 pm; Will's Pub, 1042 N. Mills Ave.; $10-$12.</p>



            
          
            <p><b>Richard Gilewitz</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $15; 407-636-9951.</p>



            
          
            <p><b>Rocket Man: Tribute to Elton John</b> 7:30 pm; House of Blues, Disney Springs, Lake Buena Vista; $8.75; 407-934-2583.</p>



            
          
            <p>Wednesday, Dec. 26</p>



            
          
            <p><b>Man in the Mirror: Tribute to Michael Jackson</b> 7 pm; House of Blues, Disney Springs, Lake Buena Vista; $8.75; 407-934-2583.</p>



            
          
            <p>Thursday, Dec. 27</p>



            
          
            <p><b>Shinedown</b> 7 pm; House of Blues, Disney Springs, Lake Buena Vista; SOLD OUT; 407-934-2583.</p>



            
          
            <p>Friday, Dec. 28</p>



            
          
            <p><b>Classic Albums Live: The Beatles' <i>Abbey Road</i></b> 8 pm; Hard Rock Live, 6050 Universal Blvd.; $16-$31; 407-351-5483.</p>



            
          
            <p><b>Shinedown</b> 7 pm; House of Blues, Disney Springs, Lake Buena Vista; SOLD OUT; 407-934-2583.</p>



            
          
            <p>Saturday, Dec. 29</p>



            
          
            <p><b>Brown Note, One Drop</b> 9 pm; Will's Pub, 1042 N. Mills Ave.; $10.</p>



            
          
            <p><b>The Conglomerate</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $15; 407-636-9951.</p>



            
          
            <p><b>Herobust</b> 10 pm; Gilt Nightclub, 740 Bennett Road; $15-$40; 407-504-7699.</p>



            
          
            <p><b>Stick Figure, the Movement</b> 6 pm; The Beacham, 46 N. Orange Ave.; $39.50-$69.50; 407-648-8363.</p>



            
          
            <p>Sunday, Dec. 30</p>



            
          
            <p><b>Corey Smith</b> 8 pm; House of Blues, Disney Springs, Lake Buena Vista; $19; 407-934-2583.</p>



            
          
            <p><b>Special EFX</b> 7:30 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $28-$55; 407-636-9951.</p>



            
          
            <p><b>Steel Pulse</b> 7 pm; The Plaza Live, 425 N. Bumby Ave.; $28-$39.50; 407-228-1220.</p>



            
          
            <p><b>Young Dolph</b> 10 pm; Gilt Nightclub, 740 Bennett Road; $30-$75; 407-504-7699.</p>



            
          
            <p>Monday, Dec. 31</p>



            
          
            <p><b>Stick Figure, the Movement, the Ries Brothers</b> 8 pm; House of Blues, Disney Springs, Lake Buena Vista; SOLD OUT; 407-934-2583.</p>



            
          
            <p>Friday, Jan. 4</p>



            
          
            <p><b>Draco Rosa</b> 7 pm; House of Blues, Disney Springs, Lake Buena Vista; $52.25-$129.25; 407-934-2583.</p>



            
          
            <p><b>Jacob Johnson, Jack Graham</b> <b>&#10;</b>8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $15; 407-636-9951.</p>



            
          
            <p><b>Leisure Chief, Lemon City Trio, Shema Shine &amp; the Shakers</b> 9 pm; Will's Pub, 1042 N. Mills Ave.; $8-$10.</p>



            
          
            <p><b>Saturday, Jan. 5</b></p>



            
          
            <p><b>Cash Unchained: Johnny Cash Tribute</b> 7:30 pm; Wayne Densch Performing Arts Center, 201 S. Magnolia Ave., Sanford; $23-$30; 407-321-8111.</p>



            
          
            <p><b>Draco Rosa</b> 7 pm; House of Blues, Disney Springs, Lake Buena Vista; $52.25-$129.25; 407-934-2583.</p>



            
          
            <p><b>MixTape Mayhem</b> 8-10:30 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $15; 407-636-9951.</p>



            
          
            <p><b>Radiohead Tribute Show: Lavola, Thrift House, Chapters</b> 9 pm; Will's Pub, 1042 N. Mills Ave.; $7-$10.</p>



            
          
            <p><b>Sandy Shugart</b> 7:30 pm; Garden Theatre, 160 W. Plant St., Winter Garden; $15-$25; 407-877-4736.</p>



            
          
            <p>Sunday, Jan. 6</p>



            
          
            <p><b>CF2: Pierrot Plus Percussion</b> 7:30 pm; Timucua White House, 2000 S. Summerlin Ave.; $10-$20; 772-418-0851.</p>



            
          
            <p><b>Fingerstripes, John David Williams, Heather DeSanctis, Rachel Gentry</b> 7 pm; Will's Pub, 1042 N. Mills Ave.; $7-$10.</p>



            
          
            <p>THEATER</p>



            
          
            <p>Through Nov. 26</p>



            
          
            <p><b><i>Assassins</i></b> Musical from Stephen Sondheim that tells the stories of nine individuals who assassinated or tried to assassinate POTUS. Breakthrough Theatre of Winter Park, 419A W. Fairbanks Ave., Winter Park; $12-$20; 407-920-4034; <a href="http://breakthroughtheatre.com" target="_blank">breakthroughtheatre.com</a>.</p>



            
          
            <p>Through Dec. 9</p>



            
          
            <p><b><i>BOOM</i></b> A dramatic comedy about a one-night stand that takes on added significance when a catastrophic event threatens to strike the planet. Theater on the Edge, 5542 Hansel Ave.; $16-$32; 407-309-0106; <a href="http://theaterontheedge.org" target="_blank">theaterontheedge.org</a>.</p>



            
          
            <p>Nov. 16-Dec. 1</p>



            
          
            <p><b><i>Avenue Q</i></b> Musical about a young man who moves to a neighborhood in New York, populated by puppets. Rollins College, Annie Russell Theatre, 1000 Holt Ave., Winter Park; $20; 407.646.2145; <a href="http://rollins.edu" target="_blank">rollins.edu</a>.</p>



            
          
            <p>Saturday, Nov. 24</p>



            
          
            <p><b>National Theatre Live: <i>King Lear</i></b> Ian McKellen stars as the tragic old king in this production, recorded live in London's West End. Enzian Theater, 1300 S. Orlando Ave., Maitland; $20; 407-629-0054; <a href="http://enzian.org" target="_blank">enzian.org</a>.</p>



            
          
            <p><b>Nov. 27-Dec. 2</b></p>



            
          
            <p><b><i>Hello, Dolly!</i></b> Classic musical about a romantic matchmaker who tries to find love for a miserly rich man. Walt Disney Theater, Dr. Phillips Center, 445 S. Magnolia Ave.; $39.25-$154.25; 844-513-2014; <a href="http://drphillipscenter.org" target="_blank">drphillipscenter.org</a>.</p>



            
          
            <p>Nov. 28-Dec. 23</p>



            
          
            <p><b><i>The Mystery of Edwin Drood</i></b> <b>&#10;</b>Based on the unfinished novel by Charles Dickens, this interactive mystery musical lets the audience choose the villain. Mad Cow Theatre, 54 W. Church St.; $20-$42; 407-297-8788; <a href="http://madcowtheatre.com" target="_blank">madcowtheatre.com</a>.</p>



            
          
            <p>Thursday, Nov. 29</p>



            
          
            <p><b>An Evening With Davis Gaines</b> An intimate evening of performances from the Broadway star. Alexis &amp; Jim Pugh Theater, Dr. Phillips Center, 445 S. Magnolia Ave.; $100-$150; <a href="http://drphillipscenter.org" target="_blank">drphillipscenter.org</a>.</p>



            
          
            <p>Nov. 29-Dec.3</p>



            
          
            <p><b><i>The Penelopiad</i></b> <b>&#10;</b>This theatrical adaptation of Margaret Atwood's novella reworks the ancient Greek epic <i>The Odyssey</i> from the perspective of Penelope.Valencia College East Campus, 701 N. Econlockhatchee Trail; $10-12; 407-582-2900; <a href="http://valenciacollege.edu" target="_blank">valenciacollege.edu</a>.</p>



            
          
            <p>Nov. 30-Dec. 1</p>



            
          
            <p><b><i>The Music Man</i></b> <b>&#10;</b>The six-time Tony Award-winning musical comedy. Wekiva High School, 2501 N. Hiawassee Road, Apopka; $5-$25; 407-937-1800; <a href="http://cfcarts.com" target="_blank">cfcarts.com</a>.</p>



            
          
            <p>Nov. 30-Dec. 16</p>



            
          
            <p><b><i>On Golden Pond</i></b> <b>&#10;</b>Drama about an aging patriarch facing his twilight years and attempting to connect with his family. Central Christian Church, 250 W. Ivanhoe Blvd.; $15-$25; 407-937-1800; <a href="http://cfcarts.com" target="_blank">cfcarts.com</a>.</p>



            
          
            <p>Wednesday, Dec. 5</p>



            
          
            <p><b>Clue for a Cause</b> <b>&#10;</b>A comedic murder mystery dinner party to benefit children and youth arts programs. Winter Park Country Club, 761 Old New England Ave., Winter Park; $50-$85; <a href="http://cfcarts.com" target="_blank">cfcarts.com</a>.</p>



            
          
            <p>Saturday, Dec. 29</p>



            
          
            <p><b>National Theatre Live: <i>The Madness of King George</i></b> <b>&#10;</b>It's 1786 and King George III is the most powerful man in the world. But his behavior is becoming increasingly erratic as he succumbs to fits of lunacy. Enzian Theater, 1300 S. Orlando Ave., Maitland; $20; 407-629-0054; <a href="http://enzian.org" target="_blank">enzian.org</a>.</p>



            
          
            <p>Jan. 4-Feb. 3</p>



            
          
            <p><b><i>A Doll's House, Part 2</i></b> <b>&#10;</b>Sequel to Ibsen's masterwork &ndash; written by Lucas Hnath &ndash; about what happens when Nora returns to her family. Mandell Theater, Lowndes Shakespeare Center, 812 E. Rollins St.; $30-$53; 407-447-1700; <a href="http://orlandoshakes.org" target="_blank">orlandoshakes.org</a>.</p>



            
          
            <p>COMEDY</p>



            
          
            <p>Nov. 23-24</p>



            
          
            <p><b>TJ Miller</b> Orlando Improv, 9101 International Drive; $25; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p>Sunday, Nov. 25</p>



            
          
            <p><b>Spunky Robinson</b> 7 pm; Orlando Improv, 9101 International Drive; $10-$40; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p>Thursday, Nov. 29</p>



            
          
            <p><b>Frankie Paul</b> <b>&#10;</b>8 pm; Orlando Improv, 9101 International Drive; $10-$40; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p><b>Randy Rainbow</b> <b>&#10;</b>8 pm; Hard Rock Live, 6050 Universal Blvd.; $35-$45; 407-351-5483; <a href="http://hardrock.com/orlando" target="_blank">hardrock.com/orlando</a>.</p>



            
          
            <p>Nov. 30-Dec. 1</p>



            
          
            <p><b>Karl Anthony</b> <b>&#10;</b>Bonkerz &ndash; Boardwalk Bowl, 10749 E. Colonial Drive; $10; 407-629-2665; <a href="http://bonkerzcomedyproductions.com" target="_blank">bonkerzcomedyproductions.com</a>.</p>



            
          
            <p><b>Richy Leis</b> Bonkerz &ndash; Otters on the River, 4380 Carraway Place, Sanford; $10; 407-629-2665; <a href="http://bonkerzcomedyproductions.com" target="_blank">bonkerzcomedyproductions.com</a>.</p>



            
          
            <p><b>Tim Meadows</b> <b>&#10;</b>Orlando Improv, 9101 International Drive; $20; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p>Thursday, Dec. 6</p>



            
          
            <p><b>Joselito Dapuppet</b> 8 pm; Orlando Improv, 9101 International Drive; $25; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p>Friday, Dec. 7</p>



            
          
            <p><b>Celeste Barber</b> <b>7 pm; The Plaza Live, 425 N. Bumby Ave.; $22.50-$50; 407-228-1220; <a href="http://plazaliveorlando.com" target="_blank">plazaliveorlando.com</a>.</b></p>



            
          
            <p>Dec. 7-9</p>



            
          
            <p><b>Sommore</b> Orlando Improv, 9101 International Drive; $25; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p>Saturday, Dec. 8</p>



            
          
            <p><b>Jersey's 40th Birthday Bash</b> 7 pm; The Social, 54 N. Orange Ave.; $13-$20; 407-246-1419; <a href="http://thesocial.org" target="_blank">thesocial.org</a>.</p>



            
          
            <p>Dec. 10-11</p>



            
          
            <p><b>Jess Hilarious</b> Orlando Improv, 9101 International Drive; $35; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p><b>Friday, Dec. 14</b></p>



            
          
            <p><b>Jaimie Roberts</b> 8 pm; Blue Bamboo Center for the Arts, 1905 Kentucky Ave., Winter Park; $20; 407-636-9951; <a href="http://bluebambooartcenter.com" target="_blank">bluebambooartcenter.com</a>.</p>



            
          
            <p>Dec. 14-16</p>



            
          
            <p><b>Frankie Quinones</b> <b>&#10;</b>Orlando Improv, 9101 International Drive; $20-$50; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p>Wednesday, Dec. 19</p>



            
          
            <p><b>B. Simone</b> 8 pm; Orlando Improv, 9101 International Drive; $35; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p><b>Dec. 20-22</b></p>



            
          
            <p><b>Tom Rhodes</b> Orlando Improv, 9101 International Drive; $17-$47; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p>Dec. 28-31</p>



            
          
            <p><b>Preacher Lawson</b> Orlando Improv, 9101 International Drive; $25-$60; 407-480-5233; <a href="http://theimprovorlando.com" target="_blank">theimprovorlando.com</a>.</p>



            
          
            <p>Saturday, Dec. 29</p>



            
          
            <p><b>Sebastian Maniscalco</b> <b>&#10;</b>7 &amp; 10 pm; Walt Disney Theater, Dr. Phillips Center, 445 S. Magnolia Ave.; $45-$150; 844-513-2014; <a href="http://drphillipscenter.org" target="_blank">drphillipscenter.org</a>.</p>



            
          
            <p><b>Sunday, Dec. 30</b></p>



            
          
            <p><b>Terry Fator</b> Ventriloquism comedy. 8 pm; Walt Disney Theater, Dr. Phillips Center, 445 S. Magnolia Ave.; $45-$99.50; 844-513-2014; <a href="http://drphillipscenter.org" target="_blank">drphillipscenter.org</a>.</p>



            
          
            <p>DANCE</p>



            
          
            <p>Wednesday, Nov. 21</p>



            
          
            <p><b>The Ladyboys vs. the Ladies of the Peek-A-Boo Lounge</b> Burlesque show featuring performers of many genders. Wednesday 8 pm; The Venue, 511 Virginia Drive; $18-$24; 407-412-6895; <a href="http://thevenueorlando.com" target="_blank">thevenueorlando.com</a>.</p>



            
          
            <p>Monday, Nov. 26</p>



            
          
            <p><b>Cherry Bomb Burlesque</b> Monday 8-10 pm; Haven Orlando, 6651 S. Semoran Blvd.; $20; 407-347-5035; <a href="http://havenorlando.com" target="_blank">havenorlando.com</a>.</p>



            
          
            <p><b>Nov. 28-Dec. 1</b></p>



            
          
            <p><b>South Open Dancesport Championships</b> Competitive dancing competitions. Hyatt Regency Orlando International Airport, 9300 Airport Blvd.; $35-$250; 407-825-1298; <a href="http://southopenchampionships.com" target="_blank">southopenchampionships.com</a>.</p>



            
          
            <p>Friday, Nov. 30</p>



            
          
            <p><b>Big Bang Boom Cabaret: The Mix</b> A burlesque game show where anything goes. Friday Nov. 30, 9 pm; The Venue, 511 Virginia Drive; $16-$25; 407-412-6895; <a href="http://bigbangboomcabaret.com" target="_blank">bigbangboomcabaret.com</a>.</p>



            
          
            <p>Saturday, Dec. 1</p>



            
          
            <p><b>Gujarati Society Group Dance Competition</b> Multiple age groups compete with performances of traditional dances from the Indian subcontinent. Saturday Dec. 1, 4:30 pm; Bob Carr Theater, 401 W. Livingston St.; $35; 407-246-4262; <a href="http://drphillipscenter.org" target="_blank">drphillipscenter.org</a>.</p>



            
          
            <p>MUSEUMS</p>



            
          
            <p><b>Albin Polasek Museum &amp; &#10;Sculpture Gardens</b> <i>&#10;</i><i>Soul of Graffiti: Jan Kalab</i>, through Dec. 2; 633 Osceola Ave, Winter Park; $10; 407-647-6294; <a href="http://polasek.org" target="_blank">polasek.org</a>.</p>



            
          
            <p><b><i>Art &amp; History Museums &ndash; Maitland</i> <i>&#10;</i><i>Indigo Waves</i>, through March 31, 2019; <i>Central Florida Yellow Ribbon Project</i>, through Nov. 30; <i>Soldier's Home: Veterans' Art in Central Florida</i>, through Jan. 7, 2019; <i>J. Andr&eacute; Smith and the Art of Camouflage</i>, through Jan. 6, 2019. 231 W. Packwood Ave, Maitland; $6; 407-539-2181; <a href="http://artandhistory.org" target="_blank">artandhistory.org</a>.</b></p>



            
          
            <p><b><i>Charles Hosmer Morse Museum &#10;of American Art</i> <i>&#10;</i><i>Nineteenth-Century American Landscapes</i>, through Jan. 27, 2019; <i>The Art Machine</i>, through Jan. 27, 2019; <i>Earth Into Art: The Flowering of American Art Pottery; American Arts &amp; Crafts; Art Nouveau From Europe and America,</i> through Sept. 27, 2020; <i>Nineteenth-Century American Landscapes</i>, through Jan. 27, 2019. 445 N. Park Ave., Winter Park; $6; 407-645-5311; <a href="http://morsemuseum.org" target="_blank">morsemuseum.org</a>.</b></p>



            
          
            <p><b>Cornell Fine Arts Museum</b> <i>&#10;</i><i>Forging Modern American Identities: Recent Acquisitions</i>, through Dec. 12; <i>Jamilah Sabur: Ibine Ela Acu / Water Sun Moon</i>, through Dec. 12; <i>Fake News? Some Artistic Responses</i>, through Dec. 12; <i>Dangerous Women: Selections from the John and Mable Ringling Museum of Art</i>, through Dec. 12. Rollins College, 1000 Holt Ave., Winter Park; free; 407-646-2526; <a href="http://cfam.rollins.edu" target="_blank">cfam.rollins.edu</a>.</p>



            
          
            <p><b>Mennello Museum of &#10;American Art</b> <i>&#10;</i><i>Shifting Gaze: A Reconstruction of The Black &amp; Hispanic Body in Contemporary Art</i>, through Jan. 13, 2019. 900 E. Princeton St.; $5; 407-246-4278; <a href="http://mennellomuseum.org" target="_blank">mennellomuseum.org</a>.</p>



            
          
            <p><b>Orlando Museum of Art</b> &#10;<i>Nick Cave: Feat.</i>, through Dec. 30; <i>Purvis Young and His Angels</i>, through March 3, 2019; <i>A Trek From North to South</i>, ongoing; <i>J. Hyde Crawford and Anthony Tortora Collection</i>, ongoing; <i>People and Places</i>, ongoing. 2416 N. Mills Ave.; $15; 407-896-4231; <a href="http://omart.org" target="_blank">omart.org</a>.</p>



            
          
            <p>EVENTS</p>



            
          
            <p>Through Nov. 25</p>



            
          
            <p><b>The Venardos Circus</b> <b>&#10;</b>An animal-free circus and musical. Family friendly. Hamlin Town Center, 16406 New Independence Parkway, Winter Garden; $15-$45; 323-790-4827; <a href="http://venardoscircus.com" target="_blank">venardoscircus.com</a>.</p>



            
          
            <p>Through Jan. 31</p>



            
          
            <p><b>Ribbit the Exhibit II</b> Exhibit featuring 26 whimsical copper frog sculptures throughout Leu Gardens. 9 am-5 pm; Harry P. Leu Gardens, 1920 N. Forest Ave.; $10; 407-246-2620; <a href="http://leugardens.org" target="_blank">leugardens.org</a>.</p>



            
          
            <p>Nov. 24-25</p>



            
          
            <p><b>FusionFest</b> Arts festival showing a diverse range of Orlando talent in music, dance, film, fashion, literature and more. &#10;Noon; Seneff Arts Plaza, 445 S. Magnolia Ave.; free-$20; 844-513-2014; <a href="http://fusionfest.org" target="_blank">fusionfest.org</a>.</p>



            
          
            <p>Sunday, Nov. 25</p>



            
          
            <p><b>Bazaar Botanica</b> A garden full of talented makers and collectors with live music, art and entertainment. 11 am-4 pm; The Veranda at Thornton Park, 111 N. Summerlin Ave.; free; 407-486-1696.</p>



            
          
            <p>Wednesday, Nov. 28</p>



            
          
            <p><b>Art 101: Edward Gorey</b> A presentation about the life and works of Victorian-inspired artist Edward Gorey, followed by an interactive workshop where attendees create their own Gorey-esque art. Registration required. 6:30-7:30 pm; Orlando Public Library, 101 E. Central Blvd.; free; 407-835-7323; <a href="http://ocls.info" target="_blank">ocls.info</a>.</p>



            
          
            <p><b>Thursday, Nov. 29</b></p>



            
          
            <p><b>Night Shift</b> <b>Emerging artists take over nontraditional gallery spaces with a diverse range of media. 7-11 pm; Orlando Museum of Art, 2416 N. Mills Ave.; $15; 407-896-4231; <a href="http://omart.org" target="_blank">omart.org</a>.</b></p>



            
          
            <p>Saturday, Dec. 1</p>



            
          
            <p><b>Glenn Beck</b> This fucking guy. 7 pm; The Plaza Live, 425 N. Bumby Ave.; $44.50-$450; 407-228-1220; <a href="http://plazaliveorlando.com" target="_blank">plazaliveorlando.com</a>.</p>



            
          
            <p>Dec. 1-2</p>



            
          
            <p><b>Repticon Orlando Reptile &amp; Exotic Animal Show</b> Reptile event featuring pets and supplies. Central Florida Fairgrounds, 4603 W. Colonial Drive; $10; 863-268-4273; <a href="http://repticon.com" target="_blank">repticon.com</a>.</p>



            
          
            <p><b>The Resting Brunch Face</b> An afternoon of brunch, booze and dance. 11:30 am-3:30 pm; The Abbey, 100 S. Eola Drive; $15-$600; 407-704-6261; <a href="http://abbeyorlando.com" target="_blank">abbeyorlando.com</a>.</p>



            
          
            <p>Sunday, Dec. 2</p>



            
          
            <p><b>Enchanted Nature Walkabout</b> Monthly educational walk to learn about trees, shrubs, fairies, gnomes, flowers and more. 9 am; Mead Garden, 1300 S. Denning Drive, Winter Park; $10; 407-623-3342.</p>



            
          
            <p>Thursday, Dec. 6</p>



            
          
            <p><b>Sweet &amp; Savory</b> <b>&#10;</b><i>Orlando Weekly</i>'s most exclusive event allows attendees to enjoy delicious decadent foods and indulgent inventive cocktails with a holiday twist. 6 pm; The Veranda at Thornton Park, 111 N. Summerlin Ave.; $35-465; 407-872-8454; <a href="http://orlandoweeklytickets.com" target="_blank">orlandoweeklytickets.com</a>.</p>



            
          
            <p><b>Saturday, Dec. 8</b></p>



            
          
            <p><b>Centermost Point Invitational Beer Festival</b> Beer festival featuring beers that aren't usually available in Central Florida. 12-4 pm; Ten10 Brewing, 1010 Virginia Drive; $25-$35; 407-930-8993; <a href="http://ten10brewing.com" target="_blank">ten10brewing.com</a>.</p>



            
          
            <p><b>Jingle Bell Run</b> Strap on your sneakers and get decked out for The Arthritis Foundation's original Jingle Bell Run. 7:30-11:30 am; Baldwin Park, New Broad Street and Jake Street; $35; 407-208-1766; <a href="http://jbr.org/orlando" target="_blank">jbr.org/orlando</a>.</p>



            
          
            <p>Dec. 8-9</p>



            
          
            <p><b>Orlando Pottery Festival</b> Annual Orlando Pottery Festival and holiday arts market featuring ceramics and unique handmade gifts. Florida National Guard Armory, 2809 S. Ferncreek Ave.; free; 407-234-4691; <a href="http://orlandopotteryfestival.org" target="_blank">orlandopotteryfestival.org</a>.</p>



            
          
            <p>Thursday, Dec. 13</p>



            
          
            <p><b>History in a Glass: &#10;The Florida Highwaymen</b> <b>&#10;</b>Local bartenders create cocktails inspired by the work of the Florida Highwaymen artists. 6-9 pm; Orange County Regional History Center, 65 E. Central Blvd.; $25; 407-836-8500; <a href="http://thehistorycenter.org" target="_blank">thehistorycenter.org</a>.</p>



            
          
            <p>Saturday, Dec. 15</p>



            
          
            <p><b>Orlando Zine Fest</b> <b>&#10;</b>Annual pop-up market showcasing DIY zines and their makers. 5 pm; Will's Dirty Laundry, 1036 N. Mills Ave.; free.</p>



            
          
            <p><b>Zinetude</b> <b>&#10;</b>A special program exploring zine making and collecting. Noon-3 pm; Orlando Museum of Art, 2416 N. Mills Ave.; free; 407-896-4231; <a href="http://omart.org" target="_blank">omart.org</a>.</p>



            
          
            <p>Dec. 15-16</p>



            
          
            <p><b>Canine Extravaganza</b> <b>&#10;</b>The nation's largest celebration of dogs returns with plenty of fun, events and thousands of dogs for the whole family to enjoy. Orange County Convention Center, 9800 International Drive; $10; 919-233-9767; <a href="http://akc.org" target="_blank">akc.org</a>.</p>



            
          
            <p>Friday, Dec. 21</p>



            
          
            <p><b>Visiting Author Series: Jonathan Weisman</b> <i>New York Times</i> editor Jonathan Weisman discusses his new book, <i>(((SEMITISM))): Being Jewish in America in the Age of Trump</i>. 7-9 pm; Jewish Community Center of Greater Orlando, 851 N. Maitland Ave., Maitland; $10-$15.</p>



            
          
            <p>Friday, Dec. 28</p>



            
          
            <p><b>Camping World Bowl Parade of Bands</b> School bands from the ACC and Big 12 conferences march through downtown Winter Park and perform a "Bandtastic Game Day Preview" in Central Park. 11 am; Downtown Winter Park, Park Avenue, Winter Park; free; <a href="http://cityofwinterpark.org" target="_blank">cityofwinterpark.org</a>.</p>



            
          
            <p><b>Saturday, Dec. 29</b></p>



            
          
            <p><b>Florida Citrus Parade</b> <b>&#10;</b>More than 3,000 participants in one of Central Florida's longest running traditions. 11 am; Downtown Orlando &ndash; Rosalind Avenue, Rosalind Avenue and Robinson Street; free; <a href="http://cityoforlando.net" target="_blank">cityoforlando.net</a>.</p>



            
          
            <p>SPORTS</p>



            
          
            <p>Wednesday, Nov. 21</p>



            
          
            <p><b>Orlando Solar Bears vs. South Carolina Stingrays</b> Ice hockey. 7 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p><b>Friday-Saturday, Nov. 23-24</b></p>



            
          
            <p><b>Orlando Solar Bears vs. Newfoundland Growlers</b> Ice hockey. 7 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p>Saturday, Dec. 1</p>



            
          
            <p><b>The Orlando Shuffle</b> Free shuffleboard event. All ages and new players welcome. 7-9 pm; Beardall Senior Center, 800 S. Delaney Ave.; free; 407-246-4440.</p>



            
          
            <p>Saturday-Sunday, Dec. 1-2</p>



            
          
            <p><b>Orlando Solar Bears vs. Norfolk Admirals</b> Ice hockey. 7 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p><b>Sunday, Dec. 2</b></p>



            
          
            <p><b>Harlem Globetrotters</b> World-famous basketball stunt team. 1 pm; CFE Arena, &#10;12777 N. Gemini Blvd.; $20-$100; 407-823-6006.</p>



            
          
            <p>Wednesday, Dec. 5</p>



            
          
            <p><b>Orlando Magic vs. Denver Nuggets</b> NBA basketball. 7 pm; Amway Center, 400 W. Church St.; $14.25-$536.50; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p><b>Friday, Dec. 7</b></p>



            
          
            <p><b>Orlando Magic vs. Indiana Pacers</b> <b>&#10;</b>NBA basketball. 7 pm; Amway Center, 400 W. Church St.; $14.25-$536.50; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p><b>Sunday, Dec. 9</b></p>



            
          
            <p><b>Orlando Solar Bears vs. Greenville Swamp Rabbits</b> <b>Ice hockey. 1:30 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</b></p>



            
          
            <p><b>Saturday, Dec. 15</b></p>



            
          
            <p><b>The Orlando Shuffle</b> Free shuffleboard event. All ages and new players welcome. 7-9 pm; Beardall Senior Center, 800 S. Delaney Ave.; free; 407-246-4440.</p>



            
          
            <p><b>Sunday, Dec. 16</b></p>



            
          
            <p><b>Orlando Solar Bears vs. Atlanta Gladiators</b> <b>Ice hockey. 1:30 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</b></p>



            
          
            <p><b>Dec. 16-22</b></p>



            
          
            <p><b>US Open Table Tennis Championships</b> Four-day table tennis tournament, open to players of all skill levels. Orange County Convention Center, 9800 International Drive; contact for price; 407-685-9800; <a href="http://teamusa.org" target="_blank">teamusa.org</a>.</p>



            
          
            <p><b>Monday, Dec. 17</b></p>



            
          
            <p><b>Orlando Solar Bears vs. South Carolina Stingrays</b> Ice hockey. 7 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p><b>Wednesday, Dec. 19</b></p>



            
          
            <p><b>Orlando Magic vs. San Antonio Spurs</b> NBA basketball. 7 pm; Amway Center, 400 W. Church St.; $14.25-$536.50; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p><b>Thursday-Friday, Dec. 20-21</b></p>



            
          
            <p><b>Orlando Solar Bears vs. Florida Everblades</b> Ice hockey. 7 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p><b>Sunday, Dec. 23</b></p>



            
          
            <p><b>Orlando Magic vs. Miami Heat</b> <b>&#10;</b>NBA basketball. 6 pm; Amway Center, 400 W. Church St.; $14.25-$536.50; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p>Wednesday, Dec. 26</p>



            
          
            <p><b>Orlando Magic vs. Phoenix Suns</b> <b>&#10;</b>NBA basketball. 7 pm; Amway Center, 400 W. Church St.; $14.25-$536.50; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p>Friday, Dec. 28</p>



            
          
            <p><b>Camping World Bowl</b> <b>&#10;</b>The top selection from the ACC against the second selection from the Big 12 outside of the CFP series. 5:15 pm; Camping World Stadium, 1 Citrus Bowl Place; $50-$110; 407-423-2476; <a href="http://campingworldstadium.com" target="_blank">campingworldstadium.com</a>.</p>



            
          
            <p><b>Orlando Magic vs. Toronto Raptors</b> NBA basketball. 7 pm; Amway Center, 400 W. Church St.; $14.25-$536.50; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p>Saturday, Dec. 29</p>



            
          
            <p><b>Orlando Solar Bears vs. Jacksonville Icemen</b> Ice hockey. 7 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p>Sunday, Dec. 30</p>



            
          
            <p><b>Orlando Magic vs. Detroit Pistons</b> <b>&#10;</b>NBA basketball. 3:30 pm; Amway Center, 400 W. Church St.; $14.25-$536.50; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p>Tuesday, Jan. 1</p>



            
          
            <p><b>Citrus Bowl</b> <b>&#10;The top Big Ten and SEC teams from outside the CFP series of bowls. 1 pm; Camping World Stadium, 1 Citrus Bowl Place; $51-$127; 407-423-2476; <a href="http://campingworldstadium.com" target="_blank">campingworldstadium.com</a>.</b></p>



            
          
            <p>Wednesday, Jan. 2</p>



            
          
            <p><b>Orlando Solar Bears vs. &#10;Greenville Swamp Rabbits</b> Ice hockey. 7 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p><b>Saturday, Jan. 5</b></p>



            
          
            <p><b>The Orlando Shuffle</b> <b>&#10;</b>Free shuffleboard event. All ages and new players welcome. 7-9 pm; Beardall Senior Center, 800 S. Delaney Ave.; free; 407-246-4440.</p>



            
          
            <p>Saturday-Sunday, Jan. 5-6</p>



            
          
            <p><b>Orlando Solar Bears vs. South &#10;Carolina Stingrays</b> Ice hockey. 1:30 pm; Amway Center, 400 W. Church St.; $15-$28; 800-745-3000; <a href="http://amwaycenter.com" target="_blank">amwaycenter.com</a>.</p>



            
          
            <p>Monday, Jan. 7</p>



            
          
            <p><b>WWE Raw</b> <b>&#10;Live taping of WWE's Monday night</b></p>
        

        
        

        
        
      </div>
    

  
  
</div> <!-- end StoryLayout -->






















  








    
    
    
    


















<div id="JumptoComments" class="SpanningFeature ContentDefault ">
  <a href="#Disqus">Jump to comments</a>
</div><!-- End JumptoComments -->















  

  

  
  

  

  











  
  
















  
  
    
  
  
  <div id="TallBar" class="SpanningFeature ContentDefault ">
    <ul>
      <li class="l0 first" style="width:50%">
        <fb:like href="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" send="true" width="275" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="standard"></fb:like></li> <li class="l0" style="width:12%;"><a href="https://twitter.com/share?url=https%3A//www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content%3Foid%3D21006450&text=Everything%20worth%20doing%20in%20Orlando%20from%20now%20till%20the%20end%20of%20the%20year%20that%20has%20nothing%20to%20do%20with%20the%20damn%20holidays" class="twitter-share-button" data-count="vertical">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></li> <li class="l0" style="width:12%;"><script>
  dnLoadScript("https://apis.google.com/js/plusone.js", true);
</script>
<g:plusone href="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" size="tall" count="true"></g:plusone></li> <li class="l0 last" style="width:12%;">




  <div class="addthis_toolbox addthis_default_style"><a addthis:url="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" addthis:title="Everything worth doing in Orlando from now till the end of the year that has nothing to do with the damn holidays" addthis:description="" class="addthis_counter"></a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54d38c2c42ccebb5", true);
  </script>


      </li>
    </ul>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  





 
  <div id="StoryTags" class="SpanningFeature ContentDefault ">
    <p class="tags">Tags: <a href="/orlando/ArticleArchives?category=2240434" rel="tag">Arts Stories & Interviews</a></p>          
  </div> <!-- end StoryTags -->








  
  

  
  
  

  
    <div id="PreviousNextInCategory" class="SpanningFeature ContentDefault ">
      <div class="prevNext">
        
          
          

          <a href="https://www.orlandoweekly.com/orlando/every-holiday-event-happening-in-orlando-till-the-end-of-the-year/Content?oid=21006445" class="prev" title="previous">&laquo;&nbsp;Every holiday event happening in Orlando till the end of the year</a>

          
          
        
        
      </div>
    </div>
  




  <div id="ArchiveLink" class="SpanningFeature ContentDefault ">
    <p class="moreArticles">
      
        <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=2240434">More Arts Stories & Interviews &raquo;</a>
      
      
    </p>
  </div> <!-- end ArchiveLink -->

<div id="AdNativeEndofArticle" class="SpanningFeature ContentDefault ">
  <!-- /43707298/ORL_DesktopNative -->
          <div id="div-gpt-ad-orl_desktopnative-3" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-3');
                  });
              </script>
          </div>
</div>








  
  
    

    

    



    

    

      
      


      <div id="Disqus" class="SpanningFeature ContentDefault ">
        <div class="fb-comments" data-href="https://www.orlandoweekly.com/orlando/everything-worth-doing-in-orlando-from-now-till-the-end-of-the-year-that-has-nothing-to-do-with-the-damn-holidays/Content?oid=21006450" data-numposts="10" data-width="100%"></div>
      </div>
    

  
  

<!-- End #Disqus -->























  
  
      <div id="LatestInCategory" class="SpanningFeature ContentDefault ">
        <h3 class="latestarts_stories___interviews"><span class="headingText">Latest in Arts Stories & Interviews</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/orlando/every-holiday-event-happening-in-orlando-till-the-end-of-the-year/Content?oid=21006445&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/21006444/cover_horizontal.jpg"
             alt="Every holiday event happening in Orlando till the end of the year"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/21006444/cover_horizontal.jpg 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/21006444/cover_horizontal.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/every-holiday-event-happening-in-orlando-till-the-end-of-the-year/Content?oid=21006445&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">Every holiday event happening in Orlando till the end of the year</a>
    </h4>
    <div class="date">Nov 14, 2018</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/orlando/scare-actor-terri-giannoutsos-just-wants-to-make-you-pee-your-pants/Content?oid=20370637&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/20370630/terrig2_crop.jpg"
             alt="Orlando scare actor Terri Giannoutsos wants to make you pee your pants for Halloween"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/20370630/terrig2_crop.jpg 1.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/scare-actor-terri-giannoutsos-just-wants-to-make-you-pee-your-pants/Content?oid=20370637&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">Orlando scare actor Terri Giannoutsos wants to make you pee your pants for Halloween</a>
    </h4>
    <div class="date">Oct 31, 2018</div>
  </li>
    
  
    
    <li class="l0 storyItem">
    
      
      <a href="https://photos.orlandoweekly.com/everyone-we-saw-in-downtown-orlando-on-halloween-night/?slide=1&a62a0735&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/20447113/a62a0735.jpg"
             alt="Everyone we saw in downtown Orlando on Halloween night"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/20447113/a62a0735.jpg 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/20447113/a62a0735.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://photos.orlandoweekly.com/everyone-we-saw-in-downtown-orlando-on-halloween-night/?slide=1&a62a0735&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory">Everyone we saw in downtown Orlando on Halloween night</a>
    </h4>
    <div class="date">Oct 31, 2018</div>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=2240434&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=LatestInCategory" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    










  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningFeature ContentDefault Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningFeature ContentDefault ">
            <h3><span class="headingText">More by Thaddeus McCollum</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/orlando/every-holiday-event-happening-in-orlando-till-the-end-of-the-year/Content?oid=21006445&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/21006444/cover_horizontal.jpg"
             alt="Every holiday event happening in Orlando till the end of the year"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/21006444/cover_horizontal.jpg 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/21006444/cover_horizontal.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/every-holiday-event-happening-in-orlando-till-the-end-of-the-year/Content?oid=21006445&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Every holiday event happening in Orlando till the end of the year</a>
    </h4>
    <div class="date">Nov 14, 2018</div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/11/08/free-play-florida-returns-with-a-bigger-venue-for-decades-of-hands-on-arcade-history?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/20657134/gal_free_play_florida_adobestock_209052433.jpeg.jpg"
             alt="Free Play Florida returns with a bigger venue for decades of hands-on arcade history"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/20657134/gal_free_play_florida_adobestock_209052433.jpeg.jpg 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/20657134/gal_free_play_florida_adobestock_209052433.jpeg.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/11/08/free-play-florida-returns-with-a-bigger-venue-for-decades-of-hands-on-arcade-history?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Free Play Florida returns with a bigger venue for decades of hands-on arcade history</a>
    </h4>
    <div class="date">Nov  8, 2018</div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/11/08/mix-and-mingle-with-the-fashion-industry-at-orlando-international-fashion-weeks-edge-event?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/20659478/gal_oifw_edge.jpg"
             alt="Mix and mingle with the fashion industry at Orlando International Fashion Week&#39;s EDGE event"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/20659478/gal_oifw_edge.jpg 1.5x, https://media2.fdncms.com/orlando/imager/u/bigsquare3x/20659478/gal_oifw_edge.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/11/08/mix-and-mingle-with-the-fashion-industry-at-orlando-international-fashion-weeks-edge-event?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Mix and mingle with the fashion industry at Orlando International Fashion Week's EDGE event</a>
    </h4>
    <div class="date">Nov  8, 2018</div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?author=2289467" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  

  
    
        <div id="PeopleWhoLiked" class="SpanningFeature ContentDefault ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/orlando/the-florida-project-portrays-the-underbelly-of-kissimmees-famous-tourist-strip-we-talk-to-some-of-the-real-people-living-the-low-rent-mote/Content?oid=7400628&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/7400631/img_9004_rgb.jpg"
             alt="&#39;The Florida Project&#39; portrays the underbelly of Kissimmee&rsquo;s famous tourist strip"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/7400631/img_9004_rgb.jpg 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/7400631/img_9004_rgb.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/the-florida-project-portrays-the-underbelly-of-kissimmees-famous-tourist-strip-we-talk-to-some-of-the-real-people-living-the-low-rent-mote/Content?oid=7400628&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">'The Florida Project' portrays the underbelly of Kissimmee’s famous tourist strip</a>
    </h4>
    <div class="date">Oct  4, 2017</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/orlando/william-egglestons-peculiar-eye-for-color-and-composition-makes-him-a-national-treasure/Content?oid=5111543&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/5111542/gal_william_eggleston_untitled_1973.jpg"
             alt="William Eggleston&#39;s peculiar eye for color and composition makes him a national treasure"
             width="190"
             height="190"
             srcset="https://media2.fdncms.com/orlando/imager/u/bigsquare2x/5111542/gal_william_eggleston_untitled_1973.jpg 1.5x, https://media2.fdncms.com/orlando/imager/u/bigsquare3x/5111542/gal_william_eggleston_untitled_1973.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/william-egglestons-peculiar-eye-for-color-and-composition-makes-him-a-national-treasure/Content?oid=5111543&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">William Eggleston's peculiar eye for color and composition makes him a national treasure</a>
    </h4>
    <div class="date">Jun 21, 2017</div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/orlando/15-pulse-events-happening-in-the-orlando-area-this-week/Content?oid=4845903&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/4845902/dsc_0555.jpg"
             alt="15 Pulse events happening in the Orlando area this week"
             width="190"
             height="190"
             srcset="https://media1.fdncms.com/orlando/imager/u/bigsquare2x/4845902/dsc_0555.jpg 1.5x, https://media1.fdncms.com/orlando/imager/u/bigsquare3x/4845902/dsc_0555.jpg 2.5x" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/15-pulse-events-happening-in-the-orlando-area-this-week/Content?oid=4845903&utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">15 Pulse events happening in the Orlando area this week</a>
    </h4>
    <div class="date">Jun  7, 2017</div>
  </li>
      
      
    
          </ul>
        </div>
      
               

      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
    

    





        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        









<div id="TabbedPopularity" class="SpanningIsland ContentDefault ">
  <h2>Most Popular</h2>
  <div class="tabs">
    <div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>
    <div id="tabCommented" class="tabBack tab"><a href="#">Most Commented</a></div>
    <div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
  </div>
  
  

  <div class="popularityBody">
    
        <ol class="moduleList">
      
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/every-holiday-event-happening-in-orlando-till-the-end-of-the-year/Content?oid=21006445&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Every holiday event happening in Orlando till the end of the year <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/i-went-to-see-boom-and-wind-up-1957-for-some-simple-human-comedy-but-inevitably-present-day-politics-intruded/Content?oid=21008899&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">I went to see BOOM  and Wind Up 1957  for some simple  human comedy, but, inevitably, present-day politics intruded <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/orlando-fringe-winter-mini-fest-lineup-announced-plus-more-in-performing-arts-news/Content?oid=21008534&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Orlando Fringe Winter Mini-Fest lineup announced, plus more in performing arts news <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/the-acoustic-theater-steinmetz-hall-is-slowly-but-surely-taking-shape-at-the-dr-phillips-center/Content?oid=20669712&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Steinmetz Hall is slowly but surely taking shape at the Dr. Phillips Center <span class="more">Read More</span></a></h4>
      </li>
      
    
      
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/spooky-empire-celebrates-the-dark-side-of-comic-con-for-its-16th-year/Content?oid=20056467&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Spooky Empire celebrates the 'dark side of Comic Con' for its 16th year <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>  

  

  <div class="popularityBody" style="display:none">
    

    
    <div id="recentcomments" class="dsq-widget"><script type="text/javascript" src="https://disqus.com/forums/orlandoweekly/popular_threads_widget.js?num_items=5&hide_avatars=1&avatar_size=32&excerpt_length=200"></script></div>
  </div>
  
  

  <div class="popularityBody" style="display:none">
    
    
      <div class="currentIssue">
        <a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=21006179&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
          
            <img src="/imager/b/cover/21006179/3abe/111418_Cover.jpg" alt="Issue Cover" />
          
        </a>
        <p>November 14-20, 2018</p>
      </div>
    
    
        <ol class="moduleList">
      
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/every-holiday-event-happening-in-orlando-till-the-end-of-the-year/Content?oid=21006445&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Every holiday event happening in Orlando till the end of the year <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/selam-ethiopian-makes-digital-dining-finger-lickin-good/Content?oid=21007024&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Selam Ethiopian makes digital dining finger-lickin’ good <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/after-two-terms-of-rick-scotts-cruel-corrupt-mismanaged-administration-nearly-41-million-of-you-still-voted-for-this-tapeworm/Content?oid=21007417&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">After two terms of Rick Scott's cruel, corrupt, mismanaged administration, nearly 4.1 million of you still voted for this tapeworm <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/hobo-johnson-extracts-victory-from-defeat-yet-again/Content?oid=21008175&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Hobo Johnson extracts victory from defeat yet again <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/the-best-concerts-coming-to-orlando-this-week/Content?oid=21008528&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">The best concerts coming to Orlando this week <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/the-coen-brothers-spin-six-western-yarns-in-the-ballad-of-buster-scruggs/Content?oid=21008906&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">The Coen brothers spin six Western yarns in 'The Ballad  of Buster Scruggs' <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
<!-- End #TabbedPopularity -->










<div id="SearchRightCol" class="SpanningIsland ContentDefault  search-wrap">
    
    <form class="prepTextForm" id="searchbox_017793458706336421686:1y5lan2fdja" action="https://www.orlandoweekly.com/orlando/Search">
      <input type="hidden" name="cx" value="017793458706336421686:1y5lan2fdja" />
      <input type="hidden" name="cof" value="FORID:9" />
      <input id="search-submit" type="submit" name="sa" value="Search" />    
      <input id="search-input" autocomplete="off" type="text"  name="q" size="25" placeholder="Search" />
    </form>
    <ul id="search-dropdown"  class="search-dropdown" style="display:none;">
      <li class="search-option"><a class="search-all" href="https://www.orlandoweekly.com/orlando/Search"><span class="dark-search-icon"></span>&nbsp;All</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/ArticleArchives"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/EventSearch"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/LocationSearch"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
    </ul>
  
</div>

<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            if( newLocation.match(/\?/)){
              newLocation = newLocation+'&';
            }else{
              newLocation = newLocation+'?';
            }
            window.location = newLocation + "keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>
<!-- End #SearchRightCol -->
<div id="AdMediumRectangle1300x250" class="SpanningIsland ContentDefault ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-1" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-1');
                  });
              </script>
          </div>
</div>


  <div id="NewsletterSignup" class="SpanningIsland ContentDefault ">
  <h2>Newsletters</h2>
    <div class="wrap">
    <h3>Never miss a beat</h3>
<a href="/orlando/NewsletterSignup/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color:#F7941E;font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
    </div>
  </div>
  <div id="ORATVAANPartnerWidget" class="SpanningIsland ContentDefault ">
  <!--
  <iframe width="300" height="169" src="//www.ora.tv/embed/partner/orlandoweekly/playlist/179/v/1"frameBorder="0" scrolling="no" webkitAllowFullScreen mozallowfullscreen allowfullscreen></iframe>
  -->
  <iframe width="300" height="169" src="//www.ora.tv/embed/partner/orlandoweekly/playlist/179/v/1"frameBorder="0" scrolling="no" webkitAllowFullScreen mozallowfullscreen allowfullscreen></iframe>

</div>












































<div id="TabbedCalendar" class="SpanningIsland ContentDefault ">
  <h2>Calendar</h2>

  <div class="tabs">
    <div id="tabEvents" class="tab"><a href="#">Events</a></div>
    <div id="tabMusic"  class="tab"><a href="#">Music</a></div>
    <div id="tabMovies" class="tab"><a href="#">Movies</a></div>
    <div id="tabArts"   class="tab"><a href="#">Arts</a></div>
    <div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/wagyu-and-wine-at-the-capital-grille/Event?oid=18517134&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Wagyu & Wine at The Capital Grille <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/jackie-otto-miller-selected-works/Event?oid=18556428&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Jackie Otto Miller: Selected Works</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/festival-of-trees-at-the-lake-mary-museum/Event?oid=19536205&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Festival of Trees at the Lake Mary Museum <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/sanford-beer-week/Event?oid=18795217&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Sanford Beer Week <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/local-charities-luncheon/Event?oid=20500626&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Local Charities Luncheon <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/eugene-snowdens-ten-pints-of-truth/Event?oid=2293074&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Eugene Snowden's Ten Pints of Truth <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/sidewalk-sets/Event?oid=20608345&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Sidewalk Sets <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/electric-dawn-one-drop-the-electric-mud-space-force/Event?oid=20723585&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Electric Dawn, One Drop, the Electric Mud, Space Force <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/the-met-live-in-hd-marnie/Event?oid=18766209&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        The Met Live in HD: <i>Marnie</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/carol-stein-and-friends/Event?oid=18606399&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Carol Stein & Friends <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/more-q-than-a-horn-from-the-heart/Event?oid=20820128&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        More Q Than A: <i>Horn From the Heart</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/die-hard/Event?oid=18766210&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Die Hard</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/anime-night-orlando-gainax-classics/Event?oid=20952747&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Anime Night Orlando: Gainax Classics <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/anime-nite/Event?oid=19979123&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Anime Nite <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/bandstand/Event?oid=20952749&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Bandstand</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/jackie-otto-miller-selected-works/Event?oid=18556428&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Jackie Otto Miller: Selected Works</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/coloring-with-robyn/Event?oid=7617991&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Coloring With Robyn <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/paint-nite-at-bloodhound-brew/Event?oid=12407841&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Paint Nite at Bloodhound Brew <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/paint-nite-at-boardwalk-bowl/Event?oid=12442502&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Paint Nite at Boardwalk Bowl <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/paint-nite-orlando-at-buca-di-beppo-maitland/Event?oid=12408559&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Paint Nite Orlando at Buca Di Beppo Maitland <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/tijuana-flats-burrito-company/Location?oid=2290207&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Tijuana Flats Burrito Company <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/siam-garden/Location?oid=2290061&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Siam Garden <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/jalapenos/Location?oid=2285356&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Jalapeno's <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
    <form name="diningSearchForm" method="get" action="https://www.orlandoweekly.com/orlando/LocationSearch">
      <input type="hidden" name="locationSection" value="2282258" />
      <input type="hidden" name="guide" value="2124367" />
      <select name="locationCategory">
        <option value="">-All Categories-</option>
        
          <option value="2282260">African</option>
        
          <option value="2282261">American</option>
        
          <option value="2282262">Argentine</option>
        
          <option value="2282263">Armenian</option>
        
          <option value="2282264">Bakery</option>
        
          <option value="2282265">Barbecue</option>
        
          <option value="2282266">Breakfast/Brunch</option>
        
          <option value="2282267">Brewpub</option>
        
          <option value="2282286">Burgers</option>
        
          <option value="2282268">Café/Bistro</option>
        
          <option value="2282269">Cajun/Creole</option>
        
          <option value="2282270">Caribbean</option>
        
          <option value="2282272">Chinese</option>
        
          <option value="2282271">Coffee house (chain)</option>
        
          <option value="2282289">Coffee house (independent)</option>
        
          <option value="2282274">Contemporary</option>
        
          <option value="2282275">Continental</option>
        
          <option value="2282276">Cuban</option>
        
          <option value="2297679">Deli</option>
        
          <option value="2282278">Diner</option>
        
          <option value="2282279">Eastern European</option>
        
          <option value="2282280">Ethiopian</option>
        
          <option value="2282281">Fondue</option>
        
          <option value="2304903">Food Truck</option>
        
          <option value="2282282">French</option>
        
          <option value="2282283">General</option>
        
          <option value="2282399">General Fare</option>
        
          <option value="2282284">German</option>
        
          <option value="2282285">Greek</option>
        
          <option value="2282287">Hawaiian</option>
        
          <option value="2282288">Hot Dogs</option>
        
          <option value="2282290">Indian</option>
        
          <option value="2282291">Indonesian</option>
        
          <option value="2282292">Irish</option>
        
          <option value="2282293">Israeli</option>
        
          <option value="2282294">Italian</option>
        
          <option value="2282295">Jamaican</option>
        
          <option value="2282296">Japanese/Sushi</option>
        
          <option value="2282297">Korean</option>
        
          <option value="2297696">Kosher</option>
        
          <option value="2282298">Latin American</option>
        
          <option value="2282299">Lebanese</option>
        
          <option value="2305936">Malaysian</option>
        
          <option value="2282300">Market</option>
        
          <option value="2282301">Mediterranean</option>
        
          <option value="2282302">Mexican</option>
        
          <option value="2282303">Middle Eastern</option>
        
          <option value="2345788">Modern American</option>
        
          <option value="2282304">Mongolian</option>
        
          <option value="2282305">Moroccan</option>
        
          <option value="2282306">Noodles</option>
        
          <option value="2282307">Pan-Asian</option>
        
          <option value="2282308">Persian</option>
        
          <option value="2282309">Peruvian</option>
        
          <option value="2282310">Philippine</option>
        
          <option value="2282311">Pizza</option>
        
          <option value="2282312">Polish</option>
        
          <option value="2297728">Pub Grub</option>
        
          <option value="2282313">Puerto Rican</option>
        
          <option value="2282314">Russian</option>
        
          <option value="2282315">Salads</option>
        
          <option value="2282277">Sandwiches/Subs</option>
        
          <option value="2282316">Seafood</option>
        
          <option value="2282317">Soup</option>
        
          <option value="2282318">Southern/Soul</option>
        
          <option value="2282319">Spanish</option>
        
          <option value="2282320">Steakhouse</option>
        
          <option value="2282321">Swedish</option>
        
          <option value="2282322">Sweets</option>
        
          <option value="2282323">Tapas</option>
        
          <option value="2282273">Tea</option>
        
          <option value="2282324">Tex-Mex</option>
        
          <option value="2282325">Thai</option>
        
          <option value="2282326">Turkish</option>
        
          <option value="2282327">Vegetarian/Vegan</option>
        
          <option value="2282328">Vietnamese</option>
        
          <option value="2282329">Wine</option>
        
      </select>
      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        <option value="2292883" >&nbsp;&nbsp;Apopka</option>
      
        <option value="2282447" >&nbsp;&nbsp;Central</option>
      
        <option value="2292887" >&nbsp;&nbsp;Audubon Park</option>
      
        <option value="2292884" >&nbsp;&nbsp;Casselberry</option>
      
        <option value="2282448" >&nbsp;&nbsp;Disney</option>
      
        <option value="2282449" >&nbsp;&nbsp;Downtown</option>
      
        <option value="2282450" >&nbsp;&nbsp;East</option>
      
        <option value="2399527" >&nbsp;&nbsp;Edgewood</option>
      
        <option value="2282451" >&nbsp;&nbsp;Elsewhere</option>
      
        <option value="2282452" >&nbsp;&nbsp;I-DriveUniversal</option>
      
        <option value="2292885" >&nbsp;&nbsp;Ivanhoe Village</option>
      
        <option value="2282453" >&nbsp;&nbsp;North</option>
      
        <option value="2282454" >&nbsp;&nbsp;South</option>
      
        <option value="2282455" >&nbsp;&nbsp;West</option>
      
        <option value="4366406" >&nbsp;&nbsp;Dr. Phillips</option>
      
        <option value="2282456" >&nbsp;&nbsp;Winter Park Area</option>
      
        <option value="2343583" >&nbsp;&nbsp;Milk District</option>
      
        <option value="2343582" >&nbsp;&nbsp;SoDo</option>
      
        <option value="2343585" >&nbsp;&nbsp;Kissimmee</option>
      
        <option value="2343584" >&nbsp;&nbsp;UCF</option>
      
        <option value="2343586" >&nbsp;&nbsp;Mount Dora</option>
      
        <option value="2343587" >&nbsp;&nbsp;Conway</option>
      
        <option value="2343589" >&nbsp;&nbsp;Belle Isle</option>
      
        <option value="2343590" >&nbsp;&nbsp;Mills 50</option>
      
        <option value="2345785" >&nbsp;&nbsp;College Park</option>
      
        <option value="2345787" >&nbsp;&nbsp;Thornton Park</option>
      
    
  </select>
      <div class="searchBox">
        <input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
        <input type="submit" value="go" />
      </div>
    </form>
  </div>
</div>




<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 3
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
<div id="AdMediumRectangle2300x250" class="SpanningIsland ContentDefault ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-2" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-2');
                  });
              </script>
          </div>
</div><div id="PhotoSlideshows" class="SpanningIsland ContentDefault ">
  <h2><a href="http://photos.orlandoweekly.com/" target="_blank">Newest Slideshows</a></h2>
  <iframe src="//photos.orlandoweekly.com/thumbnail-scroller-square/" 
          height="419" 
          width="364"
          scrolling="no" 
          frameborder="0"></iframe>
</div>
<!-- End #PhotoSlideshows -->




  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  




















    <div id="SpecialIssues" class="SpanningIsland ContentDefault ">
      <h2><a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
  
  
  <div class="reportBox">
    <a href="/orlando/welcome-to-the-2018-orlando-weekly-city-guide/Content?oid=12827125&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/12863154/screen_shot_2018-04-18_at_12.47.44_pm.png);">
      <span class="grayRedBox">City Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/a-few-of-the-best-events-coming-to-orlando-this-balmy-holiday-season/Content?oid=8534992&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/12895889/holidayguide2017.png);">
      <span class="grayRedBox">Holiday Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/Category?oid=2240491&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/orlando/imager/u/original/4587058/sidebar.jpg);">
      <span class="grayRedBox">Summer Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-orlando-weeklys-2018-newcomers-guide/Content?oid=16946054&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/orlando/imager/u/original/17005746/screen_shot_2018-08-10_at_11.01.15_am.png);">
      <span class="grayRedBox">Newcomers Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-the-best-of-orlando-2018/BestOf?oid=17445650&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/17484726/screen_shot_2018-08-22_at_7.23.27_am.png);">
      <span class="grayRedBox">Best of Orlando</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-bite-2018/Content?oid=15292363&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/15292364/screen_shot_2018-06-26_at_5.32.22_pm.png);">
      <span class="grayRedBox">Bite</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-orlando-weeklys-2018-fall-guide/Content?oid=18838010&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/18876408/screen_shot_2018-09-26_at_12.36.27_pm.png);">
      <span class="grayRedBox">Fall Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/puppy-love/Category?oid=2240490&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/2519912/sidebar_ow_homepage6.jpg);">
      <span class="grayRedBox">Puppy Love</span>
    </a>
  </div>
  

      <a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
    </div>
  
<div id="AdMediumRectangle3300x250" class="SpanningIsland ContentDefault ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-3" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-3');
                  });
              </script>
          </div>
</div>
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      

<div id="FooterInfo" class="GlobalFooter ContentDefault ">
  <div class="footerCustomInfo">
    <h2>Orlando Weekly</h2>
    <p>16 W. Pine St.</p>
    <p>Orlando, FL 32801</p>
    <p>Phone: (407) 377-0400</p>
    <p>Classified Phone: (407) 377-0415</p>
    <p>Fax: (407) 377-0420</p>
  </div>
  <div class="footerCustomWrap">
    <div class="footerCustomNav">
      <ul>
        <li><a target="_top" href="/orlando/AboutOrlandoWeekly/Page">About OW</a></li>
        <li><a target="_top" href="https://www.orlandoweekly.com/orlando/AdvertiseWithOrlandoWeekly/Page">Advertise</a></li>
        <li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
				
        <li><a target="_top" href="/orlando/WorkForUs/Page">Work Here</a></li>
      </ul>
      <p>All parts of this site Copyright &copy; 2018 Orlando Weekly.</p>
    </div>
    <div class="footerRssLink">
      <a href="https://www.orlandoweekly.com/orlando/Syndication" class="RSSLink">RSS Feeds</a>
    </div>    
    

    
    
      <div class="footerCustomLogin">
        

        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="https://posting.orlandoweekly.com/orlando/MyProfile">View Profile</a> / </li>
          <li><a href="https://posting.orlandoweekly.com/orlando/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="https://www.orlandoweekly.com/orlando/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      </div><!-- #FooterInfo -->

      <script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
    
  </div>
  <div class="clear"></div>
</div>
<!-- End #FooterInfo -->
<div id="AdFooter728x90" class="GlobalFooter ContentDefault ">
  <!-- /43707298/ORL_728x90 -->
          <div id="div-gpt-ad-orl_728x90-2" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-2');
                  });
              </script>
          </div>
</div>































<div id="FooterNavigation" class="GlobalFooter ContentDefault ">
  <div class="linkGroupColumn">

    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/news-and-features/Section?oid=2240408" 
               target="_">
              News & Features
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/news-and-features/Section?oid=2240408" >News Home</a></li>
          
            <li><a href="/orlando/first-words/Category?oid=2240418" >First Words</a></li>
          
            <li><a href="/orlando/happytown/Category?oid=2240414" >Happytown</a></li>
          
            <li><a href="/orlando/know-it-all/Category?oid=2240417" >Know It All</a></li>
          
            <li><a href="/orlando/give-me-your-money/Category?oid=2240416" >Give Me Your Money</a></li>
          
            <li><a href="/Blogs/archives/bloggytown/" >Blog: Bloggytown</a></li>
          
            <li><a href="/orlando/joblistings/Page" >Local Job Listings</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/EventSearch" 
               target="_">
              Arts & Culture
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/arts-and-culture/Section?oid=2240407" >Arts & Culture Home</a></li>
          
            <li><a href="/orlando/visual-arts/Category?oid=2240435" >Visual Arts</a></li>
          
            <li><a href="/orlando/performing-arts/Category?oid=2240436" >Performing Arts</a></li>
          
            <li><a href="/orlando/books/Category?oid=2240437" >Books</a></li>
          
            <li><a href="/orlando/live-active-cultures/Category?oid=2240438" >Live Active Cultures</a></li>
          
            <li><a href="/orlando/culture-2-go/Category?oid=2240439" >Culture 2 Go</a></li>
          
            <li><a href="/orlando/savage-love/Category?oid=2240424" >Savage Love</a></li>
          
            <li><a href="/orlando/free-will-astrology/Category?oid=2240441" >Free Will Astrology</a></li>
          
            <li><a href="/Blogs/archives/the-gist/" >Blog: The Gist</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/food-and-drink/Section?oid=2240409" 
               target="_">
              Food & Drink
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/food-and-drink/Section?oid=2240409" >Food & Drink Home</a></li>
          
            <li><a href="/orlando/restaurant-review/Category?oid=2240450" >Restaurant Reviews</a></li>
          
            <li><a href="/orlando/tip-jar/Category?oid=2240453" >Tip Jar</a></li>
          
            <li><a href="/orlando/bar-exam/Category?oid=2240455" >Bar Exam</a></li>
          
            <li><a href="/orlando/nosh-pit/Category?oid=2240452" >Nosh Pit</a></li>
          
            <li><a href="/orlando/remix/Category?oid=2240456" >Remix</a></li>
          
            <li><a href="/orlando/LocationSearch?locationSection=2282258" >Find a Restaurant</a></li>
          
            <li><a href="/orlando/LocationSearch?locationSection=2282256" >Find a Bar or Club</a></li>
          
            <li><a href="/Blogs/archives/tip-jar/" >Blog: Tip Jar</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/screens/Section?oid=2240411" 
               target="_">
              Screens
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/screens/Section?oid=2240411" >Screens Home</a></li>
          
            <li><a href="/orlando/movie-reviews-and-stories/Category?oid=2240471" >Movie reviews</a></li>
          
            <li><a href="/orlando/couchsurfing/Category?oid=2240472" >Couchsurfing</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/music/Section?oid=2240410" 
               target="_">
              Music
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/music/Section?oid=2240410" >Music Home</a></li>
          
            <li><a href="/orlando/music-stories-and-interviews/Category?oid=2240462" >Music Reviews & Stories</a></li>
          
            <li><a href="/orlando/feedback/Category?oid=2240463" >Feedback</a></li>
          
            <li><a href="/orlando/this-little-underground/Category?oid=2240465" >This Little Underground</a></li>
          
            <li><a href="/Blogs/archives/the-heard/" >Blog: The Heard</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/EventSearch" 
               target="_">
              Calendar
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/EventSearch" >Search Calendar Events</a></li>
          
            <li><a href="/orlando/EventSearch?feature=Staff%20Pick" >This Week's Selections</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/FreeStuff" 
               target="_">
              Giveaways
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273884">Contests</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2361070">25th Anniversary BIG Prizes</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2199663">Cool Stuff</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273883">Swag</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2361151">Concert Tickets</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Events</h3>
        

        <ul class="sublinkGroup">
          

          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/special-issues/Section?oid=2240413" 
               target="_">
              Special Issues
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/annual-manual/Category?oid=2240488">Annual Manual</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/summer-guide/Category?oid=2240491">Summer Guide</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/bite/Category?oid=2240489">Bite</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/newcomers-guide/Category?oid=2240498">Newcomers Guide</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/fall-guide/Category?oid=2240492">Fall Guide</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/BestOf" 
               target="_">
              Best of Orlando
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2018">2018</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2017">2017</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2016">2016</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2015">2015</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/ArticleArchives" 
               target="_">
              Search
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/ArticleArchives" >Search Authors or Stories</a></li>
          
            <li><a href="/orlando/IssueArchives" >Search Issues</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Sponsored Links</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="http://www.407apartments.com/" target="_blank">Orlando Apartments</a></li>
          
            <li><a href="http://www.407apartments.com/ucf-apartments.aspx" target="_blank">UCF Apartments</a></li>
          
            <li><a href="https://www.livesomewhere.com/ucf" target="_blank">UCF Off Campus Housing</a></li>
          
            <li><a href="http://www.407apartments.com/orlando-apartments/Winter-Park-Apartments" target="_blank">Winter Park Apartments</a></li>
          
            <li><a href="http://computerrepairdoctor.com/" target="_blank">Computer Repair Doctor</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/AboutOrlandoWeekly/Page" 
               target="_">
              About Us
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/AboutOrlandoWeekly/Page" >Staff Directory</a></li>
          
            <li><a href="/orlando/Policies/Page" >Policies</a></li>
          
            <li><a href="/orlando/FAQs/Page" >FAQ</a></li>
          
            <li><a href="/orlando/AboutOrlandoWeekly/Page" >Contact Us</a></li>
          
            <li><a href="/orlando/WorkForUs/Page" >Work for Us</a></li>
          
            <li><a href="/orlando/Wheretofindus/Page" >Where to Find Us</a></li>
          
            <li><a href="/orlando/AdvertiseWithOrlandoWeekly/Page" >Advertise</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Social Media</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="https://www.facebook.com/orlandoweekly" target="_blank">Facebook</a></li>
          
            <li><a href="https://twitter.com/OrlandoWeekly" target="_blank">Twitter</a></li>
          
            <li><a href="http://instagram.com/orlandoweekly/" target="_blank">Instagram</a></li>
          
        </ul>

      </div>
    

  </div><!-- End .linkGroupColumn -->
</div>
<!-- End #FooterNavigation -->
<div id="footerCopyright">
  <p>
   &copy; 2018
   Orlando Weekly 
   <br><br>
   Website powered by <a href="http://foundation.gyrobase.com/" target="_blank">Foundation</a>
  </p>
</div>
    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdBackground" class="Closer ContentDefault ">
  <!-- /43707298/ORL_Reskin -->
          <div id="div-gpt-ad-orl_reskin" style="" data-content-type="ad" data-slot="/43707298/ORL_Reskin" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                  googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_reskin');
                  });
              </script>
          </div>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  


