
<!DOCTYPE html>
<html class="uk-root" lang="en">
<head>

<script async>!function(){var e=window.location.hostname,t=document.createElement("script"),a=document.getElementsByTagName("script")[0],n="https://quantcast.mgr.consensu.org".concat("/choice/","ECpz7gxYXdCG2","/",e,"/choice.js"),i=0;t.async=!0,t.type="text/javascript",t.src=n,a.parentNode.insertBefore(t,a),function(){for(var e,t="__tcfapiLocator",a=[],n=window;n;){try{if(n.frames.__tcfapiLocator){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,i=!!n.frames.__tcfapiLocator;if(!i)if(a.body){var o=a.createElement("iframe");o.style.cssText="display:none",o.name=t,a.body.appendChild(o)}else setTimeout(e,5);return!i}(),n.__tcfapi=function(){var e,t=arguments;if(!t.length)return a;if("setGdprApplies"===t[0])t.length>3&&2===t[2]&&"boolean"==typeof t[3]&&(e=t[3],"function"==typeof t[2]&&t[2]("set",!0));else if("ping"===t[0]){var n={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof t[2]&&t[2](n)}else a.push(t)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,i){var o={__tcfapiReturn:{returnValue:a,success:i,callId:n.callId}};t&&(o=JSON.stringify(o)),e.source.postMessage(o,"*")}),n.parameter)}),!1))}();var o=function(){var e=arguments;typeof window.__uspapi!==o&&setTimeout((function(){void 0!==window.__uspapi&&window.__uspapi.apply(window.__uspapi,e)}),500)};if(void 0===window.__uspapi){window.__uspapi=o;var c=setInterval((function(){i++,window.__uspapi===o&&i<3?console.warn("USP is not accessible"):clearInterval(c)}),6e3)}}()</script>
<link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.min.css?cb=b12b86e2ce57bdfc6476f871f67d376c" />
<script src="/fdn-system/assets/pub/scripts/uikit.min.js"></script>
<script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js"></script>
<script src="/foundation/fontawesome/js/brands.min.js" async></script>
<script src="/foundation/fontawesome/js/solid.min.js" async></script>
<script src="/foundation/fontawesome/js/regular.min.js" async></script>
<script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
<script src="/foundation/fontawesome/js/light.min.js" async></script>
<script src="/foundation/fontawesome/js/duotone.min.js" async></script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta charset="UTF-8">
<meta name="layout" content="Content Default (Responsive, Air)" />
<meta name="oid" content="31820998" />
<script>
window.__FOUNDATION_RESPONSIVE__ = true
// 
window.__FBAPIv__ = 'v3.2'
// 
</script>
<script src="/foundation/scripts/foundation-air-2-0-1.js?cb=5f8a3af5830d4eb41a786a5a9b0ad89d"></script>
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Whole Site" href="https://www.orlandoweekly.com/orlando/Rss.xml" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Food + Drink Section" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2240409" />
<link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Food News" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=31065305" />
<script>
fixupProfileLinks("https:\/\/www.orlandoweekly.com\/orlando\/Profile", "https:\/\/posting.orlandoweekly.com\/orlando\/MyProfile");
</script>
<meta name="google-signin-client_id" content="297405715145-bcr8a9m9emb8a84o6qbd7utuefrfoknk.apps.googleusercontent.com">


<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>


<link rel="preconnect" href="https://fonts.googleapis.com">
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin>
<link href="https://fonts.googleapis.com/css2?family=Lato:wght@400;700&family=Montserrat:wght@400;700&family=Open+Sans+Condensed:wght@300;700&family=Titillium+Web:wght@400;700&display=swap" rel="stylesheet">

<style>
:root {
--pub-primary-color:#F7941E;
--pub-link-color:#F7941E;
--real-1-primary-color: #F7941E;
--real-1-secondary-color: #F7941E66;
}
</style>
<meta name="google-site-verification" content="06A5Yh5mu5xlqSkqBOzGlxA6P_yfmltTp1l0ssgpOBk" />
<meta name="google-site-verification" content="9htXi1AfaHrVLNGB2JDLtdpWEFyb-JOf5ngnP_95Zuk" />
<meta name="google-site-verification" content="s4GBlkstS6PKQwO_gDlOGL8jFPmeuL_d3m60wxOBQR0" />
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>window.googletag = window.googletag || { cmd: [] };</script>
<script>
Foundation.Ad = Foundation.Ad || {};
Foundation.Ad.slotsToDefineInHeader = ["ORL_LeaderboardHeader-1", "ORL_Footer-1", "ORL_Reskin-1"];
Foundation.Ad.setupPageTargeting = function () {
googletag.pubads().setTargeting("template", ["Content"]); // template | Content
googletag.pubads().setTargeting("media", ["screen"]); // media | screen
googletag.pubads().setTargeting("section", ["food-drink"]); // section | food-drink
googletag.pubads().setTargeting("category", ["FoodNews"]); // category | FoodNews
googletag.pubads().setTargeting("oid", ["31820998"]); // oid | 31820998
googletag.pubads().setTargeting("tags", ["King Cajun", "Mills 50", "racism", "Orlando", "hate crimes", "Instagram"]); // tags | King Cajun, Mills 50, racism, Orlando, hate crimes, Instagram
googletag.pubads().setTargeting("vertical", ["food"]); // vertical | food
googletag.pubads().setTargeting("category_type", ["Story"]); // category_type | Story
}
</script>
<script src="/gyrobase/Responsive/Custom/Scripts/Gpt.js?cb=302fb9b9f5b9859ab1b8ae7c7f5a6b1e"></script>

<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-585470-1', 'auto');
ga('set', 'anonymizeIp', true);
ga('send', 'pageview', { 'dimension1': 'content', 'dimension2': 'food' });
</script>

<script>
var Euclid = Euclid || {}
Euclid.OrlandoWeekly = Euclid.OrlandoWeekly || {}
Euclid.OrlandoWeekly.vertical = Euclid.OrlandoWeekly.vertical || ''
</script>






<link rel="shortcut icon" href="/favicon.ico" />
<meta name="title" content="Mills 50 restaurant King Cajun Crawfish films Orlando woman going on racist rant after she was denied a refund | Food News | Orlando | Orlando Weekly" />
<meta name="description" content="The staff at King Cajun in Mills 50 had to listen to an Orlando woman spew racist remarks after she was denied a refund on..." />
<meta name="keywords" content="King Cajun, Mills 50, racism, Orlando, hate crimes, Instagram, News, Blog, Culture, Dining, Events" />
<title>Mills 50 restaurant King Cajun Crawfish films Orlando woman going on racist rant after she was denied a refund | Food News | Orlando | Orlando Weekly</title>
<meta name="date" content="2022-06-15 12:54:00" />
<meta name="author" content="Patricia Tolley">
<meta name="news_keywords" content="king cajun, mills 50, racism, orlando, hate crimes, instagram, news, blog, culture, dining" />
<link rel="image_src" href="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31821304/screen_shot_2022-06-15_at_12.55.26_pm.png" />
<meta name="thumbnail" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31821304/screen_shot_2022-06-15_at_12.55.26_pm.png" />
<link rel="canonical" href="https://www.orlandoweekly.com/food-drink/mills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998" />
<meta property="og:url" content="https://www.orlandoweekly.com/food-drink/mills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998" />
<meta property="fb:app_id" content="1527160917534695" />
<meta property="og:site_name" content="Orlando Weekly" />
<meta property="og:title" content="Mills 50 restaurant King Cajun Crawfish films Orlando woman going on racist rant after she was denied a refund" />
<meta property="og:image" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31821304/screen_shot_2022-06-15_at_12.55.26_pm.png" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="423" />
<meta property="og:description" content="The staff at King Cajun in Mills 50 had to listen to an Orlando woman spew racist remarks after she was denied a refund on..." />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:image" content="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31821304/screen_shot_2022-06-15_at_12.55.26_pm.png">
<meta name="twitter:site" content="@orlandoweekly">
<meta name="twitter:title" content="Mills 50 restaurant King Cajun Crawfish films Orlando woman going on racist rant after she was denied a refund">
<meta name="twitter:description" content="The staff at King Cajun in Mills 50 had to listen to an Orlando woman spew racist remarks after she was denied a refund on...">

<script type="application/ld+json">
{
"mainEntityOfPage": {
"@type": "WebPage",
"@id":"https:\/\/www.orlandoweekly.com\/food-drink\/mills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998"
},
"headline": "Mills 50 restaurant King Cajun Crawfish films Orlando woman going on racist rant after she was denied a refund",
"description": "The staff at King Cajun in Mills 50 had to listen to an Orlando woman spew racist remarks after she was denied a refund on Tuesday.",
"image": {
"url": "https:\/\/media2.orlandoweekly.com\/orlando\/imager\/u\/original\/31821304\/screen_shot_2022-06-15_at_12.55.26_pm.png",
"width": 707,
"height": 498,
"@type": "ImageObject"
},
"datePublished": "2022-06-15T12:54:00",
"dateModified": "2022-06-15T14:59:23",
"author": {
"name": "Patricia Tolley",
"url": "https:\/\/www.orlandoweekly.com\/author\/patricia-tolley",
"@type": "Person"
},
"publisher": {
"name": "Orlando Weekly",
"logo": {
"url": "https:\/\/www.orlandoweekly.com\/imager\/b\/google-amp-logo\/808579\/5643\/OrlandoWeekly_fbook.jpg",
"width": 117,
"height": 60,
"@type": "ImageObject"
},
"@type": "Organization"
},
"@context": "https://schema.org",
"@type": "NewsArticle"
}
</script>
<script>window.twttr = (function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0],
t = window.twttr || {};
if (d.getElementById(id)) return t;
js = d.createElement(s);
js.id = id;
js.src = "https://platform.twitter.com/widgets.js";
fjs.parentNode.insertBefore(js, fjs);
t._e = [];
t.ready = function(f) {
t._e.push(f);
};
return t;
}(document, "script", "twitter-wjs"));</script>
</head>
<script src="/fdn-system/assets/pub/scripts/ResizeSensor.js"></script>
<script src="/fdn-system/assets/pub/scripts/ElementQueries.js"></script>
<script>
ElementQueries.listen();
</script>
<body id="Content" class="ContentDefault food-drink FoodNews RespOneCol">
<script>
ElementQueries.init();
</script>
<script>
jQuery(() => {
googletag.cmd.push(function() {
Foundation.Ad.showFooter('ORL_Footer-1');
});
});
</script>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KQ22CZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KQ22CZ');</script>

<div id="fb-root"></div>
<script>
(function () {
var app = new Foundation.Facebook.Application();
app.receiveAuthNotifications();
app.receiveLikeNotifications();
})();
</script>
<script>
(function () {
var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
//if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
}.bind(this), function(){
if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
})
})()
</script>
<div id="ContentDefault" class="grid-resp-1 page layout-ContentDefault">
<div class="ev-grid-layout ev-clamp@m ev-clamp@l">
<div class="ev-grid-zone ev-leader-zone">
<div class="ev-grid-col uk-width-1-1" data-ev-zone="Leader">
<div class="Leader ContentDefault   uk-root fdn-margin-vert PromoTopBar comp-" data-component-id="PromoTopBar">
<a href="https://vote.orlandoweekly.com/">
VOTE NOW! BEST OF ORLANDO® 2022
</a>
</div>
</div>
</div>
<div class="ev-grid-zone ev-header-zone">
<div class="ev-grid-col uk-width-1-1" data-ev-zone="GlobalHeader">

<div class="GlobalHeader ContentDefault  uk-margin-remove uk-root fdn-margin-vert SiteHeader comp-shell-siteheader" data-component-id="SiteHeader">
<div class="uk-flex uk-flex-wrap fdn-site-header-flex">
<div class="uk-hidden@m uk-margin-auto-right uk-margin-auto-vertical fdn-site-header-nav-toggle">
<a href="#offcanvas-slide-navigation" class="fdn-nav-toggle uk-button" uk-toggle>
<span class="uk-icon"><i class="fas fa-bars fa-2x"></i></span>
</a>
</div>
<div class="uk-margin-auto uk-width-auto uk-width-1-1@m fdn-site-header-logo">
<div class="GlobalHeader Logoresponsive  uk-margin-remove uk-root fdn-margin-vert Logo comp-shell-logo" data-component-id="Logo">
<div class="uk-margin-remove">
<a class="uk-logo" href="https://www.orlandoweekly.com/" title="Orlando Weekly">
<img src="https://www.orlandoweekly.com/images/logos/mainLogo.jpg" alt="Orlando Weekly">
</a>
</div>
<div class="uk-visible@m uk-margin-auto-left uk-flex uk-flex-middle">
<div ad-slot-div-id="ORL_LeaderboardHeader-1" display-targets="all" class="uk-width-1-1 uk-flex uk-flex-around " preset-height="true" leaderboardheader-desktop-stub hidden>
<script>Foundation.Ad.showAd();</script>
</div>
</div>
</div>
<div id="fdn-logo-hook"></div>
</div>
<div class="uk-width-1-1 uk-visible@m fdn-site-header-nav">

<div id="NavigationHorizontal" class="GlobalHeader NavigationHorizontalresponsive uk-margin-remove   uk-root fdn-margin-vert NavigationHorizontal comp-shell-navigationhorizontal" data-component-id="NavigationHorizontal">
<nav class="fdn-nav-block uk-navbar-container uk-navbar-transparent
uk-responsive-width uk-visible@m" id="mainNav" uk-navbar>
<ul class="site-nav-source uk-navbar-nav uk-width-1-1">
<li class="fdn-nav-parent uk-parent " id="News">
<a href="https://www.orlandoweekly.com/news" target="_self">
News
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/orlando-area-news-31065036" target="_self" title="">
Orlando Area News
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/florida-news-31065043" target="_self" title="">
Florida News
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/topic/lgbtq-31060459" target="_self" title="">
LGBTQ+
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/topic/pulse-31060458" target="_self" title="">
Pulse
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/views-opinions-31146339" target="_self" title="">
Views + Opinions
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando-guides" target="_self" title="">
Orlando Guides
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=this%20week" target="_self" title="">
Digital Issue
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/slideshows/?section=2240408" target="_self" title="">
News Slideshows
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="ArtsCulture">
<a href="https://www.orlandoweekly.com/arts" target="_self">
Arts + Culture
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/arts-stories-and-interviews-2240434" target="_self" title="">
Arts Stories + Interviews
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/things-to-do-31066175" target="_self" title="">
Things to Do
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/topic/orlando-theme-parks-31060466" target="_self" title="">
Orlando Theme Parks
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/slideshows/?section=2240407" target="_self" title="">
Arts + Culture Slideshows
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="FoodDrink">
<a href="https://www.orlandoweekly.com/food-drink" target="_self">
Food + Drink
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/food-news-31065305" target="_self" title="">
Food News
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/drinking-bars-31065312" target="_self" title="">
Drinking + Bars
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/restaurant-review-2240450" target="_self" title="">
Restaurant Reviews
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationSection=2282258" target="_self" title="">
Find a Restaurant
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/slideshows/?section=2240409" target="_self" title="">
Food + Drink Slideshows
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="Music">
<a href="https://www.orlandoweekly.com/music" target="_self">
Music
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/music-stories-and-interviews-2240462" target="_self" title="">
Music Stories + Interviews
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/orlando-music-news-31065388" target="_self" title="">
Orlando Music News
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/live-music-picks-previews-31065380" target="_self" title="">
Live Music Picks + Previews
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&sortType=date&v=d" target="_self" title="">
Find a Concert
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/slideshows/?section=2240410" target="_self" title="">
Music Slideshows
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="Screens">
<a href="https://www.orlandoweekly.com/movies-tv" target="_self">
Movies
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/movie-reviews-31065358" target="_self" title="">
Movie Reviews
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/streaming-31065342" target="_self" title="">
Streaming
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationCategory=2282370&sortType=name" target="_self" title="">
Find a Theater
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/MovieTimes" target="_self" title="">
Movie Times
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="Cannabis">
<a href="https://www.orlandoweekly.com/cannabis" target="_self">
Cannabis
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/weed-news-31065403" target="_self" title="">
Cannabis News
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/legislative-updates-31065418" target="_self" title="">
Legislative Updates
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/category/dispensary-directory-31065425" target="_self" title="">
Dispensary Directory
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="Calendar">
<a href="https://www.orlandoweekly.com/orlando/EventSearch" target="_self">
Calendar
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/FreeStuff" target="_self" title="">
Orlando Weekly Events
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&v=d" target="_self" title="">
Today&#39;s Events
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&sortType=date&v=d" target="_self" title="">
This Weekend
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?feature=Free&sortType=date&v=d" target="_self" title="">
Free Events
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/Events/AddEvent" target="_self" title="">
Submit an Event
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="BestOfOrlando">
<a href="https://www.orlandoweekly.com/orlando/BestOf" target="_self">
Best Of Orlando&reg;
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://vote.orlandoweekly.com/" target="_blank" title="">
Best Of Orlando&reg; 2022 Ballot
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/best-of/arts-and-culture" target="_self" title="">
Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/best-of/food-and-drink" target="_self" title="">
Food &amp; Drink
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/best-of/goods-and-services" target="_self" title="">
Goods &amp; Services
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/best-of/local-color" target="_self" title="">
Local Color
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/best-of/music-and-nightlife" target="_self" title="">
Music &amp; Nightlife
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/best-of/sports-and-recreation" target="_self" title="">
Sports &amp; Recreation
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="Slideshows">
<a href="https://www.orlandoweekly.com/slideshows" target="_self">
Slideshows
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent " id="Support">
<a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" target="_self">
Support
</a>
<div class="fdn-nav-dropdown uk-navbar-dropdown" uk-dropdown="offset: 0;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" target="_self" title="">
Support
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page" target="_self" title="">
Subscribe
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://mediakit.orlandoweekly.com/" target="_blank" title="">
Advertise
</a>
</li>
<li class="fdn-nav-item ">
<a href="http://instagram.com/orlandoweekly/" target="_blank" title="">
Instagram
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://twitter.com/orlandoweekly" target="_blank" title="">
Twitter
</a>
</li>
<li class="fdn-nav-item ">
<a href="https://www.facebook.com/orlandoweekly" target="_blank" title="">
Facebook
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent fdn-nav-login-NavigationHorizontal
fdn-login-loggedout-container" data-view="loggedout" style="display:none">
<a href="#LogIn">
<i class="fas fa-user"></i>
</a>
</li>
<li class="fdn-nav-parent uk-parent fdn-nav-logout-NavigationHorizontal
fdn-login-loggedin-container" data-view="loggedin" style="display: none;">
<a href="#"><i class="fas fa-user"></i></a>
<div class="fdn-nav-dropdown" uk-dropdown="pos:bottom-right;">
<ul class="fdn-nav-list uk-nav uk-navbar-dropdown-nav">
<li class="fdn-nav-item-header">
<span data-label="username">Username</span>
</li>
<li class="fdn-nav-item">
<a href="https://posting.orlandoweekly.com/orlando/MyProfile">
View Profile
</a>
</li>
<li class="fdn-nav-item">
<a href="https://posting.orlandoweekly.com/orlando/Profile/MySettings">
Edit Profile
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/Logout">
Log Out
</a>
</li>
</ul>
</div>
</li>
<li class="fdn-nav-parent uk-parent">
<a><i class="far fa-search fa-flip-horizontal fa-sm"></i></a>
<div id="fdn-NavigationHorizontal-dropdown-hook" uk-dropdown="mode:click,hover;offset:0;pos:bottom-right;" class="GlobalHeader NavigationHorizontalresponsive uk-margin-remove  fdn-site-search-dropdown uk-root fdn-margin-vert NavigationHorizontal comp-shell-navigationhorizontal" data-component-id="NavigationHorizontal">
<form action="https://posting.orlandoweekly.com/orlando/Search">
<div class="fdn-site-search-input-block ">
<div class="uk-search uk-search-default uk-width-1-1">
<span class="fdn-site-search-icon" uk-search-icon></span>
<input class="fdn-site-search-input ev-search-input uk-search-input" name="keywords" placeholder="Enter Keywords..." autocomplete="off" type="search" />
</div>
</div>
<div>
<ul class="fdn-site-search-list uk-nav uk-margin-remove">
<li>
<a class="fdn-site-search-item" href="https://www.orlandoweekly.com/orlando/ArticleArchives">
in Articles &amp; Posts
</a>
</li>
<li>
<a class="fdn-site-search-item" href="https://www.orlandoweekly.com/orlando/LocationSearch">
in Locations
</a>
</li>
<li>
<a class="fdn-site-search-item" href="https://www.orlandoweekly.com/orlando/EventSearch">
in Events
</a>
</li>
<li>
<a class="fdn-site-search-item" href="https://www.orlandoweekly.com/slideshows/">
in Slideshows
</a>
</li>
<li>
<a class="fdn-site-search-item" href="https://posting.orlandoweekly.com/orlando/Search">
All
</a>
</li>
</ul>
</div>
<div class="fdn-site-search-submit-block ">
<button class="uk-button fdn-button-control fdn-site-search-submit">
GO
</button>
</div>
</form>
<script>
jQuery("#fdn-NavigationHorizontal-dropdown-hook")
.on("beforehide", function(){ return !jQuery(".fdn-site-search-input").is(":focus") })
</script>
<script>
(function(){
// 
var componentId = 'NavigationHorizontal'
var defaultSearchUrl = 'https://posting.orlandoweekly.com/orlando/Search'
var componentElement = jQuery('div[data-component-id='+componentId+']')
var searchForm = componentElement.find('form') 
var searchInput = searchForm.find('input')
var searchLinks = searchForm.find('a')
// 
searchForm.submit(function(e){
e.preventDefault()
window.location = defaultSearchUrl + '?keywords=' + searchInput.val() 
})
// 
searchLinks.on('click', function(e){
e.preventDefault()
window.location = jQuery(e.target).attr('href') + '?keywords=' + searchInput.val()
})
// 
jQuery("#fdn-NavigationHorizontal-dropdown-hook")
.on("beforehide", function(){
return !jQuery(this).find(".fdn-site-search-input").is(":focus")
})
})()
</script>
</div>
</li>
</ul>
</nav>
<div id="offcanvas-slide-navigation" uk-offcanvas="overlay: true">
<div id="site-nav-target" class="fdn-nav-panel-block uk-offcanvas-bar">
<ul class="site-nav-source uk-width-1-1 uk-nav uk-nav-parent-icon" uk-nav="multiple: false;">
<li class="fdn-nav-parent uk-parent " id="offcanvas-OrlandoAreaNews">
<a href="https://www.orlandoweekly.com/news" target="_self">
News<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/orlando-area-news-31065036" target="_self" title="">
Orlando Area News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/florida-news-31065043" target="_self" title="">
Florida News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/topic/lgbtq-31060459" target="_self" title="">
LGBTQ+
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/topic/pulse-31060458" target="_self" title="">
Pulse
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/views-opinions-31146339" target="_self" title="">
Views + Opinions
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando-guides" target="_self" title="">
Orlando Guides
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=this%20week" target="_self" title="">
Digital Issue
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/slideshows/?section=2240408" target="_self" title="">
News Slideshows
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-ArtsStoriesInterviews">
<a href="https://www.orlandoweekly.com/arts" target="_self">
Arts + Culture<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/arts-stories-and-interviews-2240434" target="_self" title="">
Arts Stories + Interviews
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/things-to-do-31066175" target="_self" title="">
Things to Do
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/topic/orlando-theme-parks-31060466" target="_self" title="">
Orlando Theme Parks
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/slideshows/?section=2240407" target="_self" title="">
Arts + Culture Slideshows
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-FoodNews">
<a href="https://www.orlandoweekly.com/food-drink" target="_self">
Food + Drink<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/food-news-31065305" target="_self" title="">
Food News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/drinking-bars-31065312" target="_self" title="">
Drinking + Bars
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/restaurant-review-2240450" target="_self" title="">
Restaurant Reviews
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationSection=2282258" target="_self" title="">
Find a Restaurant
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/slideshows/?section=2240409" target="_self" title="">
Food + Drink Slideshows
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-MusicStoriesInterviews">
<a href="https://www.orlandoweekly.com/music" target="_self">
Music<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/music-stories-and-interviews-2240462" target="_self" title="">
Music Stories + Interviews
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/orlando-music-news-31065388" target="_self" title="">
Orlando Music News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/live-music-picks-previews-31065380" target="_self" title="">
Live Music Picks + Previews
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&sortType=date&v=d" target="_self" title="">
Find a Concert
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/slideshows/?section=2240410" target="_self" title="">
Music Slideshows
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-MovieReviews">
<a href="https://www.orlandoweekly.com/movies-tv" target="_self">
Movies<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/movie-reviews-31065358" target="_self" title="">
Movie Reviews
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/streaming-31065342" target="_self" title="">
Streaming
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationCategory=2282370&sortType=name" target="_self" title="">
Find a Theater
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/MovieTimes" target="_self" title="">
Movie Times
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-CannabisNews">
<a href="https://www.orlandoweekly.com/cannabis" target="_self">
Cannabis<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/weed-news-31065403" target="_self" title="">
Cannabis News
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/legislative-updates-31065418" target="_self" title="">
Legislative Updates
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/category/dispensary-directory-31065425" target="_self" title="">
Dispensary Directory
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-OrlandoWeeklyEvents">
<a href="https://www.orlandoweekly.com/orlando/EventSearch" target="_self">
Calendar<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/FreeStuff" target="_self" title="">
Orlando Weekly Events
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&v=d" target="_self" title="">
Today&#39;s Events
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&sortType=date&v=d" target="_self" title="">
This Weekend
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/EventSearch?feature=Free&sortType=date&v=d" target="_self" title="">
Free Events
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/Events/AddEvent" target="_self" title="">
Submit an Event
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-BestOfOrlando2022Ballot">
<a href="https://www.orlandoweekly.com/orlando/BestOf" target="_self">
Best Of Orlando&reg;<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://vote.orlandoweekly.com/" target="_blank" title="">
Best Of Orlando&reg; 2022 Ballot
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/best-of/arts-and-culture" target="_self" title="">
Arts &amp; Culture
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/best-of/food-and-drink" target="_self" title="">
Food &amp; Drink
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/best-of/goods-and-services" target="_self" title="">
Goods &amp; Services
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/best-of/local-color" target="_self" title="">
Local Color
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/best-of/music-and-nightlife" target="_self" title="">
Music &amp; Nightlife
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/best-of/sports-and-recreation" target="_self" title="">
Sports &amp; Recreation
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent " id="offcanvas-Slideshows">
<a href="https://www.orlandoweekly.com/slideshows" target="_self">
Slideshows
</a>
</li>
<li class="fdn-nav-parent uk-parent " id="offcanvas-SupportLocalJournalism">
<a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" target="_self">
Support<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page" target="_self" title="">
Support
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page" target="_self" title="">
Subscribe
</a>
</li>
<li class="fdn-nav-item">
<a href="https://mediakit.orlandoweekly.com/" target="_blank" title="">
Advertise
</a>
</li>
<li class="fdn-nav-item">
<a href="http://instagram.com/orlandoweekly/" target="_blank" title="">
Instagram
</a>
</li>
<li class="fdn-nav-item">
<a href="https://twitter.com/orlandoweekly" target="_blank" title="">
Twitter
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.facebook.com/orlandoweekly" target="_blank" title="">
Facebook
</a>
</li>
</ul>
</li>
<li class="fdn-nav-parent fdn-nav-login-NavigationHorizontal
fdn-login-loggedout-container" data-view="loggedout" style="display:none">
<a href="#LogIn">
<i class="fas fa-user"></i>&nbsp;Log&nbsp;in
</a>
</li>
<li class="fdn-nav-parent uk-parent fdn-nav-logout-NavigationHorizontal
fdn-login-loggedin-container" data-view="loggedin" style="display: none;">
<a href="#">
<span class="uk-text-left" data-label="username">Username</span>
<i class="fas fa-user"></i>
<span uk-icon='chevron-left'></span>
</a>
<ul class="fdn-nav-list uk-nav-sub">
<li class="fdn-nav-item">
<a href="https://posting.orlandoweekly.com/orlando/MyProfile">
View Profile
</a>
</li>
<li class="fdn-nav-item">
<a href="https://posting.orlandoweekly.com/orlando/Profile/MySettings">
Edit Profile
</a>
</li>
<li class="fdn-nav-item">
<a href="https://www.orlandoweekly.com/orlando/Logout">
Log Out
</a>
</li>
</ul>
</li>
</ul>
</div>
</div>
<script>jQuery('body').append(jQuery('#offcanvas-slide-navigation'))</script>
<script> new Foundation.LoginRequiredComponent('#NavigationHorizontal') </script>
</div>
</div>
<div class="uk-hidden@m uk-margin-auto-left uk-margin-auto-vertical fdn-site-header-search-toggle">
<span class="fdn-nav-toggle uk-button" uk-toggle="target: #fdn-SiteSearchModalOnly-modal-hook">
<span class="uk-icon"><i class="fas fa-search fa-2x"></i></span>
</span>
<div class="GlobalHeader SiteSearchModalOnlyShellresponsive   uk-root fdn-margin-vert SiteSearchModalOnly comp-shell-search" data-component-id="SiteSearchModalOnly">
<div id="fdn-SiteSearchModalOnly-modal-hook" class="fdn-site-search-modal" uk-modal="">
<div class="uk-modal-dialog uk-modal-body">
<h2 class="uk-modal-title">Search</h2>
<button class="uk-modal-close uk-modal-close-default" type="button" uk-close></button>
<form action="https://posting.orlandoweekly.com/orlando/Search" class="uk-flex uk-flex-wrap">
<div class="fdn-site-search-modal-input-block uk-width-1-1 uk-flex-none">
<div class="uk-search uk-search-default uk-width-1-1">
<span class="fdn-site-search-modal-icon" uk-search-icon></span>
<input class="fdn-site-search-modal-input ev-search-input uk-search-input" name="keywords" placeholder="Enter Keywords..." autocomplete="off" type="search" />
</div>
</div>
<div class="uk-width-expand">
<ul class="fdn-site-search-modal-list uk-nav uk-margin-remove">
<li>
<a class="fdn-site-search-modal-item" href="https://www.orlandoweekly.com/orlando/ArticleArchives">
in Articles &amp; Posts
</a>
</li>
<li>
<a class="fdn-site-search-modal-item" href="https://www.orlandoweekly.com/orlando/LocationSearch">
in Locations
</a>
</li>
<li>
<a class="fdn-site-search-modal-item" href="https://www.orlandoweekly.com/orlando/EventSearch">
in Events
</a>
</li>
<li>
<a class="fdn-site-search-modal-item" href="https://www.orlandoweekly.com/slideshows/">
in Slideshows
</a>
</li>
<li>
<a class="fdn-site-search-modal-item" href="https://posting.orlandoweekly.com/orlando/Search">
All
</a>
</li>
</ul>
</div>
<div class="fdn-site-search-modal-submit-block uk-margin-auto-left uk-margin-auto-top uk-padding-xsmall-left">
<button class="uk-button fdn-button-control fdn-site-search-modal-submit">
GO
</button>
</div>
</form>
</div>
</div>
<script>
(function(){
// 
var componentId = 'SiteSearchModalOnly'
var defaultSearchUrl = 'https://posting.orlandoweekly.com/orlando/Search'
var componentElement = jQuery('div[data-component-id='+componentId+']')
var searchForm = componentElement.find('form') 
var searchInput = searchForm.find('input')
var searchLinks = searchForm.find('a')
// 
searchForm.submit(function(e){
e.preventDefault()
window.location = defaultSearchUrl + '?keywords=' + searchInput.val() 
})
// 
searchLinks.on('click', function(e){
e.preventDefault()
window.location = jQuery(e.target).attr('href') + '?keywords=' + searchInput.val()
})
// 
jQuery("#fdn-SiteSearchModalOnly-dropdown-hook")
.on("beforehide", function(){
return !jQuery(this).find(".fdn-site-search-input").is(":focus")
})
})()
</script>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="ev-grid-zone ev-primary-zone">
<div class="ev-grid-col fdn-grid-main-single fdn-primary" data-ev-zone="MainTop">
<script>
googletag.cmd.push(function() {
  Foundation.Ad.showReskin('ORL_Reskin-1');
});
</script><div class="uk-width-1-1 uk-flex uk-flex-around uk-margin uk-margin-top" LeaderboardHeader-mobile-stub hidden>
</div>
<div class="ZoneA ContentDefault  uk-inline uk-margin-remove-top uk-root fdn-margin-vert ContentRowMultiple comp-content-contentmultirow" data-component-id="ContentRowMultiple">
<div class="content-multiple-item" fdn-content-multi-item="31820998" fdn-content-multi-item-headline="Mills 50 restaurant King Cajun Crawfish films Orlando woman going on racist rant after she was denied a refund" fdn-content-multi-item-permalink="/food-drink/mills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998" fdn-content-multi-item-canonical="https://www.orlandoweekly.com/food-drink/mills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998" fdn-content-multi-item-title="Mills 50 restaurant King Cajun Crawfish films Orlando woman going on racist rant after she was denied a refund" fdn-content-multi-item-thumb="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31821304/screen_shot_2022-06-15_at_12.55.26_pm.png?cb=1655312163" fdn-content-multi-item-thumb-width="600" fdn-content-multi-item-thumb-height="423" fdn-content-multi-item-index="1" ga-dimension1="content" ga-dimension2="food">
<div>
<div class="uk-position-relative uk-visible-toggle">
<div class="uk-hidden-hover uk-position-top-right uk-padding-xsmall uk-position-absolute">
</div>
<h1 class="fdn-content-headline uk-margin-remove">
Mills 50 restaurant King Cajun Crawfish films Orlando woman going on racist rant after she was denied a refund
</h1>
<div class="uk-flex uk-margin-xsmall-top">
<p class="uk-width-3-5 uk-margin-xsmall-bottom fdn-content-infoline">
<span>By</span>
<a href="https://www.orlandoweekly.com/author/patricia-tolley" rel="author">
Patricia Tolley
</a> on
Wed, Jun 15, 2022 at 12:54 pm
</p>
<div class="uk-flex-1 uk-margin-auto-left uk-margin-xsmall-top">
<div class="uk-width-1-1 uk-flex uk-flex-row uk-flex-middle uk-flex-right uk-grid-small fdn-content-multi-row-share-tools-small " uk-grid>
<div class="" fdn-share-button-news-tip>
<a class="fdn-share-news-tip" href="/cdn-cgi/l/email-protection#aadec3dad9eac5d8c6cbc4cec5ddcfcfc1c6d384c9c5c795d9dfc8c0cfc9de97f9cfc4ce8acb8ae4cfddd98afec3da" uk-tooltip="title:Send a News Tip" aria-expanded="false">
<span class="fdn-share-icon-submit-news-tip">
Send a News Tip
</span>
</a>
</div>
<div fdn-share-button-facebook="">
<a href="https://www.facebook.com/sharer/sharer.php?u=https:%2F%2Fwww.orlandoweekly.com%2Ffood-drink%2Fmills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998&redirect_uri=https:%2F%2Fwww.orlandoweekly.com%2Ffood-drink%2Fmills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998&app_id=1527160917534695" onClick="window.open('https://www.facebook.com/sharer/sharer.php?u=https:%2F%2Fwww.orlandoweekly.com%2Ffood-drink%2Fmills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998&redirect_uri=https:%2F%2Fwww.orlandoweekly.com%2Ffood-drink%2Fmills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998&app_id=1527160917534695','_blank','resizable,height=700,width=600'); return false;" target="_blank" uk-tooltip="title: Share on Facebook" aria-expanded="false">
<span class="uk-icon-button fdn-icon-button-smaller fdn-share-icon-facebook">
<i class="fab fa-facebook-f"></i>
</span>
</a>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script> dnLoadScript("https://platform.twitter.com/widgets.js", true); </script>
<div class="" fdn-share-button-twitter="">
<a href="https://twitter.com/intent/tweet?url=https:%2F%2Fwww.orlandoweekly.com%2Ffood-drink%2Fmills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998&redirect_uri=https:%2F%2Fwww.orlandoweekly.com%2Ffood-drink%2Fmills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998&text=Mills%2050%20restaurant%20King%20Cajun%20Crawfish%20films%20Orlando%20woman%20going%20on%20racist%20rant%20after%20she%20was%20denied%20a%20refund" onClick="window.open('https://twitter.com/intent/tweet?url=https:%2F%2Fwww.orlandoweekly.com%2Ffood-drink%2Fmills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998&redirect_uri=https:%2F%2Fwww.orlandoweekly.com%2Ffood-drink%2Fmills-50-restaurant-king-cajun-crawfish-films-orlando-woman-going-on-racist-rant-after-she-was-denied-a-refund-31820998&text=Mills%2050%20restaurant%20King%20Cajun%20Crawfish%20films%20Orlando%20woman%20going%20on%20racist%20rant%20after%20she%20was%20denied%20a%20refund','_blank','resizable,height=700,width=600'); return false;" uk-tooltip="title: Share on Twitter" aria-expanded="false">
<span class="uk-icon-button fdn-icon-button-smaller fdn-share-icon-twitter">
<i class="fab fa-twitter"></i>
</span>
</a>
</div>
<div class="" fdn-share-button-email="">
<a href="/cdn-cgi/l/email-protection#46793533242c2325327b09342a272822296374761123232d2a3f6375076374760b2f2a2a356374767376637476342335322733342728326374760d2f282163747605272c332863747605342731202f352e637476202f2a2b3563747609342a2728222963747631292b272863747621292f282163747629286374763427252f3532637476342728326374762720322334637476352e236374763127356374762223282f232263747627637476342320332822602429223f7b6376076376070b2f2a2a356374767376637476342335322733342728326374760d2f282163747605272c332863747605342731202f352e637476202f2a2b3563747609342a2728222963747631292b272863747621292f282163747629286374763427252f3532637476342728326374762720322334637476352e236374763127356374762223282f2322637476276374763423203328226376076376072e323236357c69693131316829342a272822293123232d2a3f6825292b69202929226b22342f282d692b2f2a2a356b73766b342335322733342728326b2d2f28216b25272c33286b25342731202f352e6b202f2a2b356b29342a272822296b31292b27286b21292f28216b29286b3427252f35326b342728326b27203223346b352e236b3127356b2223282f23226b276b3423203328226b75777e74767f7f7e637607637607637607" onclick="" uk-tooltip="title: Share via Email" aria-expanded="false" rel="nofollow">
<span class="uk-icon-button fdn-icon-button-smaller fdn-icon-tool-core fdn-share-icon-email">
<i class="fal fa-envelope"></i>
</span>
</a>
</div>
<div class="" fdn-share-button-print>
<a href="https://www.orlandoweekly.com/orlando/Print?oid=31820998" target="_blank" uk-tooltip="title:Print" title="" aria-expanded="false">
<span class="uk-icon-button fdn-icon-button-smaller fdn-icon-tool-core fdn-share-icon-email">
<i class="fal fa-print"></i>
</span>
</a>
</div>
<div class="" fdn-share-button-text-size>
<a class="fdn-text-size-toggle" href="#size" uk-tooltip="title:Change Font Size" aria-expanded="false" uk-toggle="target: .fdn-content-body;cls: fdn-content-body-large;">
<span class="uk-icon-button fdn-icon-button-smaller fdn-icon-tool-core fdn-share-icon-email">
<i class="fas fa-text-size"></i>
</span>
</a>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="uk-width-1-1 uk-flex uk-flex-row">
<div class="uk-width-expand uk-flex uk-flex-column" main-column>
<div class="uk-width-1-1 uk-flex uk-flex-row">
<div class="uk-width-expand fdn-content-multi-row show-first-image">
<pre debug hidden>[
      {
        "name": "Ad - NativeInline - Injected",
        "component": "31267952",
        "insertPoint": "3",
        "requiredCountToDisplay": "5"
      },{
        "name": "Real 1 Player (r2) - Inline",
        "component": "31267951",
        "insertPoint": "2/3",
        "requiredCountToDisplay": "9"
      }
    ]</pre>
<div class="ZoneA ContentDefault   uk-root fdn-margin-vert ContentRowMultiple comp-content-contentmultirow" data-component-id="ContentRowMultiple">
<div class="fdn-content-body">
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CewcubmpqOH/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="14" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:960px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CewcubmpqOH/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> <div style=" display: flex; flex-direction: row; align-items: center;"> <div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div> <div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"> <div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div> <div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div> <div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"> <div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div> <div style=" width: 0; height: ; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"> <div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div> <div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div> <div style=" width: 0; height: ; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div></div></a><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/p/CewcubmpqOH/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by King Cajun Orlando Mills50 (@officialkingcajun)</a></p></div></blockquote> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//www.instagram.com/embed.js"></script>
<p>
The staff at King Cajun in Mills 50 had to listen to an Orlando woman spew racist remarks after she was denied a refund on Tuesday.
</p>
<p>
“You're a Chinese bitch,” the woman said to King Cajun Manager Kristen Nguyen in a video shared to Instagram. “Take your ass back to your country.”<br>
</p>
<p>
The incident started when the woman said her shrimp was spoiled, so she wanted a refund. After Nguyen determined the shrimp was fine and denied the refund, the women started making racial comments, according to the post.<br>
<br>
"At the end of the meal to pay, she said the shrimp was spoiled (it wasn’t) and she ate 3," King Cajun shared on social media. "We said sorry we cannot refund it and she started saying racist remarks."
</p>
<p>
As you might expect of a racist, the woman's remarks were ill-informed. The Vietnamese-American Nguyen was born in the United States. The restaurant also noted that the woman took her supposedly spoiled food with her in a to-go container.
</p>
King Cajun claimed that the woman was a small business owner in Orlando, making her actions toward another business all the more remarkable. <span style="font-family: Lato, Helvetica, Arial, sans-serif; font-size: 1.1rem;">This incident is merely the latest example of a rise in anti-Asian rhetoric and hatred, spurred in part by the coronavirus pandemic.</span>
<p>
The Center for the Study of Hate and Extremism <a href="https://www.nbcnews.com/news/asian-america/anti-asian-hate-crimes-increased-339-percent-nationwide-last-year-repo-rcna14282" target="_blank">released a repor</a>t earlier this year showing that anti-Asian hate crimes increased by 339% in 2021 when compared to the year prior.
</p>
<p>
The Orange County Sheriff’s department<a href="https://www.wftv.com/news/local/sheriffs-program-aims-strengthen-orange-countys-asian-community/PW5WQJD22VGNFCUEJAORFUVOBE/" target="_blank"> recently</a> started an Asian American and Pacific Islander Liaison program to address this rise in AAPI hate crimes. A deputy was sent to the restaurant to discuss what happened on Tuesday evening.
</p>
<p></p>
</div>
<script>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</script>
<script>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</script>
<script>
        jQuery(function () {
          Foundation.Content['31820998'].setupInlineComponents();
        });
        </script>
</div>
</div>
</div>
<div class="uk-width-1-1">
<div class="ZoneA SiteSearchTagsresponsive   uk-root fdn-margin-vert SiteSearchTags comp-sitesearch-tags" data-component-id="SiteSearchTags">
<div class="uk-flex uk-flex-row">
<h3 class="fdn-link-tag-title fdn-line-height-med uk-flex-top uk-flex-none uk-margin-xsmall-right uk-margin-remove-bottom">
Tags:
</h3>
<ul class="uk-list uk-margin-remove uk-flex-1 fdn-line-height-small">
<li class="uk-text-nowrap fdn-line-height-med uk-inline uk-margin-remove-top fdn-link-tag">
<a href="https://posting.orlandoweekly.com/orlando/Search?tag=King%20Cajun">King Cajun</a>,
</li>
<li class="uk-text-nowrap fdn-line-height-med uk-inline uk-margin-remove-top fdn-link-tag">
<a href="https://posting.orlandoweekly.com/orlando/Search?tag=Mills%2050">Mills 50</a>,
</li>
<li class="uk-text-nowrap fdn-line-height-med uk-inline uk-margin-remove-top fdn-link-tag">
<a href="https://posting.orlandoweekly.com/orlando/Search?tag=racism">racism</a>,
</li>
<li class="uk-text-nowrap fdn-line-height-med uk-inline uk-margin-remove-top fdn-link-tag">
<a href="https://posting.orlandoweekly.com/orlando/Search?tag=Orlando">Orlando</a>,
</li>
<li class="uk-text-nowrap fdn-line-height-med uk-inline uk-margin-remove-top fdn-link-tag">
<a href="https://posting.orlandoweekly.com/orlando/Search?tag=hate%20crimes">hate crimes</a>,
</li>
<li class="uk-text-nowrap fdn-line-height-med uk-inline uk-margin-remove-top fdn-link-tag">
<a href="https://posting.orlandoweekly.com/orlando/Search?tag=Instagram">Instagram</a>
</li>
</ul>
</div>
</div>
<div class="ZoneA Scrolldowntoreadmorearticlesresponsive   uk-root fdn-margin-vert Scrolldowntoreadmorearticles comp-" data-component-id="Scrolldowntoreadmorearticles">
Scroll to read more Food News articles
</div>
<div ad-slot-div-id="ORL_NativeEndOfArticle" display-targets="all" class="uk-width-1-1 uk-flex uk-flex-around uk-margin" ad-deferred hidden>
<script>
        // Define the slot
        googletag.cmd.push(function() {
          const currentElement = jQuery('[ad-slot-div-id="ORL_NativeEndOfArticle"]').first();
          const adTemplateId = currentElement.attr('ad-slot-div-id');
          const adTemplateItem = Foundation.Ad.getSlotConfigTemplate(adTemplateId);
          const generatedDivId = Foundation.Ad.generateDivIdFromSlotConfigPresets(adTemplateId);

          currentElement.attr('ad-slot-div-id', generatedDivId);
          currentElement.attr('id', generatedDivId);

          // console.info(`[FdnAd] adTemplateId: ${adTemplateId}, generatedDivId: ${generatedDivId}, currentDivId: ${currentElement.attr('ad-slot-div-id')}`);
          // console.info(`[FdnAd] adTemplateItem && generatedDivId ${adTemplateItem !== null && generatedDivId !== null} ${adTemplateItem} ${generatedDivId}`);


          if (adTemplateItem !== null && generatedDivId !== null) {
            if (adTemplateItem.type.match(/display|native/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineSlot(adTemplateItem.adUnit, adTemplateItem.sizes, generatedDivId)
            }
            else if (adTemplateItem.type.match(/outofpage/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineOutOfPageSlot(adTemplateItem.adUnit, generatedDivId)
            }

            if (adTemplateItem.targeting) {
              adTemplateItem.targeting.forEach(function (target, index) {
                Foundation.Ad.slots[generatedDivId].setTargeting(target.key, target.value)
              })
            }

            Foundation.Ad.slots[generatedDivId].addService(googletag.pubads())

            if (adTemplateItem.sizeMap) {
              Foundation.Ad.slots[generatedDivId].defineSizeMapping(Foundation.Ad.CreateSizeMapping(adTemplateItem.sizeMap))
            }
            Foundation.Ad.slots[generatedDivId].slotLoaded = false
          }

          Foundation.Ad.showAd(currentElement);
        });
        </script>
</div><div class="ZoneA DonationEndofArticleWidgetresponsive   uk-root fdn-margin-vert DonationArticleWidget comp-" data-component-id="DonationArticleWidget">
<center>
<big><b>Join the <i>Orlando Weekly</i> Press Club</b></big><br><br>
Local journalism is information. Information is power. And we believe <b>everyone</b> deserves access to accurate independent coverage of their community and state.<br>
<b><a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page">Help us keep this coverage going with a one-time donation or an ongoing membership pledge.</a></b><br>
</center>
</div>
</div>
</div>
<div class="uk-width-auto uk-visible@sm uk-margin-left" style="width: 300px;" distribute-right-column-items>
<div class="stickCeption" style="z-index: 1;" uk-sticky="
         offset: 140;
         bottom: true;">
<div class="ZoneA TrendingContentAllSectionsresponsive  trending-by-day uk-root fdn-margin-vert TrendingContentAllSections comp-landing-trending" data-component-id="TrendingContentAllSections">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Trending
</h3>
</div>
<ul class="pres-ContentListSquareBrief uk-list uk-list-divider">
<li class="">
<div class="uk-flex">
<div class="uk-flex-1 uk-margin-remove">
<a href="https://www.orlandoweekly.com/news/donald-trump-reportedly-planning-presidential-campaign-launch-in-tallahassee-to-spite-florida-gov-ron-desantis-31812244">
<p class="fdn-teaser-headline">
Donald Trump reportedly planning presidential campaign launch in Tallahassee to spite Florida Gov. Ron DeSantis
</p>
</a>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Alex Galbraith
</p>
<time>
Jun 14, 2022
</time>
</div>
</div>
<div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
<a href="https://www.orlandoweekly.com/news/donald-trump-reportedly-planning-presidential-campaign-launch-in-tallahassee-to-spite-florida-gov-ron-desantis-31812244">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/r-bigsquare/31813163/trump.jpg?cb=1655223062" alt="Donald Trump reportedly planning presidential campaign launch in Tallahassee to spite Florida Gov. Ron DeSantis" width="400" height="400" class="" />
</a>
</div>
</div>
</li>
<li class="">
<div class="uk-flex">
<div class="uk-flex-1 uk-margin-remove">
<a href="https://www.orlandoweekly.com/news/orange-county-medical-examiner-releases-autopsy-of-tyre-sampson-who-fell-from-icon-parks-orlando-freefall-31812237">
<p class="fdn-teaser-headline">
Orange County Medical Examiner releases autopsy of Tyre Sampson, who fell from Icon Park's Orlando Freefall
</p>
</a>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Alex Galbraith
</p>
<time>
Jun 14, 2022
</time>
</div>
</div>
<div class="fdn-pres-image uk-width-1-3 uk-width-1-4@exs uk-flex-first">
<a href="https://www.orlandoweekly.com/news/orange-county-medical-examiner-releases-autopsy-of-tyre-sampson-who-fell-from-icon-parks-orlando-freefall-31812237">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/r-bigsquare/31812829/screen_shot_2022-03-28_at_10.37.48_am.png?cb=1655219201" alt="Orange County Medical Examiner releases autopsy of Tyre Sampson, who fell from Icon Park&#39;s Orlando Freefall" width="400" height="400" class="" />
</a>
</div>
</div>
</li>
</ul>
</div>
<div ad-slot-div-id="ORL_TowerATF" display-targets="all" class="uk-width-1-1 uk-flex uk-flex-around uk-margin" ad-deferred hidden>
<script>
        // Define the slot
        googletag.cmd.push(function() {
          const currentElement = jQuery('[ad-slot-div-id="ORL_TowerATF"]').first();
          const adTemplateId = currentElement.attr('ad-slot-div-id');
          const adTemplateItem = Foundation.Ad.getSlotConfigTemplate(adTemplateId);
          const generatedDivId = Foundation.Ad.generateDivIdFromSlotConfigPresets(adTemplateId);

          currentElement.attr('ad-slot-div-id', generatedDivId);
          currentElement.attr('id', generatedDivId);

          // console.info(`[FdnAd] adTemplateId: ${adTemplateId}, generatedDivId: ${generatedDivId}, currentDivId: ${currentElement.attr('ad-slot-div-id')}`);
          // console.info(`[FdnAd] adTemplateItem && generatedDivId ${adTemplateItem !== null && generatedDivId !== null} ${adTemplateItem} ${generatedDivId}`);


          if (adTemplateItem !== null && generatedDivId !== null) {
            if (adTemplateItem.type.match(/display|native/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineSlot(adTemplateItem.adUnit, adTemplateItem.sizes, generatedDivId)
            }
            else if (adTemplateItem.type.match(/outofpage/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineOutOfPageSlot(adTemplateItem.adUnit, generatedDivId)
            }

            if (adTemplateItem.targeting) {
              adTemplateItem.targeting.forEach(function (target, index) {
                Foundation.Ad.slots[generatedDivId].setTargeting(target.key, target.value)
              })
            }

            Foundation.Ad.slots[generatedDivId].addService(googletag.pubads())

            if (adTemplateItem.sizeMap) {
              Foundation.Ad.slots[generatedDivId].defineSizeMapping(Foundation.Ad.CreateSizeMapping(adTemplateItem.sizeMap))
            }
            Foundation.Ad.slots[generatedDivId].slotLoaded = false
          }

          Foundation.Ad.showAd(currentElement);
        });
        </script>
</div>
<div class="ZoneA NewsletterSignupresponsive   uk-root fdn-margin-vert NewsletterSignup comp-landing-newslettersignup" data-component-id="NewsletterSignup">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Newsletters
</h3>
</div>
<h4 class="uk-margin-remove-top uk-margin-small-bottom uk-text-bold">Join Orlando Weekly Newsletters</h4>
<p class="uk-margin-remove">Subscribe now to get the latest news delivered right to your inbox.</p>
<div class="uk-text-center">
<a class="uk-flex-inline uk-flex-center uk-flex-middle uk-button fdn-button-control uk-margin-small-top" href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page">
<i class="fal fa-newspaper"></i> <span class="uk-margin-xsmall-left">Sign Up Now</span>
</a>
</div>
</div>
<div ad-slot-div-id="ORL_300x250" display-targets="all" class="uk-width-1-1 uk-flex uk-flex-around uk-margin" ad-deferred hidden>
<script>
        // Define the slot
        googletag.cmd.push(function() {
          const currentElement = jQuery('[ad-slot-div-id="ORL_300x250"]').first();
          const adTemplateId = currentElement.attr('ad-slot-div-id');
          const adTemplateItem = Foundation.Ad.getSlotConfigTemplate(adTemplateId);
          const generatedDivId = Foundation.Ad.generateDivIdFromSlotConfigPresets(adTemplateId);

          currentElement.attr('ad-slot-div-id', generatedDivId);
          currentElement.attr('id', generatedDivId);

          // console.info(`[FdnAd] adTemplateId: ${adTemplateId}, generatedDivId: ${generatedDivId}, currentDivId: ${currentElement.attr('ad-slot-div-id')}`);
          // console.info(`[FdnAd] adTemplateItem && generatedDivId ${adTemplateItem !== null && generatedDivId !== null} ${adTemplateItem} ${generatedDivId}`);


          if (adTemplateItem !== null && generatedDivId !== null) {
            if (adTemplateItem.type.match(/display|native/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineSlot(adTemplateItem.adUnit, adTemplateItem.sizes, generatedDivId)
            }
            else if (adTemplateItem.type.match(/outofpage/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineOutOfPageSlot(adTemplateItem.adUnit, generatedDivId)
            }

            if (adTemplateItem.targeting) {
              adTemplateItem.targeting.forEach(function (target, index) {
                Foundation.Ad.slots[generatedDivId].setTargeting(target.key, target.value)
              })
            }

            Foundation.Ad.slots[generatedDivId].addService(googletag.pubads())

            if (adTemplateItem.sizeMap) {
              Foundation.Ad.slots[generatedDivId].defineSizeMapping(Foundation.Ad.CreateSizeMapping(adTemplateItem.sizeMap))
            }
            Foundation.Ad.slots[generatedDivId].slotLoaded = false
          }

          Foundation.Ad.showAd(currentElement);
        });
        </script>
</div>
</div>
</div>
</div>
</div>
<div class="ZoneA SlideshowTeaserStripresponsive   uk-root fdn-margin-vert SlideshowTeaserStrip comp-landing-slideshows" data-component-id="SlideshowTeaserStrip">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Food + Drink Slideshows
</h3>
</div>
<div class="uk-flex uk-flex-wrap uk-child-width-1-2 uk-child-width-1-2@s uk-child-width-1-4@m">
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/here-are-all-the-menus-for-orlandos-bite30-2022/Slideshow/31741801">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31741871/screen_shot_2022-06-01_at_10.47.52_am.png?cb=1654349701" alt="Here are all the menus for Orlando&#39;s Bite30 2022" width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">Here are all the menus for Orlando's Bite30 2022</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/orlando-celebrated-stars-and-suds-at-beer-merica-this-weekend/Slideshow/31606979">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31607064/img_9607.jpg?cb=1652729258" alt="Orlando celebrated stars and suds at Beer &#39;Merica this weekend" width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">Orlando celebrated stars and suds at Beer 'Merica this weekend</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/20-essential-orlando-brunch-spots-serving-bottomless-mimosas/Slideshow/30945210">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/golden-s/30847675/310-restaurants-sandra-l..jpg?cb=1651933360" alt="310 Restaurants  
    Multiple locations
    
    This Orlando chain offers American-style cuisine at several locations. Brunch times and bottomless mimosa prices vary per location, so make sure to call ahead.
    
    
     Photo via Yelp/Sandra I." width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">18 essential Orlando brunch spots serving bottomless mimosas</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/the-essential-winter-garden-restaurants-everyone-should-try/Slideshow/31499275">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/golden-s/31499281/screen_shot_2022-05-01_at_9.43.18_am.png?cb=1651419075" alt="Harrell&rsquo;s Hot Dogs and Cold Cones

54 W. Plant St., Winter Garden, 407-554-2021

Harrell&rsquo;s is the perfect spot for classic and inventive hot dogs. You can build your own hotdog by choosing the type of bun, meat and toppings." width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">The essential Winter Garden restaurants that everyone should try</h3>
</a>
</div>
</div>
</div>
<div ad-slot-div-id="ORL_Billboard" display-targets="all" class="uk-width-1-1 uk-flex uk-flex-around uk-margin-top uk-margin-bottom" ad-deferred hidden>
<script>
        // Define the slot
        googletag.cmd.push(function() {
          const currentElement = jQuery('[ad-slot-div-id="ORL_Billboard"]').first();
          const adTemplateId = currentElement.attr('ad-slot-div-id');
          const adTemplateItem = Foundation.Ad.getSlotConfigTemplate(adTemplateId);
          const generatedDivId = Foundation.Ad.generateDivIdFromSlotConfigPresets(adTemplateId);

          currentElement.attr('ad-slot-div-id', generatedDivId);
          currentElement.attr('id', generatedDivId);

          // console.info(`[FdnAd] adTemplateId: ${adTemplateId}, generatedDivId: ${generatedDivId}, currentDivId: ${currentElement.attr('ad-slot-div-id')}`);
          // console.info(`[FdnAd] adTemplateItem && generatedDivId ${adTemplateItem !== null && generatedDivId !== null} ${adTemplateItem} ${generatedDivId}`);


          if (adTemplateItem !== null && generatedDivId !== null) {
            if (adTemplateItem.type.match(/display|native/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineSlot(adTemplateItem.adUnit, adTemplateItem.sizes, generatedDivId)
            }
            else if (adTemplateItem.type.match(/outofpage/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineOutOfPageSlot(adTemplateItem.adUnit, generatedDivId)
            }

            if (adTemplateItem.targeting) {
              adTemplateItem.targeting.forEach(function (target, index) {
                Foundation.Ad.slots[generatedDivId].setTargeting(target.key, target.value)
              })
            }

            Foundation.Ad.slots[generatedDivId].addService(googletag.pubads())

            if (adTemplateItem.sizeMap) {
              Foundation.Ad.slots[generatedDivId].defineSizeMapping(Foundation.Ad.CreateSizeMapping(adTemplateItem.sizeMap))
            }
            Foundation.Ad.slots[generatedDivId].slotLoaded = false
          }

          Foundation.Ad.showAd(currentElement);
        });
        </script>
</div>
<div class="content-multiple-item" fdn-content-multi-item="31778348" fdn-content-multi-item-headline="The Michelin Guide handed out its stars tonight. Here are the Florida restaurants that earned them" fdn-content-multi-item-permalink="/food-drink/the-michelin-guide-handed-out-its-stars-tonight-here-are-the-florida-restaurants-that-earned-them-31778348" fdn-content-multi-item-canonical="https://www.orlandoweekly.com/food-drink/the-michelin-guide-handed-out-its-stars-tonight-here-are-the-florida-restaurants-that-earned-them-31778348" fdn-content-multi-item-title="The Michelin Guide handed out its stars tonight. Here are the Florida restaurants that earned them" fdn-content-multi-item-thumb="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31780948/resized_20220609_201825.jpeg?cb=1654823318" fdn-content-multi-item-thumb-width="600" fdn-content-multi-item-thumb-height="389" fdn-content-multi-item-index="2" ga-dimension1="content" ga-dimension2="food" fdn-content-multi-item-loader="fetch">
</div>
<div class="ZoneA SlideshowTeaserStripresponsive   uk-root fdn-margin-vert SlideshowTeaserStrip comp-landing-slideshows" data-component-id="SlideshowTeaserStrip">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Food + Drink Slideshows
</h3>
</div>
<div class="uk-flex uk-flex-wrap uk-child-width-1-2 uk-child-width-1-2@s uk-child-width-1-4@m">
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/here-are-all-the-menus-for-orlandos-bite30-2022/Slideshow/31741801">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31741871/screen_shot_2022-06-01_at_10.47.52_am.png?cb=1654349701" alt="Here are all the menus for Orlando&#39;s Bite30 2022" width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">Here are all the menus for Orlando's Bite30 2022</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/orlando-celebrated-stars-and-suds-at-beer-merica-this-weekend/Slideshow/31606979">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31607064/img_9607.jpg?cb=1652729258" alt="Orlando celebrated stars and suds at Beer &#39;Merica this weekend" width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">Orlando celebrated stars and suds at Beer 'Merica this weekend</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/20-essential-orlando-brunch-spots-serving-bottomless-mimosas/Slideshow/30945210">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/golden-s/30847675/310-restaurants-sandra-l..jpg?cb=1651933360" alt="310 Restaurants  
    Multiple locations
    
    This Orlando chain offers American-style cuisine at several locations. Brunch times and bottomless mimosa prices vary per location, so make sure to call ahead.
    
    
     Photo via Yelp/Sandra I." width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">18 essential Orlando brunch spots serving bottomless mimosas</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/the-essential-winter-garden-restaurants-everyone-should-try/Slideshow/31499275">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/golden-s/31499281/screen_shot_2022-05-01_at_9.43.18_am.png?cb=1651419075" alt="Harrell&rsquo;s Hot Dogs and Cold Cones

54 W. Plant St., Winter Garden, 407-554-2021

Harrell&rsquo;s is the perfect spot for classic and inventive hot dogs. You can build your own hotdog by choosing the type of bun, meat and toppings." width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">The essential Winter Garden restaurants that everyone should try</h3>
</a>
</div>
</div>
</div>
<div ad-slot-div-id="ORL_Billboard" display-targets="all" class="uk-width-1-1 uk-flex uk-flex-around uk-margin-top uk-margin-bottom" ad-deferred hidden>
<script>
        // Define the slot
        googletag.cmd.push(function() {
          const currentElement = jQuery('[ad-slot-div-id="ORL_Billboard"]').first();
          const adTemplateId = currentElement.attr('ad-slot-div-id');
          const adTemplateItem = Foundation.Ad.getSlotConfigTemplate(adTemplateId);
          const generatedDivId = Foundation.Ad.generateDivIdFromSlotConfigPresets(adTemplateId);

          currentElement.attr('ad-slot-div-id', generatedDivId);
          currentElement.attr('id', generatedDivId);

          // console.info(`[FdnAd] adTemplateId: ${adTemplateId}, generatedDivId: ${generatedDivId}, currentDivId: ${currentElement.attr('ad-slot-div-id')}`);
          // console.info(`[FdnAd] adTemplateItem && generatedDivId ${adTemplateItem !== null && generatedDivId !== null} ${adTemplateItem} ${generatedDivId}`);


          if (adTemplateItem !== null && generatedDivId !== null) {
            if (adTemplateItem.type.match(/display|native/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineSlot(adTemplateItem.adUnit, adTemplateItem.sizes, generatedDivId)
            }
            else if (adTemplateItem.type.match(/outofpage/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineOutOfPageSlot(adTemplateItem.adUnit, generatedDivId)
            }

            if (adTemplateItem.targeting) {
              adTemplateItem.targeting.forEach(function (target, index) {
                Foundation.Ad.slots[generatedDivId].setTargeting(target.key, target.value)
              })
            }

            Foundation.Ad.slots[generatedDivId].addService(googletag.pubads())

            if (adTemplateItem.sizeMap) {
              Foundation.Ad.slots[generatedDivId].defineSizeMapping(Foundation.Ad.CreateSizeMapping(adTemplateItem.sizeMap))
            }
            Foundation.Ad.slots[generatedDivId].slotLoaded = false
          }

          Foundation.Ad.showAd(currentElement);
        });
        </script>
</div>
<div class="content-multiple-item" fdn-content-multi-item="31778963" fdn-content-multi-item-headline="Michelin inspectors in Florida: One Orlando chef on the angst of waiting for external validation" fdn-content-multi-item-permalink="/food-drink/michelin-inspectors-in-florida-one-orlando-chef-on-the-angst-of-waiting-for-external-validation-31778963" fdn-content-multi-item-canonical="https://www.orlandoweekly.com/food-drink/michelin-inspectors-in-florida-one-orlando-chef-on-the-angst-of-waiting-for-external-validation-31778963" fdn-content-multi-item-title="Michelin inspectors in Florida: One Orlando chef on the angst of waiting for external validation" fdn-content-multi-item-thumb="https://media2.orlandoweekly.com/orlando/imager/u/slideshow/31779244/eliot-hollis-8.jpg?cb=1654803220" fdn-content-multi-item-thumb-width="600" fdn-content-multi-item-thumb-height="400" fdn-content-multi-item-index="3" ga-dimension1="content" ga-dimension2="food" fdn-content-multi-item-loader="fetch">
</div>
<div class="ZoneA SlideshowTeaserStripresponsive   uk-root fdn-margin-vert SlideshowTeaserStrip comp-landing-slideshows" data-component-id="SlideshowTeaserStrip">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Food + Drink Slideshows
</h3>
</div>
<div class="uk-flex uk-flex-wrap uk-child-width-1-2 uk-child-width-1-2@s uk-child-width-1-4@m">
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/here-are-all-the-menus-for-orlandos-bite30-2022/Slideshow/31741801">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31741871/screen_shot_2022-06-01_at_10.47.52_am.png?cb=1654349701" alt="Here are all the menus for Orlando&#39;s Bite30 2022" width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">Here are all the menus for Orlando's Bite30 2022</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/orlando-celebrated-stars-and-suds-at-beer-merica-this-weekend/Slideshow/31606979">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31607064/img_9607.jpg?cb=1652729258" alt="Orlando celebrated stars and suds at Beer &#39;Merica this weekend" width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">Orlando celebrated stars and suds at Beer 'Merica this weekend</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/20-essential-orlando-brunch-spots-serving-bottomless-mimosas/Slideshow/30945210">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/golden-s/30847675/310-restaurants-sandra-l..jpg?cb=1651933360" alt="310 Restaurants  
    Multiple locations
    
    This Orlando chain offers American-style cuisine at several locations. Brunch times and bottomless mimosa prices vary per location, so make sure to call ahead.
    
    
     Photo via Yelp/Sandra I." width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">18 essential Orlando brunch spots serving bottomless mimosas</h3>
</a>
</div>
<div class="uk-padding-xsmall fdn-slideshow-teaser">
<a href="https://www.orlandoweekly.com/orlando/the-essential-winter-garden-restaurants-everyone-should-try/Slideshow/31499275">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/golden-s/31499281/screen_shot_2022-05-01_at_9.43.18_am.png?cb=1651419075" alt="Harrell&rsquo;s Hot Dogs and Cold Cones

54 W. Plant St., Winter Garden, 407-554-2021

Harrell&rsquo;s is the perfect spot for classic and inventive hot dogs. You can build your own hotdog by choosing the type of bun, meat and toppings." width="600" height="371" class="" />
<h3 class="fdn-teaser-headline">The essential Winter Garden restaurants that everyone should try</h3>
</a>
</div>
</div>
</div>
<div ad-slot-div-id="ORL_Billboard" display-targets="all" class="uk-width-1-1 uk-flex uk-flex-around uk-margin-top uk-margin-bottom" ad-deferred hidden>
<script>
        // Define the slot
        googletag.cmd.push(function() {
          const currentElement = jQuery('[ad-slot-div-id="ORL_Billboard"]').first();
          const adTemplateId = currentElement.attr('ad-slot-div-id');
          const adTemplateItem = Foundation.Ad.getSlotConfigTemplate(adTemplateId);
          const generatedDivId = Foundation.Ad.generateDivIdFromSlotConfigPresets(adTemplateId);

          currentElement.attr('ad-slot-div-id', generatedDivId);
          currentElement.attr('id', generatedDivId);

          // console.info(`[FdnAd] adTemplateId: ${adTemplateId}, generatedDivId: ${generatedDivId}, currentDivId: ${currentElement.attr('ad-slot-div-id')}`);
          // console.info(`[FdnAd] adTemplateItem && generatedDivId ${adTemplateItem !== null && generatedDivId !== null} ${adTemplateItem} ${generatedDivId}`);


          if (adTemplateItem !== null && generatedDivId !== null) {
            if (adTemplateItem.type.match(/display|native/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineSlot(adTemplateItem.adUnit, adTemplateItem.sizes, generatedDivId)
            }
            else if (adTemplateItem.type.match(/outofpage/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineOutOfPageSlot(adTemplateItem.adUnit, generatedDivId)
            }

            if (adTemplateItem.targeting) {
              adTemplateItem.targeting.forEach(function (target, index) {
                Foundation.Ad.slots[generatedDivId].setTargeting(target.key, target.value)
              })
            }

            Foundation.Ad.slots[generatedDivId].addService(googletag.pubads())

            if (adTemplateItem.sizeMap) {
              Foundation.Ad.slots[generatedDivId].defineSizeMapping(Foundation.Ad.CreateSizeMapping(adTemplateItem.sizeMap))
            }
            Foundation.Ad.slots[generatedDivId].slotLoaded = false
          }

          Foundation.Ad.showAd(currentElement);
        });
        </script>
</div>
<script>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</script>
</div>
<div class="ZoneA ContentDefault  trending-by-day uk-root fdn-margin-vert TrendingContentHome comp-landing-trending" data-component-id="TrendingContentHome">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Trending
</h3>
</div>
<div class="pres-ContentTileRectangleBriefVariableAcross uk-grid uk-grid-small" uk-grid="true" data-ev-presentation="ContentTileRectangleBriefVariableAcross" uk-height-match=".fdn-pres-image">
<div class="uk-width-1-2@s uk-width-1-4@m">
<a class="uk-flex uk-flex-column fdn-decoration-remove" href="https://www.orlandoweekly.com/food-drink/the-michelin-guide-handed-out-its-stars-tonight-here-are-the-florida-restaurants-that-earned-them-31778348">
<div>
<p class="fdn-teaser-headline">
The Michelin Guide handed out its stars tonight. Here are the Florida restaurants that earned them
</p>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Faiyaz Kara
</p>
<time>
Jun 9, 2022
</time>
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31780948/resized_20220609_201825.jpeg?cb=1654823318" alt="Happy starry chefs." width="600" height="371" class="" />
</div>
</a>
</div>
<div class="uk-width-1-2@s uk-width-1-4@m">
<a class="uk-flex uk-flex-column fdn-decoration-remove" href="https://www.orlandoweekly.com/food-drink/global-korean-fried-chicken-chain-bbq-chicken-lures-the-orlandos-fowl-mouthed-to-mills-50-31765777">
<div>
<p class="fdn-teaser-headline">
Global Korean fried chicken chain Bb.q Chicken lures Orlando's fowl-mouthed to Mills 50
</p>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Faiyaz Kara
</p>
<time>
Jun 8, 2022
</time>
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31765781/bbq.-chicken-1.jpg?cb=1655218896" alt="Global Korean fried chicken chain Bb.q Chicken lures the Orlando&#39;s fowl-mouthed to Mills 50" width="600" height="371" class="" />
</div>
</a>
</div>
<div class="uk-width-1-2@s uk-width-1-4@m">
<a class="uk-flex uk-flex-column fdn-decoration-remove" href="https://www.orlandoweekly.com/food-drink/orlando-gets-outposts-of-cruncheese-korean-hot-dogs-daves-hot-chicken-stuff-a-bagel-juan-valdez-cafe-and-i-heart-mac-and-cheese-31765785">
<div>
<p class="fdn-teaser-headline">
Orlando gets outposts of CrunCheese Korean Hot Dogs, Dave's Hot Chicken, Stuff-A-Bagel, Juan Valdez Cafe and I Heart Mac and Cheese
</p>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Faiyaz Kara
</p>
<time>
Jun 8, 2022
</time>
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/golden-s/31765783/cruncheese-dogs-about-00.jpeg?cb=1654649548" alt="CrunCheese Korean Hot Dogs opens this summer at Waterford Lakes Town Center" width="600" height="371" class="" />
</div>
</a>
</div>
<div class="uk-width-1-2@s uk-width-1-4@m">
<a class="uk-flex uk-flex-column fdn-decoration-remove" href="https://www.orlandoweekly.com/food-drink/the-michelin-guide-is-coming-to-florida-should-orlando-care-31762901">
<div>
<p class="fdn-teaser-headline">
So the Michelin Guide came to Florida, bestowing stars, Bib Gourmands and recommendations.
</p>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Faiyaz Kara
</p>
<time>
Jun 7, 2022
</time>
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/golden-s/31816212/knife_fork_2_web.jpg?cb=1655261176" alt="Knife &amp; Spoon at the Ritz-Carlton Orlando is one of four Orlando restaurants to receive a Michelin star." width="600" height="371" class="" />
</div>
</a>
</div>
</div>
</div>
<div class="componentGrid-ThreeAcross uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-component-grid-row@m" uk-height-match data-component-grid-id="ContentFooterTriplet">
<div class="uk-width-1-1 uk-width-1-3@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<div ad-slot-div-id="ORL_TowerAfterInfinite" display-targets="all" class="uk-width-1-1 uk-flex uk-flex-around uk-margin" ad-deferred hidden>
<script>
        // Define the slot
        googletag.cmd.push(function() {
          const currentElement = jQuery('[ad-slot-div-id="ORL_TowerAfterInfinite"]').first();
          const adTemplateId = currentElement.attr('ad-slot-div-id');
          const adTemplateItem = Foundation.Ad.getSlotConfigTemplate(adTemplateId);
          const generatedDivId = Foundation.Ad.generateDivIdFromSlotConfigPresets(adTemplateId);

          currentElement.attr('ad-slot-div-id', generatedDivId);
          currentElement.attr('id', generatedDivId);

          // console.info(`[FdnAd] adTemplateId: ${adTemplateId}, generatedDivId: ${generatedDivId}, currentDivId: ${currentElement.attr('ad-slot-div-id')}`);
          // console.info(`[FdnAd] adTemplateItem && generatedDivId ${adTemplateItem !== null && generatedDivId !== null} ${adTemplateItem} ${generatedDivId}`);


          if (adTemplateItem !== null && generatedDivId !== null) {
            if (adTemplateItem.type.match(/display|native/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineSlot(adTemplateItem.adUnit, adTemplateItem.sizes, generatedDivId)
            }
            else if (adTemplateItem.type.match(/outofpage/i) !== null) {
              Foundation.Ad.slots[generatedDivId] = googletag.defineOutOfPageSlot(adTemplateItem.adUnit, generatedDivId)
            }

            if (adTemplateItem.targeting) {
              adTemplateItem.targeting.forEach(function (target, index) {
                Foundation.Ad.slots[generatedDivId].setTargeting(target.key, target.value)
              })
            }

            Foundation.Ad.slots[generatedDivId].addService(googletag.pubads())

            if (adTemplateItem.sizeMap) {
              Foundation.Ad.slots[generatedDivId].defineSizeMapping(Foundation.Ad.CreateSizeMapping(adTemplateItem.sizeMap))
            }
            Foundation.Ad.slots[generatedDivId].slotLoaded = false
          }

          Foundation.Ad.showAd(currentElement);
        });
        </script>
</div>
</div>
<div class="uk-width-1-1 uk-width-1-3@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<div class="ComponentZoneB ContentFooterTripletresponsive  fdn-margin-medium-vert uk-root fdn-margin-vert LatestinSectionMultiContent comp-landing-sectionstories" data-component-id="LatestinSectionMultiContent">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Also in Food + Drink
</h3>
</div>
<div class="pres-ContentTileRectangleBriefVariableAcross uk-grid uk-grid-small" uk-grid="true" data-ev-presentation="ContentTileRectangleBriefVariableAcross" uk-height-match=".fdn-pres-image">
<div class="uk-width-1-2@s uk-width-1-2@m">
<a class="uk-flex uk-flex-column fdn-decoration-remove" href="https://www.orlandoweekly.com/food-drink/global-korean-fried-chicken-chain-bbq-chicken-lures-the-orlandos-fowl-mouthed-to-mills-50-31765777">
<div>
<p class="fdn-teaser-headline">
Global Korean fried chicken chain Bb.q Chicken lures Orlando's fowl-mouthed to Mills 50
</p>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Faiyaz Kara
</p>
<time>
Jun 8, 2022
</time>
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31765781/bbq.-chicken-1.jpg?cb=1655218896" alt="Global Korean fried chicken chain Bb.q Chicken lures the Orlando&#39;s fowl-mouthed to Mills 50" width="600" height="371" class="" />
</div>
</a>
</div>
<div class="uk-width-1-2@s uk-width-1-2@m">
<a class="uk-flex uk-flex-column fdn-decoration-remove" href="https://www.orlandoweekly.com/food-drink/orlando-brewing-shares-plans-to-move-to-international-drive-31727898">
<div>
<p class="fdn-teaser-headline">
Orlando Brewing shares plans to move to International Drive
</p>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Alex Galbraith
</p>
<time>
Jun 2, 2022
</time>
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31728223/screen_shot_2022-03-02_at_9.58.54_am.png?cb=1654185580" alt="Orlando Brewing shares plans to move to International Drive" width="600" height="371" class="" />
</div>
</a>
</div>
<div class="uk-width-1-2@s uk-width-1-2@m">
<a class="uk-flex uk-flex-column fdn-decoration-remove" href="https://www.orlandoweekly.com/food-drink/the-cantonese-cuisine-at-west-colonials-ten-ten-seafood-and-grill-doesnt-pander-to-the-gweilo-31716390">
<div>
<p class="fdn-teaser-headline">
The Cantonese cuisine at West Colonial's Ten Ten Seafood and Grill doesn't pander to the gweilo
</p>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Bao Le-Huu
</p>
<time>
Jun 1, 2022
</time>
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31716389/ten-ten-seafood-3.jpg?cb=1654049946" alt="The Cantonese cuisine at West Colonial&#39;s Ten Ten Seafood and Grill doesn&#39;t pander to the gweilo" width="600" height="371" class="" />
</div>
</a>
</div>
<div class="uk-width-1-2@s uk-width-1-2@m">
<a class="uk-flex uk-flex-column fdn-decoration-remove" href="https://www.orlandoweekly.com/food-drink/thai-farm-kitchen-brings-its-siamese-fare-from-brooklyn-to-college-park-and-sets-itself-apart-from-the-pack-31674473">
<div>
<p class="fdn-teaser-headline">
Thai Farm Kitchen brings its Siamese fare from Brooklyn to College Park and sets itself apart from the pack
</p>
<div class="fdn-teaser-infoline fdn-inline-split-list">
<p>
By Faiyaz Kara
</p>
<time>
May 25, 2022
</time>
</div>
</div>
<div class="uk-margin-small-bottom uk-flex-first">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/golden-s/31674469/thai-farm-kitchen-1.jpg?cb=1653523943" alt="Thai Farm Kitchen brings its Siamese fare from Brooklyn to College Park and sets itself apart from the pack" width="600" height="371" class="" />
</div>
</a>
</div>
</div>
<div class="uk-margin-small uk-clearfix uk-text-right ">
<a class="uk-align-right uk-margin-remove fdn-more-link-primary uk-flex-inline uk-flex-middle" href="https://www.orlandoweekly.com/orlando/ArticleArchives?section=2240409">
More <i class='far fa-chevron-double-right fa-xs'></i>
</a>
</div>
</div>
</div>
<div class="uk-width-1-1 uk-width-1-3@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
<div class="ComponentZoneC ContentFooterTripletresponsive   uk-root fdn-margin-vert CurrentIssuu comp-landing-currentissuu" data-component-id="CurrentIssuu">
<div class="fdn-component-header-block uk-margin ">
<h3 class="fdn-component-header-text uk-margin-remove ">
Digital Issue
</h3>
</div>
<h3>June 15, 2022</h3>
<iframe src="https://e.issuu.com/embed.html?d=orlando_weekly_june_15_2022&hideIssuuLogo=true&pageLayout=singlePage&u=euclidmediagroup" allowfullscreen allow="fullscreen" style="border:none;width:100%;height:300px;"></iframe>
<p>
<a class="more" href="https://www.orlandoweekly.com/orlando/IssueArchives">View more issues <i class="fas fa-angle-right fa-lg"></i></a>
</p>
</div>
</div>
</div>
</div>
</div>
<div class="ev-grid-zone ev-column-zone uk-flex uk-flex-wrap uk-child-width-1-2@m">
<div class="ev-grid-col" data-ev-zone="ZoneB">
</div>
<div class="ev-grid-col" data-ev-zone="ZoneC">
</div>
</div>
<div class="ev-grid-zone ev-secondary-zone" data-ev-zone="ZoneD">
<div class="ev-grid-col uk-width-1-1">
</div>
</div>
<div class="ev-grid-zone ev-footer-zone" data-ev-zone="GlobalFooter">
<div class="ev-grid-col uk-width-1-1">
<div class="GlobalFooter ContentDefault   uk-root fdn-margin-vert FooterNavigationCustom comp-shell-footernavigation" data-component-id="FooterNavigationCustom">
<div class="uk-flex uk-flex-wrap uk-grid-small fdn-custom-footer-link-block" uk-grid>
<div class="fdn-custom-footer-section-column">
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-news">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/news" target="_self">News</a>
</li>
<li>
<a href="/category/orlando-area-news-31065036" target="_self">Orlando Area News</a>
</li>
<li>
<a href="/category/florida-news-31065043" target="_self">Florida News</a>
</li>
<li>
<a href="/topic/lgbtq-31060459" target="_self">LGBTQ+</a>
</li>
<li>
<a href="/topic/pulse-31060458" target="_self">Pulse</a>
</li>
<li>
<a href="/topic/informed-dissent-31060456" target="_self">Informed Dissent</a>
</li>
<li>
<a href="/category/views-opinions-31146339" target="_self">Views + Opinions</a>
</li>
<li>
<a href="/topic/orlando-sports-31060463" target="_self">Orlando Sports</a>
</li>
<li>
<a href="/category/savage-love-2240424" target="_self">Savage Love</a>
</li>
<li>
<a href="/topic/reader-reactions-31067344" target="_self">Reader Reactions</a>
</li>
<li>
<a href="/category/comics-2240423" target="_self">Comics</a>
</li>
<li>
<a href="/orlando/IssueArchives?issue=this%20week" target="_self">Digital Issue</a>
</li>
<li>
<a href="/slideshows/?section=2240408" target="_self">News Slideshows</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-movies">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/movies-tv" target="_self">Movies</a>
</li>
<li>
<a href="/category/movie-reviews-31065358" target="_self">Movie Reviews</a>
</li>
<li>
<a href="/category/streaming-31065342" target="_self">Streaming</a>
</li>
<li>
<a href="/orlando/LocationSearch?locationCategory=2282370&sortType=name" target="_self">Find a Theater</a>
</li>
<li>
<a href="/orlando/MovieTimes" target="_self">Movie Times</a>
</li>
</ul>
</div>
</div>
<div class="fdn-custom-footer-section-column">
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-arts___culture">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/arts" target="_self">Arts + Culture</a>
</li>
<li>
<a href="/category/arts-stories-and-interviews-2240434" target="_self">Arts Stories + Interviews</a>
</li>
<li>
<a href="/topic/live-active-cultures-31060467" target="_self">Live Active Cultures</a>
</li>
<li>
<a href="/category/things-to-do-31066175" target="_self">Things to Do</a>
</li>
<li>
<a href="/topic/orlando-theme-parks-31060466" target="_self">Orlando Theme Parks</a>
</li>
<li>
<a href="/category/astrology-31065290" target="_self">Astrology</a>
</li>
<li>
<a href="/topic/performing-arts-31060468" target="_self">Performing Arts</a>
</li>
<li>
<a href="/topic/visual-arts-31060469" target="_self">Visual Arts</a>
</li>
<li>
<a href="/slideshows/?section=2240407" target="_self">Arts + Culture Slideshows</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-calendar">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/orlando/EventSearch" target="_self">Calendar</a>
</li>
<li>
<a href="/orlando/FreeStuff" target="_self">Orlando Weekly Events</a>
</li>
<li>
<a href="/orlando/EventSearch?narrowByDate=Today&v=d" target="_self">Today's Events</a>
</li>
<li>
<a href="/orlando/EventSearch?narrowByDate=This%20Weekend&sortType=date&v=d" target="_self">This Weekend</a>
</li>
<li>
<a href="/orlando/EventSearch?feature=Free&sortType=date&v=d" target="_self">Free Events</a>
</li>
<li>
<a href="/orlando/Events/AddEvent" target="_self">Submit an Event</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-social_media">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header fdn-no-click">
<a href="#" target="_blank">Social Media</a>
</li>
<li>
<a href="http://instagram.com/orlandoweekly/" target="_blank">Instagram</a>
</li>
<li>
<a href="https://twitter.com/orlandoweekly" target="_blank">Twitter</a>
</li>
<li>
<a href="https://www.facebook.com/orlandoweekly" target="_blank">Facebook</a>
</li>
</ul>
</div>
</div>
<div class="fdn-custom-footer-section-column">
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-food___drink">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/food-drink" target="_self">Food + Drink</a>
</li>
<li>
<a href="/category/food-news-31065305" target="_self">Food News</a>
</li>
<li>
<a href="/category/drinking-bars-31065312" target="_self">Drinking + Bars</a>
</li>
<li>
<a href="/category/restaurant-review-2240450" target="_self">Restaurant Reviews</a>
</li>
<li>
<a href="/orlando/LocationSearch?locationSection=2282258" target="_self">Find a Restaurant</a>
</li>
<li>
<a href="/slideshows/?section=2240409" target="_self">Food + Drink Slideshows</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-best_of_orlando_">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/orlando/BestOf" target="_self">Best Of Orlando®</a>
</li>
<li>
<a href="/best-of/arts-and-culture" target="_self">Arts & Culture</a>
</li>
<li>
<a href="/best-of/food-and-drink" target="_self">Food & Drink</a>
</li>
<li>
<a href="/best-of/goods-and-services" target="_self">Goods & Services</a>
</li>
<li>
<a href="/best-of/local-color" target="_self">Local Color</a>
</li>
<li>
<a href="/best-of/music-and-nightlife" target="_self">Music & Nightlife</a>
</li>
<li>
<a href="/best-of/sports-and-recreation" target="_self">Sports & Recreation</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-orlando_guides">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/orlando-guides" target="_self">Orlando Guides</a>
</li>
<li>
<a href="/category/annual-manual-2240488" target="_self">Annual Manual</a>
</li>
<li>
<a href="/category/bite-2240489" target="_self">Bite</a>
</li>
<li>
<a href="/category/fall-guide-2240492" target="_self">Fall Guide</a>
</li>
<li>
<a href="/category/holiday-guide-2240493" target="_self">Holiday Guide</a>
</li>
<li>
<a href="/category/newcomers-guide-2240498" target="_self">Newcomers Guide</a>
</li>
<li>
<a href="/category/summer-guide-2240491" target="_self">Summer Guide</a>
</li>
<li>
<a href="/blogs/LegalAdvertising/" target="_self">Legal Advertising</a>
</li>
<li>
<a href="/sponsored" target="_self">Sponsored Articles</a>
</li>
</ul>
</div>
</div>
<div class="fdn-custom-footer-section-column">
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-music">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/music" target="_self">Music</a>
</li>
<li>
<a href="/category/music-stories-and-interviews-2240462" target="_self">Music Stories + Interviews</a>
</li>
<li>
<a href="/category/orlando-music-news-31065388" target="_self">Orlando Music News</a>
</li>
<li>
<a href="/category/live-music-picks-previews-31065380" target="_self">Live Music Picks + Previews</a>
</li>
<li>
<a href="/topic/this-little-underground-31060485" target="_self">This Little Underground</a>
</li>
<li>
<a href="/orlando/EventSearch?eventSection=2167738&sortType=date&v=d" target="_self">Find a Concert</a>
</li>
<li>
<a href="/slideshows/?section=2240410" target="_self">Music Slideshows</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-cannabis">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/cannabis" target="_self">Cannabis</a>
</li>
<li>
<a href="/category/weed-news-31065403" target="_self">Cannabis News</a>
</li>
<li>
<a href="/category/legislative-updates-31065418" target="_self">Legislative Updates</a>
</li>
<li>
<a href="/category/dispensary-directory-31065425" target="_self">Dispensary Directory</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-sponsored_links">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header fdn-no-click">
<a href="#" target="_blank">Sponsored Links</a>
</li>
<li>
<a href="https://www.407apartments.com/ucf-apartments" target="_blank">Apartments Near UCF</a>
</li>
<li>
<a href="https://www.407apartments.com/orlando-apartments/apartments-near-valencia-college" target="_blank">Apartments Near Valencia College</a>
</li>
<li>
<a href="https://www.407apartments.com/orlando-apartments/student-apartments-in-orlando" target="_blank">Student Housing in Orlando</a>
</li>
</ul>
</div>
</div>
<div class="fdn-custom-footer-section-column">
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-giveaways___events">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header ">
<a href="/orlando/FreeStuff" target="_self">Giveaways + Events</a>
</li>
<li>
<a href="/orlando/FreeStuff?category=2273884" target="_self">Contests</a>
</li>
<li>
<a href="/orlando/FreeStuff?category=2273894" target="_self">Orlando Weekly Events</a>
</li>
<li>
<a href="/orlando/orlando-burger-week/FreeStuff?oid=23026965" target="_self">Orlando Burger Week</a>
</li>
<li>
<a href="/orlando/beer-merica/FreeStuff?oid=2541677" target="_self">Beer 'Merica</a>
</li>
<li>
<a href="/orlando/bite30/FreeStuff?oid=2321136" target="_self">Bite30</a>
</li>
<li>
<a href="/orlando/tacos-and-tequila/FreeStuff?oid=4575095" target="_self">Tacos & Tequila</a>
</li>
<li>
<a href="/orlando/orlando-taco-week/FreeStuff?oid=9414612" target="_self">Orlando Taco Week</a>
</li>
<li>
<a href="/orlando/orlando-beer-festival/FreeStuff?oid=2387425" target="_self">Orlando Beer Festival</a>
</li>
<li>
<a href="/orlando/whiskey-business/FreeStuff?oid=2387353" target="_self">Whiskey Business</a>
</li>
</ul>
</div>
<div class="fdn-custom-footer-section-block fdn-custom-footer-section-block-about_us">
<ul class="uk-list">
<li class="fdn-custom-footer-section-header fdn-no-click">
<a href="#" target="_self">About Us</a>
</li>
<li>
<a href="/orlando/AboutOrlandoWeekly/Page" target="_self">Contact Us</a>
</li>
<li>
<a href="/orlando/WorkForUs/Page" target="_self">Work For Us</a>
</li>
<li>
<a href="/orlando/AboutOrlandoWeekly/Page" target="_self">Staff Directory</a>
</li>
<li>
<a href="/orlando/Wheretofindus/Page" target="_self">Where to Find Us</a>
</li>
<li>
<a href="/orlando/FAQs/Page" target="_self">FAQ</a>
</li>
<li>
<a href="/orlando/Policies/Page" target="_self">Policies</a>
</li>
<li>
<a href="/orlando/SupportLocalJournalism/Page" target="_self">Support</a>
</li>
<li>
<a href="/orlando/NewsletterSignup/Page" target="_self">Subscribe</a>
</li>
<li>
<a href="https://mediakit.orlandoweekly.com/" target="_blank">Advertise</a>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class="GlobalFooter ContentDefault   uk-root fdn-margin-vert FooterSisterPublications comp-shell-footersisterpublications" data-component-id="FooterSisterPublications">
<style>
  .fdn-custom-footer-publications-logo-orlando {
    display: none !important;
  }
  </style>
<div class="uk-text-center fdn-custom-footer-publications-header">
<h3 class="uk-margin-remove">Euclid Media Group, LLC</h3>
<p class="uk-margin-remove">Read our sister publications</p>
</div>
<div class="uk-flex uk-flex-wrap uk-child-width-1-5 uk-child-width-expand@s uk-flex-around uk-padding-small fdn-custom-footer-publications-logos">
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-clevescene" uk-tooltip="Cleveland Scene" href="https://www.clevescene.com" target="_blank">
<img alt="Cleveland Scene" src="/images/air/clevescene.jpg">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-sacurrent" uk-tooltip="San Antonio Current" href="https://www.sacurrent.com" target="_blank">
<img alt="San Antonio Current" src="/images/air/sacurrent.jpg">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-citybeat" uk-tooltip="Cincinnati CityBeat" href="https://www.citybeat.com/" target="_blank">
<img alt="Cincinnati CityBeat" src="/images/air/citybeat.png">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-cltampa" uk-tooltip="Creative Loafing Tampa Bay" href="https://www.cltampa.com/" target="_blank">
<img alt="Creative Loafing Tampa Bay" src="/images/air/cltampa.png">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-metrotimes" uk-tooltip="Detroit Metro Times" href="https://www.metrotimes.com" target="_blank">
<img alt="Detroit Metro Times" src="/images/air/metrotimes.jpg">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-orlando" uk-tooltip="Orlando Weekly" href="https://www.orlandoweekly.com" target="_blank">
<img alt="Orlando Weekly" src="/images/air/orlandoweekly.png">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-riverfronttimes" uk-tooltip="St Louis Riverfront Times" href="https://www.riverfronttimes.com" target="_blank">
<img alt="St Louis Riverfront Times" src="/images/air/riverfront.png">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-outinsa" uk-tooltip="Out in SA" href="https://outinsa.com/" target="_blank">
<img alt="Out in SA" src="/images/air/outinsa.png">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-outinstl" uk-tooltip="Out in STL" href="https://outinstl.com/" target="_blank">
<img alt="Out in STL" src="/images/air/outinstl.png">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-leo" uk-tooltip="LEO Weekly" href="https://www.leoweekly.com/" target="_blank">
<img alt="LEO Weekly" src="/images/air/leo-weekly.png">
</a>
<a class="uk-padding-small fdn-custom-footer-publications-logo fdn-custom-footer-publications-logo-local-culture" uk-tooltip="Local Culture Creative" href="https://localculturecreative.com/" target="_blank">
<img alt="Local Culture Creative" src="/images/air/local-culture.png">
</a>
</div>
</div>
<div id="FooterInfo" class="GlobalFooter ContentDefault   uk-root fdn-margin-vert FooterInfo comp-shell-footerinfo" data-component-id="FooterInfo">
<div class="uk-flex uk-flex-wrap fdn-custom-footer-info-block">
<div class="uk-width-1-1 fdn-custom-footer-info-address">
<h3 class="uk-margin-remove">
Orlando Weekly
</h3>
<p class="uk-margin-remove">16 W. Pine St.</p>
<p class="uk-margin-remove">Orlando, FL 32801</p>
</div>
<div class="uk-width-1-1 uk-flex fdn-custom-footer-info-links">
<div class="uk-grid-small uk-flex-middle fdn-custom-footer-info-social-links" uk-grid>
<a href="https://www.facebook.com/orlandoweekly" target="_blank" uk-tooltip="Facebook">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/square/29222996/f_logo_rgb-blue_512.png?cb=1645724922" alt="Facebook Icon" width="120" height="120" class="no-foundation-imgeditor" />
</a>
<a href="https://twitter.com/orlandoweekly" target="_blank" uk-tooltip="Twitter">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/square/26132864/twitter-201910-35.png?cb=1645724928" alt="Twitter Icon" width="120" height="120" class="no-foundation-imgeditor" />
</a>
<a href="https://instagram.com/orlandoweekly/" target="_blank" uk-tooltip="Instagram">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/square/29222997/instagram_appicon_aug2017.png?cb=1645724934" alt="Instagram Icon" width="120" height="120" class="no-foundation-imgeditor" />
</a>
<a href="https://apple.news/TvED6otrDR9OFO33_r61W_g" target="_blank" uk-tooltip="Apple News">
<img uk-img="" data-src="https://media2.orlandoweekly.com/orlando/imager/u/square/29222998/c8269638ca74fdcb0896367bbc1eff24.png?cb=1645724939" alt="Apple News Icon" width="120" height="120" class="no-foundation-imgeditor" />
</a>
<a href="https://news.google.com/publications/CAAqLQgKIidDQklTRndnTWFoTUtFVzl5YkdGdVpHOTNaV1ZyYkhrdVkyOXRLQUFQAQ?hl=en-US&gl=US&ceid=US%3Aen" target="_blank" uk-tooltip="Google News">
<img uk-img="" data-src="https://media1.orlandoweekly.com/orlando/imager/u/square/29223000/google_news_icon.png?cb=1645724945" alt="Google News Icon" width="120" height="120" class="no-foundation-imgeditor" />
</a>
</div>
</div>
</div>
</div>
<script>
if (typeof window.__uspapi === 'function') {
  window.__uspapi('uspPing', 1, function(obj, status) {
    if (status && obj.mode.includes('USP') && obj.jurisdiction.includes(obj.location.toUpperCase())) {
      var message = document.createElement("p");
      message.setAttribute("class", "ccpaNotice");
      message.innerHTML = 'Our website uses technical, analytical, marketing, and preference cookies to provide the best experience for our readers and to give us information about how our site is used. You may request that your data not be shared with third parties here: ' 
        + `<a href="#" onclick="window.__uspapi('displayUspUi');"` 
        + '>Do Not Sell My Data</a>' 
        + '.';
      document.getElementById('FooterInfo').append(message);
      window.__uspapi('setUspDftData', 1, function(obj, status) {
        if (!status) {
            console.log("Error: USP string not updated!")
        }
      });
   }
  });
}
</script>
<div class="GlobalFooter ContentDefault   uk-root fdn-margin-vert FooterCopyright comp-shell-footercopyright" data-component-id="FooterCopyright">
<div class="uk-text-center">
<div class="fdn-copyright-text">
© 2022 Orlando Weekly
</div>
<div class="fdn-copyright-text uk-margin-small-top">
<a class="fdn-copyright-link" href="https://publishwithfoundation.com/" target="_blank">
<img width="110" alt="Powered By Foundation" src="/foundation/images/PoweredByFoundation.svg">
</a>
</div>
</div>
</div>

<script type="text/javascript">
  (function(e,t,o,n,p,r,i){e.visitorGlobalObjectAlias=n;e[e.visitorGlobalObjectAlias]=e[e.visitorGlobalObjectAlias]||function(){(e[e.visitorGlobalObjectAlias].q=e[e.visitorGlobalObjectAlias].q||[]).push(arguments)};e[e.visitorGlobalObjectAlias].l=(new Date).getTime();r=t.createElement("script");r.src=o;r.async=true;i=t.getElementsByTagName("script")[0];i.parentNode.insertBefore(r,i)})(window,document,"https://diffuser-cdn.app-us1.com/diffuser/diffuser.js","vgo");
  vgo('setAccount', '26668640');
  vgo('setTrackByDefault', true);

  vgo('process');
</script>
</div>
</div>
<div class="ev-grid-zone ev-closer-zone" data-ev-zone="Closer">
<div class="ev-grid-col uk-width-1-1">
<div class="Closer ContentDefault   uk-root fdn-margin-vert SupportUs comp-shell-supportus" data-component-id="SupportUs">
<div class="fdn-support-us-button-block">
<a href="/orlando/SupportLocalJournalism/Page">Support Us</a>
</div>
</div>
</div>
</div>
</div>
</div>
</body>
</html>
