































































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="27563092" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=905d2fe84e2e3608936c2ef088916f65" />
  <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=905d2fe84e2e3608936c2ef088916f65" />
  <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=905d2fe84e2e3608936c2ef088916f65" />
  <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=905d2fe84e2e3608936c2ef088916f65" />

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Whole Site" href="https://www.orlandoweekly.com/orlando/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Blogs Section" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2250908" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Blogs" href="https://www.orlandoweekly.com/orlando/Rss.xml?oid=2250909" />
      
        <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Blogs: " href="https://www.orlandoweekly.com/orlando/Rss.xml?category=2250909&amp;topic=oid%3A2265199" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Orlando Weekly RSS: Comments on One month after second phase of reopening, Florida hits new record-high for coronavirus cases" href="https://www.orlandoweekly.com/orlando/Rss.xml?id=comments&amp;oid=27563092" />
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=7beca3529ec87149d5f504efe3a8129f"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=7beca3529ec87149d5f504efe3a8129f"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.orlandoweekly.com\/orlando\/Profile", "https:\/\/posting.orlandoweekly.com\/orlando\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="297405715145-bcr8a9m9emb8a84o6qbd7utuefrfoknk.apps.googleusercontent.com">
  

    
  

  
  <!-- Begin Google Fonts -->
<link href='https://fonts.googleapis.com/css?family=Lato:400,700|Titillium+Web:400,700|Montserrat:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Fonts -->

<meta name="google-site-verification" content="06A5Yh5mu5xlqSkqBOzGlxA6P_yfmltTp1l0ssgpOBk" />


<!-- Google Verification -->   
<meta name="google-site-verification" content="9htXi1AfaHrVLNGB2JDLtdpWEFyb-JOf5ngnP_95Zuk" />
<meta name="google-site-verification" content="s4GBlkstS6PKQwO_gDlOGL8jFPmeuL_d3m60wxOBQR0" />


<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
          <script type='text/javascript'>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</script>
<!-- Begin Google Analytics -->
  
    <script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    ga('create', 'UA-585470-1', 'orlandoweekly.com');
    ga('send', 'pageview', { 'dimension1': 'blogs', 'dimension2': 'news' });
    </script>
  
  <!-- End Google Analytics -->




<!-- Quantcast Choice. Consent Manager Tag -->
  <script type="text/javascript" async=true>
    var __cmp = (function () {
      return typeof (__cmp) == "function" ? __cmp : function (c) {
        var b = arguments;
        if (!b.length) {
          return __cmp.a;
        }
        else if (c == '__cmp')
          return false;
        else {
          if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
          }
          __cmp.a.push([].slice.apply(b));
        }
      }
    })();
    var elem = document.createElement('script');
    elem.src = "https://quantcast.mgr.consensu.org/cmp.js";
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);

    window.__cmp('init', {
      'Language': 'en',
    'Initial Screen Reject Button Text': 'I do not accept',
    'Initial Screen Accept Button Text': 'I accept',
    'Purpose Screen Header Title Text': 'Privacy settings',
    'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
    'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
    'Vendor Screen Accept All Button Text': 'Accept all',
    'Vendor Screen Reject All Button Text': 'Reject all',
    'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
    'Initial Screen Body Text Option': 1,
    'Publisher Name': 'Orlando Weekly',
    'Publisher Purpose IDs': [1,2,5,4,3],
    'Post Consent Page': 'https://www.orlandoweekly.com/orlando/Policies/Page',
    });
  </script>
  <!-- End Quantcast Choice. Consent Manager Tag -->
    <style>
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            background-color: #000000 !important;
            border-color: #000000 !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            background-color: transparent !important;
            border-color: #000000 !important;
        }
        .qc-cmp-alt-action,
        .qc-cmp-link {
            color: #000000 !important;
        }
        .qc-cmp-button,
        .qc-cmp-button.qc-cmp-secondary-button:hover {
            color: #ffffff !important;
        }
        .qc-cmp-button:hover,
        .qc-cmp-button.qc-cmp-secondary-button {
            color: #000000 !important;
        }
        .qc-cmp-small-toggle.qc-cmp-toggle-on,
        .qc-cmp-toggle.qc-cmp-toggle-on {
            background-color: #ee1c25 !important;
            border-color: #ee1c25 !important;
        }
        .qc-cmp-small-toggle,
        .qc-cmp-toggle {
            background-color: #C0C0C0 !important;
            border-color: #C0C0C0 !important;
        }
    </style>
<link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.css" />
  <script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.js"></script>
  <script>
  

  window.addEventListener("load", function(){
  window.cookieconsent.initialise({
    "palette": {
      "popup": {
        "background": "#000000",
        "text": "#ffffff"
      },
      "button": {
        "background": "#D91F34",
        "text": "#ffffff"
      }
    },
    "position": "top",
    "content": {
      "message": "We use cookies to understand how you use our site and to improve your experience. By continuing to use our site, you accept our use of cookies, revised Privacy Policy and Terms.",
      "href": "https://www.orlandoweekly.com/orlando/Policies/Page"
    }
  })});

  
  </script>



<script>
  var Euclid = Euclid || {}
  Euclid.OrlandoWeekly = Euclid.OrlandoWeekly || {}
  Euclid.OrlandoWeekly.vertical = Euclid.OrlandoWeekly.vertical || 'news'
  </script>
<script>
  (function() {
  if(document.getElementById('commitchange-script')) return;
  var npo = 5276;
  var script = document.createElement('script');
  var first = document.getElementsByTagName('script')[0];
  script.setAttribute('data-npo-id', npo);
  script.id = 'commitchange-script';
  script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
  first.parentNode.insertBefore(script, first);
  })();
  </script>
  

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'https://cdn.taboola.com/libtrc/sacurrent-orlandoweekly/loader.js');
</script>
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="One month after second phase of reopening, Florida hits new record-high for coronavirus cases | Blogs" />
  <meta name="description" content="On June 3, as Gov. Ron DeSantis announced the second phase of his economic reopening efforts, 58,764 people had tested positive for the coronavirus in..." />
  <meta name="keywords" content="Orlando, coronavirus, COVID-19, Orange County Florida, public health, safety, Ron DeSantis, new record, masks, Bloggytown" />
  <title>One month after second phase of reopening, Florida hits new record-high for coronavirus cases | Blogs</title>

  
  
    <meta name="date" content="2020-07-04 13:10:00" />
  

  
  
  
    <meta name="author" content="Jim Saunders, News Service of Florida">
  

  
  
  <meta name="news_keywords" content="orlando, coronavirus, covid19, orange county florida, public health, safety, ron desantis, new record, masks, bloggytown" />

  
  

  
  
    
  
  
    <link rel="image_src" href="https://media1.fdncms.com/orlando/imager/u/slideshow/27563313/eb7z_hnu8aegqou.jpeg" />
    <meta name="thumbnail" content="https://media1.fdncms.com/orlando/imager/u/slideshow/27563313/eb7z_hnu8aegqou.jpeg" />
  

  
    
      <link rel="canonical" href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases" />
    
  

  
    <meta property="fb:app_id" content="1527160917534695" />
  

  
  <meta property="og:site_name" content="Orlando Weekly" />
  <meta property="og:title" content="One month after second phase of reopening, Florida hits new record-high for coronavirus cases" />

   
  
    

    
    

    
    

    <meta property="og:image" content="https://media1.fdncms.com/orlando/imager/u/slideshow/27563313/eb7z_hnu8aegqou.jpeg" />

    
      <meta property="og:image:width" content="600" />
      <meta property="og:image:height" content="340" />
    
  

  
  
    <meta property="og:description" content="On June 3, as Gov. Ron DeSantis announced the second phase of his economic reopening efforts, 58,764 people had tested positive for the coronavirus in..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/orlando/imager/u/slideshow/27563313/eb7z_hnu8aegqou.jpeg">

    
    

    

    <meta name="twitter:site" content="@orlandoweekly">
    <meta name="twitter:title" content="One month after second phase of reopening, Florida hits new record-high for coronavirus cases">
    <meta name="twitter:description" content="On June 3, as Gov. Ron DeSantis announced the second phase of his economic reopening efforts, 58,764 people had tested positive for the coronavirus in...">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">27563092</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20200704131009</Attribute>
        <Attribute name="creationdate">20200704111413</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20200704131000</Attribute>
            <Attribute name="releasedate">20200704</Attribute>
            <Attribute name="releaseepoch">1593882600</Attribute>
            <Attribute name="title">One month after second phase of reopening, Florida hits new record-high for coronavirus cases</Attribute>
            <Attribute name="author">2351647</Attribute>
            <Attribute name="authorname">Jim Saunders, News Service of Florida</Attribute>
            <Attribute name="authorsortname">Florida, Jim Saunders News Service of</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.orlandoweekly.com\/Blogs\/archives\/2020\/07\/04\/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases"
          },
          "headline": "One month after second phase of reopening, Florida hits new record-high for coronavirus cases",
          
            "description": "On June 3, as Gov. Ron DeSantis announced the second phase of his economic reopening efforts, 58,764 people had tested positive for the coronavirus in Florida.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/orlando\/imager\/u\/original\/27563313\/eb7z_hnu8aegqou.jpeg",
              "width": 1000,
              "height": 566,
              "@type": "ImageObject"
            },
          
          "datePublished": "2020-07-04T13:10:00",
          "dateModified": "2020-07-04T13:10:09",
          
            "author": {
              "name": "Jim Saunders, News Service of Florida",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Orlando Weekly",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.orlandoweekly.com\/imager\/b\/google-amp-logo\/808579\/5643\/OrlandoWeekly_fbook.jpg",
                "width": 117,
                "height": 60,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Post" class="BlogPost Blogs Iapetus10Zone">




<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KQ22CZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KQ22CZ');</script>
<!-- End Google Tag Manager -->

<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  <div id="AdInterstitial" class="Leader BlogPost ">
  <!-- /43707298/ORL_DesktopInterstitial -->
          <div id="div-gpt-ad-orl_desktopinterstitial" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopInterstitial" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopinterstitial');
                });
              </script>
          </div>
</div>
  <style>
  /*-- desktop styles --*/
   #AdBackground {top:50px!important;}
  .nominate-bar {
    background: #e27a00;
    z-index: 1;
    overflow:hidden;
    width: 100%;
    padding: 0;
    text-transform: uppercase;
    text-align: center;
    color: #fff;
    font-size: 18px;
  }
  .nominate-bar div {
    border: 1px solid #FFBF6E;
    margin: 5px auto;
    max-width: 1000px;
      color:#fff;
}
  .nominate-bar a {
    color:#fff;
  }

  /* Adjust the ad positioning */
  body {
    background-position-y: 39px !important;
  }
  </style>


<div class="nominate-bar">
  <div>
    <p>
      <a href="/orlando/BestofOrlandoReadersPoll2020/Page#/">CAST YOUR VOTE IN THE BEST OF ORLANDO READERS POLL</a>
    </p>
  </div>
</div>
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="https://m.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  












<div id="LogoHeader" class="GlobalHeader BlogPost ">
  
    
    <div id="logoLeft">      
      <a href="https://www.orlandoweekly.com/" title="Orlando Weekly">Orlando Weekly</a>
    </div>

    <div id="leaderboardAdHeader">
      <!-- /43707298/ORL_728x90 -->
          <div id="div-gpt-ad-orl_728x90-1" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-1');
                });
              </script>
          </div>
    </div>
      
      
</div>
<!-- End #LogoHeader -->















  <div id="NavigationHorizontal" class="GlobalHeader BlogPost  ">
    
      
      
          <ul id="mainNav">
        
        

        

        

        

        <li class="first" id="NavItem_NewsFeatures">
          <a href="https://www.orlandoweekly.com/orlando/news-and-features/Section?oid=2240408"  class="subnav_link" id="SNAVL_NewsFeatures">News</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_GoodtoGo">
          <a href="https://www.orlandoweekly.com/orlando/GoodTo-GoOrlandoADirectoryofLocalBusinessesYouCanSupportDuringtheCoronavirusEra/Page"  >Good-to-Go</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_ArtsCulture">
          <a href="https://www.orlandoweekly.com/orlando/arts-and-culture/Section?oid=2240407"  >Arts</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Music">
          <a href="https://www.orlandoweekly.com/orlando/music/Section?oid=2240410"  >Music</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Screens">
          <a href="https://www.orlandoweekly.com/orlando/movies/Section?oid=2240411"  class="subnav_link" id="SNAVL_Screens">Movies</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_FoodDrink">
          <a href="https://www.orlandoweekly.com/orlando/food-and-drink/Section?oid=2240409"  class="subnav_link" id="SNAVL_FoodDrink">Food &amp; Drink</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Calendar">
          <a href="https://www.orlandoweekly.com/orlando/EventSearch"  >Calendar</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_BestOfOrlando">
          <a href="https://www.orlandoweekly.com/orlando/BestOf"  class="subnav_link" id="SNAVL_BestOfOrlando">Best Of Orlando&reg;</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Galleries">
          <a href="http://photos.orlandoweekly.com"  >Galleries</a>
        </li>
        
      
        

        

        

        

        <li class="" id="NavItem_Support">
          <a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page"  class="subnav_link" id="SNAVL_Support">Support</a>
        </li>
        
      
        

        

        

        

        <li class="last" id="NavItem_Advertise">
          <a href="https://www.orlandoweekly.com/orlando/AdvertiseWithOrlandoWeekly/Page"  >Advertise</a>
        </li>
        
      
          </ul>
        

      
        
        
          
            <h3 class="hidden">Browse News</h3>
            <ul class="subnav_content" id="SNAV_NewsFeatures" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=coronavirus"  title="">Coronavirus Updates</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=this%20week"  title="">Digital Issue</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/IssueArchives"  title="">Browse Issues</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/joblistings/Page"  title="">Local Job Listings</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413"  title="">Special Issues</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Food &amp; Drink</h3>
            <ul class="subnav_content" id="SNAV_FoodDrink" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/GoodTo-GoOrlandoADirectoryofLocalBusinessesYouCanSupportDuringtheCoronavirusEra/Page"  title="">Good To-Go Orlando</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Movies</h3>
            <ul class="subnav_content" id="SNAV_Screens" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/movie-reviews-and-stories/Category?oid=2240471"  title="">Movie Reviews and News</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/LocationSearch?locationCategory=2282370&sortType=name"  title="">Find a Theater</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/MovieTimes"  title="">Movie Times</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Best Of Orlando&reg;</h3>
            <ul class="subnav_content" id="SNAV_BestOfOrlando" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/BestofOrlandoReadersPoll2020/Page#//"  title="">Readers Poll 2020</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Promos + Events</h3>
            <ul class="subnav_content" id="SNAV_PromosEvents" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/FreeStuff"  title="">Giveaways</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273894"  title="">OW Events</a>
          </li>
          
            </ul>
          
        
          
            <h3 class="hidden">Browse Support</h3>
            <ul class="subnav_content" id="SNAV_Support" style="display:none;">
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page"  title="">Donate</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.orlandoweekly.com/orlando/NewsletterSignup/Page"  title="">Subscribe</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://www.facebook.com/orlandoweekly" target="_blank" title="">Orlando Weekly Facebook</a>
          </li>
          
        
          

          

          <li class="">
            <a href="https://twitter.com/orlandoweekly" target="_blank" title="">Orlando Weekly Twitter</a>
          </li>
          
        
          

          

          <li class="">
            <a href="http://instagram.com/orlandoweekly/" target="_blank" title="">Orlando Weekly Instagram</a>
          </li>
          
            </ul>
          
        

        

        
        
        
      
    
  </div>


  

  
  
  
    
    

      

      <script>
      "use strict";
      (function(){
        //
        if(navigator.userAgent.match(/\b(iPad|iPhone|iPod|Android|Pre|BlackBerry|Windows Phone)\b/i)){
          //
          //
            jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
          //
          //

        //
        }else{
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
          var navigationID = jQuery(this).attr('id');
          var navigationSelector = '#'+navigationID;
          var navMenuSelector = '#NavigationHorizontal #SNAV_'+navigationID.split('_')[1];
          var navigationTimeout;
          var focusNavigation = function(e){
            window.clearTimeout(navigationTimeout);
            jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
            jQuery(navMenuSelector).show();
          }
          var blurNavigation = function(e){
              jQuery(navMenuSelector).hide();
            navigationTimeout = window.setTimeout(function(){
            },75);
          }
          jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
        });
        }
      })();
      </script>
    
  
  <!-- true == "true"
         && true == "devel" -->


<!-- End #NavigationHorizontal --><div id="AdPencilBar" class="GlobalHeader BlogPost ">
  <!-- /43707298/ORL_970x90 -->
          <div id="div-gpt-ad-orl_970x90" style="" data-content-type="ad" data-slot="/43707298/ORL_970x90" data-output="asynchronous" data-width="970" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_970x90');
                });
              </script>
          </div>
</div>
  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  
  
  

  <!-- UIkit CSS -->
  <link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=9814765d8bcb1360770d0ee73d97e65b" />

  <!-- UIkit JS -->
  <script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=9814765d8bcb1360770d0ee73d97e65b"></script>
  <script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=9814765d8bcb1360770d0ee73d97e65b"></script>


  

  <style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>








 
   



 


  

    



  <div id="TopicHeader" class="SpanningFeature BlogPost  topic_bloggytown">      
       <a href="https://www.orlandoweekly.com/Blogs/archives/bloggytown/">
         <h2 id="ArchiveHead" class="archiveHead">
           Bloggytown
         </h2>
       </a>   
      
  </div>  




  
  















  
  
  

  
  
  

  
 
  




  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="SpanningFeature BlogPost ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:20%; height: 20px; float:left;">
        <fb:like href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:20%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases&text=One%20month%20after%20second%20phase%20of%20reopening%2C%20Florida%20hits%20new%20record-high%20for%20coronavirus%20cases" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:20%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.orlandoweekly.com/orlando/Tools/EmailFriend?oid=27563092" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:20%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases?mode=print" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0 last" style="width:20%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=ra-54d38c2c42ccebb5" addthis:url="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases" addthis:title="One month after second phase of reopening, Florida hits new record-high for coronavirus cases" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54d38c2c42ccebb5", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  

















  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  


  <div id="BlogsBlogPost" class="SpanningFeature BlogPost  topicView topic_bloggytown">

    

    


































    

    
    

    
      
      
        <h2 class="blogDate">Saturday, July  4, 2020</h2>
      

      
      <div class="blogPost blogs topic-bloggytown">
    
    
      <div class="postCategories">
                
        <span class="postCategory CategoryBlogs">
          <a href="https://www.orlandoweekly.com/Blogs/archives/bloggytown/" class="topic-bloggytown">Bloggytown</a>
        </span>
      </div>
    
    
    <h1 class="postTitle" id="a27563092">
      
      
      
      
      
      
        One month after second phase of reopening, Florida hits new record-high for coronavirus cases
      

      
    </h1>

    

    
      <h4 class="postedBy">
        
        <span class="byAttribute">Posted</span>
        
          
          <span class="byAttribute">By</span> <a href="https://www.orlandoweekly.com/author/jim-saunders-news-service-of-florida" rel="author">Jim Saunders, News Service of Florida</a>
        
        
          
            on <span class="postTime">Sat, Jul  4, 2020</span> at <span class="postTime"> 1:10 PM</span>
          
        
           
      </h4>
    

   
    
    

    

    
    <div id="TrinityPlayer" class="SpanningFeature TrinityPlayer " style="width:100%; max-height:50px;">
      <script type="text/javascript" src="https://trinitymedia.ai/sas/player/trinity.php?sCampaignID=2601060359"></script>
    </div>

    
    

    <div class="postBody">
      
          
      


      
     
       
      

        

        

        

        

        

        

        
        

        

        

        
      
      
      
      
       
      
      

      
      

      
      
        
        <script>
          dnLoadScript("https://platform.twitter.com/widgets.js", true);
        </script>
        
          
          
        
        
        <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/orlando/imager/u/original/27563313/eb7z_hnu8aegqou.jpeg" class="zoomable" rel="contentImg_gal-27563092" title="PHOTO VIA RON DESANTIS/TWITTER">                  <img src="https://media1.fdncms.com/orlando/imager/u/blog/27563313/eb7z_hnu8aegqou.jpeg?cb=1593882603" width="580" height="328" alt="PHOTO VIA RON DESANTIS/TWITTER" srcset="" />                </a>                                                                                                           <ul style="width:580px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Photo via Ron DeSantis/Twitter                                          </li>                                                                                                                                                                                      </ul>                                                       </div>





            
          
            <p>
   On June 3, as Gov. Ron DeSantis announced the second phase of his economic reopening efforts, 58,764 people had tested positive for the coronavirus in Florida. 
</p>
   


            

              
              

              <div class="inlineComponent AdNativeInline">
                <div id="AdNativeInline" class="SpanningFeature AdNativeInline ">
  <!-- /43707298/ORL_DesktopNative -->
          <div id="div-gpt-ad-orl_desktopnative-2" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-2');
                });
              </script>
          </div>
</div>
              </div>
            
          
            <p>
     Just one day past a month later, that number has exploded to&nbsp;190,052, with more than 11,000 new cases <a href="/Blogs/archives/2020/07/04/another-record-high-day-for-coronavirus-in-florida-as-cases-jump-more-than-11400-on-friday?utm_source=feature&amp;utm_medium=home&amp;utm_campaign=hpfeatures&amp;utm_content=HomeTopFeature" target="_blank">in one day on Friday</a>. 
</p>
   


            
          
            <p>
     Forget New York. Florida and other sunbelt states have become the face — at least for now — of the coronavirus pandemic. 
</p>
   


            
          
            <p>
     DeSantis has generally downplayed the significance of the spike in cases. In part, he has focused on the numbers including many young adults, who aren’t as likely to suffer severe health consequences as seniors or people with underlying medical conditions. 
</p>
  The governor got backing Thursday from Vice President Mike Pence and high-ranking federal health officials who joined him for an event in Tampa. DeSantis and Pence tried to assure residents that Florida is responding effectively to the pandemic.

            
          
            <br>
  <br>
  Pence said the state was in a “much better place” to respond to the surge in cases because of increased testing and availability of protective equipment, though he acknowledged that work needed to be done to “flatten the curve.”

            
          
            <br>
  <br>
  “No one wants to see these numbers where they are or no one wants to see them go up,” Pence said.

            
          
            <br>
  <br>

<div class="pullQuote">
              <a href="https://twitter.com/intent/tweet?url=https%3A//www.orlandoweekly.com/Blogs/archives/2020/07/04/one-month-after-second-phase-of-reopening-florida-hits-new-record-high-for-coronavirus-cases&text=Florida+and+other+sunbelt+states+have+become+the+face+of+the+coronavirus+pandemic.">
                Florida and other sunbelt states have become the face of the coronavirus pandemic.
                <span class="pullQuoteTwitter">click to tweet</span>
              </a>
            </div>

Other people — especially Democrats — weren’t so calm as the surge of cases continued day after day. More than 3,803&nbsp;Florida residents had died as of Saturday from COVID-19, the respiratory disease caused by the coronavirus.

            
          
            <br>
  <br>
  Many local governments have required people to wear masks in public to try to prevent the spread of the virus, and DeSantis has faced heavy criticism for refusing to issue a statewide mask mandate.

            
          
            <br>
  <br>
  “For much of this pandemic, the governor's approach, like the President's (Donald Trump’s), has been hands-off,” Sen. Annette Taddeo, D-Miami, said during a conference call that Senate Democrats held with reporters this week. “We saw this in reporting transparency, in stay-at-home orders, in beach closings, in wearing masks and in bringing down these incredibly high numbers. It's like he's reluctant to take on a fight to stop the virus, always running after it instead of getting in front of it.”

            
          
            <br>
  <br>
  <b>MAYBE NEXT YEAR</b>

            
          
            <br>
  <br>
  When Florida lawmakers passed a $93.2 billion budget in March, the state was starting to feel the health and economic effects of the coronavirus. They knew the pandemic likely would cut into tax revenues, as businesses closed or scaled back. But at that point, the situation remained hazy.

            
          
            <br>
  <br>
  No more. With revenues plummeting, DeSantis this week vetoed $1 billion in proposed spending and signed a $92.2 billion budget for the fiscal year that started Wednesday.

            
          
            <br>
  <br>
  DeSantis stressed during a news conference that the vetoes did not reflect the merits of projects or programs. Indeed, DeSantis said he vetoed $550 million in items that he had included in a budget he proposed before the legislative session.

            
          
            <br>
  <br>
  “We were operating under a certain set of assumptions. The Legislature was as well. As the reality changes (with the pandemic), I think we all have to recognize that none of us are going to get everything that we want. So, I thought it was important that I was stepping up to the plate on that as well,” the governor said.

            
          
            <br>
  <br>
  DeSantis was able to spare from vetoes high-profile issues such as spending $500 million to increase teacher pay, providing $625 million for the Everglades and other water-related projects and giving 3 percent pay raises to state employees.

            
          
            <br>
  <br>
  But some areas of the budget took big hits, including more than $140 million in cuts to health and human services spending. As an example, DeSantis vetoed $58.4 million that lawmakers included to increase the wages of people who provide services, such as adult day training, to people with developmental and intellectual disabilities.

            
          
            <br>
  <br>
  “That one hurt the most,” Senate Health and Human Services Appropriations Chairman Aaron Bean, R-Fernandina Beach, said. “These people who are making $9 an hour are taking care of our most vulnerable citizens. We all knew it was coming. Does that make it any less painful? No. However, I understand because of the times we are in.”

            
          
            <br>
  <br>
  <b>WRAPPING UP THE SESSION</b>

            
          
            <br>
  <br>
  While the legislative session ended in March, most bills remained unsigned for three months.

            
          
            <br>
  <br>
  But in a flurry of action during the past week, DeSantis signed dozens of bills, including some of the highest-profile measures of the year.

            
          
            <br>
  <br>
  For instance, he signed a bill that requires parental consent before minors can have abortions, a long-sought goal of abortion opponents.

            
          
            <br>
  <br>
  “The serious and irrevocable decision to end a pregnancy involves undergoing a significant medical procedure that results, in many cases, in lifelong emotional and physical impacts,” Senate President Bill Galvano, R-Bradenton, said in a prepared statement after the bill was signed. “The parents of a minor child considering an abortion must be involved in such a substantial and permanent decision.”

            
          
            <br>
  <br>
  But opponents contend the parental-consent requirement will endanger teens who could be subject to retribution or abuse if their parents find out they are pregnant or considering an abortion.

            
          
            <br>
  <br>
  “This law will put already at-risk young people in even greater danger at the worst possible time,” Stephanie Fraim, president and CEO of Planned Parenthood of Southwest and Central Florida, said in a statement. “What’s worse, it could open the door to a reinterpretation of our constitutional right to privacy and the right to a safe and legal abortion in Florida.”

            
          
            <br>
  <br>
  Among other bills, DeSantis signed a controversial measure that will require all government employers and some private businesses to use a federal electronic system known as E-Verify to check the immigration status of new workers.

            
          
            <br>
  <br>
  <b>STORY OF THE WEEK:</b>  Gov. Ron DeSantis signed a $92.2 billion budget for the new fiscal year and issued <a href="/Blogs/archives/2020/06/29/florida-gov-desantis-slashes-1-billion-from-states-budget" target="_blank">$1 billion in vetoes</a>. 

            
          
            <br>
  <br>
  <b>QUOTE OF THE WEEK:</b> “I’ve been calling people all day and telling them where we are and in most instances that their community project didn’t make the final cut. We will fight again for almost all of the above next year. We’ll just do it again.” — Senate Health and Human Services Appropriations Chairman Aaron Bean, R-Fernandina Beach, after Gov. Ron DeSantis issued $1 billion in vetoes.

            
          
            <br>
  <br>
  <i>_<br>
  Please follow <a href="https://www.cdc.gov/coronavirus/2019-nCoV/index.html" target="_blank">CDC guidelines</a> and Orange County <a href="https://newsroom.ocfl.net/media-advisories/press-releases/2020/03/coronavirus-updates/" target="_blank">advisories</a> to stay safe, and please <a href="/orlando/SupportLocalJournalism/Page" target="_blank">support this free publication</a>. Our small but mighty team is working tirelessly to bring you news on how coronavirus is affecting Central Florida. Please consider making a one-time or monthly donation. <a href="/orlando/SupportLocalJournalism/Page" target="_blank">Every little bit helps</a>.</i>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    
      
    

    

    
      
      <p class="tags">
        Tags: <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=Orlando" rel="tag">Orlando</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=coronavirus" rel="tag">coronavirus</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=COVID-19" rel="tag">COVID-19</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=Orange%20County%20Florida" rel="tag">Orange County Florida</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=public%20health" rel="tag">public health</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=safety" rel="tag">safety</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=Ron%20DeSantis" rel="tag">Ron DeSantis</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=new%20record" rel="tag">new record</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=masks" rel="tag">masks</a>, <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?contentFeature=2124603" rel="tag">Image</a>
      </p>
    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>






  


  

  <style>
    #SendaLettertotheEditor {
      border:1px solid #D0D1D3;
      padding:10px 10px 10px 120px;
      min-height:100px;
      background-image:url('/binary/5643/OrlandoWeekly_fbook.jpg');
      background-position:10px 10px;
      background-repeat:no-repeat;
      background-size:100px auto;
    }
      #SendaLettertotheEditor p {
        margin-top:1em;
        margin-bottom:1em;
      }
        #SendaLettertotheEditor p:first-child {
          margin-top:0;
        }
        #SendaLettertotheEditor p:last-child {
          margin-bottom:0;
        }
  </style>

  <div id="SendaLettertotheEditor" class="SpanningFeature BlogPost ">
    <p>
    We welcome readers to submit letters regarding articles and content in <i>Orlando Weekly</i>. Letters should be a minimum of 150 words, refer to content that has appeared on <i>Orlando Weekly</i>, and must include the writer's full name, address, and phone number for verification purposes. No attachments will be considered. Writers of letters selected for publication will be notified via email. Letters may be edited and shortened for space.
  </p>

    <p>
      Email us at <a href="mailto:feedback%40orlandoweekly.com?subject=Letter%20to%20the%20Editor">feedback@orlandoweekly.com</a>.
    </p>
  </div>









































<div id="CommitChangeWidget" class="SpanningFeature BlogPost " style="background-color: rgba(247, 148, 30, 0.20); padding: 10px;">

  <center><p><big><b>Orlando Weekly works for you, and your support is essential.</b></big><br><br>
Our small but mighty local team works tirelessly to bring you high-quality, uncensored news and cultural coverage of Central Florida. 
<br><br>

Unlike many newspapers, ours is free – and we'd like to keep it that way, because we believe, <b>now more than ever</b>, everyone deserves access to accurate, independent coverage of their community. 
<br><br>

Whether it's a one-time acknowledgement of this article or an ongoing pledge, your support helps keep Orlando’s true free press <b>free.</b><br><br>


  <script>
  (function() {
  if(document.getElementById('commitchange-script')) return;
  var npo = 5276;
  var script = document.createElement('script');
  var first = document.getElementsByTagName('script')[0];
  script.setAttribute('data-npo-id', npo);
  script.id = 'commitchange-script';
  script.src = 'https://us.commitchange.com/js/donate-button.v2.js';
  first.parentNode.insertBefore(script, first);
  })();
  </script>
<a data-amounts='5,10,25,50,100,200' class='commitchange-donate' data-custom-fields='Join Orlando Weekly Press Club Emails (Y/N)' data-designation='Article Donation' data-hide-dedication='' data-redirect='https://www.orlandoweekly.com/orlando/NewsletterSignup/Page'></a>
</center>
</div><div id="ORAPlayer" class="SpanningFeature BlogPost ">
  

<script>
!function(n){if(!window.cnx){window.cnx={},window.cnx.cmd=[];var t=n.createElement('iframe');t.display='none',t.onload=function(){var n=t.contentWindow.document,c=n.createElement('script');c.src='//cd.connatix.com/connatix.player.js',c.setAttribute('async','1'),c.setAttribute('type','text/javascript'),n.body.appendChild(c)},n.head.appendChild(t)}}(document);
</script>
<script id="65b536ed7ae44d4188d263b7fa0c6f5c">
  cnx.cmd.push(function() {
    cnx({
      playerId: '4b310643-875b-43ba-b870-d0cecbae8d90'
    }).render('65b536ed7ae44d4188d263b7fa0c6f5c');
  });
</script>


</div>


  
  

  <div id="BlogsPreviousNext" class="SpanningFeature BlogPost ">
    <div class="prevNext">
      
        <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/another-record-high-day-for-coronavirus-in-florida-as-cases-jump-more-than-11400-on-friday" class="prev" rel="prev">&laquo;&nbsp;Another record-high day for coronav&hellip;</a>
        
    </div>
  </div>





  <div id="ArchiveLink" class="SpanningFeature BlogPost ">
    <p class="moreArticles">
      
        <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?category=2250909">More Blogs &raquo;</a>
      
      
    </p>
  </div> <!-- end ArchiveLink -->












  
  

  
  



    
    
    
    
























  
      <div id="RelatedStories" class="SpanningFeature BlogPost RelatedItem">
        <h3><span class="headingText">Related Stories</span></h3>
        <ul class="">
    
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-desantis-vp-pence-offer-assurances-as-cases-surge?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/27558210/pence-desantis-cspan-3_1_.jpg"
             alt="Florida Gov. DeSantis, VP Pence offer assurances as cases surge"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-desantis-vp-pence-offer-assurances-as-cases-surge?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Florida Gov. DeSantis, VP Pence offer assurances as cases surge</a>
    </h4>
    <div class="date">Jul  3, 2020 </div>
  </li> 

    
  
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-ron-desantis-net-worth-was-up-in-his-first-year-as-governor?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27557360/desantis-athletes-bill-103783387_3167869113271127_1491043989.jpeg"
             alt="Florida Gov. Ron DeSantis&#39; net worth was up in his first year as governor"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-ron-desantis-net-worth-was-up-in-his-first-year-as-governor?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Florida Gov. Ron DeSantis' net worth was up in his first year as governor</a>
    </h4>
    <div class="date">Jul  3, 2020 </div>
  </li> 

    
  
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/02/vp-mike-pence-excited-about-coming-to-jacksonville-for-republican-national-convention?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/27558213/mike_pence_by_gage_skidmore_4_1_.jpg"
             alt="VP Mike Pence &#39;excited&#39; about coming to Jacksonville for Republican National Convention"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/02/vp-mike-pence-excited-about-coming-to-jacksonville-for-republican-national-convention?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">VP Mike Pence 'excited' about coming to Jacksonville for Republican National Convention</a>
    </h4>
    <div class="date">Jul  2, 2020 </div>
  </li> 

    
  
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/30/ron-desantis-signs-law-restricting-abortion-access-in-florida?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27544310/floridacabinet2019.jpg"
             alt="Ron DeSantis signs law restricting abortion access in Florida"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/30/ron-desantis-signs-law-restricting-abortion-access-in-florida?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Ron DeSantis signs law restricting abortion access in Florida</a>
    </h4>
    <div class="date">Jun 30, 2020 </div>
  </li> 

    
  
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/29/florida-gov-desantis-slashes-1-billion-from-states-budget?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27538783/desantis-monday-1000.jpg"
             alt="Florida Gov. DeSantis slashes $1 billion from state&#39;s budget"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/29/florida-gov-desantis-slashes-1-billion-from-states-budget?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Florida Gov. DeSantis slashes $1 billion from state's budget</a>
    </h4>
    <div class="date">Jun 29, 2020 </div>
  </li> 

    
  
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/27/florida-business-groups-question-gov-desantis-refusal-to-issue-statewide-masks-requirement?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27526646/desantis-mask-bad.jpg"
             alt="Florida business groups question Gov. DeSantis&#39; refusal to issue statewide masks requirement"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/27/florida-business-groups-question-gov-desantis-refusal-to-issue-statewide-masks-requirement?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RelatedStories">Florida business groups question Gov. DeSantis' refusal to issue statewide masks requirement</a>
    </h4>
    <div class="date">Jun 27, 2020 </div>
  </li> 

    
  
        </ul>
      </div>
    

<div id="AdNativeEndofArticle" class="SpanningFeature BlogPost ">
  <!-- /43707298/ORL_DesktopNative -->
          <div id="div-gpt-ad-orl_desktopnative-3" style="" data-content-type="ad" data-slot="/43707298/ORL_DesktopNative" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_desktopnative-3');
                });
              </script>
          </div>
</div>
  



















  

  























  
      <div id="RecentByTag" class="SpanningFeature BlogPost ">
        <h3 class="latestblogs">
          <span class="headingText">
          
            Speaking of...
          
          </span>
        </h3>
        
        <ul class="moduleList">

        
        
        
    
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/another-record-high-day-for-coronavirus-in-florida-as-cases-jump-more-than-11400-on-friday?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27563096/cdc-coronavirus.jpg"
             alt="Another record-high day for coronavirus in Florida, as cases jump more than 11,400 on Friday"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/another-record-high-day-for-coronavirus-in-florida-as-cases-jump-more-than-11400-on-friday?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">Another record-high day for coronavirus in Florida, as cases jump more than 11,400 on Friday</a>
    </h4>
    <div class="date">Jul  4, 2020 </div>
  </li>
    

    
  
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-desantis-vp-pence-offer-assurances-as-cases-surge?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/27558210/pence-desantis-cspan-3_1_.jpg"
             alt="Florida Gov. DeSantis, VP Pence offer assurances as cases surge"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-desantis-vp-pence-offer-assurances-as-cases-surge?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">Florida Gov. DeSantis, VP Pence offer assurances as cases surge</a>
    </h4>
    <div class="date">Jul  3, 2020 </div>
  </li>
    

    
  
    

    
    

    

    
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/02/vp-mike-pence-excited-about-coming-to-jacksonville-for-republican-national-convention?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/27558213/mike_pence_by_gage_skidmore_4_1_.jpg"
             alt="VP Mike Pence &#39;excited&#39; about coming to Jacksonville for Republican National Convention"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/02/vp-mike-pence-excited-about-coming-to-jacksonville-for-republican-national-convention?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentByTag">VP Mike Pence 'excited' about coming to Jacksonville for Republican National Convention</a>
    </h4>
    <div class="date">Jul  2, 2020 </div>
  </li>
    

    
  
        

        

        
          <li class="l0 storyItem more">
            <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?tag=Orlando%7C%7Ccoronavirus%7C%7CCOVID-19%7C%7COrange%20County%20Florida%7C%7Cpublic%20health%7C%7Csafety%7C%7CRon%20DeSantis%7C%7Cnew%20record%7C%7Cmasks" class="more">More &raquo;</a>
          </li>
        
        </ul>
      </div>
    
  






<!-- Debug 2250909 has value 
             && Blog eq "blog"
-->








  
  
      <div id="RecentbyTopic" class="SpanningFeature BlogPost ">
        <h3 class="latestbloggytown">
          <span class="headingText">
          
            More on Bloggytown
                
          </span>
        </h3>
        
        <ul class="moduleList">
    
    
    
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/another-record-high-day-for-coronavirus-in-florida-as-cases-jump-more-than-11400-on-friday?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27563096/cdc-coronavirus.jpg"
             alt="Another record-high day for coronavirus in Florida, as cases jump more than 11,400 on Friday"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/04/another-record-high-day-for-coronavirus-in-florida-as-cases-jump-more-than-11400-on-friday?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">Another record-high day for coronavirus in Florida, as cases jump more than 11,400 on Friday</a>
    </h4>
    <div class="date">Jul  4, 2020 </div>
  </li>

    
  
    
    
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-desantis-vp-pence-offer-assurances-as-cases-surge?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/27558210/pence-desantis-cspan-3_1_.jpg"
             alt="Florida Gov. DeSantis, VP Pence offer assurances as cases surge"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-desantis-vp-pence-offer-assurances-as-cases-surge?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">Florida Gov. DeSantis, VP Pence offer assurances as cases surge</a>
    </h4>
    <div class="date">Jul  3, 2020 </div>
  </li>

    
  
    
    
    

    <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-ron-desantis-net-worth-was-up-in-his-first-year-as-governor?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27557360/desantis-athletes-bill-103783387_3167869113271127_1491043989.jpeg"
             alt="Florida Gov. Ron DeSantis&#39; net worth was up in his first year as governor"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-ron-desantis-net-worth-was-up-in-his-first-year-as-governor?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=RecentbyTopic">Florida Gov. Ron DeSantis' net worth was up in his first year as governor</a>
    </h4>
    <div class="date">Jul  3, 2020 </div>
  </li>

    
  
      
        <li class="l0 storyItem">
          
          
            
             <a href="https://www.orlandoweekly.com/Blogs/archives/bloggytown/" class="more">More Bloggytown &raquo;</a>
            
          
          
        </li>
      
        </ul>
      </div>
    
  









  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningFeature BlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningFeature BlogPost ">
            <h3><span class="headingText">More by Jim Saunders, News Service of Florida</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/30/ron-desantis-signs-law-restricting-abortion-access-in-florida?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27544310/floridacabinet2019.jpg"
             alt="Ron DeSantis signs law restricting abortion access in Florida"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/30/ron-desantis-signs-law-restricting-abortion-access-in-florida?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Ron DeSantis signs law restricting abortion access in Florida</a>
    </h4>
    <div class="date">Jun 30, 2020 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/23/court-rejects-challenge-to-moving-lakelands-confederate-monument?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27506755/lakelandconfederate.jpeg"
             alt="Court rejects challenge to moving Lakeland&#39;s Confederate monument"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/23/court-rejects-challenge-to-moving-lakelands-confederate-monument?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Court rejects challenge to moving Lakeland's Confederate monument</a>
    </h4>
    <div class="date">Jun 23, 2020 </div>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/23/judge-to-weigh-class-action-lawsuit-over-floridas-unemployment-system?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">
        <img src="https://media1.fdncms.com/orlando/imager/u/bigsquare/27506523/deo-1000.jpg"
             alt="Judge to weigh class-action lawsuit over Florida&#39;s unemployment system"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/23/judge-to-weigh-class-action-lawsuit-over-floridas-unemployment-system?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=MorebyThisAuthor">Judge to weigh class-action lawsuit over Florida's unemployment system</a>
    </h4>
    <div class="date">Jun 23, 2020 </div>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.orlandoweekly.com/orlando/ArticleArchives?author=2351647" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  

  
    
        <div id="PeopleWhoLiked" class="SpanningFeature BlogPost ">
          <h3><span class="headingText">Readers also liked&hellip;</span></h3>
          <ul>
      
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/11/28/maitlands-mediterranean-street-food-by-shishco-gets-new-mural-makeover?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/21701172/unnamed.jpg"
             alt="Maitland&#39;s Mediterranean Street Food By Shishco gets new mural makeover"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2018/11/28/maitlands-mediterranean-street-food-by-shishco-gets-new-mural-makeover?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">Maitland's Mediterranean Street Food By Shishco gets new mural makeover</a>
    </h4>
    <div class="date">Nov 28, 2018 </div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2019/01/02/sanctum-cafe-owners-to-open-sanctum-coffee-and-juice-bar-this-month?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/22872587/chelsie.jpg"
             alt="Sanctum Cafe owners to open Sanctum Coffee &amp; Juice Bar this month"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2019/01/02/sanctum-cafe-owners-to-open-sanctum-coffee-and-juice-bar-this-month?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">Sanctum Cafe owners to open Sanctum Coffee & Juice Bar this month</a>
    </h4>
    <div class="date">Jan  2, 2019 </div>
  </li>
      
      
    
      
      
      <li class="l0 storyItem">
    
      
      <a href="https://www.orlandoweekly.com/Blogs/archives/2019/01/10/so-what-if-i-have-a-rare-strain-of-killer-herpes?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">
        <img src="https://media2.fdncms.com/orlando/imager/u/bigsquare/23108686/333862688_d7218e6900_z.jpg"
             alt="So what if I have a rare strain of killer herpes"
             width="190"
             height="190"
             srcset="" />
      </a>
    
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/Blogs/archives/2019/01/10/so-what-if-i-have-a-rare-strain-of-killer-herpes?utm_source=widget&utm_medium=articleblog&utm_campaign=endofarticle&utm_content=PeopleWhoLiked">So what if I have a rare strain of killer herpes</a>
    </h4>
    <div class="date">Jan 10, 2019 </div>
  </li>
      
      
    
          </ul>
        </div>
      
               



  
  

  

  

  <div id="BlogHeader" class="SpanningFeature BlogPost  topic_bloggytown Blogs">
    <a href="https://www.orlandoweekly.com/blogs/Blogs/">
    <div class="Blogs">
      
        Blogs
      
    </div>
    </a>

    

    <p>
      
        <a href="https://www.orlandoweekly.com/orlando/Blogs/blogs/Archives">Archives</a> |
        <a href="/orlando/Rss.xml?category=2250909">RSS</a>
      
      
    </p>
  </div>








      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        
      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        <div id="slideshow-feed"></div>









<div id="TabbedPopularity" class="SpanningIsland BlogPost ">
  <h2>Most Popular</h2>
  <div class="tabs">
    <div id="tabViewed" class="tabCurrent tab"><a href="#">Most Read</a></div>

    <div id="tabLatest" class="tabBack tab tabLast"><a href="#">This Issue</a></div>
  </div>
  
  

  <div class="popularityBody">
    

    
      
          <ol class="moduleList">
        
        
        <li>
          <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/01/on-july-4-a-day-of-black-lives-matter-protests-planned-at-lake-eola-park?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">On July 4, a day of Black Lives Matter protests planned at Lake Eola Park <span class="more">Read More</span></a></h4>
        </li>
        
      
        
        <li>
          <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/02/a-summer-with-no-brits-could-spell-big-trouble-for-orlando?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">A summer with no Brits could spell big trouble for Orlando <span class="more">Read More</span></a></h4>
        </li>
        
      
        
        <li>
          <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/02/workers-at-over-20-central-florida-publix-stores-test-positive-for-coronavirus?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Workers at over 20 Central Florida Publix stores test positive for coronavirus <span class="more">Read More</span></a></h4>
        </li>
        
      
        
        <li>
          <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2020/06/30/ron-desantis-signs-law-restricting-abortion-access-in-florida?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Ron DeSantis signs law restricting abortion access in Florida <span class="more">Read More</span></a></h4>
        </li>
        
      
        
        <li>
          <h4 class="headline"><a href="https://www.orlandoweekly.com/Blogs/archives/2020/07/03/florida-gov-ron-desantis-net-worth-was-up-in-his-first-year-as-governor?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Florida Gov. Ron DeSantis' net worth was up in his first year as governor <span class="more">Read More</span></a></h4>
        </li>
        
      
          </ol>
        
    
  </div>  

  

  
  

  <div class="popularityBody" style="display:none">
    
    
      <div class="currentIssue">
        <a href="https://www.orlandoweekly.com/orlando/IssueArchives?issue=27544950&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity" class="no-foundation-imgeditor">
          
            <img src="/imager/b/cover/27544950/8017/OW_Cover-07012020.jpg" alt="Issue Cover" />
          
        </a>
        <p>July  1- 7, 2020</p>
      </div>
    
    
        <ol class="moduleList">
      
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/new-girl-stars-nasim-pedrad-and-lamorne-morris-reunite-in-desperados-debuting-friday-on-netflix/Content?oid=27544965&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">'New Girl' stars Nasim Pedrad and Lamorne Morris reunite in 'Desperados,' debuting Friday on Netflix <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/a-massive-black-lives-matter-mural-on-rosalind-avenue-seemed-like-a-positive-step-but-some-in-orlandos-black-community-would-rather-see-syst/Content?oid=27545406&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">A massive Black Lives Matter mural on Rosalind Avenue seemed like a positive step. But some in Orlando's Black community would rather see systemic change <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/orlando-rapper-sean-mingo-finds-his-voice-with-tktb/Content?oid=27545416&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Orlando rapper Sean Mingo finds his voice with 'T.K.T.B.' <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/those-who-did-manage-to-grab-disney-tickets-will-have-a-very-different-experience-compared-to-the-pre-pandemic-park/Content?oid=27545421&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Those who did manage to grab Disney tickets will have a very different experience compared to the pre-pandemic park <span class="more">Read More</span></a></h4>
      </li>
      
    
        
      <li>
        <h4 class="headline"><a href="https://www.orlandoweekly.com/orlando/chicken-fire-owner-kwame-boakye-takes-nashville-hot-chicken-lovers-to-hell-and-back/Content?oid=27545435&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity">Chicken Fire owner Kwame Boakye takes Nashville hot chicken lovers to hell and back <span class="more">Read More</span></a></h4>
      </li>
      
    
        </ol>
      
  </div>
</div>



<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedPopularity div.tabs>div"),
        $$("#TabbedPopularity div.popularityBody"),
        "tabCurrent", "tabBack"
    );
    
    // Deactivate links.
    $$("#TabbedPopularity div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedPopularity li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>
<!-- End #TabbedPopularity -->










<div id="SearchRightCol" class="SpanningIsland BlogPost  search-wrap">
    
    <form class="prepTextForm" id="searchbox_017793458706336421686:1y5lan2fdja" action="https://www.orlandoweekly.com/orlando/Search">
      <input type="hidden" name="cx" value="017793458706336421686:1y5lan2fdja" />
      <input type="hidden" name="cof" value="FORID:9" />
      <input id="search-submit" type="submit" name="sa" value="Search" />    
      <input id="search-input" autocomplete="off" type="text"  name="q" size="25" placeholder="Search" />
    </form>
    <ul id="search-dropdown"  class="search-dropdown" style="display:none;">
      <li class="search-option"><a class="search-all" href="https://www.orlandoweekly.com/orlando/Search"><span class="dark-search-icon"></span>&nbsp;All</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/ArticleArchives"><span class="dark-search-icon"></span>&nbsp;in Articles &amp; Posts</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/EventSearch"><span class="dark-search-icon"></span>&nbsp;in Events</a></li>
      <li class="search-option"><a href="https://www.orlandoweekly.com/orlando/LocationSearch"><span class="dark-search-icon"></span>&nbsp;in Locations</a></li>
    </ul>
  
</div>

<script type="text/javascript">
/* SEARCH WIDGET */

var searchInputSelector = '#search-input';
var searchFormSelector = 'form.prepTextForm';

dropDownLinksEmptyKeywordAlert = function (){
  jQuery(searchInputSelector).attr('placeholder','Please enter a keyword.');
  setTimeout(function(){jQuery(searchInputSelector).attr('placeholder','Search');},3000);
}

// 
jQuery(searchFormSelector+' input[type="submit"]').click(function(e){
  jQuery(searchInputSelector).click();
  if(jQuery(searchInputSelector).val() == ""){
    e.preventDefault();
    dropDownLinksEmptyKeywordAlert();
  }
});

dropDownLinks = new FloatingPanel(
  'search-input', // 
  'search-dropdown', // 
  {
    effects: 'off',
    closeDelay: 1,
    triggerEvent: 'click',
    allowDefault: true,
    beforeOpen: function() {
      var searchInput = jQuery(searchInputSelector);
      jQuery('.search-option a').click(function(e){
        e.preventDefault(); // 
        // 
        if(jQuery(searchInputSelector).val() != ""){
          if(jQuery(e.target).hasClass('search-all')){
            jQuery(searchFormSelector).submit();
          } else {
            var newLocation = jQuery(e.target).attr('href') || "";
            if( newLocation.match(/\?/)){
              newLocation = newLocation+'&';
            }else{
              newLocation = newLocation+'?';
            }
            window.location = newLocation + "keywords=" + jQuery(searchInputSelector).val() +  "&submit=Search";
          }
        }else{
          dropDownLinksEmptyKeywordAlert();
        }
      });

      //
      SearchRightColCloseSearchPanel = function(event){
        if(jQuery(event.target).parents('#SearchRightCol').length == 0){
          dropDownLinks.closePanel();
        }
      }
      jQuery(document).click(function(e){SearchRightColCloseSearchPanel(e);});
    },
    beforeClose: function() {
      //
      jQuery(document).off('click', '*', SearchRightColCloseSearchPanel);
    },
    togglePanel: function(){
      //
    }
  }
);
</script>
<!-- End #SearchRightCol -->
<div id="AdMediumRectangle1300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-1" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-1');
                });
              </script>
          </div>
</div>


  <div id="NewsletterSignup" class="SpanningIsland BlogPost ">
  <h2>Newsletters</h2>
    <div class="wrap">
    <h3>Never miss a beat</h3>
<a href="/orlando/NewsletterSignup/Page" style="float:right;border: 0; color: rgb(255, 255, 255); display: inline-block; padding: 8px 15px; text-shadow: none; border-top-left-radius: 8px; border-top-right-radius: 8px; border-bottom-right-radius: 8px; border-bottom-left-radius: 8px; background-color:#F7941E;font-family:'Montserrat',sans-serif;text-transform: uppercase;text-decoration:none;">Sign Up Now</a>
<p>Subscribe now to get the latest news delivered right to your inbox.</p>
    </div>
  </div>
  


  <div id="CurrentIssuu" class="SpanningIsland BlogPost ">
  <h2>Read the Digital Print Issue</h2>
    <div class="wrap">
    <h3>July 1, 2020</h3>

<iframe allowfullscreen allow="fullscreen" style="border:none;width:100%;height:326px;" src="//e.issuu.com/embed.html?d=orlando_weekly_july_1__2020&hideIssuuLogo=true&u=euclidmediagroup"></iframe>

<p style="margin:10px 0;"><a class="more" href="/orlando/IssueArchives">View more issues</a></p>
    </div>
  </div>
  
<div id="AdMediumRectangle2300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-2" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-2');
                });
              </script>
          </div>
</div><div id="PhotoSlideshows" class="SpanningIsland BlogPost ">
  <h2><a href="http://photos.orlandoweekly.com/" target="_blank">Newest Slideshows</a></h2>
  <iframe src="//photos.orlandoweekly.com/thumbnail-scroller-square/" 
          height="419" 
          width="364"
          scrolling="no" 
          frameborder="0"></iframe>
</div>
<!-- End #PhotoSlideshows -->
















    <div id="SpecialIssues" class="SpanningIsland BlogPost ">
      <h2><a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">Special Issues</a></h2>
  
  
  <div class="reportBox">
    <a href="/orlando/welcome-to-the-2019-orlando-weekly-city-guide/Content?oid=25059388&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedPopularity&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/25157334/screen_shot_2019-04-17_.jpg);">
      <span class="grayRedBox">City Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/happy-hot-lidays-orlando-our-annual-preview-of-everything-to-look-forward-to-this-holiday-season/Content?oid=26331794&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/26341390/cover_for_right_rail.jpg);">
      <span class="grayRedBox">Holiday Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/Category?oid=2240491&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/27509200/salvageyoursummer_water_rightrail.jpg);">
      <span class="grayRedBox">Summer Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-orlando/Content?oid=25798051&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media2.fdncms.com/orlando/imager/u/original/26132383/newcomers2019_rrlink.jpg);">
      <span class="grayRedBox">Newcomers Guide</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/BestofOrlandoReadersPoll2019/Page#//?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/orlando/imager/u/original/26132382/cover_rrlink.jpg);">
      <span class="grayRedBox">Best of Orlando</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-bite-2019-the-best-guide-to-orlando-dining/Content?oid=25603613&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/orlando/imager/u/original/25632553/cover_bite2019_rightrailwidget.jpg);">
      <span class="grayRedBox">Bite</span>
    </a>
  </div>
  

  
  <div class="reportBox">
    <a href="/orlando/welcome-to-orlando-weeklys-2019-fall-arts-guide/Content?oid=26055488&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues" 
       
       style="background-image:url(https://media1.fdncms.com/orlando/imager/u/original/26132380/cover_rightraillink.jpg);">
      <span class="grayRedBox">Fall Guide</span>
    </a>
  </div>
  

      <a href="https://www.orlandoweekly.com/orlando/special-issues/Section?oid=2240413&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=SpecialIssues">More...</a>
    </div>
  
<div id="AdMediumRectangle3300x250" class="SpanningIsland BlogPost ">
  <!-- /43707298/ORL_300x250 -->
          <div id="div-gpt-ad-orl_300x250-3" style="" data-content-type="ad" data-slot="/43707298/ORL_300x250" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_300x250-3');
                });
              </script>
          </div>
</div>












































<div id="TabbedCalendar" class="SpanningIsland BlogPost ">
  <h2>Calendar</h2>

  <div class="tabs">
    <div id="tabEvents" class="tab"><a href="#">Events</a></div>
    <div id="tabMusic"  class="tab"><a href="#">Music</a></div>
    <div id="tabMovies" class="tab"><a href="#">Movies</a></div>
    <div id="tabArts"   class="tab"><a href="#">Arts</a></div>
    <div id="tabDining" class="tab tabLast"><a href="#">Dining</a></div>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/orlando-city-sc-vs-toronto-fc/Event?oid=26654775&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Orlando City SC vs. Toronto FC <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/austins-coffee-the-falcon/Event?oid=24704000&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Austins Coffee + The Falcon <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/lake-mary-farmers-market/Event?oid=25439521&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Lake Mary Farmers Market <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/photography-walking-tour-lake-eola/Event?oid=24647767&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Photography Walking Tour Lake Eola <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/qi-gong-breathing-slow-movement-and-healing/Event?oid=15426004&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Qi Gong Breathing, Slow Movement, & Healing <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventSection=2167738&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/all-new-saturdays/Event?oid=2302686&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        All New Saturdays <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/island-saturday/Event?oid=2302685&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Island Saturday <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/smokin-torpedoes/Event?oid=6455776&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Smokin' Torpedoes <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/signature/Event?oid=2445916&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Signature <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/barrio-sundays/Event?oid=2302680&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Barrio Sundays <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2292851&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/cartoons-and-cereal/Event?oid=26578687&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Cartoons & Cereal <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <div class="tabsButtonRow">
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Today&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Today</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=Tomorrow&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Tomorrow</a>
    <a class="grayRedBox" href="https://www.orlandoweekly.com/orlando/EventSearch?eventCategory=2282439&amp;narrowByDate=This%20Weekend&&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">This Weekend</a>
  </div>
    <ol class="moduleList">
        

    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/charles-hosmer-morses-arts-and-crafts-study-at-osceola-lodge/Event?oid=18881356&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        <i>Charles Hosmer Morse’s Arts and Crafts Study at Osceola Lodge</i> <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/iridescence-a-celebration/Event?oid=24193784&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        'Iridescence: A Celebration' <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
      <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/space-oddities-the-sequel/Event?oid=25543847&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        'Space Oddities: The Sequel' <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
    
  </ol>
    <a id="TabbedCalendarSubmitBtn" href="https://posting.orlandoweekly.com/orlando/Events/AddEvent?utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">Submit an Event</a>
  </div>

  

  

  <div class="eventTabGuts" style="display:none">
    <ol class="moduleList">
      
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/bob-marley-a-tribute-to-freedom/Location?oid=2284790&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Bob Marley - A Tribute to Freedom <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/bonfires-bar-and-grill/Location?oid=2288841&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Bonfires Bar & Grill <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
        <li>
    <h4 class="headline">
      <a href="https://www.orlandoweekly.com/orlando/little-saigon/Location?oid=2285480&utm_source=widget&utm_medium=articleblog&utm_campaign=rightrail&utm_content=TabbedCalendar">
        Little Saigon <span class="more">&nbsp;Read More</span>
      </a>
    </h4>
  </li>
        
    </ol>
    <form name="diningSearchForm" method="get" action="https://www.orlandoweekly.com/orlando/LocationSearch">
      <input type="hidden" name="locationSection" value="2282258" />
      <input type="hidden" name="guide" value="2124367" />
      <select name="locationCategory">
        <option value="">-All Categories-</option>
        
          <option value="2282260">African</option>
        
          <option value="2282261">American</option>
        
          <option value="2282262">Argentine</option>
        
          <option value="2282263">Armenian</option>
        
          <option value="2282264">Bakery</option>
        
          <option value="2282265">Barbecue</option>
        
          <option value="27096422">Brazilian</option>
        
          <option value="2282266">Breakfast/Brunch</option>
        
          <option value="2282267">Brewpub</option>
        
          <option value="2282286">Burgers</option>
        
          <option value="2282268">Café/Bistro</option>
        
          <option value="2282269">Cajun/Creole</option>
        
          <option value="2282270">Caribbean</option>
        
          <option value="2282272">Chinese</option>
        
          <option value="2282271">Coffee house (chain)</option>
        
          <option value="2282289">Coffee house (independent)</option>
        
          <option value="2282274">Contemporary</option>
        
          <option value="2282276">Cuban</option>
        
          <option value="2297679">Deli</option>
        
          <option value="27294676">Desserts</option>
        
          <option value="2282278">Diner</option>
        
          <option value="27012503">Dutch</option>
        
          <option value="2282279">Eastern European</option>
        
          <option value="26255950">Egyptian</option>
        
          <option value="26628154">Eritrean</option>
        
          <option value="2282280">Ethiopian</option>
        
          <option value="2282275">European</option>
        
          <option value="26302999">Filipino-American</option>
        
          <option value="2282281">Fondue</option>
        
          <option value="2304903">Food Truck</option>
        
          <option value="2282282">French</option>
        
          <option value="2282283">General</option>
        
          <option value="2282399">General Fare</option>
        
          <option value="2282284">German</option>
        
          <option value="2282285">Greek</option>
        
          <option value="2282287">Hawaiian</option>
        
          <option value="2282288">Hot Dogs</option>
        
          <option value="27069718">Ice Cream</option>
        
          <option value="2282290">Indian</option>
        
          <option value="2282291">Indonesian</option>
        
          <option value="2282292">Irish</option>
        
          <option value="2282293">Israeli</option>
        
          <option value="2282294">Italian</option>
        
          <option value="2282295">Jamaican</option>
        
          <option value="27069314">Japanese</option>
        
          <option value="2282296">Japanese/Sushi</option>
        
          <option value="25626307">Juice</option>
        
          <option value="2282297">Korean</option>
        
          <option value="2297696">Kosher</option>
        
          <option value="27095777">Laotian</option>
        
          <option value="2282298">Latin American</option>
        
          <option value="2282299">Lebanese</option>
        
          <option value="2305936">Malaysian</option>
        
          <option value="2282300">Market</option>
        
          <option value="2282301">Mediterranean</option>
        
          <option value="2282302">Mexican</option>
        
          <option value="2282303">Middle Eastern</option>
        
          <option value="2345788">Modern American</option>
        
          <option value="2282304">Mongolian</option>
        
          <option value="2282305">Moroccan</option>
        
          <option value="2282306">Noodles</option>
        
          <option value="2282307">Pan-Asian</option>
        
          <option value="2282308">Persian</option>
        
          <option value="2282309">Peruvian</option>
        
          <option value="2282310">Philippine</option>
        
          <option value="2282311">Pizza</option>
        
          <option value="26186721">Poké</option>
        
          <option value="2282312">Polish</option>
        
          <option value="2297728">Pub Grub</option>
        
          <option value="2282313">Puerto Rican</option>
        
          <option value="2282314">Russian</option>
        
          <option value="2282315">Salads</option>
        
          <option value="2282277">Sandwiches/Subs</option>
        
          <option value="26147501">Saudi</option>
        
          <option value="26147502">Saudi-Indonesian</option>
        
          <option value="2282316">Seafood</option>
        
          <option value="2282317">Soup</option>
        
          <option value="2282318">Southern/Soul</option>
        
          <option value="2282319">Spanish</option>
        
          <option value="2282320">Steakhouse</option>
        
          <option value="2282321">Swedish</option>
        
          <option value="2282322">Sweets</option>
        
          <option value="2282323">Tapas</option>
        
          <option value="2282273">Tea</option>
        
          <option value="2282324">Tex-Mex</option>
        
          <option value="2282325">Thai</option>
        
          <option value="2282326">Turkish</option>
        
          <option value="2282327">Vegetarian/Vegan</option>
        
          <option value="2282328">Vietnamese</option>
        
          <option value="2282329">Wine</option>
        
      </select>
      <select name="neighborhood">
    <option value="">-All Neighborhoods-</option>
    
      
        <option value="2292883" >&nbsp;&nbsp;Apopka</option>
      
        <option value="2282447" >&nbsp;&nbsp;Central</option>
      
        <option value="2292887" >&nbsp;&nbsp;Audubon Park</option>
      
        <option value="2292884" >&nbsp;&nbsp;Casselberry</option>
      
        <option value="2282448" >&nbsp;&nbsp;Disney</option>
      
        <option value="2282449" >&nbsp;&nbsp;Downtown</option>
      
        <option value="2282450" >&nbsp;&nbsp;East</option>
      
        <option value="2399527" >&nbsp;&nbsp;Edgewood</option>
      
        <option value="2282451" >&nbsp;&nbsp;Elsewhere</option>
      
        <option value="2282452" >&nbsp;&nbsp;I-Drive/Universal</option>
      
        <option value="2292885" >&nbsp;&nbsp;Ivanhoe Village</option>
      
        <option value="2282453" >&nbsp;&nbsp;North</option>
      
        <option value="2282454" >&nbsp;&nbsp;South</option>
      
        <option value="2282455" >&nbsp;&nbsp;West</option>
      
        <option value="4366406" >&nbsp;&nbsp;Dr. Phillips</option>
      
        <option value="2282456" >&nbsp;&nbsp;Winter Park Area</option>
      
        <option value="2343583" >&nbsp;&nbsp;Milk District</option>
      
        <option value="2343582" >&nbsp;&nbsp;SoDo</option>
      
        <option value="2343585" >&nbsp;&nbsp;Kissimmee</option>
      
        <option value="2343584" >&nbsp;&nbsp;UCF</option>
      
        <option value="2343586" >&nbsp;&nbsp;Mount Dora</option>
      
        <option value="2343587" >&nbsp;&nbsp;Conway/Curry Ford</option>
      
        <option value="2343589" >&nbsp;&nbsp;Belle Isle</option>
      
        <option value="2343590" >&nbsp;&nbsp;Mills 50</option>
      
        <option value="2345785" >&nbsp;&nbsp;College Park</option>
      
        <option value="2345787" >&nbsp;&nbsp;Thornton Park</option>
      
        <option value="26484602" >&nbsp;&nbsp;North Florida</option>
      
        <option value="26718775" >&nbsp;&nbsp;Baldwin Park</option>
      
        <option value="26947375" >&nbsp;&nbsp;Eola Heights</option>
      
        <option value="26947376" >&nbsp;&nbsp;South Eola</option>
      
        <option value="27106618" >&nbsp;&nbsp;Online Only</option>
      
        <option value="27050023" >&nbsp;&nbsp;Sanford</option>
      
    
  </select>
      <div class="searchBox">
        <input type="text" name="keywords" title="Enter keyword" placeholder="Search" autocomplete="off" class="text" value="" />
        <input type="submit" value="go" />
      </div>
    </form>
  </div>
</div>




<script type="text/javascript">
<!--
Event.observe(document, "dom:loaded", function () {
    dnSetupTabGroup(
        $$("#TabbedCalendar div.tabs>div"),
        $$("#TabbedCalendar div.eventTabGuts"),
        "tabCurrent", "tabBack", 0
    );

    // Deactivate links.
    $$("#TabbedCalendar div.tabs>div a").each(function (a) {
        a.onclick = function () { 
          setTimeout(function(){ jQuery('#TabbedCalendar li').css('counter-reset','item'); },10);
          return false; 
        };
    });
});
//-->
</script>

      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      

<div id="FooterInfo" class="GlobalFooter BlogPost ">
  <div class="footerCustomInfo">
    <h2>Orlando Weekly</h2>
    <p>16 W. Pine St.</p>
    <p>Orlando, FL 32801</p>
    <p>Phone: (407) 377-0400</p>
    <p>Classified Phone: (407) 377-0415</p>
    <p>Fax: (407) 377-0420</p>
  </div>
  <div class="footerCustomWrap">
    <div class="footerCustomNav">
      <ul>
        <li><a target="_top" href="/orlando/AboutOrlandoWeekly/Page">About OW</a></li>
        <li><a target="_top" href="https://www.orlandoweekly.com/orlando/AdvertiseWithOrlandoWeekly/Page">Advertise</a></li>
        <li><a target="_blank" href="http://www.ruxton.com/">National Advertising</a></li>
				
				    <li><a target="_blank" href="/blogs/LegalAdvertising/">Legal Advertising</a></li>
				
        <li><a target="_top" href="/orlando/WorkForUs/Page">Work Here</a></li>
      </ul>
      <p>All parts of this site Copyright &copy; 2020 Orlando Weekly.</p>
    </div>
    <div class="footerRssLink">
      <a href="https://www.orlandoweekly.com/orlando/Syndication" class="RSSLink">RSS Feeds</a>
    </div>    
    

    
    
      <div class="footerCustomLogin">
        

        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="https://posting.orlandoweekly.com/orlando/MyProfile">View Profile</a> / </li>
          <li><a href="https://posting.orlandoweekly.com/orlando/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="https://www.orlandoweekly.com/orlando/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      </div><!-- #FooterInfo -->

      <script>
        new Foundation.LoginRequiredComponent("FooterInfo");
      </script>
    
  </div>
  <div class="clear"></div>
</div>
<!-- End #FooterInfo -->
<div id="AdFooter728x90" class="GlobalFooter BlogPost ">
  <!-- /43707298/ORL_728x90 -->
          <div id="div-gpt-ad-orl_728x90-2" style="" data-content-type="ad" data-slot="/43707298/ORL_728x90" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_728x90-2');
                });
              </script>
          </div>
</div>































<div id="FooterNavigation" class="GlobalFooter BlogPost ">
  <div class="linkGroupColumn">

    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/news-and-features/Section?oid=2240408" 
               target="_">
              News & Features
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/ArticleArchives?tag=coronavirus" >Coronavirus Updates</a></li>
          
            <li><a href="/orlando/news-and-features/Section?oid=2240408" >News Home</a></li>
          
            <li><a href="/orlando/first-words/Category?oid=2240418" >First Words</a></li>
          
            <li><a href="/orlando/happytown/Category?oid=2240414" >Happytown</a></li>
          
            <li><a href="/orlando/know-it-all/Category?oid=2240417" >Know It All</a></li>
          
            <li><a href="/orlando/give-me-your-money/Category?oid=2240416" >Give Me Your Money</a></li>
          
            <li><a href="/Blogs/archives/bloggytown/" >Blog: Bloggytown</a></li>
          
            <li><a href="/orlando/joblistings/Page" >Local Job Listings</a></li>
          
            <li><a href="/orlando/IssueArchives?issue=this%20week" >Digital Issue</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/EventSearch" 
               target="_">
              Arts & Culture
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/arts-and-culture/Section?oid=2240407" >Arts & Culture Home</a></li>
          
            <li><a href="/orlando/visual-arts/Category?oid=2240435" >Visual Arts</a></li>
          
            <li><a href="/orlando/performing-arts/Category?oid=2240436" >Performing Arts</a></li>
          
            <li><a href="/orlando/books/Category?oid=2240437" >Books</a></li>
          
            <li><a href="/orlando/live-active-cultures/Category?oid=2240438" >Live Active Cultures</a></li>
          
            <li><a href="/orlando/culture-2-go/Category?oid=2240439" >Culture 2 Go</a></li>
          
            <li><a href="/orlando/savage-love/Category?oid=2240424" >Savage Love</a></li>
          
            <li><a href="/orlando/free-will-astrology/Category?oid=2240441" >Free Will Astrology</a></li>
          
            <li><a href="/Blogs/archives/the-gist/" >Blog: The Gist</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/food-and-drink/Section?oid=2240409" 
               target="_">
              Food & Drink
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/GoodTo-GoOrlandoADirectoryofLocalBusinessesYouCanSupportDuringtheCoronavirusEra/Page" >Good To-Go Orlando</a></li>
          
            <li><a href="/orlando/restaurant-review/Category?oid=2240450" >Restaurant Reviews</a></li>
          
            <li><a href="/orlando/tip-jar/Category?oid=2240453" >Tip Jar</a></li>
          
            <li><a href="/orlando/bar-exam/Category?oid=2240455" >Bar Exam</a></li>
          
            <li><a href="/orlando/nosh-pit/Category?oid=2240452" >Nosh Pit</a></li>
          
            <li><a href="/orlando/remix/Category?oid=2240456" >Remix</a></li>
          
            <li><a href="/orlando/LocationSearch?locationSection=2282258" >Find a Restaurant</a></li>
          
            <li><a href="/orlando/LocationSearch?locationSection=2282256" >Find a Bar or Club</a></li>
          
            <li><a href="/Blogs/archives/tip-jar/" >Blog: Tip Jar</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Movies</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/movie-reviews-and-stories/Category?oid=2240471" >Movie Reviews and News</a></li>
          
            <li><a href="/orlando/LocationSearch?locationCategory=2282370&sortType=name" >Find a Theater</a></li>
          
            <li><a href="/orlando/MovieTimes?show=theater" >Movie Times by Theater</a></li>
          
            <li><a href="/orlando/MovieTimes" >Movie Times by Title</a></li>
          
            <li><a href="/orlando/MovieTimes?show=times" >Movie Times by Time of Day</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/music/Section?oid=2240410" 
               target="_">
              Music
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/music/Section?oid=2240410" >Music Home</a></li>
          
            <li><a href="/orlando/music-stories-and-interviews/Category?oid=2240462" >Music Reviews & Stories</a></li>
          
            <li><a href="/orlando/feedback/Category?oid=2240463" >Feedback</a></li>
          
            <li><a href="/orlando/this-little-underground/Category?oid=2240465" >This Little Underground</a></li>
          
            <li><a href="/Blogs/archives/the-heard/" >Blog: The Heard</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/EventSearch" 
               target="_">
              Calendar
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/EventSearch" >Search Calendar Events</a></li>
          
            <li><a href="/orlando/EventSearch?feature=Staff%20Pick" >This Week's Selections</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/FreeStuff" 
               target="_">
              Giveaways
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273884">Contests</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2361070">25th Anniversary BIG Prizes</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2199663">Cool Stuff</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2273883">Swag</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/FreeStuff?category=2361151">Concert Tickets</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Events</h3>
        

        <ul class="sublinkGroup">
          

          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/special-issues/Section?oid=2240413" 
               target="_">
              Special Issues
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/bite/Category?oid=2240489">Bite</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/newcomers-guide/Category?oid=2240498">Newcomers Guide</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/fall-guide/Category?oid=2240492">Fall Guide</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/holiday-guide/Category?oid=2240493">Holiday Guide</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/summer-guide/Category?oid=2240491">Summer Guide</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/BestOf" 
               target="_">
              Best of Orlando ®
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2019">2019</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2018">2018</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2017">2017</a></li>
  
    <li><a href="https://www.orlandoweekly.com/orlando/BestOf?year=2016">2016</a></li>

          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/ArticleArchives" 
               target="_">
              Search
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/ArticleArchives" >Search Authors or Stories</a></li>
          
            <li><a href="/orlando/IssueArchives" >Search Issues</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Sponsored Links</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="https://www.mckinley.com/apartments/florida/orlando" >Apartments in Orlando</a></li>
          
            <li><a href="https://www.407apartments.com/orlando-apartments/apartments-near-disney" target="_blank">Apartments near Disney World</a></li>
          
            <li><a href="https://www.orlandofuntickets.com/" target="_blank">Discount Disney Tickets</a></li>
          
            <li><a href="http://www.407apartments.com/" target="_blank">Orlando Apartments</a></li>
          
            <li><a href="https://www.bestoforlando.com/" target="_blank">Orlando Tickets</a></li>
          
            <li><a href="http://www.407apartments.com/ucf-apartments" target="_blank">UCF Apartments</a></li>
          
            <li><a href="https://www.livesomewhere.com/ucf" target="_blank">UCF Off Campus Housing</a></li>
          
        </ul>

      </div>
    

      

      
      
        </div><!-- End .linkGroupColumn -->
        <div class="linkGroupColumn">
      

      <div class="linkGroup ">
        
          <h3>
            <a href="/orlando/AboutOrlandoWeekly/Page" 
               target="_">
              About Us
            </a>
          </h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="/orlando/AboutOrlandoWeekly/Page" >Staff Directory</a></li>
          
            <li><a href="/orlando/Policies/Page" >Policies</a></li>
          
            <li><a href="/orlando/FAQs/Page" >FAQ</a></li>
          
            <li><a href="/orlando/AboutOrlandoWeekly/Page" >Contact Us</a></li>
          
            <li><a href="/orlando/WorkForUs/Page" >Work for Us</a></li>
          
            <li><a href="/orlando/Wheretofindus/Page" >Where to Find Us</a></li>
          
            <li><a href="/orlando/AdvertiseWithOrlandoWeekly/Page" >Advertise</a></li>
          
        </ul>

      </div>
    

      

      
      

      <div class="linkGroup ">
        
          <h3>Social Media</h3>
        

        <ul class="sublinkGroup">
          

          
            <li><a href="https://www.facebook.com/orlandoweekly" target="_blank">Facebook</a></li>
          
            <li><a href="https://twitter.com/OrlandoWeekly" target="_blank">Twitter</a></li>
          
            <li><a href="http://instagram.com/orlandoweekly/" target="_blank">Instagram</a></li>
          
        </ul>

      </div>
    

  </div><!-- End .linkGroupColumn -->
</div>
<!-- End #FooterNavigation -->
<div id="footerCopyright">
  <p>
   &copy; 2020
   Orlando Weekly 
   <br><br>
   Website powered by <a href="https://www.publishwithfoundation.com/" target="_blank">Foundation</a>
  </p>
</div>
<a data-amounts='5,10,25,50,100,200' class='commitchange-donate' data-custom-fields='Join Orlando Weekly Press Club Emails (Y/N)' data-designation='Floating Button Donation' data-fixed='' data-hide-dedication='' data-redirect='https://www.orlandoweekly.com/orlando/SupportLocalJournalism/Page'></a>


  <img src="/foundation/images/icons/pixel.gif?oid=27563092" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdBackground" class="Closer BlogPost ">
  <!-- /43707298/ORL_Reskin -->
          <div id="div-gpt-ad-orl_reskin" style="" data-content-type="ad" data-slot="/43707298/ORL_Reskin" data-output="asynchronous" data-width="" data-height="">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-orl_reskin');
                });
              </script>
          </div>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  


